Jump to content

s60

Forum Members
  • Posts

    31
  • Joined

  • Last visited

Equipment

  • Keenetic
    Omni KeeneticOS: 3.1.10

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

s60's Achievements

Member

Member (2/5)

1

Reputation

  1. по этому пути файл точно есть? у меня , например, этот путь такой : /lib/modules/4.9-ndm-3/videodev.ko
  2. какая строка входа? надо ssh root@ip_вашего_роутера с паролем keenetic
  3. попробовал с такими настройками - из журнала видим, что frames per second стало -1 вместо ранее укаазнных 15, но загрузка процессора все так же 100%
  4. камера как USB устройство отвалилась..... а я модули мучил... итого: 1) камера как USB устройство по lsusb есть 2) kmod_ndms установлен взамен kmod (напопробовать поставил - разницы пока не видно ни в чем) 3) установлены модули из ветки репозитория test (те первые, те что с "отломанными строками" не качал) 4) запущен стандартный скрипт S96mjpg-streamer 4) картинка есть 5) загрузка процессора 100% (89% из которых занимает процесс mjpg_streamer в несколько потоков) Вопрос: как-нибудь можно уменьшить загрузку процессора ? А то роутер свои прямые обязанности начнет плохо выполнять с такой загрузкой.....
  5. в журнале кинетика только: Ноя 15 12:53:45 MJPG-streamer [30769] starting application Ноя 15 12:53:45 MJPG-streamer [30769] enabling daemon mode Ноя 15 12:53:45 MJPG-streamer [30771] MJPG Streamer Version.: 2.0 Ноя 15 12:53:45 MJPG-streamer [30771] Using V4L2 device.: /dev/video0 Ноя 15 12:53:45 MJPG-streamer [30771] Desired Resolution: 640 x 480 Ноя 15 12:53:45 MJPG-streamer [30771] Frames Per Second.: 24 Ноя 15 12:53:45 MJPG-streamer [30771] Format............: YUYV Ноя 15 12:53:45 MJPG-streamer [30771] JPEG Quality......: 80 Ноя 15 12:53:45 MJPG-streamer [30771] TV-Norm...........: DEFAULT Ноя 15 12:53:45 MJPG-streamer [30771] init_VideoIn failed
  6. вчера картинка была, запустил сегодня - картинки нет... ((( поскольку журнал ругался на флешку - форматнул ее в ext3, заново развернул Entware, поставил kmode_ndms в этот раз (получил замечание на отсутствие compat.ko) поставил пакеты mjpg-streamer* из test'овой ветки modprobe в этот раз как и положено ругается, что модуль уже в ядре: но видеокамеры нет запуск скрипта S96mjpg-streamer опять не возвращает ~# в консоль (процесс mjpg-streamer не появляется в htop) что-то совсем все сломалось.... (((
  7. с новым скриптом картинка в браузере есть.... правда периодически проскакивают полоски в 1 пиксель толщиной в верхней трети, потом посередине, потом в нижней трети (на не test пакетах) загрузка процессора в htop скачет от 100% (процесс mjpg-stream от 80% до 90%) status возвращает PID процесса mjpg-stream почему start не возвращает в консоль ~# ?
  8. скопировал вышеприведенный код в файл S98mjpg-streamer результат старый.... не возвращает в консоль ~# список запущенный модулей: журнал после запуска нового скрипта:
  9. поспешил это kmod без пррблем установился....
  10. по modprobe --first-time -v uvcvideo они оказывается не грузилиись.... (странно.. почему... разве так должно быть.... вроде ж раньше срабатывало...) загрузил руками и как результат ls: /dev/vid*: No such file or directory
  11. Ноя 12 22:11:33 ndm kernel: EXT4-fs (sda1): error count since last fsck: 13 Ноя 12 22:11:33 ndm kernel: EXT4-fs (sda1): initial error at time 1573490308: ext4_mb_generate_buddy:759 Ноя 12 22:11:33 ndm kernel: EXT4-fs (sda1): last error at time 1573568786: ext4_mb_generate_buddy:759 при том, что как так то.... после какого последнего запуска fsck счетчик ошибок 13 ?
  12. сделал проверку - все норм говорит.... ~ # badblocks -v /dev/sda1 Checking blocks 0 to 1957503 Checking for bad blocks (read-only test): done Pass completed, 0 bad blocks found. (0/0/0 errors)
  13. флешка для Entware отформатирована в EXT2 через два дня пользования в журнале появились записи ~ # mount /dev/sda1 on /tmp/mnt/f18c1b68-c0df-452b-ba18-7e516d270d5f type ext2 (rw,noatime) /dev/sda1 on /opt type ext2 (rw,noatime) Как понимать: плевать на текст "EXT4-fs" и считать, что флешка посыпалась или ?
  14. с пакетами из ветки test скрипт S96mjpg-streamer не возвращает ~# в командную строку....
×
×
  • Create New...