Jump to content

Saymer

Forum Members
  • Content Count

    23
  • Joined

  • Last visited

  • Days Won

    1

Saymer last won the day on September 20 2016

Saymer had the most liked content!

Community Reputation

4 Neutral

About Saymer

  • Rank
    Member
  • Birthday 04/25/1987

Converted

  • Location
    Москва
  • Interests
    IT, VoIP, телефония, GSM
  • Occupation
    Инженер IT отдела
  • Skype Account
    saymer.87

Equipment

  • Keenetic
    Ultra II, KN-1010, Extra II, 4GIII, VOX, Keenetic DECT

Recent Profile Visitors

552 profile views
  1. Присоединяюсь, у меня после последнего обновления так же. Ультра 2.
  2. Задал вопрос на двух форумах, поэтому часть ответов есть на другом форуме, а на этом ответов нет. Может кому пригодится, поэтому думаю, что стоит сюда скопировать. Так же прилагаю схему, которую хочу получить на выходе. Основная идея оставить режим точки доступа, но один LAN порт сделать с режимом роутера, что бы там можно было поднять VPN.
  3. Не могу добавить в сообщение выше. Спросил на другом форуме. По сути тоже самое, что выше, но может чуть понятнее будет, чем выше написал. Если возможно, то добавить в вопрос выше. vasek00 Скажите, хочу реализовать следующую задачу, увидел на картинке выше. Попробую описать, что хочу получить на выходе. Есть сеть предприятия, имеем сетку 10.0.4.0/24, DHCP выдается сервером в этой сетке. Есть роутер ZyXEL Keenetic 4G III rev.A. Раньше он работал у меня в режиме точки доступа, начиная с какой то версии появилось отдельный режим такой, переключается в web интерфейсе и проблем с этим нет, понятно. В этом режиме отключается NAT, а так же отключается встроенный DHCP сервер. При этом трафик со всех портов работает как на обычном неуправляемом коммутаторе, LAN и WAN порт объединяются и работают все одинаково. Так же там поднимается Wi-Fi точка доступа, которая находится в одном сегменте с LAN портами и все устройства, которые подключаются к этой Wi-Fi сети, которую создает эта точка доступа получают ip адреса от DHCP сервера сети предприятия и могут обращаться к другим компьютерам в этой сети, а другие компьютеры могут обращаться к клиентам, которые подключены по воздуху без каких либо проблем. Тут всё просто, понятно и логично. Далее, у меня возникла потребность сделать следующее. 1. Поднять ещё две Wi-Fi точки доступа с NAT. Два разных VPN подключения, для них две разных Wi-Fi сети. 2. Выделить один порт LAN для подключения через VPN. Остальные порты оставить как были в режиме точки доступа. Как я понял, в режиме ТД такое сделать невозможно. Поэтому вчера перевел устройство в режим роутера, и попытался настроить то, что описано выше. И надо сказать, у меня получилось это сделать. Правда, я проверял получение DHCP от сервера предприятия только клиентом по Wi-Fi, на проводных портах вчера не проверял. После, вчера установил ещё некоторые пакеты, что бы реализовать ещё клиента l2tp ipsec, а после и sstp сервер через облако. Сегодня сделал сброс, и попытался произвести настройки как вчера, и у меня ничего не вышло. Стал по разному разбираться, делал сброс несколько раз. Пришел к выводу, что если удалить компоненты, которых изначально вчера не было, а потом произвести настройку как вчера, они у меня сохраняются. С компонентами не настройки не сохранялись. Но вчера я проверял на Wi-Fi клиенте, что бы он получал DHCP от сервера предприятия. Сегодня я проверял на 3 портах LAN. И эти порты у меня не получали DHCP от от сервера предприятия. Один из вариантов, сделать 3 LAN порта - портами для TV приставки, тогда они объединятся в один с портом WAN, и клиенты проводные будут получать DHCP от сервера предприятия. Вопрос, а как сделать, что бы один из Wi-Fi сетей стал тоже получать как TV порт, если по другому сделать нельзя?
  4. Доброго времени суток! Имеется роутер Keenetic 4G III Rev.b, на котором установлена прошивка 2.12.B.0.0-4 (последняя на момент написания) этого поста. Имеется некоторая странная зависимость, прошивка работает по разному в зависимости от установленных компонентов. Вчера (по отношению ко дню написания поста), у меня всё работало как задумано. Но вчера, при меньшем количестве компонентов необходимые настройки удалось произвести, после была проверена работа, а после компоненты были установлены, и необходимая работа сохранилась. Исходя из этого я могу сделать вывод такой. Что если текстовый файл конфигурации сформировался правильно, и всё работает так, как задумано, то уже дальнейшая установка компонентов ничего не ломает. Если же установить все необходимые компоненты, потом сделать сброс и попытаться настроить всё ещё раз, но уже с компонентами, то уже ничего не работает. То есть, не работает совсем. При этом в журнале пишет ошибку, при попытке сохранения необходимой конфигурации. Сегодня спрашивал в чате неофициальной технической поддержки про это, но ответа там не получил и мне посоветовали написать вопрос здесь. Так как там есть некоторые скриншоты, то продублирую сюда ссылки из чата. https://t.me/Keenetic_ru/7977 Опишу, что хочу сделать и как сделано сейчас. Есть сеть предприятия, есть DHCP сервер и есть клиенты, которые подключаются к сети. Есть устройство Keenetic 4G III Rev.b с прошивкой 2.12.B.0.0-4. Ранее данный роутер работал в режиме ТД (точки доступа), сам ни каких изменений не вносил, DHCP не раздавал. Работал как коммутатор и раздавал при этом Wi-Fi. Проблем это не вызывало. Задумал сделать одну вещь. К одному из портов подключен SIP шлюз D-Link 5112s, который может работать только в режиме UDP или TCP. Он подключен к SIP серверу. На SIP сервере имеется возможность подключаться по VPN тоннелю, при этом сервер выдает маршруты, что до сервера идет только SIP трафик, а другой трафик идет как обычно, даже без создания отдельного профиля для отдельно устройства. Вчера взял и выделил отдельный порт, порт 1 в отдельный сегмент. Для этого сегмента сделал необходимые настройки и шлюз стал работать через VPN туннель как и задумано. Так же сделал отдельный сегмент, чисто с Wi-Fi сетью, и сделал там правило, что бы все устройства этого сегмента ходили через VPN сервер, другой VPN сервер, который находится во Франции. Это было сделано для того, что бы тестировать на предмет работы при всяких блокировках. Так же сделал третий сегмент. Третий сегмент это 3 порта LAN и Wi-Fi сеть, которые бы работали как в режиме точки доступа. Отключил там DHCP и снял чек бокс использовать NAT. Вчера у меня всё работало как и задумано, и я решил сделать сброс, что бы настроить всё так же, но с нуля. Но вот, пол дня ничего не получалось сделать, и тогда в качестве предположения я удалил все компоненты, и оставил только самые необходимые и всё стало работать нормально. Но всё равно немного не так как вчера. То есть от каждого компонента есть некоторая зависимость, но стабильной работы и зависимости от какого компонента это происходит мне пока установить не удалось. Одно только понятно, что если текстовый конфигурационный файл правильно сгенерирован, то всё работает нормально. Если же нет, то не работает. Файл генерирует web-интерфейс, который зависит от компонентов. Компоненты которые добавлял/удалял Режим клиента Wi-Fi - вчера этот компонент я не удалял, но сегодня удалил на всякий случай Клиент L2TP - нужно для подключения к серверу VPN SSTP VPN-сервер - для подключения к сети через облако, роутер за NAT находится L2TP/IPsec VPN-сервер - пишет, что это обязательный компонент IPsec VPN - на сервере l2tp ipsec Клиент OpenVPN - нужно для подключения к другому серверу Шлюз прикладного уровня (ALG) для SIP - вчера был, сегодня удалил его Контроль состояния интернет-подключения (Ping Check) - вчера был, сегодня удалил его Captive portal - вчера был, сегодня удалил И да, сегодня при попытке сохранить конфиг (при компонентах установленных) была вот такая вот ошибка. Июн 6 16:09:20 ndm Network::Nat: no removing NAT rule found. Вот эта ошибка. Но вчера её не было. self-test (1).txt self-test.txt
  5. При вводе этих значений, как там, ну адрес сервера, логин и пароль и ключ, статус соединения написано "Не готово". Почему оно не готово я не понял. А есть какое то решение по проблеме с прохождением пакетов?
  6. Я бы с радостью, но на сайте написано: Я как то пробовал настроить, но у меня не получилось, а там не написано как. А с OpenVPN сразу начало работать (после редактирования файла), и работало вполне успешно, пока пользователь не обновил прошивку, которому я и настраивал это. А вообще, почему так нужно делать, почему без этого не работает. Пользователь находится в СНГ, и его провайдер не пропускает SIP трафик, режет. Приходится заворачивать трафик в туннель. что бы провайдер не резал.
  7. Да, спасибо, опечатка. Сейчас (у меня на U II) прошивка 2.11.A.1.0-1. Но изначально я настраивал человеку, у него Z K 4GIII Rev.A.
  8. Доброго времени суток! Есть такой замечательный сервис talk37.ru, он же rovoip.net. Не так давно даже был добавлен в список провайдеров для Keenetic DECT, по просьбам, за что отдельное спасибо. Так вот некоторое время назад там был организован VPN сервер средствами SoftEtherVPN. На сайте talk37 есть инструкция, как это настроить, в том числе там есть и OpenVPN файл, конфигурационный файл. https://talk37.ru/voip/settings/vpn/ Обычно как делал я, когда проверял, брал этот файл, открывал его в блокноте, брал оттуда все данные, и как тут рекомендовали выше, логин и пароль указать в тегах. <auth-user-pass> "указать логин, а во второй пароль от устройства или внешней учётной записи."</auth-user-pass> На прошивке 2.10 данная схема завелась, и работала. На прошивке 2.11.A.1.0-1, возникает интересная проблема. Соединение так же устанавливается и работает, пакеты ходят, соединение есть. IP адрес роутер от сервера получает, всё с виду так же как и раньше было на 2.10. Но, если бы не одно но, SIP программы на сервере регистрируются, работают, даже делают исходящие вызовы, но нет звука. Не ходят пакеты RTP. Вот как такое может быть? И есть ли какие то пути решения этой проблемы? Из за того, что не ходят пакеты RTP, нет звука в обе стороны, а Gigaset 510 телефон вообще отказывается звонить и принимать вызовы.
  9. Трубка BBK китайская. Есть две штуки. Так же есть Панасоник, он она сейчас без стакана. Привёз на пробу с дачи её. С ней проблем нет. А с трубкой BBK есть. Могу ошибаться, но ранее, когда модуль только только вышел, стояла другая прошивка и эта трубка работала по другому, вроде даже вызовы INT работали на ней. В web интерфейсе по ней видно следующее: Номер трубки: 1 Модель: IPUI:008FD85AA5 Поддерживаемые технологии: DECT GAP Трубка гуглится эта как "марка: BBK товар: Радиотелефон BBK BKD-810". В принципе мне не критична эта трубка, покупал их при стоимости 600 рублей новыми, сейчас бы такие не купил бы ни когда. Провайдер - сервер talk37.ru он же ruvoip.net. С другими устройствами, в том числе Keenetic III и многострадальным Keenetic VOX ни каких проблем нет с этим сервером уже очень давно. КПВ и прочее, там всё отлично работает. А вот именно на трубке от BBK КПВ нет. Подозреваю, что проблема в трубке, но раньше, на другой прошивке в модуле КПВ были, на сколько я помню. Полностью перейти на K DECT не могу, потому что нужны входящие по ТфОП медной линии от МГТС. Можно конечно перейти на GPON, и оттуда SIP в модуль завести. Но с другой стороны сейчас всё работает нормально. Три трубки Gigaset. Одна трубка C610 и две трубки A440, подключены к базе Gigaset 610. Всё это работает в такой связке с 2012 года, подключено к talk37.ru. Ранее к базе Gigaset были подключены трубки BBK. КПВ там было. Так же КПВ было, если подключать эти трубки к базе Панасоник. КПВ нет только на KDECT.
  10. Нормальный DECT, это который по медной линии? Но что бы на медной линии сделать отбой, начала нужно поднять трубку, занять линию, а потом положить трубку. Тогда будет отбой. Это же не SIP, где можно подать код отбоя в линию. Но, если трубки умеют подавать сигнал отбоя, то, почему бы тогда не реализовать эту возможность. Медными линиями сейчас меньше пользуются людей, чем раньше. Так же вопрос по K_DECT есть. Возник давно. Есть трубка BBK, когда только появился модуль, там были КПВ. Сейчас же, при звонках там тишина, КПВ нет. Но когда на вызываемой стороне берут трубку связь есть. Но без КПВ жутко бесит это. Мне не критично это, не пользуюсь. Не знаю, стоит ли по этой причине создавать тему здесь? Я так понимаю, нужно новую создать и все логи приложить там?
  11. Saymer

    Интересная информация. Я попытки давно забросил. Прошил подходящий Keenetic на прошивку от Padavan и там всё работает из коробки. У меня модемов много, они меняются местами и мне их кроме как по IMEI различать по другим признакам нельзя. Кодек у меня везде только alaw установлен. Нагрузка разная, раньше была 0-3% от одного модема, теперь периодически стала до 20% от одного модема. Правда я на модемах прошивку обновлял, поставил 21 версию. На текущий момент у меня 12 модемов. Из них все 1550 модемы. Один правда 173 модем в 209 прошивкой. Но есть особенность. подходят устройства на MTK 7620. Устройства MTK 7621 больше 4 модемов не видят, не знаю почему. Может какая то особенность, не разбирался в этом дальше. Просто для себя сделал такой вывод. На подходе микрокомпьютер Orange PI, у него процессор по мощнее и есть положительные кейзы по работе модемов на нём. Сейчас модемы подключены по IAX2, раньше были по SIP. Но с IAX2 есть тоже проблемы, залипает соединение. Хотя и хорошо проходит через NAT. Доступ и управление организованно через вход в домашнюю сетку по IPSec и дальнейшее обращение на приватные адреса шлюза. На текущий момент модемы работают под управлением ПО Padavan на Keenetic 4G III Rev. A.
  12. У меня вылезают аналогичные сообщения на нескольких устройствах. На прошивке 2.08 (актуальная версия), после сброса они не пропали. Устройства Keenetic Extra, Keenetic III, Keenetic Ultra II.
  13. Saymer

    Решение я сегодня нашел. На первый взгляд оно довольно абсурдное. Если работать на Keenetic Giga II на прошивке v2.06(AAFS.4)C1 на респозитарии чем это грозит? Нет смысла переходить на 2.08, если нужен только Астериск?
  14. Saymer

    Жаль, что это мало кому нужно, и это не приоритетная задача. Как я понимаю, решение здесь существует, но мне оно не известно. А тем, кому оно известно, этими вещами заниматься не будут.
  15. Saymer

    По описанию похоже на эту проблему
×