Jump to content

Kvazar

Forum Members
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Kvazar

  • Rank
    Newbie

Equipment

  • Keenetic
    Giga III

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Kvazar

    Проблема решилась сменой На iptables -t nat -A PREROUTING -p tcp --dport 80 -j DNAT --to-destination 10.0.0.100:80 iptables -t nat -A POSTROUTING -p tcp -d 10.0.0.100 --dport 80 -j SNAT --to-source 10.0.0.1 Огромное спасибо ICMP за помощь!
  2. Kvazar

    Итак, что я имею: Раутер перезагрузил. Но маршрут до 99… все еще через ISP Про НАТ на сервере я бы и сам задумался, но ведь при подключении с Windows всё работает! Порт пробрасывается, пакет доходит до машины и возвращается во внешний интернет (предварительно конечно отключал впн на раутере, проверял с телефона с интернетом от мобильного оператора). Почему у раутера так не получается P.S.: Просто на всякий случай, в настройках везде конечно реальный айпи, а не 99, я его только на скриншотах подрисовываю.
  3. Kvazar

    Простите, а где именно выбрать? В настройках PPTP подключения? Или новый раут создать и там выбрать ISP как гейтвей? Если раут - то до какого из узлов?
  4. Kvazar

    Так я его и не добавлял, у меня только такой: Что с ним что без него 10.0.0.1 пингуется, но админка раутера не открывается. 99.99.99.99 пингуется, но опять же админку не открывает. Сейчас у меня в разделе статические маршруты пусто, но в системном мониторе - маршруты всё еще висит раут на 99... через ISP.
  5. Kvazar

    Заметил такую деталь еще: Я предполагал, что в результате добавления статического маршрута трафик до этого узла должен идти через PPTP0 и шлюз 10,0,0,100, а не ISP и 192.168.100.1?
  6. Kvazar

    К сожалению, это не помогло (айпи раздался правильный - 10.0.0.100, на который и проброшены порты на сервере VPN). Я так и предполагал, но это уже был жест отчаяния
  7. Добрый день! Я нахожусь за NAT провайдера. Мой айпи серый и динамический, например 66.66.66.66 У меня есть арендованный виртуальный сервер с Ubuntu на борту. У сервера белый статический айпи, например 99.99.99.99. На нем настроен PPTP сервер и проброс 80 порта: iptables -t nat -A PREROUTING -p tcp --dport 80 -j DNAT --to-destination 10.0.0.100:80 iptables -t nat -A POSTROUTING -p tcp -d 10.0.0.100 --dport 80 -j SNAT --to-source 99.99.99.99 При подключении к этому VPN с компьютера под управлением Windows (из моей сети) я снимаю галочку Use as default gateway и выполняю следующую команду: route -p add 99.99.99.99 mask 255.255.255.255 10.0.0.100 при этом я получаю следующее поведение: 1. Скорость моего подключения к интернету остается полной и соответствует заявленной провайдером. 2. Мой айпи с точки зрения всех сервисов остается 66.66.66.66 3. Самое главное - при запросе к айпи 99.99.99.99 открывается веб-сервер моего компьютера под управлением Windows - то есть, я получаю белый айпи без необходимости трясти провайдера. Я бы хотел получит аналогичное поведение при подключении к этому VPN со своего раутера Zyxel Keenetic Giga III - хочу чтобы все запросы по айпи 99.99.99.99 приходили на мой раутер и я дальше сам их распределял по своей локальной сети на основании правил Port Forwarding без необходимости подключать к VPN каждый узел сети по отдельности. Таким образом в настоящий момент, я ожидаю что при обращении к айпи 99.99.99.99 по 80 порту у меня откроется панель управления раутером. Остальные правила маршрутизации я намерен настроить позднее. Настройки, которые я применяю для подключения к VPN (скриншоты): Раутер успешно подключается к VPN, получает айпи 10.0.0.100 и успшено пингует сервер по айпи 10.0.0.1, сервер тоже может пропинговать раутер по айпи 10.0.0.100 Но при открытии адреса 99.99.99.99 в браузере я получаю Page can not be loaded. Вопрос: что я делаю не так и как мне добиться ожидаемого результата? Почему эта схема успешно работает в Windows, но не работает в моем раутере? Буду очень признателен за любую помощь! P.S.: Версия прошивки - v2.07(AAUW.5)C3
×
×
  • Create New...