Jump to content

Search the Community

Showing results for tags 'l2tp'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Keenetic Community
    • Keenetic Development
    • Keenetic Community Support
    • KeeneticOS Testing
    • Mobile App
  • Open Package Support
    • Opkg Help
    • Opkg Cookbook
    • Opkg Cookbook RUS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Web-site


Interests


Occupation


AOL Account


ICQ Account


WLM


YAHOO


Facebook Account


Twitter Account


Skype Account


Youtube Account


Google+ Account


Keenetic

Found 20 results

  1. Сделайте пожалуйста чтобы l2tp сервер мог работать через сертификат, загруженный или самоподписанный.
  2. Приветствую! Постараюсь изложить наиболее подробно. Дано: Дома роутер Keenetic 4G III подключенный к интернету от Билайна по витой паре через L2TP. Стационарный компьютер c Windows 10 / Ubuntu 18.04.2 на борту подключен к роутеру (1) по витой паре. Ноутбук c Windows 10 / Ubuntu 18.04.2 на борту подключен к роутеру (1) по wi-fi. Nokia 6.1 с Android 9 на борту. Motorola MOTO G5 с Android 8.1 на борту. На работе роутер Keenetic (модель не известна) подключенный к интернету от Yota через USB-модем. Что работает: Компьютер (2), Ноутбук (3) и Moto G5 (5) подключаются к интернету (1) успешно, тесты скорости от Ookla и Yandex показывают заявленную провайдером скорость (50 мб/с на отправку и получение) Nokia (4) подключаются к интернету (6) успешно, тесты скорости от Ookla и Yandex показывают скорость исходящего и входящего трафика установленную в личном кабинете Yota. Nokia (4) подключается к точке доступа на Moto (5) успешно, тесты скорости от Ookla и Yandex показывают скорость соответствующую 4G. Что не работает: Nokia (4) при подключении к интернету через роутер (1) не может отправить сообщения в Viber и Whatsup; Тест скорости от Yandex показывает входящий трафик 50 мб/с, исходящего трафика нет; Тест скорости от Ookla показывает входящий и исходящий трафик на скорости 60 мб/с; Тест скорости приложением Meteor показывает входящий трафик 50 мб/с, исходящего трафика нет Вопрос: Что может быть не так в схеме подключения Nokia 6.1 -> wi-fi -> Keenetic 4G III -> Билайн -> L2TP (от билайна) -> интернет? Какие тесты провести и какие логи смотреть чтобы узнать где проблема? Спасибо!
  3. При обновлении роутера Giga II с версии 2.13 до последней версии, при использовании VPN подключения по типу L2TP для выхода в интернет через сервис Frootvpn, получил перезагрузку роутера спустя 10-20 секунд после подключения к VPN. При этом если использовать тип подключения PPTP все нормально работает.
  4. Alexander_74

    Добрый день! Прошу помощи в настройке туннеля L2TP на Keenetic DSL на прошивке 2.11.C.1.0-3. Туннель не устанавливается. Прошу прощения, если попал не в ту ветку, продублировал сообщение сюда, т.к. похоже та 2.11, что в архиве, уже закрыта. Ситуация следующая: имеется два маршрутизатора Keenetic II и Keenetic DSL, первый из которых имеет белый адрес, и на нем необходимо поднять VPN-сервер для связи со вторым маршрутизатором. Маршрутизаторы используют разных провайдеров. В целом, схема работает, т.к. уже пользовался PPTP-сервером, но назрело время перемен, сейчас PPTP не устраивает, решил перейти на l2tp/IPsec. Установил на Keenetic DSL прошивку 2.11.C.1.0-3 заменой файла firmware (стояла официальная 2.05) из webUI с целью получить L2TP/IPSec клиента. На Keenetic II (2.12.C.1.0-6, поставил также с целью заполучить L2TP/IPSec сервер, до этого стояла официальная 2.06) и поднял сервер. Сразу оговорюсь, что пробовал подключаться к серверу используюя провайдера, где установлен Keenetic DSL, и с помощью Windows-клиента и c помощью Android 5 - соединение работает, причем выход в интернет осуществлялся через keenetic DSL. Однако сам Keenetic DSL подключиться встроенными средствами к серверу не может. Исходя из этого, сделал вывод, что провайдер, скорее всего, не виноват, и дело не в сервере, а в клиенте. Соединение находится в постоянном цикле - канал установлен - внезапно разорван, судя по логу: сначала пишет L2TP0 is up, но через некоторое время "appeared down". Имеется также self-test, снятый во время подключения, приложу в следующем скрытом сообщении. keenetic.log
  5. Добрый день! Подскажите, как настроить подключение L2TP/IPsec с Keenetic DSL? Прошивка: v2.05(AAGK.0)C7 В настройках туннеля есть только настройки проверки подлинности (MS-CHAP) и логин/пароль L2TP. Параметров IPSec нет. Насколько я понял, что IPSec вообще нету в Keenetic DSL на этой версии прошивки. Как же тогда пользоваться L2TP? P.S.Сервер настроен на Keenetic II после установки delta-прошивки 2.12.C.1.0-6. Ставил через CLI (components list delta -> components commit). Однако, такой фокус на Keenetic DSL не прошел, пишет argument parse error. Также читал, что некоторые delta-прошвики на DSL могут привести к неработоспособности самого DSL модема. Если ставить delta-прошивку, то какую лучше ставить на DSL? И как это сделать? Прошу прощения, если попал не в ту ветку или данная тема уже поднималась.
  6. Суть задачи следующая. Основной интернет канал на даче по проводу, резервный на модеме с серым адресом создаю соединение на Zyxel Ultra II на интерфейсе модема l2tp + ipsec до сервера с прямым адресом на сервере делаю проброс порта 3389 на адрес полученный Zyxel а на Zyxel правило проброса 3389 в локальную сеть на ПК Не работает... Если Mikroik -> Mikrotik работает Мне надо что бы Mikrotik сервер VPN -> Zyxel работало.... Перепробовал разные комбинации настроек - чет никак... Может быть есть какой то другой способ что бы в случаи падения основного канала можно было достучаться до внутренней сети и сервисов... Или я чет не там где то настраиваю? Если кто то делал что то подобное напишите пожалуйста как чего куда.... p.s. где l2tp ipsec на Zyxel - c галочкой использовать для доступа в интернет и без нее результат одинаковый прошивка 2.10.C.1.0-0
  7. Всем доброго времени суток! Трабл в следующем: при копировании через l2tp файла размером 2,74 ГБ на винт, подключенный к роутеру, рвется соединение, когда остается буквально 200-300 метров. Пробовал раза 3-4 - результат всегда одинаковый. Этот же файл, но через pptp, копируется без проблем, отладку прилагаю Keenetic Giga II, версия NDMS 2.11.A.8.0-8
  8. Обратил внимание на такую странность. Если вручную остановить L2TP-соединение, или поменять его параметры так, что кинетик его сам останавливает, фактически интерфейс еще остается в работе. Я это заметил, работая удалённо, через TeamViever. Поменял параметры соединения, кинетик показывает, что оно неактивно, но ... я продолжал работать! При этом в журнале видно, что кинетик пытается заново подключиться к серверу, но получает ошибку CHAP-авторизации too many connections. Выходит, что L2TP зависает в поднятом состоянии, при этом NDMS считает, что он прибит и пытается поднять его снова. А сервер не пускает, потому что сессия и у него еще в UP state. Через пару минут сессия таки рвётся и кинетик её нормально завязывает вновь. Это ПОСТОЯННО воспроизводимая ситуация, не разовая. Прошивка - последняя 2.07, доступная в релизном канале. В чём может быть причина такого поведения?
  9. Товарищи, не планируется ли реализация полноценного сервера vpn на наших девайсах, а не тот куцый что есть сейчас только с PPTP, хотелось бы l2tp шифрование и ему подобное.
  10. Здравствуйте, имеется Keenetic Giga белый, прошивка v2.04(USD.9)C7 на котором настроено в и запущено VPN подключение PPTP. Вопрос: как сделать так, чтобы конкретные адреса из локальной сети имели доступ в интернет через VPN, при том, чтобы остальные имели обычный доступ через провайдера? И вопрос №2: можно ли как-то организовать роутинг, чтобы к определенным адресам (не всем) доступ был через VPN для всех локальных ip?
  11. Всем добра. Столкнулся со странной штукой. Имеется 2 провайдера (beeline(l2tp) и 2kom(IPoE), билайн основной), во время загрузки больших торрентов на ПК заметил "мистику", в uTorrent скорость периодически повышается выше 100 мегабит, точнее наблюдал 130 мегабит, это как раз сумма обоих каналов. Не поверил, на резервном включил ускорение до 100 мегабит, и действительно, суммарная скорость поднялась до 200 мегабит, думаю интересно.... При этом происходят чудеса с подключениями, l2tp от билайна постоянно отваливается и снова подключается, думаю в этом и кроется причина активации второго канала, похоже, что пока билайн отвалился, utorrent успевает поднять подключения через другой канал и не отпускает их даже, когда билайн "возвращается". Эта бага конечно хорошо, при загрузке "больших" торрентов начинает приносить пользу резервный канал, но с другой стороны напрягает регулярная падучесть l2tp, если эта бага/фича с суммированием скорости действительно работает при отключении основного канала, то я это и руками смогу делать, а вот падения коннектов нужно посмотреть/подчинить. Ниже собственно скрины, на которых видно, что оба провайдера работают, ни каких маршрутов сам не прописывал, все происходит во время скачки торрентов с ПК, который подключен по проводу. ниже добавлю селф в моменты падения подключения l2tp
  12. Только сейчас заметил то, на что, похоже, никто не обратил внимание в теме Периодически отваливается L2TP/IPSec соединение - при использовании L2TP/IPSec соединения отваливается только L2TP без пересогласования IPSec. Поэтому скромно спрошу у уважаемых администраторов, программистов и @Le ecureuil персонально - не появилось ли у Вас новых идей, почему такое может быть? Полный селфтест, как обычно, в следующем сообщении. PS Более того, VPN провайдер, похоже, не считает это событие разрывом соединения, потому что, например, сохраняется port-forwarding, запрошенный в начале соединения.
  13. Обратил внимание, что для моего L2TP/IPSec соединения (конфиг ниже прилагаю) очень странно работает tcp adjust-mss pmtu с некоторыми сайтами, например forum.keenetic.net, сервисы google (например, получение почты через мобильный клиент, hangouts через web-интерфейс и пр.) - для пользователя это выглядит как очень медленное, с таймаутами, соединение. Но если проявить настойчивость, то после нескольких таймаутов соединение с сайтом устанавливается и все начинает работать как положено, до отключения L2TP/IPSec соединения. При соединении через PPTP такого не наблюдается. Как можно исправить эту проблему понятно, поставить в ip tcp adjust-mss значение поменьше, но хотелось бы, чтобы заработало и tcp adjust-mss pmtu. Версия прошивки v2.09(AAUX.5)A3
  14. Добрый день! Прошу подсказки по настройке прозрачного (без NAT) роутинга между private-интерфейсами, когда один из них - L2TP/ipsec туннель. L2TP0 интерфейс на KeeneticII имеет security-level private, no global, прописана команда ip nat L2TP0, чтобы с сервера проходили пакеты к условному хосту 7.7.7.7, который доступен только через один из WAN-портов KeeneticII. Я ожидаю, что команда ip nat L2TP0 приведет к трансляции адресов из подсетей 192.168.200.0/24 и 192.168.230.0/24 при отправке пакетов в public-интерфейсы KeeneticII (к хосту 7.7.7.7, например), а при обращении к хостам из подсети 192.168.60.0/22 пакеты будут проходить прозрачно. Однако wireshark, запущенный на 192.168.60.40 показывает, что при пинге с адресов 192.168.230.33 или 192.168.200.130 хоста 192.168.60.40 источником пакетов является 192.168.60.1 Как сделать, чтобы хосты на разных концах туннелей этого RAS обращались друг к другу без NAT? Схема подключения для наглядного понимания на рисунке ниже.
  15. Ребята приветствую. Подскажите на кинетиках есть возможность настроить l2tp сервер без костылей (l2tp клиент вроде поддерживается)? Есть ли возможность менять стандартный порт 1701 по udp пртоколу на нестандартный?
  16. Добрый вечер Бьюсь с проблемой, но не получается. Есть Кинетик (первый вроде), release: v2.04(BFW.2)C7 Подключен к провайдеру по 3G и к частной сети по PPTP. NAT включен только для соединения 3G, при создании PPTP галку "Выход в интернет" убрал. В VPN соединение прокинут маршрут к SIP шлюзу и он успешно пингуется. Однако, при попытке регистрации SIP клиентом на шлюзе получаю проблему из-за того, что кинетик натит пакеты в PPTP соединении (хотя вообще не должен был бы?), и делает это крайне странно - подменяя адрес источника на адрес провайдера сети 3G, что мне совсем не понятно... Когда-то стоял SIP ALG шлюз, но я его снес и делал команды config, components, далее команда remove nathelper-sip, commit В списке компонентов его нет, но проблема есть. Как быть подскажите?
  17. Giga II v2.09(AAFS.3)A0 Роутер не может установить соединение по L2TP/IPsec к сервису HideMy. Обратился в тех поддержку сервиса но те после непродолжительной переписки предположили,что дело в роутере.
  18. Собственно, сабж. Обратил внимание после того, как заметил, что соединение периодичски замирает буквально на несколько секунд. В логах увидел, что L2TP соединение существует ровно 5 минут 42 секунды, отваливается и подключается снова. Выглядит это так (свой внешний белый IP забил крестиками): Self-test прилагаю. Пока переключился на PPTP, там никаких обрывов соединения не наблюдается. Вопрос, как обычно, кто виноват и что делать? UPD: Просматривая ночные логи увидел, что с такими же симптомами отваливается модем, только время отвала у него другое:
  19. На моем GIGA II стоит последняя 2,08 А11. К интернету подключен через WISP от Keenetic 4G III. Еще с А10 заметил что при перезагрузке сами не подключались 2 соединения L2TP/IpSEC до офисных микротиков. Вручную подключались без проблем. После обновления до А11 все осталось так же. Затем подключения были снесены, что бы заново настроить. И тут начались странности: первое подключение создалось, подключилось, но после создания второго, первое удалялось. Решив оставить одно соединение, я перегрузил роутер, после чего у него начало идти циклическая перезагрузка. Помог только сброс роутера в начальные настройки. Но и после этого при поднятии L2TP/IpSEC соединения при перезагрузке роутер из нее не выходит. Что это баг системы? Или проблема именно с роутером? self-test выложу при необходимости
  20. goddamnlb

    Добрый день, господа. Есть необходимость поднять l2tp сервер на роутете (Giga II). Подключил Entware, поставил xl2tp, настроил конфиг, а дальше не знаю, куда мне копать. Когда пробую запустить сервер в режиме отладки xl2tp -D, он сообщает xl2tpd[2064]: open_controlfd: Unable to open /opt/var/run/xl2tpd/l2tp-control for reading. До этого l2tp/pptp сервер доводилось разворачивать только на обычных gnu/linux дистрах.
×
×
  • Create New...