Jump to content
  • 0
r13

На KN1810 не выгружается selftest 2

Question

Добрый вечер

Перешел на ультре на ветку 3.6(альфа 5)

И столкнулся с проблемкой как раньше

Сразу после загрузки  селфтест выгружается(его и приложу) а через какое-то (пока проверяю на следующий день после запуска) попытка выгрузки селфтеста приводит к подвисаню процесса, и веб становится не доступен. работоспособность в какой-то мере сохраняется.

Тогда это было из-за большого количества маршрутов, и их удаление исправляло ситуацию, сейчас это не помогает. лог при этом следующий:

Скрытый текст

ov 11 17:50:23 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1200 seconds.
Nov 11 17:50:45 192.168.255.1 ndm: Core::Watchdog: SCGI Session /var/run/ndm.scgi.socket holds CORE (2) lock 1256 seconds acquired Nov 11 17:29:49.
Nov 11 17:50:45 192.168.255.1 ndm: Main: "SCGI Session /var/run/ndm.scgi.socket": backtrace:
Nov 11 17:50:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:50:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:50:53 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1230 seconds.
Nov 11 17:51:23 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1260 seconds.
Nov 11 17:51:45 192.168.255.1 ndm: Core::Watchdog: SCGI Session /var/run/ndm.scgi.socket holds CORE (2) lock 1316 seconds acquired Nov 11 17:29:49.
Nov 11 17:51:45 192.168.255.1 ndm: Main: "SCGI Session /var/run/ndm.scgi.socket": backtrace:
Nov 11 17:51:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:51:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:51:53 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1290 seconds.
Nov 11 17:52:23 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1320 seconds.
Nov 11 17:52:45 192.168.255.1 ndm: Core::Watchdog: SCGI Session /var/run/ndm.scgi.socket holds CORE (2) lock 1376 seconds acquired Nov 11 17:29:49.
Nov 11 17:52:45 192.168.255.1 ndm: Main: "SCGI Session /var/run/ndm.scgi.socket": backtrace:
Nov 11 17:52:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:52:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:52:53 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1350 seconds.
Nov 11 17:53:16 192.168.255.1 ndhcps: DHCPREQUEST received (STATE_RENEWING) for 192.168.250.41 from 2c:f4:32:04:9b:97.
Nov 11 17:53:17 192.168.255.1 ndhcps: sending ACK of 192.168.250.41 to 2c:f4:32:04:9b:97.
Nov 11 17:53:23 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1380 seconds.
Nov 11 17:53:45 192.168.255.1 ndm: Core::Watchdog: SCGI Session /var/run/ndm.scgi.socket holds CORE (2) lock 1436 seconds acquired Nov 11 17:29:49.
Nov 11 17:53:45 192.168.255.1 ndm: Main: "SCGI Session /var/run/ndm.scgi.socket": backtrace:
Nov 11 17:53:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:53:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:53:53 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1410 seconds.
Nov 11 17:54:23 192.168.255.1 ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 1440 seconds.
Nov 11 17:54:45 192.168.255.1 ndm: Core::Watchdog: SCGI Session /var/run/ndm.scgi.socket holds CORE (2) lock 1496 seconds acquired Nov 11 17:29:49.
Nov 11 17:54:45 192.168.255.1 ndm: Main: "SCGI Session /var/run/ndm.scgi.socket": backtrace:
Nov 11 17:54:45 192.168.255.1 ndm: Main:   <unknown>+0x0
Nov 11 17:54:45 192.168.255.1 ndm: Main:   <unknown>+0x0

 

 

Edited by r13

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Проверил на своем KN-1810. self-test выгружается нормально и со страницы "Общие настройки системы" и со страницы "Диагностика". Отработал более 4-х суток:

Скрытый текст

792968748__800.png.dfad483ea18c5fc7eead7e18c5c355f1.png

 

Share this post


Link to post
Share on other sites
  • 0
5 минут назад, AndreBA сказал:

Проверил на своем KN-1810. self-test выгружается нормально и со страницы "Общие настройки системы" и со страницы "Диагностика". Отработал более 4-х суток:

  Показать содержимое

792968748__800.png.dfad483ea18c5fc7eead7e18c5c355f1.png

 

Не сомневаюсь, это я на очередные свои грабли наткнулся, рядом вива стоит, на ней все выгружается.

Edited by r13

Share this post


Link to post
Share on other sites
  • 0

IPsec заклинивает похоже. А что настроено в плане IPsec при этом?

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
4 минуты назад, Le ecureuil сказал:

IPsec заклинивает похоже. А что настроено в плане IPsec при этом?

Включены Ikev1/ikev2/l2tp/ipsec сервера без подключений и 1 ikev2 исходящий туннель

все.

Share this post


Link to post
Share on other sites
  • 0

Надо будет проверить, я слышал о чем-то подобном при ike-подключении клиентском.

Share this post


Link to post
Share on other sites
  • 0
5 минут назад, Le ecureuil сказал:

Надо будет проверить, я слышал о чем-то подобном при ike-подключении клиентском.

Со своей стороны проверю как без него будет работать. 

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Le ecureuil said:

IPsec заклинивает похоже. А что настроено в плане IPsec при этом?

Аналогично на KN-1010. Надо было сейчас self-test выгрузить - веб-морда зависла и выдала HTTP 504. Пришлось перезагрузить роутер по питанию. Поднят IPsec-туннель до другого Keenetic. 

Share this post


Link to post
Share on other sites
  • 0

Да чего-то не то с ipsec

Сутки без клиента проработал все ок, работает штатно

Включил клиента, клиент завис, ну и селфтест тоже сдулся сразу

кусочек лога в следом

 

 

 

В 11.11.2020 в 19:56, Le ecureuil сказал:

Надо будет проверить, я слышал о чем-то подобном при ike-подключении клиентском.

 

Share this post


Link to post
Share on other sites
  • 0

@r13 С какой версии примерно это стало воспроизводится? На 3.5 было?
 

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Le ecureuil сказал:

@r13 С какой версии примерно это стало воспроизводится? На 3.5 было?
 

Надо поисследовать, на ультру на которой ipsec как раз первый раз 3.6а5 установил, до этого 3.5.2 стояла. Откачу на нее, убедюсь что на ней точно ок.

Edited by r13
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, Le ecureuil said:

@r13 С какой версии примерно это стало воспроизводится? На 3.5 было?
 

У меня на 3.5.2 воспроизводится.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

У меня уже 2е суток работает на 3.5.2

Пока не воспроизвелось.

Share this post


Link to post
Share on other sites
  • 0

@Le ecureuilвобщем на 3.5.2/3.5.3 воспроизвести не улалось.

Еще из странного на 3.6 при одном ike клиенте все ок, а воспроизводится при наличии 2х ike клиентов, причем один из них даже может быть выключен, это странно влиять вроде как не должно 🤔

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

На 3.6 Alpha 5 KN-1010 в какой-то момент зависло выполнение "show ipsec" в CLI. Из настроенного - два IPIP-туннеля и VirtualIP. В этот момент были проблемы с одним из IPIP

Воспроизвести повторно пока не удалось

Share this post


Link to post
Share on other sites
  • 0
8 минут назад, KorDen сказал:

На 3.6 Alpha 5 KN-1010 в какой-то момент зависло выполнение "show ipsec" в CLI. Из настроенного - два IPIP-туннеля и VirtualIP. В этот момент были проблемы с одним из IPIP

Воспроизвести повторно пока не удалось

А в логе далее что-то есть про завиcший ipsec есть что нибудь?

У меня после этого постоянно идут сообщения unable to send с увеличивающимся таймером.

Share this post


Link to post
Share on other sites
  • 0
9 минут назад, r13 сказал:

А в логе далее что-то есть про завиcший ipsec есть что нибудь?

У меня после этого постоянно идут сообщения unable to send с увеличивающимся таймером.

Да

О, я и себе на KN-1810 поломал только что посредством show ipsec :P

W [Nov 28 10:17:15] ndm: Core::Watchdog: Session /var/run/ndm.core.socket holds CORE (2) lock 65 seconds acquired Nov 28 10:16:11.
W [Nov 28 10:17:15] ndm: Main: "Session /var/run/ndm.core.socket": backtrace:
W [Nov 28 10:17:16] ndm: Main:   <unknown>+0x0
W [Nov 28 10:17:16] ndm: Main:   <unknown>+0x0
W [Nov 28 10:17:32] ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 30 seconds.

Всего-то одно "клиентское" IPIP и запущенный VirtualIP + L2TP/IPsec, но активен только IPIP.

Edited by KorDen

Share this post


Link to post
Share on other sites
  • 0

А вот что этому предшествовало похоже

I [Nov 26 23:25:37] ndm: Network::Interface::SecureIpTunnel: "IPIP0": IPsec client layer is up, do start tunnel
                    layer.
C [Nov 26 23:25:37] ndm: Network::Interface::SecureIpTunnel: "IPIP0": system failed [0xcffd02f7], unable to change
                    tunnel settings: file exists.
C [Nov 26 23:25:37] ndm: Network::Interface::SecureIpTunnel: "IPIP0": system failed [0xcffd00a9].
I [Nov 26 23:25:37] ndm: Network::Interface::SecureIpTunnel: "IPIP0": secured tunnel is ready.

 

Edited by KorDen

Share this post


Link to post
Share on other sites
  • 0
21 минуту назад, KorDen сказал:

Да

О, я и себе на KN-1810 поломал только что посредством show ipsec :P


W [Nov 28 10:17:15] ndm: Core::Watchdog: Session /var/run/ndm.core.socket holds CORE (2) lock 65 seconds acquired Nov 28 10:16:11.
W [Nov 28 10:17:15] ndm: Main: "Session /var/run/ndm.core.socket": backtrace:
W [Nov 28 10:17:16] ndm: Main:   <unknown>+0x0
W [Nov 28 10:17:16] ndm: Main:   <unknown>+0x0
W [Nov 28 10:17:32] ndm: Event::Forwarder: unable to send "Event::Type::DbKey" to "IpSec::Manager" for 30 seconds.

Всего-то одно "клиентское" IPIP и запущенный VirtualIP + L2TP/IPsec, но активен только IPIP.

Ага, похоже тоже самое :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...