Jump to content
  • 0
Vladimir Dobromyslov

KeenDNS на версии 3.5.4 и выше не NAT loopback

Question

Имеется  KN-1111 с прошивкой 3.4.12 и все замечательно работает. Белый динамический ip и настрое KeenDNS с разными правилами пробросов портов и поднятым VPN.
После обновления на 3.5.4 из локальной сети невозможно достучаться по адресу KeenDNS. Запросы уходят совсем на другой ip и там теряются.
NAT loopback очень странно работает.
Повторное обновление на 
3.4.12 возвращает работоспособность KeenDNS из локальной сети. но делает невозможность добавить компоненты VPN серверов, так как это моментально обновляет прошивку до последней стабильной. Замкнутый круг однако! 
Проблема частично решается с помощью костыля (использования стороннего DDNS) 
Но хочется использовать старый добрый KeenDNS. 
Help!

  • Thanks 1

Share this post


Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0

У Вас не один из этих KeenDNS?

Скрытый текст

mykeenetic.com, mykeenetic.ru, mykeenetic.net, mykeenetic.by. Домен mykeenetic.kz

Если вдруг, да. Возможно это вам поможет.

Edited by AndreBA

Share this post


Link to post
Share on other sites
  • 0

К сожалению нет. Пробовал сбрасывать роутер до заводских с регистрацией нового домена keenetic.pro. Эффект тот-же. Интересно что при откате на предыдущую все работает. Почти все. если бы компоненты можно было добавить.

18 minutes ago, AndreBA said:

У Вас не один из этих KeenDNS?

  Reveal hidden contents

mykeenetic.com, mykeenetic.ru, mykeenetic.net, mykeenetic.by. Домен mykeenetic.kz

Если вдруг, да. Возможно это вам поможет.

 

Share this post


Link to post
Share on other sites
  • 0
On 11/29/2020 at 8:10 PM, Vladimir Dobromyslov said:

После обновления на 3.5.4 из локальной сети невозможно достучаться по адресу KeenDNS. Запросы уходят совсем на другой ip и там теряются.

А из интернета запросы на правильный ip идут?

Share this post


Link to post
Share on other sites
  • 0

такая же проблема. заметил что появляется статическая запись xxxx.keentic.pro  78.47.125.180

проверить можно командой в cli

  more temp:ndnproxymain.conf

в версии 3.4.12 и 3.6alpha5 запись не появляется и все работает

непонятно что с этим делать. 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
On 11/29/2020 at 8:10 PM, Vladimir Dobromyslov said:

Имеется  KN-1111 с прошивкой 3.4.12 и все замечательно работает. Белый динамический ip и настрое KeenDNS с разными правилами пробросов портов и поднятым VPN.
После обновления на 3.5.4 из локальной сети невозможно достучаться по адресу KeenDNS. Запросы уходят совсем на другой ip и там теряются.
NAT loopback очень странно работает.
Повторное обновление на 
3.4.12 возвращает работоспособность KeenDNS из локальной сети. но делает невозможность добавить компоненты VPN серверов, так как это моментально обновляет прошивку до последней стабильной. Замкнутый круг однако! 
Проблема частично решается с помощью костыля (использования стороннего DDNS) 
Но хочется использовать старый добрый KeenDNS. 
Help!

Друзья! Посыпались обращения в поддержку и сюда тоже. Всему виной выпавшее условие на облачный режим и wildcard-запись *.имя.keendns-домен, которая поначалу казалась незаметным улучшением в работе доменов 4-го уровня из локалки. Всё в сумме вылилось в такую проблему. Планируем включить исправление в draft 3.6 на выходные. Вернём, как было.

  • Thanks 3

Share this post


Link to post
Share on other sites
  • 0
В 04.12.2020 в 09:51, ndm сказал:

Планируем включить исправление в draft 3.6 на выходные. Вернём, как было.

А каким образом можно в данный момент восстановить работоспособность домена из локалки? Возможно почистить какие-то данные "руками"? Полный сброс не хотелось бы делать.

Share this post


Link to post
Share on other sites
  • 0

3.6 Alpha 8 пока по-прежнему не работает. Как говорится лучшее враг хорошего.

Как вариант, пока откатить на 3.4.12 и добавить нужные компоненты через CLI или использовать сторонний dns, что в принципе решает проблему.

Share this post


Link to post
Share on other sites
  • 0

Самое забавное, что  при переходе по своему KeenDNS из локалки по 80 порту всеравно попадаешь в админку даже если "Allow access from the Internet" выключен. из интернета все ок. но другие порты не работают. Просканировав порты изнутри по забросу домена KeenDns оказалось что открыты: 23, 53, 80, 443, 8081, 49257 и ссылается на адрес 78.47.125.180. Если тоже самое на 192.168.1.1 то порты 23, 53, 80, 443, 49257. Разница лишь в порте 8081. Интересно! 
Из интернета конечно все закрыты. Но видимо ждать пока все наладится. И надеяться на лучшее))

Share this post


Link to post
Share on other sites
  • 0
9 часов назад, Vladimir Dobromyslov сказал:

Как вариант, пока откатить на 3.4.12

Пробовал откат на 3.5.2, но там в прошивке сразу все компоненты установлены, а после удаления автоматом обновляется на 3.5.4. Есть способ это обойти как-то?

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, Федор сказал:

Пробовал откат на 3.5.2, но там в прошивке сразу все компоненты установлены, а после удаления автоматом обновляется на 3.5.4. Есть способ это обойти как-то?

Нет. Только если найти у кого сохраненную 3.5.2 c необходимым набором компонент. 

Share this post


Link to post
Share on other sites
  • 0

А когда ожидается фикс данной проблемы? По факту важный функционал прошивки сейчас в нерабочем состоянии...

Share this post


Link to post
Share on other sites
  • 0
12 часа назад, Vladimir Dobromyslov сказал:

Как вариант, пока откатить на 3.4.12 и добавить нужные компоненты через CLI 

Как это?! При добавлении/удалении компонент прошивка обязательно обновится до максимальной (в выбраном канале).

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Федор said:

А когда ожидается фикс данной проблемы? По факту важный функционал прошивки сейчас в нерабочем состоянии...

Просьба проверить, что на 3.6 Alpha 8 проблема исправлена.

Share this post


Link to post
Share on other sites
  • 0

Вставлю свои пять копеек, с записью xxxx.keentic.pro  78.47.125.180 логика работы была верной (только было обрадовался) , а теперь 3.6А8 увы.😭

 

 

Edited by r777ay

Share this post


Link to post
Share on other sites
  • 0
17 часов назад, Vladimir Dobromyslov сказал:

3.6 Alpha 8 пока по-прежнему не работает.

Доменное имя "Освободите"

Share this post


Link to post
Share on other sites
  • 0
3 часа назад, r777ay сказал:

Вставлю свои пять копеек, с записью xxxx.keentic.pro  78.47.125.180 логика работы была верной (только было обрадовался) , а теперь 3.6А8 увы.😭

Хмм.. Вернулось, всё на круги своя 3.6А8 

Share this post


Link to post
Share on other sites
  • 0
On 12/5/2020 at 9:50 PM, Vladimir Dobromyslov said:

3.6 Alpha 8 пока по-прежнему не работает. Как говорится лучшее враг хорошего.

Как вариант, пока откатить на 3.4.12 и добавить нужные компоненты через CLI или использовать сторонний dns, что в принципе решает проблему.

ура. снова работает. пару раз перезагрузился и пашет! спасибо всем! 3.6 Alpha 8 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
5 часов назад, Vladimir Dobromyslov сказал:

3.6 Alpha 8

А какие-то баги известные есть в прошивке, что может нормальной работе помешать? Альфа все-таки...

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, Федор сказал:

А какие-то баги известные есть в прошивке, что может нормальной работе помешать? Альфа все-таки...

Видимых нет.

Edited by iggo

Share this post


Link to post
Share on other sites
  • 0

В стабильной ветке прошивки примерно через какой срок появятся изменения по NAT loopback?

Share this post


Link to post
Share on other sites
  • 0
осталась такая ошибка - подскажите что может быть не так ?
keenetic-3544 nginx
2020/12/13 21:45:49 [error] 583#0: *1868 SSL_do_handshake() failed (SSL: error:1408F10B:lib(20):func(143):reason(267)) while SSL handshaking to upstream, client: ip, server: адрес до сервера, request: "GET / HTTP/1.1", upstream: "https://ip:PORT/", host: "....keenetic.link"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...