Jump to content
Equalizer

Обновление роняет систему

Recommended Posts

Там драйвер SPI NOR для 6856 через одно место написан. Попытались улучшить - стало еще хуже как видно :)

Share this post


Link to post
Share on other sites

Для KN-1810/1910, как я понял, эта проблема не актуальна?

Share this post


Link to post
Share on other sites
Только что, drugold сказал:

Для KN-1810/1910, как я понял, эта проблема не актуальна?

всё, до куда дотянулись руки, переведено на legacy, в основном это кн-хх10 -- проблем не обнаружено...

У тс же сотоварищи ,как я понял, старые модели до кн-хх10!

Share this post


Link to post
Share on other sites
57 минут назад, drugold сказал:

Для KN-1810/1910, как я понял, эта проблема не актуальна?

Нет, только ZK2/ZKG2/ZKU/ZKDSL/ZKVOX.

  • Thanks 2

Share this post


Link to post
Share on other sites
13 минуты назад, Le ecureuil сказал:

А до этой версии не было вопросов?

Да, не было никаких. Несколько месяцев назад без всяких проблем заменил SMB/CIFS на TSMB CIFS beta.

Share this post


Link to post
Share on other sites
39 минут назад, kodirovshchik сказал:

Да, не было никаких. Несколько месяцев назад без всяких проблем заменил SMB/CIFS на TSMB CIFS beta.

А если вернуться снова на SMB/CIFS проблема возникает?

  • Thanks 1

Share this post


Link to post
Share on other sites
5 минут назад, krass сказал:

А если вернуться снова на SMB/CIFS проблема возникает?

Спасибо за совет. Проверю когда все потребители интернета спать улягутся 😃

Share this post


Link to post
Share on other sites

@kodirovshchik ошибке tgt_transport_fill_network_ifinfo посвящена эта тема.
 

Ошибка проявляется только в 2.16, что несколько ухудшает прогнозы по скорости починки. Если есть рецепт быстрого воспроизведения, то это сильно приблизит исправление.

  • Thanks 1

Share this post


Link to post
Share on other sites

Посмотрел. У меня на прошивке 2.16.D.10.0-0 работает только SMB/CIFS. Со всеми своими неприятными моментами - линуксовый комп, например, из коробки, через обзор, в таким режиме, в сети компьютеров не видит.

Для TSMB CIFS beta веб-морда отваливается, если запретить анонимный доступ и попытаться зайти на шару с виндовой машины. С линуксовой машины веб-морда не падает ни с обычным ни с анонимным доступом:

- С виндовой машиной TSMB CIFS beta просто не пускает на шару когда доступ анонимный, и отваливается веб-морда когда вход по логину/паролю.

- С линуксовой машины TSMB CIFS beta при анонимном доступе все работвает как часы. При доступе по логину/паролю я вижу расшаренные папки но не могу на них зайти.

Нашел различие с поведением на предыдущей версии прошивки. С первого дня на TSMB CIFS beta роутер виделся с линукса и андроида как два разных устройства. "Router CIFS" по адресу smb://router.local и "Router" по адресу smb://192.168.1.1. Имя устройства в настройках было "Router". На прошивке 10.0-0 такого нет. Роутер видится и доступен с линукс машины только как  "Router CIFS" по адресу smb://router.local.

Edited by kodirovshchik
  • Upvote 1

Share this post


Link to post
Share on other sites

 

14 часа назад, kodirovshchik сказал:

https://pastebin.com/eY6qZEb8

Здравствуйте. Начал отваливаться web-интерфейс при попытке зайти на расшаренный через роутер диск. Заметил через сутки использования: 2.16.D.10.0-0, Keenetic Viva

log (1).txt 105 \u041a\u0431 · 4 downloads

Аналогично, только Giga II, вчера вечером обновился и к ночи заметил тоже самое, tsmb, не разбирался пока, с утра откатился до 8.0.2, все заработало.

Edited by ziv

Share this post


Link to post
Share on other sites
В 19.01.2021 в 14:38, Ваджио сказал:

С первого раза не прокатило. Пришлось восстанавливать прежнюю прошивку 2.16.D.9.0-1. Восстановил, запустил обновление прошивки.

Обновился до 2.16.D.10.0-0 раза с 7-8-го. Keenetic Gaga II работает! Проверил работу путём добавления и удаления компонентов ― прошивка нормально устанавливается и удаляется.

Также обновил Keenetic DSL ― обновление прошло с первого раза.

Спасибо за проделанную работу!

  • Thanks 1

Share this post


Link to post
Share on other sites

Видимо да, стало лучше раз тема резко затихла ))) На Giga II мои эксперименты с изменением состава компонентов прошли успешно.

Я свой зоопарк пока оставил на 10-ой версии и не стал обновлять до 10.01.

Share this post


Link to post
Share on other sites
В 29.01.2021 в 11:50, Le ecureuil сказал:

Ну как, на 10-й версии стало лучше?

Ну, у меня проблемы с установкой не было, поскольку стояла версия 2.16.D.7.0-1, а обновляться выше в свое время я не стал (когда увидел, что на Giga 2, у некоторых после 8 версии начались проблемы с кирпичами).

Как вышла 10 обновился успешно, правда только со второго раза. Первый раз после обновления осталась та же самая версия. Повторная установка 10 прошла нормально. 10-01 с первого раза без проблем поставилась.

Share this post


Link to post
Share on other sites

Аналогично. После исправления бага с окирпичиванием тот самый роутер из шапки обновился с полтычка на 2.16.D.10.0-1.

Полёт нормальный

Share this post


Link to post
Share on other sites

Обновился с первого раза с 2.16.D.9.0-0 на 2.16.D.10.0-1.

Edited by Антон Яровой

Share this post


Link to post
Share on other sites

Тоже обновил 1 гигу2 с 2.16.D.9.0-0 на 2.16.D.10.0-1 без проблем, а второй начал себя странно вести: не пускал в сеть клиенты, хотя политика стояла на доступ, потом в веб-морде в консоле браузера на странице dashboard выдавало ошибку с отсутствием id, на странице настройки локальной сети что не может rename. После этих ошибок js отваливался и ничего нельзя было сделать на странице. Бился, бился, дебаг логи смотрел. В итоге решил сбросом конфигурации. Заново настроил - проблем пока не наблюдается.

Edited by qw qw

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...