Jump to content
  • 0
Artur Pirojkov

Keenetic Giga III (3.5.6) периодически не срабатывает приоритет подключений

Question

Доброго дня, господа. Столкнулся с проблемой несрабатывания приоритета подключений на роутере. Роутер ходит в инет через модем E3372h - подключение Huawei Mobile Broadband. Поверх модемного соединения настроен Wireguard как основное подключение. Для домашней и гостевой сети выставлен основным подключением он же. Скрины в спойлере:

Скрытый текст

image.png.10858961650a62146fa086f3f14bf641.png

image.png.3b5c084e2aebc824567cda56de9be0d7.png

К сожалению, в случае редкогого отвала соединения Wireguard или при перезагрузке роутера, непонятным для меня образом включается отправка данных напрямую через модем. Убедился в этом, попытавшись зайти на 2ip.ru сразу после перезагрузки роутера. Тут же увидел инфу провайдера и IP выданный модему вместо Wireguard-а. Из-за этого провайдер включает шейп и рубит трафик. Получаю такую ситуацию стабильно. При этом при таких же настройках на GIGA II (2.16.D.11.0-0) такой проблемы нет. И при перезагрузках и при отвале Wireguard-а, трафик никуда не уходит пока не поднимется соединение. Приходится отдельно перезапускать модемное подключение, тогда шейп сбрасывается и скорость восстанавливается. Подскажите, пожалуйста, можно ли добиться аналогичной работы приоритета подключений как на GIGA II или внести какие-то дополнительные настройки, чтобы трафик не утекал мимо в модемное подключение ?

Edited by Artur Pirojkov
обновил скриншот

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
В 28.02.2021 в 11:48, Artur Pirojkov сказал:

Доброго дня, господа. Столкнулся с проблемой несрабатывания приоритета подключений на роутере. Роутер ходит в инет через модем E3372h - подключение Huawei Mobile Broadband. Поверх модемного соединения настроен Wireguard как основное подключение. Для домашней и гостевой сети выставлен основным подключением он же. Скрины в спойлере:

  Показать содержимое

image.png.10858961650a62146fa086f3f14bf641.png

image.png.3b5c084e2aebc824567cda56de9be0d7.png

К сожалению, в случае редкогого отвала соединения Wireguard или при перезагрузке роутера, непонятным для меня образом включается отправка данных напрямую через модем. Убедился в этом, попытавшись зайти на 2ip.ru сразу после перезагрузки роутера. Тут же увидел инфу провайдера и IP выданный модему вместо Wireguard-а. Из-за этого провайдер включает шейп и рубит трафик. Получаю такую ситуацию стабильно. При этом при таких же настройках на GIGA II (2.16.D.11.0-0) такой проблемы нет. И при перезагрузках и при отвале Wireguard-а, трафик никуда не уходит пока не поднимется соединение. Приходится отдельно перезапускать модемное подключение, тогда шейп сбрасывается и скорость восстанавливается. Подскажите, пожалуйста, можно ли добиться аналогичной работы приоритета подключений как на GIGA II или внести какие-то дополнительные настройки, чтобы трафик не утекал мимо в модемное подключение ?

отключить "доступ в интернет" для модема не помогает?

Share this post


Link to post
Share on other sites
  • 0
В 01.03.2021 в 17:48, Mikesk сказал:

отключить "доступ в интернет" для модема не помогает?

@Mikesk, не совсем понял как это должно помочь. 🙄 Ведь если у модема не будет доступа в интернет, то и Wireguard не поднимется поверх него ? Ошибаюсь ?

На всякий случай посмотрел настройки в интерфейсе. Селектора отключения доступа в интернет не вижу. Подразумевается это делать через CLI или настройками брандмауэра ?

Скрытый текст

image.thumb.png.07b0f14daab0a3e752f0689fc52684c1.png

 

Edited by Artur Pirojkov

Share this post


Link to post
Share on other sites
  • 0
3 часа назад, Artur Pirojkov сказал:

@Mikesk, не совсем понял как это должно помочь. 🙄 Ведь если у модема не будет доступа в интернет, то и Wireguard не поднимется поверх него ? Ошибаюсь ?

На всякий случай посмотрел настройки в интерфейсе. Селектора отключения доступа в интернет не вижу. Подразумевается это делать через CLI или настройками брандмауэра ?

no ip global для интерфейса модема.

Насчет вайргарда не проверял, по идее для туннеля (при настройке маршрутизации, куда его строить) ведет ли интерфейс именно в "весь интернет"  или нет не должно играть роли. А вот "весь трафик" до поднятия туннеля при его падении в модемный неглобальный интерфейс не полезет.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...