Jump to content
  • 0
Илья Мухин

После аппаратного сброса настроек часть "старого" все равно остается.

Question

Всем привет.
Все началось с того что я экспериментировал с передачей IPTV мультикаст трафика через Wi-Fi.
Создал новый мост, переименовал его на "свой вкус", объединил WAN и новую SSID точку + добавил 1й порт коммутатора через VLAN чтобы подключить 2ю приставку по проводу.

Все работало хорошо но потом я отказался от этой затеи т.к. появился Smart TV. Не помню зачем но я сбросил до завода роутер и заново его настроил, из всего этого осталась только проводная приставка на 1м порту.

В вебконфиге я выбрал 1й порт и присвоил ему режим TV-BOX, уже через CLI в дальнейшем надо было выполнить пару настроек и на мое удивление я увидел мост и VLAN с моими же старыми названием и параметрами.
После нескольких обновлений ПО еще глючил модем Huawei E5372, он перестал определяться в HiLink, сброс настроек не помогал, хотя на OpenWRT работал исправно. Все необходимые компоненты были установлены, пробовал делать сброс по разному, даунгрейд прошивки на сток из коробки, потом опять аппаратный сброс и апгрейд до последней и о чудо модем начал определяться нормально, только почему то начал мешать PPPoE интерфейсу(на нем пропадет инет при подключении модема, хотя стоит приоритет по умолчанию).

Но при выборе 1го порта под TV-box по прежнему возвращались "мои" названия интерфейсов и их параметры.

Хочу чтобы внутренне все файлы прошивки были как из коробки. Предполагаю что нужно затереть какую то область и записать ее заново оригинальной прошивкой.
В какой области прошивки может что то сохраняться после аппаратного сброса? Куда дальше копать?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
4 минуты назад, Илья Мухин сказал:

Всем привет.
Все началось с того что я экспериментировал с передачей IPTV мультикаст трафика через Wi-Fi.
Создал новый мост, переименовал его на "свой вкус", объединил WAN и новую SSID точку + добавил 1й порт коммутатора через VLAN чтобы подключить 2ю приставку по проводу.

Все работало хорошо но потом я отказался от этой затеи т.к. появился Smart TV. Не помню зачем но я сбросил до завода роутер и заново его настроил, из всего этого осталась только проводная приставка на 1м порту.

В вебконфиге я выбрал 1й порт и присвоил ему режим TV-BOX, уже через CLI в дальнейшем надо было выполнить пару настроек и на мое удивление я увидел мост и VLAN с моими же старыми названием и параметрами.
После нескольких обновлений ПО еще глючил модем Huawei E5372, он перестал определяться в HiLink, сброс настроек не помогал, хотя на OpenWRT работал исправно. Все необходимые компоненты были установлены, пробовал делать сброс по разному, даунгрейд прошивки на сток из коробки, потом опять аппаратный сброс и апгрейд до последней и о чудо модем начал определяться нормально, только почему то начал мешать PPPoE интерфейсу(на нем пропадет инет при подключении модема, хотя стоит приоритет по умолчанию).

Но при выборе 1го порта под TV-box по прежнему возвращались "мои" названия интерфейсов и их параметры.

Хочу чтобы внутренне все файлы прошивки были как из коробки. Предполагаю что нужно затереть какую то область и записать ее заново оригинальной прошивкой.
В какой области прошивки может что то сохраняться после аппаратного сброса? Куда дальше копать?

Попробуйте восстановить прошивку с помощью утилиты восстановления

Share this post


Link to post
Share on other sites
  • 0
13 минуты назад, Илья Картавенко сказал:

Попробуйте восстановить прошивку с помощью утилиты восстановления

Да, забыл о ней написать, пробовал уже, не помогло.

Share this post


Link to post
Share on other sites
  • 0

Переименования (ваши названия) же по-любому в основном конфиге хранятся.

Пробовали загрузить дефолтный конфиг? В принципе сброс так же должен был бы привести к загрузке с дефолтного. 

Вряд ли  что-то из настроек браузера берется. Но можно и эти настройки для адреса роутера попробовать сбросить.

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0
5 минут назад, Mamay сказал:

P.S. А модель и версия какие?

KN-1910, версия прошивки не имеет значения, т.к. делался сброс и на коробочной версии и на Dev и на Stable и там все равно всплывали "мои" названия интерфейсов.

Share this post


Link to post
Share on other sites
  • 0
Только что, Илья Мухин сказал:

KN-1910, версия прошивки не имеет значения, т.к. делался сброс и на коробочной версии и на Dev и на Stable и там все равно всплывали "мои" названия интерфейсов.

При этом вы конфиг старый подливаете или с нуля настройки?

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, Илья Мухин сказал:

т.к. делался сброс и на коробочной версии и на Dev и на Stable и там все равно всплывали "мои" названия интерфейсов.

А расширение от кинетика браузерное не установлено у вас случаем?

Вот это не установлено :  https://forum.keenetic.net/topic/7533-ночная-тема-расширение-браузера/?sortby=date

P.S. Уже не просто темная тема...

Версия 0.5.73 (2020-11-30):

  • название порта на дашборде отображается в центре иконки порта (по просьбе @AndreBA)
  • исправлен цвет иконок при отображении ассиметричного ограничения скорости хоста на странице "Список устройств"
  • в результате обсуждения описания портов на дашборде, начатого @Hotery, добавлена возможность вручную настроить отображение портов на дашборде
Edited by krass

Share this post


Link to post
Share on other sites
  • 0
Только что, Илья Картавенко сказал:

А что есть такое?

Dark theme 

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, Mamay сказал:

При этом вы конфиг старый подливаете или с нуля настройки?

После сброса захожу в Wired ставлю 1й порт под приставку и сохраняю. Иду в CLI и вижу мое название интерфейса.
Я хз, у меня стоит галка о передачи инфы об использовании устройства в целях улучшения продукта - это может как то зависеть?

Еще заметил что после сброса мой KeenDNS автоматом подвязывается на роутер, после подключения к инету.

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, Илья Мухин сказал:

После сброса захожу в Wired ставлю 1й порт под приставку и сохраняю. Иду в CLI и вижу мое название интерфейса.
Я хз, у меня стоит галка о передачи инфы об использовании устройства в целях улучшения продукта - это может как то зависеть?

Еще заметил что после сброса мой KeenDNS автоматом подвязывается на роутер, после подключения к инету.

1. Нет 

2. Это норма 

Share this post


Link to post
Share on other sites
  • 0
11 минуту назад, krass сказал:

А расширение от кинетика браузерное не установлено у вас случаем?

Вот это не установлено :  https://forum.keenetic.net/topic/7533-ночная-тема-расширение-браузера/?sortby=date

P.S. Уже не просто темная тема...

Версия 0.5.73 (2020-11-30):

  • название порта на дашборде отображается в центре иконки порта (по просьбе @AndreBA)
  • исправлен цвет иконок при отображении ассиметричного ограничения скорости хоста на странице "Список устройств"
  • в результате обсуждения описания портов на дашборде, начатого @Hotery, добавлена возможность вручную настроить отображение портов на дашборде

Нет, даже не знал о таком :)
Тоже поднадоела тема официальная.

Share this post


Link to post
Share on other sites
  • 0

Ваще барабашки. Для очистки совести спрошу всё же. На внутреннюю память, что считанные килобайты доступны, не писали конфиг? Ну и качестве бреда, может как то с энтвар связано...

Share this post


Link to post
Share on other sites
  • 0

Кто может проверить?

Нужно просто выбрать любой ненужный порт комка и присвоить ему режим "TV set-top box", далее посмотреть в CLI, у меня создаются два интерфейса: Vlan4 и Bridge3 (Хотя до этого в системе есть только Vlan1, Vlan3, Bridge0, Bridge1), если мост у вас "Rename ISP-IPTV" то я балбес что посчитал это за свое название :)

P.S. если настраивать все через CLI то никаких приколов. Стоит только в веб-интерфейсе это сделать - происходит как выше.

Edited by Илья Мухин

Share this post


Link to post
Share on other sites
  • 0
36 минут назад, Mamay сказал:

Ваще барабашки. Для очистки совести спрошу всё же. На внутреннюю память, что считанные килобайты доступны, не писали конфиг? Ну и качестве бреда, может как то с энтвар связано...

На внутрянку ничего не писал, незачем. Стоит entware на флешке, без нее тоже самое.

Share this post


Link to post
Share on other sites
  • 0
17 часов назад, Илья Мухин сказал:

Стоит только в веб-интерфейсе это сделать - происходит как выше.

Значит ЭТО отправляет браузер. Может у вас кэш такой? Другим попробуйте.

Share this post


Link to post
Share on other sites
  • 0

А какое именно ваше название возвращается? Случаем не с keenetic cloud или мобильного приложения прилетает?

Share this post


Link to post
Share on other sites
  • 0
21 час назад, Илья Мухин сказал:

у меня создаются два интерфейса: Vlan4 и Bridge3 (Хотя до этого в системе есть только Vlan1, Vlan3, Bridge0, Bridge1), если мост у вас "Rename ISP-IPTV" то я балбес что посчитал это за свое название :)

Вот писал. Если бы где то резервировалось то прилетали бы все настройки уж.

Share this post


Link to post
Share on other sites
  • 0
3 минуты назад, Le ecureuil сказал:

А какое именно ваше название возвращается? Случаем не с keenetic cloud или мобильного приложения прилетает?

ISP-IPTV. Что скорее всего является стандартным именем интерфейса в режиме ТВ-приставки.

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0
Только что, keenet07 сказал:

ISP-IPTV. Что скорее всего является стандартным именем порта в режиме ТВ-приставки.

В том то и дело что не порта а название моста, т.к. по умолчанию когда они создаются эти имена стандартные (Bridge0, Bridge1-xx), а я сам менял название этой командой:

 

21 час назад, Илья Мухин сказал:

"Rename ISP-IPTV"

 

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, Илья Мухин сказал:

В том то и дело что не порта а название моста, т.к. по умолчанию когда они создаются эти имена стандартные (Bridge0, Bridge1-xx), а я сам менял название этой командой:

Прослойка, которую использует веб-интерфейс для настройки, так называет получающийся мост, если у Кинетика синий порт на отдельном свитче. У интерфейса есть идентификатор вида BridgeX и псевдоним ISP-IPTV.

Вы можете в этом убедиться, посмотрев на вкладке "Network" в консоли разработчика браузера на ответы, которые веб-интерфейсу приходят от устройства.

В одном из ответов будет "... 'next-name': 'ISP-IPTV'", при этом в запросе такого имени нет.

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, Илья Мухин сказал:

В том то и дело что не порта а название моста, т.к. по умолчанию когда они создаются эти имена стандартные (Bridge0, Bridge1-xx), а я сам менял название этой командой:

У мостов тоже могут быть удобоваримые названия.

Проверил то о чем вы просили.

Перевел один порт в режим ТВ-приставка. Скачал running-config и в нем появилось:

Цитата

!
interface Bridge3
    rename ISP-IPTV
 

До всех манипуляций такой записи там не было.

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, keenet07 сказал:

У мостов тоже могут быть удобоваримые названия.

Проверил то о чем вы просили.

Перевел один порт в режим ТВ-приставка. Скачал running-config и в нем появилось:

До всех манипуляций такой записи там не было.

Ну тогда я параноик раз решил что это "мое" название))) Т.к. изначально создавал такой интерфейс вручную через CLI и называл его так для удобства, создавал для передачи мультикаста на порт 1 + Wi-Fi, при этом в веб-интерфейсе было пусто, пока я не добавил 1 порту "role IPTV for ISP-IPTV".
Тогда думаю тему можно закрыть. Всем спасибо!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...