Jump to content
Александр Разживин

MQTT сервер ( mosquitto ) на Keenetic

Recommended Posts

Добрый день.

Тема эта не новая, в сети информация есть, но иногда устаревшая и весьма разрозненная. Поэтому по окончании установки на свой кинетик решил написать свою статью, где постарался описать процесс максимально подробно.

Статья получилась достаточно объемная, здесь переписывать весь этот труд лень, да и правки вношу пока что.

Если кому-то будет полезно: https://kotyara12.ru/pubs/iot/keenetic-mqtt/

  • Upvote 1

Share this post


Link to post
Share on other sites

Прошу помощи, уже 3ий день бьюсь

Делаю все по инструкции (этой и аналогичным), установил, пользователя добавил

далее запускаю  mosquitto -v

и получаю

1621457939: mosquitto version 2.0.10 starting
1621457939: Using default config.
1621457939: Starting in local only mode. Connections will only be possible from clients running on this machine.
1621457939: Create a configuration file which defines a listener to allow remote access.
1621457939: For more details see https://mosquitto.org/documentation/authentication-methods/
1621457939: Opening ipv4 listen socket on port 1883.
1621457939: Opening ipv6 listen socket on port 1883.
1621457939: Error: Cannot assign requested address
1621457939: mosquitto version 2.0.10 running

Что я делаю не так?

 

Share this post


Link to post
Share on other sites

такая же фигня ... кто в теме помогите 

1631087443: mosquitto version 2.0.11 starting
1631087443: Using default config.
1631087443: Starting in local only mode. Connections will only be possible from clients running on this machine.
1631087443: Create a configuration file which defines a listener to allow remote access.
1631087443: For more details see https://mosquitto.org/documentation/authentication-methods/
1631087443: Opening ipv4 listen socket on port 1883.
1631087443: Error: Address already in use
1631087443: Opening ipv6 listen socket on port 1883.
1631087443: Error: Address already in use
 

На OpenWrt установил пакет mosquitto-nossl и всё работает само и сразу , а тут как-то не работает

Share this post


Link to post
Share on other sites

В 20.05.2021 в 00:01, Andriy Shushlebin сказал:

Что я делаю не так?

Он у вас стартанул, но в локальном режиме, о чем и написал... Ну и на IPV6 не смог забиндить себя ...

37 минут назад, umc сказал:

такая же фигня ... кто в теме помогите 

Пишет что адрес/порт занят ... как 4 так и 6 ...

Share this post


Link to post
Share on other sites

То что порт занят я смог перевести ... Почему и чем ?... Сбросил роутер к заводским настройкам , форматнул флешку и заново установил Entware . Установил только mosquitto . Результат тот же ... порт занят.

Что предпринять?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...