Jump to content
  • 0
TanerJames

Giga SMB Network Share

Question

Hi,

 

i have Keenetic Giga.

my cable connections:

 

123.png.69ce2bb46f9b86b873f928addb871ca4.png

Name: Keenetic_Giga
Workgroup Name: Workgroup

SMB: Enabled

 

I inserted the USB stick in keenetic, it works normally.

My problem: In my own internal network, I cannot see Keenetic.

\\Keenetic_Giga
does not open.

I'm typing the \\192.168.5.10  not working. 

 

http://192.168.5.10
It works as normal.

 

What is the problem?

 

Thanks.

Edited by TanerJames

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
7 часов назад, TanerJames сказал:

What is the problem?

You are trying to connect from WAN, from Giga's point of view. By default firewall prevents connections from public networks (WAN).  You can switch router to the Access Point mode, or  you can create permissive rules in the firewall.

https://help.keenetic.com/hc/en-us/articles/360000578240-Firewall     https://help.keenetic.com/hc/en-us/articles/360000571060-Access-Point-Extender-Mode

Share this post


Link to post
Share on other sites

  • 0
On 7/22/2021 at 11:14 AM, werldmgn said:

You are trying to connect from WAN, from Giga's point of view. By default firewall prevents connections from public networks (WAN).  You can switch router to the Access Point mode, or  you can create permissive rules in the firewall.

https://help.keenetic.com/hc/en-us/articles/360000578240-Firewall     https://help.keenetic.com/hc/en-us/articles/360000571060-Access-Point-Extender-Mode

so, will it work if I use the LAN port instead of the WAN port?

Do I have to change the operating mode to access point ?

I don't want anyone else to reach my Local network (as a guest)

 

Thanks.

Share this post


Link to post
Share on other sites

  • 0

To try:
I added ICMP firewall rule for PING, ping response is coming.

 

ping 192.168.10.30

Pinging 192.168.10.30 with 32 bytes of data:
Reply from 192.168.10.30: bytes=32 time<1ms TTL=64
Reply from 192.168.10.30: bytes=32 time<1ms TTL=64
Reply from 192.168.10.30: bytes=32 time<1ms TTL=64
Reply from 192.168.10.30: bytes=32 time<1ms TTL=64

 

What firewall rule is required for SMB? 145 and 139 ?

Edited by TanerJames

Share this post


Link to post
Share on other sites

  • 0
6 часов назад, TanerJames сказал:

What firewall rule is required for SMB? 145 and 139 ?

You can just open all tcp and all udp for 192.168.5.0/24 network source.

17 часов назад, TanerJames сказал:

so, will it work if I use the LAN port instead of the WAN port?

For that to work you need to disable dhcp server on Giga and manually add 192.168.5.10 ip-address on Bridge0 interface. This will be equivalent to switching the device to the Access point mode. That's why I said that the easiest way is to switch your Giga to access point mode.

17 часов назад, TanerJames сказал:

I don't want anyone else to reach my Local network (as a guest)

This has nothing to do with switching to the access point mode.

Share this post


Link to post
Share on other sites

  • 0

I switched to "access point" mode to test it. Yes, the USB stick worked without any problems. 

But there is no guest mode feature in this mode, guest mode in router mode is speed limiting etc. 
I created a new segment , but there is no option for speed limiting. I guess the features change with the two modes.

 

Also, since it is an "access point", it started to distribute IP from my other router's DHCP to all wifi devices (microtik)
In terms of security, it would be better for me if wifi users connect to the internet via keenetic (firewall etc).

 

 

 

I will try other things you said for router mod.

Thanks again.

Edited by TanerJames

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...