Jump to content
  • 1
Sfut

Настройка РРРоЕ и MTU

Question

Сегодня провайдер без предупреждения перевел с IPoE на PPPoE. Настроил, но что то не нравится мне как оно работает. В связи с этим возникли вопросы, надеюсь на Вашу помощь.

1. Какое значение MTU ставить на PPPoE, достаточно того что устанавливается автоматом или лучше узнать у провайдера. Посмотрел в CLI установленное значение  -1200, не маловато ли? Значение MTU на PPPoE устанавливать в CLI?. В Вэб-конфигураторе вроде бы настроек нет.

2. Насколько меньше скорость при PPPoE по сравнению с IPoE, теоретически вроде бы совсем немного. А меня по результатам сегодняшнего вечера получается меньше процентов на 20, что как то совсем не радует.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Итак, что получается:

в startup-config mtu 1492;

в running-config mtu 1492;

в выводе show interface PPPoE0 mtu 1200.

Проверка пингом с флагом запрета фрагментации показывает, что реально установлено значение mtu 1200. При этом в CLI можно принудительно выставить для PPPoE0 значение mtu 1492, проверка пингом показывает, что фрагментация пакетов в этом случае не требуется.

Может быть стоит создать отдельную тему в "Тестирование NDMS" с данным багом для того чтобы разработчики обратили внимание?

 

 

 

Share this post


Link to post
Share on other sites
  • 0

По себе выяснил, если проще: на стороне провайдерской железяки "Автоподстройка TCP-MSS" имеет значение 1452. 1452 + 40 = 1492

По мне всё нормально, так и должно быть. Подробнее тут

33 минуты назад, Sfut сказал:

Может быть стоит создать отдельную тему в "Тестирование NDMS" с данным багом для того чтобы разработчики обратили внимание?

я думаю они прочли уже данную тему, но лучше отдельно создать. 

 

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, Leksey118 сказал:

По себе выяснил, если проще: на стороне провайдерской железяки "Автоподстройка TCP-MSS" имеет значение 1452.

Как выяснили?

Какие у Вас значения mtu в  startup-config running-config  и выводе CLI ?

Edited by Sfut

Share this post


Link to post
Share on other sites
  • 0

Побеседовал с людьми, которые настраивали эти железки.

Share this post


Link to post
Share on other sites
  • 0
23 минуты назад, Sfut сказал:

startup-config

ip mtu 1492

26 минут назад, Sfut сказал:

running-config

ip mtu 1492

32 минуты назад, Sfut сказал:

выводе CLI

mtu: 1480

Share this post


Link to post
Share on other sites
  • 0

@Leksey118 тоже как то странно, если 

2 часа назад, Leksey118 сказал:

на стороне провайдерской железяки "Автоподстройка TCP-MSS" имеет значение 1452. 1452 + 40 = 1492

то и на выводе CLI должно 1492, а не 1480.

Посмотрел у себя в логе 

Jan 28 07:52:49 ndm: Network::Interface::Base: "PPPoE0": interface is up.
Jan 28 07:52:49 ndm: Network::Interface::Base: "PPPoE0": static MTU is 1400.
Jan 28 07:52:49 ndm: Network::Interface::Base: "PPPoE0": static MTU is 1492.
Jan 28 07:52:49 ndm: Network::Interface::Repository: created interface PPPoE0.
Jan 28 07:52:50 ndm: kernel: br1: port 1(eth2.3) entered forwarding state
Jan 28 07:52:50 ndm: Network::Interface::Base: "PPPoE0": description saved.
Jan 28 07:52:50 ndm: Command::LogResponse: IPv6CP disabled.
Jan 28 07:52:50 ndm: Network::Interface::PPP: LCP echo parameters updated.
Jan 28 07:52:50 ndm: Command::LogResponse: using peer as a default gateway.
Jan 28 07:52:50 ndm: Command::LogResponse: using remote name servers.
Jan 28 07:52:50 ndm: Command::LogResponse: DNS routes enabled.
Jan 28 07:52:50 ndm: Command::LogResponse: CCP disabled.
Jan 28 07:52:50 ndm: Network::Interface::IP: "PPPoE0": security level set to "public".
Jan 28 07:52:50 ndm: Network::Interface::Supplicant: identity saved.
Jan 28 07:52:50 ndm: Network::Interface::Supplicant: password saved.
Jan 28 07:52:50 ndm: Network::Interface::Base: "PPPoE0": static MTU is 1492.

А в выводе CLI mtu 1200. 99,9% что это у провайдера в настройках что то не так.

Но все же очень хочется послушать разработчиков.

Edited by Sfut

Share this post


Link to post
Share on other sites
  • 0

Подниму тему. В CLI можно установить для PPPoE0 значение mtu 1492, при этом все корректно работает (фрагментации пакетов нет). Но при переподключении или изменении настроек PPPoE значение mtu снова сбрасывается в 1200. Снятие галки с "Автоподстройка ТСР-МSS" ситуацию не меняет.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
В 29.01.2017 в 10:14, Sfut сказал:

Подниму тему. В CLI можно установить для PPPoE0 значение mtu 1492, при этом все корректно работает (фрагментации пакетов нет). Но при переподключении или изменении настроек PPPoE значение mtu снова сбрасывается в 1200. Снятие галки с "Автоподстройка ТСР-МSS" ситуацию не меняет.

Абсолютно та же проблема. MTU PPPoE в конфиге 1492, в CLI 1480. У провайдера 100% MTU 1492.

Версия Keenetic OS 2.15.A.4.0-6

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...