Jump to content
  • 0
nogood

Несколько VLAN на порту

Question

На данный момент есть необходимость по одному кабелю подключить несколько сегментов сети. На одном конце будет сидеть RubyTech ES-2410C, а на другом, собсно, кинетик. Проблема такая - при создании сегмента можно указать VLAN для него, разрешить передавать теги и указать порт. Но, если на этом порту уже есть другой сегмент - то нет возможность выбрать этот же порт повторно, но с другим VLAN. Тоесть смысла в передаче тегов почти нет. Выходит 1 порт - 1 сегмент - 1 VLAN на нём. Можно ли как-то исправить такое поведение? Устройство Keenetic II, прошивка  v2.09(AAFG.0)A

 

2017-02-04_170543.png

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Всё это делается.

Вот вам кусочек конфига.

interface GigabitEthernet0
    up
!
interface GigabitEthernet0/0
    rename 1
    description Vlan-101
    switchport mode access
    switchport access vlan 101
    up
!
interface GigabitEthernet0/1
    rename 2
    description Vlan-102
    switchport mode access
    switchport access vlan 102
    up
!
interface GigabitEthernet0/2
    rename 3
    description Vlan-103
    switchport mode access
    switchport access vlan 103
    up
!
interface GigabitEthernet0/3
    rename 4
    description nas
    switchport mode access
    switchport access vlan 1
    up
!
interface GigabitEthernet0/4
    rename 5
    description admin-pc
    switchport mode access
    switchport access vlan 1
    up
!
interface GigabitEthernet0/5
    rename 6
    switchport mode access
    switchport access vlan 1
    up
!
interface GigabitEthernet0/6
    rename 7
    description mag
    switchport mode access
    switchport mode trunk
    switchport access vlan 101
    switchport trunk vlan 101
    switchport trunk vlan 102
    switchport trunk vlan 103
    switchport trunk vlan 104
    switchport trunk vlan 1
    up
!
interface GigabitEthernet0/Vlan1
    description "Home VLAN"
    security-level private
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface GigabitEthernet0/Vlan3
    description "Guest VLAN"
    security-level public
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface GigabitEthernet0/Vlan101
    rename Vlan101
    description Vlan-101
    mac address 58:8b:f3:66:a1:11
    security-level private
    ip address 192.168.101.254 255.255.255.0
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface GigabitEthernet0/Vlan104
    rename Vlan104-MCAST
    description Vlan-104
    mac address 58:8b:f3:66:a1:14
    security-level private
    ip address 192.168.104.254 255.255.255.0
    ip dhcp client dns-routes
    ip dhcp client name-servers
    igmp downstream
    up
!
interface GigabitEthernet1
    rename OTS
    description Internet
    mac address factory wan
    security-level public
    ip address dhcp
    ip access-group _WEBADMIN_OTS in
    ip global 700
    ip dhcp client no dns-routes
    ip dhcp client no name-servers
    igmp upstream
    up
!
interface GigabitEthernet1/0
    rename 0
    up
!
interface Bridge0
    rename Home
    description "Home network"
    inherit GigabitEthernet0/Vlan1
    include AccessPoint
    include AccessPoint_5G
    security-level private
    ip address 192.168.100.254 255.255.255.0
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface Bridge1
    rename Guest
    description "Guest network"
    traffic-shape rate 5120
    inherit GigabitEthernet0/Vlan3
    include GuestWiFi
    security-level protected
    ip address 192.168.99.254 255.255.255.0
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up

Обратите внимание на созданные интерфейсы и как раскинуты порты по Vlan.

Только при этом можете про вэб интерфейс забыть и делать все через Cli.

  • Thanks 2

Share this post


Link to post
Share on other sites

  • 0

И не надо, а то юзверь запутается и будет сидеть без тЫрнетика и вконтактика.

Вопросы будут - пишите, постараюсь помочь.

Share this post


Link to post
Share on other sites

  • 0
В 04.02.2017 в 18:04, dexter сказал:

Вопросы будут - пишите, постараюсь помочь.

Приветствую!

Подскажите плиз как мне один из компьютеров домашней сети, подключаемый по WiFi изолировать от возможности какого-либо контакта с другими компьютерами этой сети но сохранив при этом возможность доступа этому компу в инет и к нему из инета (есть настройки NAT на определенные порты этого компа.

 

Share this post


Link to post
Share on other sites

  • 0
В 04.02.2017 в 18:04, dexter сказал:

Вопросы будут - пишите, постараюсь помочь.

Возникла пара вопросов:

1) Что такое 

security-level

2) Где бы взять мануальчик по конфигу? Или это пресловутый cli-manual?

Share this post


Link to post
Share on other sites

  • 0
Только что, nogood сказал:

Возникла пара вопросов:

2) Где бы взять мануальчик по конфигу? Или это пресловутый cli-manual?

Он самый cli-manual и с каждым днем книжка становится все толще.

Share this post


Link to post
Share on other sites

  • 0
В 06.02.2017 в 20:09, smartandr сказал:

Это я знаю, но уже нет возможности. На нем Linux и там уже настроен коннект на 5-ти герцовую точку в Ultra

Если других девайсов на 5GHz нет, то можно саму 5GHz-точку засунуть в гостевой бридж. Еще вариант, но не знаю, насколько он возможен для первой Ultra/Extra (вдруг речь шла только о 11ac) - в сегодняшней прошивке добавилась возможность создавать до четырех точек на 5GHz, опять же существующую точку засовываем в гостевой бридж, а второй делаем основную в домашнем бридже.

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...