Jump to content
  • 0
ToLive

Постоянная перезагрузка Keenetic II после обновления

Question

Здравствуйте!

Попал мне в пользование Keenetic II. Зайдя в веб-интерфейс я заметил, что текущая версия прошивки 2.02, при актуальной 2.06 и предложение обновиться. Предложение я принял, роутер начал обновляться, под конец процесса сообщил, что всё ок, но больше я не могу к нему подключиться.

Ведет он себя следующим образом: при включении, загорается светодиод Статуса и сетевого подключения (1). Сетевое подключение мигает. Секунд через 10 происходит перезагрузка устройста (один раз мигает статус, после этого загоряются на секунду все сетевые (0-5) и всё по новой, через 10 секунд опять перезагрузка).

Что я пробовал:

1. Восстановление через Keenetic Recovery. Проходит успешно, но после этого ничего не меняется.

2. Восстановление через tftp server - прошивка скачивается, но также ничего не меняется.

3. По telnet не подключается при в одном из режимов (обычная работа и режим загрузки прошивки).

4. Не пингуется.

Можно ли еще что-то попробовать сделать или только сервис (точнее скорее всего помойка)? Буду очень благодарен за помощь.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1
9 минут назад, colimp сказал:

Второй такой же Giga II здоровый. Обновил прошивку, предварительно сняв галочку с Интерфейса WiFi, скачал её и залил в первый роутер - все равно циклический ребут.

Ну вы откопали старую тему...

Точно-точно все компоненты с упоминанием WiFi убрали?

Прошивка под гигу тут была - https://forum.keenetic.net/topic/3272-прошивка-для-giga-ii-без-wi-fi/?sortby=date

 

Share this post


Link to post
Share on other sites
  • 0
37 minutes ago, zyxmon said:

Кнопочкой reset надеюсь пользовались.

Попробуйте через tftp поставить V1 - http://l10n.ndl.ru/firmwares/TEST/28112015/ и уже из нее через морду накатить V2

В некоторых случаяхпомогало.

Да, reset-ом получалось только попасть в режим восстановления, в обычной работе она не имела эффекта, то есть хоть держи ее, хоть нет - через 10 сек перезагрузка.

Спасибо! Попробовал поставить 1 версию и роутер частично ожил. Появился доступ по Telnet и веб-интерфейсу. Установка сверху версии 2.09 приводит к такой же проблеме, как и ранее (циклическая перезагрузка).

В добавок ко всему, не работает WiFi, не горит светодиод, хотя в веб-интерфейсе вроде как включен (кнопку на верхней панели тоже пробовал держать).

diag.log

usb_devs.log

KEENETIC_II.log

Share this post


Link to post
Share on other sites
  • 0
13 минуты назад, ToLive сказал:

Установка сверху версии 2.09 приводит к такой же проблеме, как и ранее (циклическая перезагрузка).

Не надо 2.09 сразу накатывать. Поставьте v2 с zyxel.ru. Если есть разные - попробуйте разные. А уже сверху 2.09.

Share this post


Link to post
Share on other sites
  • 0
1 час назад, ToLive сказал:

Да, reset-ом получалось только попасть в режим восстановления, в обычной работе она не имела эффекта, то есть хоть держи ее, хоть нет - через 10 сек перезагрузка.

Спасибо! Попробовал поставить 1 версию и роутер частично ожил. Появился доступ по Telnet и веб-интерфейсу. Установка сверху версии 2.09 приводит к такой же проблеме, как и ранее (циклическая перезагрузка).

В добавок ко всему, не работает WiFi, не горит светодиод, хотя в веб-интерфейсе вроде как включен (кнопку на верхней панели тоже пробовал держать).

diag.log

usb_devs.log

KEENETIC_II.log

Судя по выводу "ifconfig -a" и "iwconfig" из "diag.log", у вас полностью отсутствуют интерфейсы Wi-Fi. Это, скорее всего, аппаратная неисправность.

Edited by sergeyk

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, sergeyk said:

Судя по выводу "ifconfig -a" из "diag.log" у вас полностью отсутствуют интерфейсы Wi-Fi. Это, скорее всего, аппаратная неисправность.

Вот это я как раз тоже подозревал и, похоже, так оно и есть :(

1 hour ago, zyxmon said:

Не надо 2.09 сразу накатывать. Поставьте v2 с zyxel.ru. Если есть разные - попробуйте разные. А уже сверху 2.09.

С сайта не работает, запустилась только 2.02. 2.03 и новее уводят роутер в циклический ребут.

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, ToLive сказал:

 

Ведет он себя следующим образом: при включении, загорается светодиод Статуса и сетевого подключения (1). Сетевое подключение мигает. Секунд через 10 происходит перезагрузка устройста (один раз мигает статус, после этого загоряются на секунду все сетевые (0-5) и всё по новой, через 10 секунд опять перезагрузка).

Что я пробовал:

1. Восстановление через Keenetic Recovery. Проходит успешно, но после этого ничего не меняется.

Была такого рода оказия! Похоже суть косяка в том, что к старым конфигам прибавляются новые, вместо того, чтобы их заменять, и получается каша. Рецепт лечения у меня заключался в следующем:

Брал рекавери утилиту, путём подмены файлов, тех что есть в утилите, на те что сбэкапил перед прошивкой, перезаливал старую прошивку. Сбрасывал настройки на заводские (долгим удержанием ресета). Потом, если версия новой прошивки имеет слишком большую разницу с той, что была на момент перешивки, то качал отсюда версию на ступеньку больше чем была изначально прошита (допустим была 2.04 качал 2.05, а не сразу 2.08). Конфиги вроде бы корректно дополнялись. Делал опять ресет к заводским. И так, до тех пор, пока нормально само не обновилось через веб.

Опять-таки, хотел написать авторам, но никак руки на доходили. Пожалуй сейчас это сделаю :)  А чего рекавери утилита при её использовании не затирает старые конфиги? Или я не прав?

Share this post


Link to post
Share on other sites
  • 0

Нужно просто в v1 "задевнулить" раздел с конфигом. Можно просто reset кнопкой или из морды попробовать. Подозреваю, что в месте флеша, где конфиг, или мусор, или несовместимый с новой прошивкой конфиг. С V1 нет проблем, т.к. конфиг в другом месте того же раздела. ЕМНИП все это где то описано.... На ixbt?

Share this post


Link to post
Share on other sites
  • 0
5 минут назад, zyxmon сказал:

Подозреваю, что в месте флеша, где конфиг, или мусор, или несовместимый с новой прошивкой конфиг.

Вот я к этому же выводу пришёл эмпирическим путём :)  И был очень неприятно удивлён работой рекавери-утилиты. По логике она должна обнулять вообще всё и ставить всё начисто. На деле оказалось, что не казалось.

Edited by BACbKA

Share this post


Link to post
Share on other sites
  • 0
41 минуту назад, ToLive сказал:

Вот это я как раз тоже подозревал и, похоже, так оно и есть :(

С сайта не работает, запустилась только 2.02. 2.03 и новее уводят роутер в циклический ребут.

Да, новые версии, если установлен компонент "Интерфейс Wi-Fi" и не удается обнаружить соответствующие интерфейсы, не стартует.

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, sergeyk сказал:

Да, новые версии, если установлен компонент "Интерфейс Wi-Fi" и не удается обнаружить соответствующие интерфейсы, не стартует.

Погодите ка. Недопонял. На 2.02 у вас работает штатно? 

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, Mamay said:

Погодите ка. Недопонял. На 2.02 у вас работает штатно? 

Вроде всё работает, кроме WiFi. Обновление на версию выше - ребут.

 

24 minutes ago, zyxmon said:

Нужно просто в v1 "задевнулить" раздел с конфигом. Можно просто reset кнопкой или из морды попробовать. Подозреваю, что в месте флеша, где конфиг, или мусор, или несовместимый с новой прошивкой конфиг. С V1 нет проблем, т.к. конфиг в другом месте того же раздела. ЕМНИП все это где то описано.... На ixbt?

Осталось только понять, как его очистить, шуршу ixbt, но пока не нашел. Конечно, пробовал reset с кнопки и через веб-интерфейс, не помогает. (как я понимаю, эта процедура только один файл переписывает).

Share this post


Link to post
Share on other sites
  • 0
Только что, ToLive сказал:

Вроде всё работает, кроме WiFi. Обновление на версию выше - ребут.

 

Осталось только понять, как его очистить, шуршу ixbt, но пока не нашел. Конечно, пробовал reset с кнопки и через веб-интерфейс, не помогает. (как я понимаю, эта процедура только один файл переписывает).

Значит Wi-Fi модуль сказал гав. Печалька. 

Прям из web-UI скажите сбросить на заводские. Каждый раз. 

Share this post


Link to post
Share on other sites
  • 0
5 минут назад, ToLive сказал:

Вроде всё работает, кроме WiFi.

Детский вопрос: а вай-фай физически с кнопки пытался включить/выключить?

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, ToLive сказал:

Вроде всё работает, кроме WiFi. Обновление на версию выше - ребут.

Исходя из ответа @sergeyk, попробуйте на 2.02 зайти в компоненты и снять галку со всех компонентов WiFi - он у вас вероятно дохлый - по идее, должно обновиться нормально

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, BACbKA сказал:

Детский вопрос: а вай-фай физически с кнопки пытался включить/выключить?

Ыыы. Что-то подобное было уже на форуме. Но тут фиг в том, что физически выключенная кнопка Wi-Fi, не посылала бы старшие версии в reboot! Видимо на 2.02 так жёстко не проверялось железо... 

Share this post


Link to post
Share on other sites
  • 0
Just now, Mamay said:

Значит Wi-Fi модуль сказал гав. Печалька. 

Прям из web-UI скажите сбросить на заводские. Каждый раз. 

Да, я уже почти смирился. Если за сегодня не починю, то в трэш его.

Был у меня когда-то планшет HP Touchpad прошитый на Android, потом я решил поменять прошивку, она не заработала, вернув обратно первую прошивку, она тоже не заработало. Решил проблему только после долгих копаний, с помощью чистки разделов.

Пока у меня всё же есть надежда, что кривые руки, от которых мне пришло это устройство, не полностью его убило)

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, KorDen сказал:

Исходя из ответа @sergeyk, попробуйте на 2.02 зайти в компоненты и снять галку со всех компонентов WiFi - он у вас вероятно дохлый - по идее, должно обновиться нормально

Если даже заработает, человек поимеет умный свич? 

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Mamay сказал:

Если даже заработает, человек поимеет умный свич? 

Это больше чем ничего :13_upside_down: Но у меня стойкое убеждение, что железка жива и она здесь не при делах.

Share this post


Link to post
Share on other sites
  • 0
Только что, BACbKA сказал:

Это больше чем ничего :13_upside_down: Но у меня стойкое убеждение, что железка жива и она здесь не при делах.

Шанс есть всегда. Вы грешите на настройки, а не на хард. Будем посмотреть...

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, KorDen said:

Исходя из ответа @sergeyk, попробуйте на 2.02 зайти в компоненты и снять галку со всех компонентов WiFi - он у вас вероятно дохлый - по идее, должно обновиться нормально

Сейчас попробую, терять-то нечего

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, Mamay сказал:

Если даже заработает, человек поимеет умный свич? 

Умный свич не умеет NAT и торренты :) Чисто проводной роутер со всеми остальными функциями. У него ведь WiFi и сейчас в 1.xx / 2.02 не работает.

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, KorDen сказал:

Умный свич не умеет NAT и торренты :) Чисто проводной роутер со всеми остальными функциями. У него ведь WiFi и сейчас в 1.xx / 2.02 не работает.

Окей. Умный plus свич. Из-за наличия usb, расширяемый до невозможья... Но всё же свич... :mrgreen:

Share this post


Link to post
Share on other sites
  • 0
3 минуты назад, KorDen сказал:

Умный свич не умеет NAT и торренты :) Чисто проводной роутер со всеми остальными функциями. У него ведь WiFi и сейчас в 1.xx / 2.02 не работает.

Кстати, а если в этот умный свич воткнуть вай-фай донгл, он заведётся?... 

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, BACbKA сказал:

Кстати, а если в этот умный свич воткнуть вай-фай донгл, он заведётся?... 

Было уже. Нет. 

Share this post


Link to post
Share on other sites
  • 0

Один товарищ предлагал. Зачем покупать топ модели, вжухх донгл 802.11ac и вперёд к победе коммунизма... :mrgreen:

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Mamay сказал:

Один товарищ предлагал. Зачем покупать топ модели, вжухх донгл 802.11ac и вперёд к победе коммунизма... :mrgreen:

Кстати, идея-то здравая :) Но боюсь прошивка, которая и так уже не во все модели уже помещается, разбухнет ещё больше :222_hear_no_evil:

Share this post


Link to post
Share on other sites
  • 0
19 минут назад, BACbKA сказал:

Это больше чем ничего :13_upside_down: Но у меня стойкое убеждение, что железка жива и она здесь не при делах.

Если оно и на v1 и на v2 говорит о сдохшем WiFi, маловероятно...

12 минуты назад, Mamay сказал:

Окей. Умный plus свич. Из-за наличия usb, расширяемый до невозможья... Но всё же свич...

Чертов маркетинг. Можно еще развести холивар на тему "роутер - L3-коммутатор", ибо роутит и вообще NAT - происки с Нибиру. Что в вашем понимании свич, а что - роутер? Так ли уж обязательно роутеру (c NAT) иметь WiFi, чтобы быть роутером? Или все же это "WiFi-роутер"?
У меня Keenetic (I) как-то продолжительное время работал в качестве проводного роутера. Просто потому что от двух десятков WiFi-устройств начинаются дикие лаги у большинства домашних роутеров. А стоит поставить точку доступа (UniFi AP) - и все прекрасно.

10 минут назад, BACbKA сказал:

Кстати, а если в этот умный свич воткнуть вай-фай донгл, он заведётся?... 

Не-а

6 минут назад, Mamay сказал:

Один товарищ предлагал. Зачем покупать топ модели, вжухх донгл 802.11ac и вперёд к победе коммунизма... :mrgreen:

И получаем весьма вероятные лаги при нескольких подключенных устройствах

Edited by KorDen

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, BACbKA сказал:

Кстати, идея-то здравая :) Но боюсь прошивка, которая и так уже не во все модели уже помещается, разбухнет ещё больше :222_hear_no_evil:

Уверен, что keenetic не пойдёт на это. Прямая конкуренция с их же топами. Если пойдут, то только со своими свистками, ценой... 

Не думаю что научить Linux уметь Wi-Fi приёмо-передатчик,  во внешнем исполнении, будет занимать десятки мегабайт кода... 

Edited by Mamay

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...