Jump to content
  • 0
Sign in to follow this  
m__a__l

Билaйн l2tp + резервный провайдер, при торрентах рвет соединение

Question

Всем добра.

Столкнулся со странной штукой.

Имеется 2 провайдера (beeline(l2tp) и 2kom(IPoE), билайн основной), во время загрузки больших торрентов на ПК заметил "мистику", в uTorrent скорость периодически повышается выше 100 мегабит, точнее наблюдал 130 мегабит, это как раз сумма обоих каналов.

Не поверил, на резервном включил ускорение до 100 мегабит, и действительно, суммарная скорость поднялась до 200 мегабит, думаю интересно....

При этом происходят чудеса с подключениями, l2tp от билайна постоянно отваливается и снова подключается, думаю в этом и кроется причина активации второго канала, похоже, что пока билайн отвалился, utorrent успевает поднять подключения через другой канал и не отпускает их даже, когда билайн "возвращается".

Эта бага конечно хорошо, при загрузке "больших" торрентов начинает приносить пользу резервный канал, но с другой стороны напрягает регулярная падучесть l2tp, если эта бага/фича с суммированием скорости действительно работает при отключении основного канала, то я это и руками смогу делать, а вот падения коннектов нужно посмотреть/подчинить.

Ниже собственно скрины, на которых видно, что оба провайдера работают, ни каких маршрутов сам не прописывал, все происходит во время скачки торрентов с ПК, который подключен по проводу.

beeline-2.jpg.7f3211a03fa2f7ead63836f21c017625.jpg2kom-2.jpg.1f2c151f35000c7921c2932e611ce5c1.jpg

ниже добавлю селф в моменты падения подключения l2tp

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

@m__a__l попрбуйте отключить ping-check вообще, похоже это он вам рвет соединение. Если поможет - потом попрбуем настроить правильно.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
15 часов назад, Le ecureuil сказал:

@m__a__l попрбуйте отключить ping-check вообще, похоже это он вам рвет соединение. Если поможет - потом попрбуем настроить правильно.

Не помогло, что делал:

1) отключил ping-check запустил большой торрент, выключил l2tp, поднялись коннекты через 2-го провайдера, включил обратно, качает с обоих, суммарно больше 20 мегабайт/с, прошло около 10 мин, ну думаю все гуд, вернулся к компу, не гуд....., отвалилось и продолжало отваливаться много раз, это в первом селфе.

2) решил на всякий случай перепроверить, отключил 2-го провайдера через IPoE, все равно рвет подключение, ну и последним этапом перегрузил роутер без 2-го провайдера, не помогло, даже когда кабель только от билайна, все равно рвет коннекты.

Смутил момент, что через Broadband connection загрузка скакала до 20 мегабит, может это рвет связь? может l2tp не хватает канала для поддержания тунеля?

селфы ниже добавлю, первый без ping-check, второй без ping-check, 2-го провайдера(выдернут шнурок) и после перезагрузки.

Share this post


Link to post
Share on other sites
  • 0

На выходных удалось на пару часов добраться до компа с возможностью обновлять/перегружать роутер, поставил версию 2.09.A.9.0-0 и случилось чудо, за ~1 час закачки большого торрента ни разу l2tp не отвалился сам.

Так же наблюдался и отрицательный эффект для 2-х каналов, т.е. "фишка/баг" версии v2.08(AAUW.0)C2 не работал(а), а именно, при принудительном отключении l2tp нагрузка полностью переходила на резервный канал, при возвращении l2tp в работу, все коннекты с резервного канала "терялись" и закачка полностью переходила только на основной канал, т.е. волшебных 200Мбит/с больше добиться не получалось.

Тут я подумал, что и фиг бы с этими непостоянными 200Мбит/с, главное стабильность, и хотел остаться на драфте, но опять это но..... после перезагрузки стал отваливаться HDD, к сожалению лог не сохранил(закончилось время на игрушки с роутером и все нужно было быстро возвращать в полностью рабочее состояние), помню, что после перезагрузки в момент попытки подключения HDD в логах появлялась ошибка: /tmp/mnt/"метка диска"  not empty, флешка при этом цеплялась нормально.

HDD и флешка подключены через такой хаб, может в это проблема, но на v2.08(AAUW.0)C2 все работает.

 В итоге получается, что проблема с l2tp от пчилайна проявляется на v2.08(AAUW.0)C2, а на 2.09.A.9.0-0 этой проблемы нет, но перестает работать фишка при суммировании каналов на больших торрентах при временно ручном отключении l2tp основного провайдера. Ну и появилась проблема с HDD, если бы не это, остался бы на драфте.

Share this post


Link to post
Share on other sites
  • 0

Этот хаб - это просто жесть, вам очень везет что оно вообще иногда работает с внешним жестким диском через него.

Для внешних винтов нужны только активные хабы с внешним питанием, все остальное рано или поздно (по мере окисления контактов) превратится в тыкву и описанные вами проблемы.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

@Le ecureuil это хаб как бы имеет внешнее питание, единственное, что оно сейчас физически не подключено, да и на кабеля питания для огрызков и микро юсб к этой конторе вопросов нет, даже в машину длинный microusb менял от них, т.к. от обычной китайщины даже 1 ампера выдавить не получалось на 3 метра, а их провод необходимые 2ампера продавливает. 

Я правильно понимаю, что ошибки на 2.09.9 были из за нехватки питания? Проблема то возникала  именно после перезагрузки, я даже для проверки сделал сброс, все гуд, накатил конфиг, гуд, ребут и тогда уже проблема начинается. Очень уж на софтовую ошибку похоже.

На выходных отправлю жену с ребенком в деревню и появится свободное время для проверок. 

Жаль 2.09.9 не сохранил для проверок, скорее всего новый драфт уже появится. 

Share this post


Link to post
Share on other sites
  • 0
37 минут назад, m__a__l сказал:

Жаль 2.09.9 не сохранил для проверок

Скачайте у @enpa. Он все прошивки сохраняет и выкладывает. За,что ему Спасибо!!!

Вот ссылка:  https://cloud.mail.ru/public/4Ex3/f7JzaPzJZ

Хотя можно и более длинным путем установить с 2.08 до 2.09....:grin:

Edited by AndreBA
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
В 13.05.2017 в 10:33, m__a__l сказал:

Имеется 2 провайдера (beeline(l2tp) и 2kom(IPoE), билайн основной), во время загрузки больших торрентов на ПК заметил "мистику", в uTorrent скорость периодически повышается выше 100 мегабит, точнее наблюдал 130 мегабит, это как раз сумма обоих каналов.

Не поверил, на резервном включил ускорение до 100 мегабит, и действительно, суммарная скорость поднялась до 200 мегабит, думаю интересно....

При этом происходят чудеса с подключениями, l2tp от билайна постоянно отваливается и снова подключается, думаю в этом и кроется причина активации второго канала, похоже, что пока билайн отвалился, utorrent успевает поднять подключения через другой канал и не отпускает их даже, когда билайн "возвращается".

Эта бага конечно хорошо, при загрузке "больших" торрентов начинает приносить пользу резервный канал, но с другой стороны напрягает регулярная падучесть l2tp, если эта бага/фича с суммированием скорости действительно работает при отключении основного канала, то я это и руками смогу делать, а вот падения коннектов нужно посмотреть/подчинить.

Ниже собственно скрины, на которых видно, что оба провайдера работают, ни каких маршрутов сам не прописывал, все происходит во время скачки торрентов с ПК, который подключен по проводу.

ниже добавлю селф в моменты падения подключения l2tp

Это не "баг", а результат того что оба канала подняты.

При таком раскладе как уже говорилось - оба канала подняты, но default через тот у которого приоритет выше. Итак ПК качает -> default на роутере куда надо, но самое главное помним что имеем TCP и UDP соединения. Пусть считаем что pingcheck переключил так как ему что-то не понравилось на данном канале -> default сменился, но сам то канал поднят и маршруты все остались кеш то никуда не делся (если конечно pingchek их не подчищает). Так как торент все еще работает то опять таки те соединения которые еще активны продолжают качать по старым маршрутам, те которые закрылись по причине переключения создадутся заново но по новому маршруту (так как default сменился на роутере). Теперь pingchek восстановил основной канал т.е. сделал его default и что имеем в итоге = активные соединения (по маршрутам) на двух каналах = это все прелести  uTorrent и так же UDP потоков. Более точно можно сказать если посмотреть conntack и маршруты.

 

Share this post


Link to post
Share on other sites
  • 0

@AndreBA Спасибо за ссылку!

11 минуту назад, vasek00 сказал:

Это не "баг", а результат того что оба канала подняты.

При таком раскладе как уже говорилось - оба канала подняты, но default через тот у которого приоритет выше. Итак ПК качает -> default на роутере куда надо, но самое главное помним что имеем TCP и UDP соединения. Пусть считаем что pingcheck переключил так как ему что-то не понравилось на данном канале -> default сменился, но сам то канал поднят и маршруты все остались кеш то никуда не делся (если конечно pingchek их не подчищает). Так как торент все еще работает то опять таки те соединения которые еще активны продолжают качать по старым маршрутам, те которые закрылись по причине переключения создадутся заново но по новому маршруту (так как default сменился на роутере). Теперь pingchek восстановил основной канал т.е. сделал его default и что имеем в итоге = активные соединения (по маршрутам) на двух каналах = это все прелести  uTorrent и так же UDP потоков. Более точно можно сказать если посмотреть conntack и маршруты.

 

Если Вы внимательно читали мое следующее сообщение, 

то выясняется, что это именно "баг", который существует в v2.08(AAUW.0)C2 (возможно и других версиях), почему это баг? да по простой причине, l2tp самопроизвольно отваливается и потом повторно поднимается, а вот к примеру в 2.09.A.9.0-0 этой проблемы нет, т.е. l2tp самопроизвольно не отваливается, но перестает работать фишка при суммировании каналов при временно ручном отключении l2tp и повторном его включении, тут вот уж хз, возможно как раз начали подчищать кеш.

Share this post


Link to post
Share on other sites
  • 0

m__a__l

Речь шла о принципе работы двух маршрутов, а не про то что у вас исправилось или не исправилось, но сначала про :.

Баг не какого отношения к двум маршрутам не имеет. А по поводу pingcheck - и если посмотреть на форуме посты про него (да и на ixbt тоже) то можно увидеть кучу примеров в основном все вешают его на проверку например на google, а вот он google могу сказать на все 100% на любом подключении роутера к интернету может вести себя по разному, т.е. сегодня даст отлуп а завтра нет. Я писал про свой опыт Pingchek на PPPoE на одном включенном канале, после его применения канал разорвался и не поднялся, это правда было давно (нужно попробовать на днях еще раз).

Но вы перешли с 2.08 на 2.09, а если вы посмотрите список изменений по 2.08 поиск по L2TP то увидите кучу изменений

Цитата

2.09.A.9.0-0 этой проблемы нет, т.е. l2tp самопроизвольно не отваливается, но перестает работать фишка при суммировании каналов при временно ручном отключении l2tp и повторном его включении, тут вот уж хз, возможно как раз начали подчищать кеш.

Просто в "ручном отключении l2tp и повторном его включении" это просто "up" и "down", а вот когда pingchek проверил канал и переключил его на другой посчитав что он "плохой" просто на основании того что IP по которому он проверял не ответил он просто сделал замену default и только, а потом опять вернул (в логах можно увидеть, был ли сброс соединения или нет).

Где-то уже описывали его работу - но все упомнить проблематично.

Edited by vasek00

Share this post


Link to post
Share on other sites
  • 0
4 часа назад, vasek00 сказал:

Баг не какого отношения к двум маршрутам не имеет. А по поводу pingcheck - и если посмотреть на форуме посты про него (да и на ixbt тоже) то можно увидеть кучу примеров в основном все вешают его на проверку например на google, а вот он google могу сказать на все 100% на любом подключении роутера к интернету может вести себя по разному, т.е. сегодня даст отлуп а завтра нет. Я писал про свой опыт Pingchek на PPPoE на одном включенном канале, после его применения канал разорвался и не поднялся, это правда было давно (нужно попробовать на днях еще раз).

Я так и не смог понять при чем здесь pingcheck??? если вы думаете, что проблема в нем, то это не так, об этом я писал в своем 2-м сообщении, без pingcheck канал все равно падает на прошивке 2.08.

В 14.05.2017 в 14:00, m__a__l сказал:

Не помогло, что делал:

1) отключил ping-check запустил большой торрент, выключил l2tp, поднялись коннекты через 2-го провайдера, включил обратно, качает с обоих, суммарно больше 20 мегабайт/с, прошло около 10 мин, ну думаю все гуд, вернулся к компу, не гуд....., отвалилось и продолжало отваливаться много раз, это в первом селфе.

4 часа назад, vasek00 сказал:

Просто в "ручном отключении l2tp и повторном его включении" это просто "up" и "down", а вот когда pingchek проверил канал и переключил его на другой посчитав что он "плохой" просто на основании того что IP по которому он проверял не ответил он просто сделал замену default и только, а потом опять вернул (в логах можно увидеть, был ли сброс соединения или нет).

Снова вы не правы... еще раз прошу, если даете ответ, не читайте по диагонали, тот же ответ в моем сообщении:

В 14.05.2017 в 14:00, m__a__l сказал:

Не помогло, что делал:

1) отключил ping-check запустил большой торрент, выключил l2tp, поднялись коннекты через 2-го провайдера, включил обратно, качает с обоих, суммарно больше 20 мегабайт/с, прошло около 10 мин, ну думаю все гуд, вернулся к компу, не гуд....., отвалилось и продолжало отваливаться много раз, это в первом селфе.

Т.е. я на 2.08 и на 2.09 делал одинаковые манипуляции, выключал l2tp руками, так вот на 2.08 "фишка" с суммированием каналов работает, а на 2.09 нет.

Share this post


Link to post
Share on other sites
  • 0

Для начала читать

Цитата

Снова вы не правы... еще раз прошу, если даете ответ, не читайте по диагонали, тот же ответ в моем сообщении:

не умею, обучен со школы слева на право, по горизонтали.

Проверим на 2.09.А.9.0.0 попроще поднимаю два канала в результате имеем PPPoE (ppp0) приоритет 1000 скорость 100Мбит и PPTP/L2TP (ppp1) приоритет 900 скорость 50Мбит

/opt/tmp # ip ro | grep default
default via хх.хх.хх.54 dev ppp1

меняем default в ручную (ждать чего то когда все это сделает система не хочется)

/opt/tmp # ip ro replace default via хх.хх.хх.1 dev ppp0

1. запускаем на ПК торрент ждем пару минут (что скачка пошла) смотрим что имеем в таблице на роутере, кроме пары тек.для второго канала (т.е. только в сторону провайдера) там все для интерфейса ppp0

/opt/tmp # ip route list cache

выводить весь список не вижу смысла 

81.236.хх.хх from 192.168.1.2 dev ppp0  src 192.168.1.100 
    cache <src-direct>  iif br0
...
94.50.хх.хх from 192.168.1.2 dev ppp0  src 192.168.1.100 
    cache <src-direct>  iif br0
...

и т.д. для ppp1 нет маршрутов
      

2. меняем маршрут default

ip ro replace default via хх.хх.хх.52 dev ppp1

и смотрим 

/ # ip route list cache
192.168.1.2 from 79.67.хх.хх dev br0  src хх.хх.хх.52 
    cache  rtt 4ms rttvar 4ms cwnd 10 iif ppp0
94.179.хх.хх from 192.168.1.2 dev ppp1  src 192.168.1.100 
    cache <src-direct>  iif br0
134.249.хх.хх from 192.168.1.2 dev ppp1  src 192.168.1.100 
    cache <src-direct>  iif br0
192.168.1.2 from 185.18.хх.хх dev br0  src хх.хх.хх.52 
    cache <src-direct>  rtt 4ms rttvar 4ms cwnd 10 iif ppp1
...

3. смотрим на ПК и его торрент, как он качал со скоростью 9,1МБ так и качает.

4. проходит время и все устаканивается, т.е. скорость приходит в норму к 50Мбит согласно default ppp1.

Запускаем процедуру обратную переход с ppp1 на ppp0, ждем скорости в районе 45Мбит и переходим на другой канал ppp0. Спустя некоторое время скорость канала поднялась, выше чем на ppp1.

Нужно будет еще раз попробовать, что то разное получается время при переходе с PPPoE на PPTP/L2TP и на оборот с  PPTP/L2TP на PPPoE, в первом случае как-то очень долго скорость не падает до уровня PPTP/L2TP.

 

Теперь немного теории. Запись в таблице маршрутизации не вечна, если данный маршрут в кэше неактивен по моему около 5минут, то он просто удалиться из него, хотя соединение conntrack может еще быть активно, при запросе опять же по этому соединению но маршрута по нему нет да default уже сменился -> пойдет по новому маршруту (примечание у любых соединений  есть время жизни в любом случае keep-alive). Есть переменные ядра которые устанавливают временные интервалы. Проверим память по значению 5минут:

/proc/sys/net/ipv4/route # cat gc_interval
60
/proc/sys/net/ipv4/route # cat gc_timeout
300
/proc/sys/net/ipv4/route # cat min_adv_mss
256
/proc/sys/net/ipv4/route # cat max_size
16384
/proc/sys/net/ipv4/route # cat gc_elasticity
8
/proc/sys/net/ipv4/route # cat gc_thresh
1024
/proc/sys/net/ipv4/route # 

Переменные которые используются для сборки мусора в кэше, а к другому маршруту через gc_timeout, ограничение по max_size -> больше 10минут нет не чего.

Использовать два канала с одним default можно только стат.маршрутами.

 

Из всего делаю вывод кой какие не стыковки по времени работы якобы на 2.08 в отличие от 2.09 с двумя каналами.

Edited by vasek00

Share this post


Link to post
Share on other sites
  • 0

@vasek00 фраза "вы не правы" звучала в другом контексте, ни в коем случае не затрагивая ваши познания, все относилось только к локальной проблеме. 

А все, что описано с локальной проблемой выполнялось через веб морду.

С теорией о прнципе работы наверняка можно согласиться, но я описывал только то, что есть, с одной стороны проблема с самопроизвольным падением канала (хз может там полосатые виноваты, ответа то не было по селфам) с другой стороны была явная разница при сохранении активных подключений при ручном или самопроизвольным падением канала на разных прошивках. 

Share this post


Link to post
Share on other sites
  • 0

Для информации - выключение канала через WEB со страницы /#broadband.globals как и говорил ранее это "down" и "up" данного интерфейса => и маршрутизация

Скрытый текст

ДО ppp0 приоритет 1000 ppp1 приоритет 900

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:хх.хх.хх.100  P-t-P:хх.хх.хх.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
...

ppp1      Link encap:Point-to-Point Protocol  
          inet addr:хх.хх.хх.52  P-t-P:хх.хх.хх.6  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1400  Metric:1
         

default via хх.хх.хх.1 dev ppp0
...

хх.хх.хх.52 dev ppp1  scope link
...        

ПОСЛЕ

ppp1      Link encap:Point-to-Point Protocol  
          inet addr:хх.хх.хх.52  P-t-P:хх.хх.хх.6  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1400  Metric:1

default dev ppp1 scope link

 

ВКЛЮЧЕНИЕ

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:хх.хх.хх.225  P-t-P:хх.хх.хх.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
...

ppp1      Link encap:Point-to-Point Protocol  
          inet addr:хх.хх.хх.52  P-t-P:хх.хх.хх.6  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1400  Metric:1

default via хх.хх.хх.1 dev ppp0
...

хх.хх.хх.52 dev ppp1  scope link
...       

 

Цитата

Так же наблюдался и отрицательный эффект для 2-х каналов, т.е. "фишка/баг" версии v2.08(AAUW.0)C2 не работал(а), а именно, при принудительном отключении l2tp нагрузка полностью переходила на резервный канал, при возвращении l2tp в работу, все коннекты с резервного канала "терялись" и закачка полностью переходила только на основной канал, т.е. волшебных 200Мбит/с больше добиться не получалось.

....

с другой стороны была явная разница при сохранении активных подключений при ручном или самопроизвольным падением канала на разных прошивках. 

На 2.08 для начала достаточно было посмотреть что происходит с каналами. Как можно назвать "отрицательный эффект для 2-х каналов" вы о чем, если дальше речь идет о балансировке двух каналов - есть два варианта резервного канала - первый как есть, второй держать его в отключенном состоянии и поднимать при потери связи на основном разница будет на лицо - время его подъема.

Не понятно что реально вкладывается в ваше сообщение-"самопроизвольным падением канала на разных прошивках", при ручном я описал выше. Например приведу пример (к теме постов отношения не имеет) многие пользователи пишут не работает интернет, при дальнейшем выясняется что канал активен а проблемы с DNS. Так как вы приложили selftest только для разработчиков то другим он не виден и что-то  подсказать что и как не могут (конечно весь selftest не нужен). В вашем случае если вы на данном форуме то помимо selftest можно получить данные по системе даже обычными командами, которые предоставят так же полезную информацию что и как и именно по "самопроизвольным падением канала".

Share this post


Link to post
Share on other sites
  • 0

Кое что интересное нашел в данном поведении. Пояснения к графику ниже (обозначения интерфейсов по ifconfig):

- br0 интерфейс Home в котором wi-fi + eth2.1(LAN), ppp0 (pppoe) пров.1 скорость до 100 привязка к eth2.2, ppp1 (pptp) пров.2 сег. скорость до 20 привязка eth2.4

- для поднятия ppp1 использовался LAN eth2.4, для ppp0 WAN eth2.2

- 9:33 старт торрента на ПК, def на ppp0

- 9:40 смена маршрута через ip ro replace default на ppp1

- 9:45 промежуточный результат, но как видно скорость упала до текущей на ppp1

- 9:50 смена маршрута через ip ro replace default на ppp0 и тут то как раз обратил внимание что якобы трафик идет через ppp1, подумал счетчик дал сбой, но нет ifconfig так же дает увеличение байтиков на ppp1 (хотя в связке он с eth2.4, но на нем тишина в отличие от eth2.2). Через ppp1 такой скорости быть не может. Вывод работает как бы правильно но информация не верна.

eth2.2    Link encap:Ethernet  HWaddr  
...
          RX bytes:29461691523 (27.4 GiB)  TX bytes:767221999 (731.6 MiB)
...
eth2.4    Link encap:Ethernet  HWaddr  
...
          RX bytes:2737133463 (2.5 GiB)  TX bytes:120769947 (115.1 MiB)
...
ppp0      Link encap:Point-to-Point Protocol  
...
          RX bytes:6880620968 (6.4 GiB)  TX bytes:163160352 (155.6 MiB)

ppp1      Link encap:Point-to-Point Protocol  
...
          RX bytes:5066326633 (4.7 GiB)  TX bytes:125398136 (119.5 MiB)

через некоторо время

eth2.2    Link encap:Ethernet  HWaddr   
...
          RX bytes:30000109890 (27.9 GiB)  TX bytes:781012544 (744.8 MiB)
...
eth2.4    Link encap:Ethernet  HWaddr   
...
          RX bytes:2737635241 (2.5 GiB)  TX bytes:120800859 (115.2 MiB)
...
ppp0      Link encap:Point-to-Point Protocol  
...
          RX bytes:6880622486 (6.4 GiB)  TX bytes:163189571 (155.6 MiB)

ppp1      Link encap:Point-to-Point Protocol  
...
          RX bytes:5604743749 (5.2 GiB)  TX bytes:139170078 (132.7 MiB)

Так же интересную деталь увидел на br0 (Home) при работе клиента на ПК (LAN) трафик для него от ppp0 попадает на eth2.1 (LAN) как и положено, но при работе через ppp1 трафик попал в br0 ( 9:40 смена def на ppp1 с ppp0), а с 9:30 при работе через ppp0 трафик только в eth2.1( для LAN клиента ).

Вывод думаю не есть хорошо от попадания трафика в br0 от ppp1 для eth2.1.

WAN2.jpg

Edited by vasek00

Share this post


Link to post
Share on other sites
  • 0
В 29.05.2017 в 11:36, m__a__l сказал:

помню, что после перезагрузки в момент попытки подключения HDD в логах появлялась ошибка: /tmp/mnt/"метка диска"  not empty, флешка при этом цеплялась нормально.

 

В 29.05.2017 в 20:00, m__a__l сказал:

Я правильно понимаю, что ошибки на 2.09.9 были из за нехватки питания? Проблема то возникала  именно после перезагрузки, я даже для проверки сделал сброс, все гуд, накатил конфиг, гуд, ребут и тогда уже проблема начинается. Очень уж на софтовую ошибку похоже.

Как и предполагал, ошибка была именно софтовая, не в прошивке конечно, но прошивка все таки косвенно виновата, а именно: ошибка возникала из за syslog-ng, который у меня пишет на внешний диск, а opkg стоит на флешке, так вот в версии 2.09.B.0.0-0 поменялся приоритет подключения флешки и hdd местами, ранее на 2.08 hdd стартовал раньше и все гуд, а теперь первая стартует флшка и запускает syslog-ng, который начинает писать по пути /tmp/mnt/"метка диска"/log/... и винт не может подцепиться, т.к.по пути /tmp/mnt/"метка диска"/log/... уже есть данные, ну и не страшно, переключил запись логов на флешку и все вернулось в строй.

По основному вопросу, который и послужил для создания данной темы, да, баг l2tp от пчилайна действительно живет на прошивке 2.08, на 2.09.B.0.0-0 не воспроизводится, если не будет новых "сюрпризов" останусь на ней.

 

Есть еще отдельный вопрос к @Le ecureuil, за что был опущен ниже плинтуса usb хаб, на который я давал ссылку???

В 29.05.2017 в 16:47, Le ecureuil сказал:

Этот хаб - это просто жесть, вам очень везет что оно вообще иногда работает с внешним жестким диском через него.

Для внешних винтов нужны только активные хабы с внешним питанием, все остальное рано или поздно (по мере окисления контактов) превратится в тыкву и описанные вами проблемы.

я даже было усомнился в своем выборе не дорогого (по скидке был ~800р.) и надеялся хорошего хаба, в итоге заморочился, нашел бп способный дать более 2 ампер, запитал хаб, к уже имеющимся флешке и HDD 2.5, добавил еще и HDD 3.5 на 1 Тб, все взлетело без проблем, в итоге так и не понимаю, чем же плоха железяка??? если все так плохо, ткните носом, в чем подвох? и что же считается хорошим?

 

и еще просьба, на прошивке  2.09.B.0.0-0 вновь вернулся спам в журнал, на 2.08 спама не было, как в этой теме: 

 

Edited by m__a__l

Share this post


Link to post
Share on other sites
  • 0
23 часа назад, m__a__l сказал:

Есть еще отдельный вопрос к @Le ecureuil, за что был опущен ниже плинтуса usb хаб, на который я давал ссылку???

я даже было усомнился в своем выборе не дорогого (по скидке был ~800р.) и надеялся хорошего хаба, в итоге заморочился, нашел бп способный дать более 2 ампер, запитал хаб, к уже имеющимся флешке и HDD 2.5, добавил еще и HDD 3.5 на 1 Тб, все взлетело без проблем, в итоге так и не понимаю, чем же плоха железяка??? если все так плохо, ткните носом, в чем подвох? и что же считается хорошим?

По выданной ссылке нигде не указано, что хаб позволяет подключить внешнее питание. Если позволяет, и оно помогает - тогда он хороший, но об этом стоило указать.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...