Jump to content
zyxmon

Entware-3x. Проблемы с установкой, настройки...

Recommended Posts

У меня Кинетик Вива 2. Обновил прошивку через веб-интерфейс. Был установлен opkg. Теперь не могу зайти по ssh. При попытке залогиниться, в журнале появляется запись: dropbearUser 'user' has invalid shell, rejected". Сейчас установил релизную прошивку "v2.08(AANT.4)C2". Проблема осталась. Что делать?

Share this post


Link to post
Share on other sites
7 минут назад, pro777 сказал:

У меня Кинетик Вива 2. Обновил прошивку через веб-интерфейс. Был установлен opkg. Теперь не могу зайти по ssh. При попытке залогиниться, в журнале появляется запись: dropbearUser 'user' has invalid shell, rejected". Сейчас установил релизную прошивку "v2.08(AANT.4)C2". Проблема осталась. Что делать?

Модели Viva II не существует.

https://help.keenetic.net/hc/ru/sections/203198569

Share this post


Link to post
Share on other sites
29 минут назад, sergeyk сказал:

Модели Viva II не существует.

Поправлюсь: Keenetic Viva. Проблема осталась.

Edited by pro777

Share this post


Link to post
Share on other sites
27 минут назад, zyxmon сказал:

Установите заново

Удалил компонент opkg, установил снова. Ошибка осталась.

И еще. В разделе Система-Обновление было три типа прошивок: Релиз, Отладочная, Бета-версия. Теперь остались только две: Релиз и Бета-версия. Черт дернул меня обновиться :((

Edited by pro777

Share this post


Link to post
Share on other sites
8 минут назад, pro777 сказал:

Удалил компонент opkg

А Entware кто удалять будет? Пушкин? Возьмите чистую флешку и на ней потренируйтесь.

Share this post


Link to post
Share on other sites
40 минут назад, zyxmon сказал:

А Entware кто удалять будет?

Правильно я понял, что нужно с флешки сохранить мои данные, отформатировать ее, и установить все новой? 
Интересно, из-за чего возникла проблема?

Share this post


Link to post
Share on other sites

Поставил прошивку 2.09.C.1.0-1 на Кинетик Вива. Установил Entware3. Поставил lighttpd. Не запускается:
~ # /opt/etc/init.d/S80lighttpd start
 Starting lighttpd...              done.
~ # /opt/etc/init.d/S80lighttpd check
 Checking lighttpd...              dead.
В журнале только эта информация:
"Nov 08 12:05:40root Started lighttpd from"
В /var/log/lighttpd пусто..
Ставить apache не хочется.
В чем может быть дело?

P.S. Можно ли на виву с этой прошивкой поставить вместо Entware3 просто Entware? Она меня вполне устраивала. Кроме того, в Entware3 придется ставить PHP7. А это переписывание некоторой части кода..

P.P.S. Вчера пытался поставить Debian. Установка не удалась. 

Edited by pro777

Share this post


Link to post
Share on other sites
9 минут назад, pro777 сказал:

В чем может быть дело?

а лайти настроен?

9 минут назад, pro777 сказал:

Можно ли на виву с этой прошивкой поставить вместо Entware3 просто Entware?

можно, только и там РНР5 "выпилен"

Share this post


Link to post
Share on other sites
13 минуты назад, TheBB сказал:

а лайти настроен?

lighttpd.conf не менял. В папке /opt/share/www лежит index.html. 

 

13 минуты назад, TheBB сказал:

можно, только и там РНР5 "выпилен"

А как? Пытался копировать в папку install старый installer-entware.tar.gz. Он при установке обращается к ndm.zyxmon.org. И ничего там не находит. Может в Entware lighttpd будет работать? :)

Edited by pro777

Share this post


Link to post
Share on other sites

Решил попробовать Debian на Виве. Прошивка 2.09.C.1.0-1. Сделал все по инструкции. Не устанавливается, привожу лог журнала:

Nov 08 17:12:16 ndm Event::Acceptor: sending "Event::Type::DbKey" to "Opkg::Manager" 30 seconds.
Nov 08 17:12:44 keenetic_viva nginx(conn: *6570) upstream timed out (145: Unknown error) while reading response header from upstream, client: 192.168.1.х
Nov 08 17:12:46 ndm Event::Acceptor: sending "Event::Type::DbKey" to "Opkg::Manager" 60 seconds.
Nov 08 17:13:16 ndm Event::Acceptor: sending "Event::Type::DbKey" to "Opkg::Manager" 90 seconds.
Nov 08 17:13:44 ndm Opkg::Manager: system failed [0xcffd017f], timed out.
Nov 08 17:13:44 ndm Core::ConfigurationSaver: configuration saved.
Nov 08 17:13:49 ndm Opkg::Manager: /opt/etc/initrc: Please, define Debian services to start in /opt/debian/chroot-services.list first!
Nov 08 17:13:49 ndm Opkg::Manager: /opt/etc/initrc: One service per line. Hint: this is a script names from Debian /etc/init.d/.
Nov 08 17:13:49 ndm Opkg::Manager: /opt/etc/initrc: exit code 1.

ПОЧЕМУ?!!!

Share this post


Link to post
Share on other sites
6 минут назад, pro777 сказал:

ПОЧЕМУ?!!!

А почему Вы в этой теме пишите? Есть отличающихся способа установки Debian. Никто не знает, какой Вы выбрали. Создайте отдельную тему и опишите свои действия.

Share this post


Link to post
Share on other sites
10 минут назад, zyxmon сказал:

А почему Вы в этой теме пишите?

Виноват, не посмотрел на тему. Пост можно перенести?
Инструкцию использовал Отсюда

Edited by pro777

Share this post


Link to post
Share on other sites
19 часов назад, pro777 сказал:

Решил попробовать Debian на Виве. Прошивка 2.09.C.1.0-1. Сделал все по инструкции. Не устанавливается, привожу лог журнала:

Nov 08 17:12:16 ndm Event::Acceptor: sending "Event::Type::DbKey" to "Opkg::Manager" 30 seconds.
Nov 08 17:12:44 keenetic_viva nginx(conn: *6570) upstream timed out (145: Unknown error) while reading response header from upstream, client: 192.168.1.х
Nov 08 17:12:46 ndm Event::Acceptor: sending "Event::Type::DbKey" to "Opkg::Manager" 60 seconds.
Nov 08 17:13:16 ndm Event::Acceptor: sending "Event::Type::DbKey" to "Opkg::Manager" 90 seconds.
Nov 08 17:13:44 ndm Opkg::Manager: system failed [0xcffd017f], timed out.
Nov 08 17:13:44 ndm Core::ConfigurationSaver: configuration saved.
Nov 08 17:13:49 ndm Opkg::Manager: /opt/etc/initrc: Please, define Debian services to start in /opt/debian/chroot-services.list first!
Nov 08 17:13:49 ndm Opkg::Manager: /opt/etc/initrc: One service per line. Hint: this is a script names from Debian /etc/init.d/.
Nov 08 17:13:49 ndm Opkg::Manager: /opt/etc/initrc: exit code 1.

ПОЧЕМУ?!!!

Скорее всего слишком тормозная флешка/накопитель, у вас установщик вылетел по таймауту.

  • Thanks 1

Share this post


Link to post
Share on other sites
4 часа назад, Le ecureuil сказал:

Скорее всего слишком тормозная флешка/накопитель

Спасибо, вы правы. Подключил HDD через USB. Установка Debian прошла удачно.

Share this post


Link to post
Share on other sites

Zyxel Keenetic Extra.
Прошивка v.2.08(AANS.4)C2

Делал все согласно инструкции в теме https://forum.keenetic.net/topic/560-entware-3x/

Монтирую флешку, закидаю архив, прописываю строку /opt/etc/init.d/rc.unslung и нажимаю "применить". Запускается процес, после чего снова глухо. Логи журнала прикрепляю. Я новичок в етом, поетому сильно не матюжьте, если что. Подскажите в какую сторону рыть.

Скрытый текст
Nov 28 18:03:36ndm
Opkg::Manager: disk is set to: a54f6320-7290-e6fd-e16f-04baa85bb96d:
Nov 28 18:03:36ndm
Opkg::Manager: configured init script: "/opt/etc/init.d/rc.unslung".
Nov 28 18:03:36ndm
kernel: EXT4-fs (sda1): re-mounted. Opts: (null)
Nov 28 18:03:36ndm
Opkg::Manager: /tmp/mnt/disk_a1 mounted to /tmp/mnt/disk_a1.
Nov 28 18:03:36ndm
Opkg::Manager: /tmp/mnt/disk_a1 mounted to /opt/.
Nov 28 18:03:36ndm
Core::ConfigurationSaver: saving configuration...
Nov 28 18:03:42ndm
Opkg::Manager: none mounted to /opt/proc/.
Nov 28 18:03:42ndm
Opkg::Manager: none mounted to /opt/sys/.
Nov 28 18:03:42ndm
Opkg::Manager: /dev mounted to /opt/dev/.
Nov 28 18:03:42ndm
Opkg::Manager: /tmp mounted to /opt/tmp.
Nov 28 18:03:42ndm
Opkg::Manager: none mounted to /opt/dev/pts/.
Nov 28 18:03:42ndm
Opkg::Manager: system failed [0xcffd02a5].
Nov 28 18:03:42ndm
Opkg::Manager: system failed [0xcffd02ab].
Nov 28 18:03:42ndm
Opkg::Manager: system failed [0xcffd02b7], unable to copy /etc/shells -> /opt/etc/shells.
Nov 28 18:03:42ndm
Opkg::Manager: system failed [0xcffd02bf], unable to copy /etc/profile -> /opt/etc/profile.
Nov 28 18:03:42ndm
Opkg::Manager: /tmp/mnt/disk_a1 initialized.
Nov 28 18:03:42ndm
Opkg::Manager: invalid initrc "/opt/etc/init.d/rc.unslung": no such file or directory, trying /opt/etc/init.d/.
Nov 28 18:03:42ndm
Core::ConfigurationSaver: configuration saved.

 

Edited by _sergius

Share this post


Link to post
Share on other sites
1 час назад, _sergius сказал:

Подскажите в какую сторону рыть.

Есть подозрение, что в cli вводилась команда `opkg chroot`. Отменяйте.

Share this post


Link to post
Share on other sites

IPv6 нетю.

~ # nginx -t
nginx: [emerg] invalid port in "[::]:" of the "listen" directive in /opt/etc/nginx/nginx.conf:3
nginx: configuration file /opt/etc/nginx/nginx.conf test failed

Скрытый текст

configure arguments: --crossbuild=Linux::mipsel --with-cc=mipsel-openwrt-linux-gnu-gcc --with-cc-opt='-I/zyxel/Entware-ng-3x/staging_dir/target-mipsel_mips32r2_glibc-2.25/opt/include -I/zyxel/Entware-ng-3x/staging_dir/target-mipsel_mips32r2_glibc-2.25/include -I/zyxel/Entware-ng-3x/staging_dir/toolchain-mipsel_mips32r2_gcc-6.3.0_glibc-2.25/usr/include -I/zyxel/Entware-ng-3x/staging_dir/toolchain-mipsel_mips32r2_gcc-6.3.0_glibc-2.25/include -O2 -pipe -mno-branch-likely -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -msoft-float -I/zyxel/Entware-ng-3x/staging_dir/target-mipsel_mips32r2_glibc-2.25/opt/include/libxml2 -Wno-error=parentheses' --with-ld-opt='-L/zyxel/Entware-ng-3x/staging_dir/target-mipsel_mips32r2_glibc-2.25/opt/lib -L/zyxel/Entware-ng-3x/staging_dir/target-mipsel_mips32r2_glibc-2.25/lib -Wl,-rpath,/opt/lib -Wl,-rpath-link=/zyxel/Entware-ng-3x/staging_dir/target-mipsel_mips32r2_glibc-2.25/opt/lib -Wl,--dynamic-linker=/opt/lib/ld.so.1 -L/zyxel/Entware-ng-3x/staging_dir/toolchain-mipsel_mips32r2_gcc-6.3.0_glibc-2.25/usr/lib -L/zyxel/Entware-ng-3x/staging_dir/toolchain-mipsel_mips32r2_gcc-6.3.0_glibc-2.25/lib -lxml2' --prefix=/opt --conf-path=/opt/etc/nginx/nginx.conf --http-log-path=/opt/var/log/nginx/access.log --error-log-path=/opt/var/log/nginx/error.log --lock-path=/opt/var/lock/nginx.lock --pid-path=/opt/var/run/nginx.pid --modules-path=/opt/lib/nginx --http-client-body-temp-path=/opt/var/lib/nginx/body --http-fastcgi-temp-path=/opt/var/lib/nginx/fastcgi --http-proxy-temp-path=/opt/var/lib/nginx/proxy --http-scgi-temp-path=/opt/var/lib/nginx/scgi --http-uwsgi-temp-path=/opt/var/lib/nginx/uwsgi --with-debug --with-pcre-jit --with-http_ssl_module --with-http_stub_status_module --with-http_realip_module --with-http_auth_request_module --with-http_v2_module --with-http_dav_module --with-http_slice_module --without-http_upstream_zone_module --without-stream_upstream_zone_module --with-http_addition_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_image_filter_module=dynamic --with-http_mp4_module --with-http_random_index_module --with-http_secure_link_module --with-http_sub_module --with-http_xslt_module=dynamic --with-mail=dynamic --with-mail_ssl_module --with-stream=dynamic --with-stream_ssl_module 


 

Share this post


Link to post
Share on other sites

После обновления репозитория не стартует lighttpd. Ошибка:

lighttpd -t -f /opt/etc/lighttpd/lighttpd.conf
2017-12-25 19:16:53: (configfile.c.60) Warning: please add "mod_openssl" to server.modules list in lighttpd.conf.  A future release of lighttpd 1.4.x *will not* automatically load mod_openssl and lighttpd *will not* use SSL/TLS where your lighttpd.conf contains ssl.* directives

 

Подскажите, как можно побороть?

Share this post


Link to post
Share on other sites
Цитата

   Доступен релиз легковесного http-сервера lighttpd 1.4.46. В состав новой версии включены новые модули: mod_openssl, в который вынесен весь код, связанный с OpenSSL;...

А мы перескочили с 45 на 48... Взято в починку. Пока можете откатиться на предыдущую версию

  • Thanks 1

Share this post


Link to post
Share on other sites
1 час назад, Lordmaster сказал:

Warning: please add

А чем Вам предупреждение не нравится. Оно сообщает, что в следующих версиях конфиг нужно будет отредактировать и предлагает это сделать заранее.

Share this post


Link to post
Share on other sites
5 минут назад, TheBB сказал:

сыграем на опережение

А где сообщение об ошибке или пример конфига, когда сервер не запускается? С конфигом по умолчанию стартует и работает!

Share this post


Link to post
Share on other sites
1 час назад, zyxmon сказал:

А где сообщение об ошибке или пример конфига, когда сервер не запускается? С конфигом по умолчанию стартует и работает!

Конфиг следующий (связано скорее всего с добавкой про ssl:

Скрытый текст

server.document-root        = "/opt/share/www/owncloud"
server.upload-dirs          = ( "/tmp" )
server.errorlog             = "/opt/var/log/lighttpd/error.log"
server.pid-file             = "/opt/var/run/lighttpd.pid"
#server.username             = "http"
#server.groupname            = "www-data"

index-file.names            = ( "index.php", "index.html",
                                "index.htm", "default.htm",
                              )

static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

### Options that are useful but not always necessary:
#server.chroot               = "/"
server.port                 = 86
#server.bind                 = "localhost"
#server.tag                  = "lighttpd"
#server.errorlog-use-syslog  = "enable"
server.network-backend      = "writev"

### Use IPv6 if available
#include_shell "/opt/share/lighttpd/use-ipv6.pl"

#dir-listing.encoding        = "utf-8"
#server.dir-listing          = "enable"

include "/opt/etc/lighttpd/mime.conf"
include "/opt/etc/lighttpd/conf.d/*.conf"

$HTTP["url"] =~ "^/data/" {
url.access-deny = ("")
}
$HTTP["url"] =~ "^/($|/)" {
dir-listing.activate = "disable"
}

$HTTP["scheme"] == "https" {
    setenv.add-response-header  = ( "Strict-Transport-Security" => "max-age=63072000; includeSubdomains; ")
}

#ssl
$SERVER["socket"] == ":486" {
    ssl.engine = "enable"
    ssl.pemfile = "/opt/etc/lighttpd/certs/lighttpd.pem"

    # enforce strong cypher
    ssl.use-sslv2 = "disable"
    ssl.cipher-list = "TLSv1+HIGH !SSLv2 RC4+MEDIUM !aNULL !eNULL !3DES @STRENGTH"
}

 

1 час назад, TheBB сказал:

сыграем на опережение owrt`ешников :) 

попытка раз

При данных обновлениях все работает. Спасибо большое

Share this post


Link to post
Share on other sites

просьба уточнить: сервер не запускался вообще? просто предупреждение вылезало, а сервер стартовал? или ещё что-то?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...