Jump to content
Sign in to follow this  
hd44780

DLNA на GIGA III

Recommended Posts

Привет всем.

Купил на днях Keenetic GIGA 3, обновил прошивку до 2.08 C2. Настроил всё легко и быстро, включая ssh, opkg, entware, openvpn на USB винте.
А вот встроенный DLNA никак не заведётся - телек (Sharp примерно 2011 г, никакого смарта там нет) его видит, но он типа пустой, в нём нет никаких файлов. В вебе при конфигурировании иногда проскакивает ошибка типа "can't get file list". Почему - не могу понять. В лог как-то не догадался глянуть :( ...
Прочитал тут где-то, что ему может мешать IGMP proxy - вырубил - не помогло. После развёртывания entware помер вообще, телек его перестал видеть.

Поставил minidlna (как я понял, это сторонняя разработка) - телек увидел, файлы видны, но тоже не без приколов - сортировка файлов какая-то бредовая, опция force_sort_criteria в конфиге не помогла.

На старой белой гиге 1 я таких траблов вообще не замечал - DLNA взлетал с полпинка из веб-морды и без проблем. Я вообще не задумывался, как оно там работает и пр.
Файлы все проверенные тыщу раз.


В чём может быть дело?

Спасибо.

Share this post


Link to post
Share on other sites

А что говорят в поддержке по поводу встроенного DLNA. Entware при общении с официальной поддержкой лучше отключить.

 

Share this post


Link to post
Share on other sites
11 минуту назад, hd44780 сказал:

В чём может быть дело?

:1295_raised_hands_tone1:

Встроенный DLNA - норм (или Вы ему "что-то" зажимаете?). А сэлф будет? А смарт на телике - это панацея? Там все от стокового плеера зависит. IGMP Proxy - это, кхм, ближе к другому слою, но миф забавный. Minidlna .. все украдено до нас. force_sort_criteria

Share this post


Link to post
Share on other sites

Отключить minidlna Entware. Затем стереть setting.json встроенного dlna с внешнего hdd. Заново настроить "родной" dlna и получить работоспособный вариант. 

Ежели нет - письмо в официальную поддержку... 

Share this post


Link to post
Share on other sites
12 часа назад, zyxmon сказал:

А что говорят в поддержке по поводу встроенного DLNA. Entware при общении с официальной поддержкой лучше отключить.

 

Entware отключил, включил встроенный DLNA, глянул в лог. Увидел там такую красоту:

sql_get_int_field: step failed: SQL logic error or missing database SELECT count(*) from OBJECTS where PARENT_ID = '0';

Т.е. телек мой тут ни при чём (в чём, я, в принципе, не сомневался). Зашёл на DLNA-сервер кинетика с компа через VLC - ровно то же самое, что и на телеке. Ну оно и понятно.

Пойду в техподдержку.

setting.json посмотрю, тогда отпишусь.

Спасибо.

Share this post


Link to post
Share on other sites
1 час назад, Mamay сказал:

Затем стереть setting.json встроенного dlna с внешнего hdd.

Разве конфиг dlna так называется? Если уж стирать, то базу, а не настройки.

Share this post


Link to post
Share on other sites
22 минуты назад, zyxmon сказал:

Разве конфиг dlna так называется? Если уж стирать, то базу, а не настройки.

Блин. Я спутал с transmission... Извиняюсь. 

. dlna_files.db конечно же. 

Share this post


Link to post
Share on other sites

2 недели молчал - общался с техподдержкой на предмет встроенного DLNA. Общение пока продолжается, сказать пока нечего. Сдвигов тоже никаких. Поставил бету (вышла в пятницу, 9 июля) - изменений не заметил. Пытался добавить ему лог - он на мои правки не реагирует, при перезапуске роутера они исчезают.

self-test я им отсылал. Если кому интересно - могу и сюда его выложить, ничего военного там нет. Те же самые ошибки, что и в вебе.

Запустил ещё раз minidlna из entware - какой-то DLNA плеер на планшете нормально показывает, не слетает. Возможно это какие-то особенности моего телевизора.

Ну да ладно. Mediatomb мои проблемы с телевизором решил. Пожалуй, на нём и остановлюсь пока. Дальше посмотрим.

Единственное, что остаётся непонятным - что там такого изменилось со времён гиги1, на которой встроенный dlna работал без проблем, включая ту спецпрошивку с opkg. Там я minidlna из entware вообще не ставил - нужды не было.

Share this post


Link to post
Share on other sites

Со встроенным minidlna разобрались, заработал. В веб-морде есть список каких-то "общих папок". Оказывается туда надо было вносить каталоги с фильмами/музыкой и прочим. Я туда ничего не добавлял, меня совершенно сбил с толку термин "Общая папка". А в логе и при сохранении настроек нет никаких сообщений о том, что ему не заданы каталоги.

Попросил их добавить туда каких-то внятных сообщений об этой ситуации.

Сейчас сижу, наблюдаю за стабильностью его работы.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...