Jump to content
  • 0
Vladislav Kravchenko

Giga 2 тормозит при работе Resilio

Question

Друзья,

Что скажете в отношении следующей беды:

1. Есть ZyXel Giga II с установленной v2.06(AAFS.4)C2 (последней и официальной). Он держит небольшую домашнюю сеточку, где работают еще его два младших собрата в качестве проводных репитеров, а так же сервер на Ubuntu. Все оборудование, за исключением IOT подключено по гигабитной сети. У Giga II белый IP и подключен тоннель 6to4.

2. В сети с Giga II на Ubuntu сервере стоит Resilio (бывший BTSync). На том же сервере стоит еще и Transmission.

3. Giga II при помощи встроенного L2TP подключен с удаленной сетью (понятное дело VPN), где в качестве хоста используется другой Ubuntu-сервер со StrongSwan в качестве L2TP VPN. На этом же сервере стоит ответная часть Resilio. В удаленной сети стоят хуавей и древний LinkSys.

По загрузке Giga II почти что пустой: 

Загрузка ЦП    6%
Память    11% (27/256 МБ)

И это когда качает Transmission какую-то хрень.

Но, возникает проблема когда большой файл начинает передавать Resilio. Пока Resilio передает большой файл, например, видосик под пару гиг, вся сеть Giga II практически ложится. Все сетевые доступы, в том числе и внутри сети начинают отвечать ОЧЕНЬ медленно. Через веб-интерфейс зайти не могу на роутер, он просто не открывается. Сам роутер пингуется. Скорость аплинка в интернет всего 20 мбит по оптике (через модем). Я плотно общался с поддержкой Resilio и мы пришли к выводу, что проблема заключается в большом количестве пакетов (не подключений, по подключениям ничего такого аномального не выявили).

Как можно попытаться выяснить, что залипает в зюхеле? И исправить залипания.

 

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0
23 минуты назад, Vladislav Kravchenko сказал:

Есть ZyXel Giga II с установленной v2.06(AAFS.4)C2 (последней и официальной).

Вам не сюда.Вам в официальную поддержку надо:https://help.keenetic.net/hc/ru/requests/new, а здесь не официальная.

Edited by AndreBA

Share this post


Link to post
Share on other sites
  • 0

Насколько я понимаю, данные получается передаются через L2TP VPN? Не помню, есть ли в 2.06 L2TP/IPsec с аппаратным ускорением...

В общем и целом я бы посоветовал поставить 2.08 delta и перейти с L2TP на IPIP поверх IPsec, или даже просто попробовать чистый туннельный IPsec, без L2TP, если конечно через это соединение не нужно выходить наружу

Share this post


Link to post
Share on other sites
  • 0
18 часов назад, KorDen сказал:

Насколько я понимаю, данные получается передаются через L2TP VPN? Не помню, есть ли в 2.06 L2TP/IPsec с аппаратным ускорением...

В общем и целом я бы посоветовал поставить 2.08 delta и перейти с L2TP на IPIP поверх IPsec, или даже просто попробовать чистый туннельный IPsec, без L2TP, если конечно через это соединение не нужно выходить наружу

К сожалению, понять как идут пакеты через L2TP или через сервер Resilio в интернет - нельзя. Возможно, что идут и так и так. Тем не менее, проблема была и до установки тоннеля L2TP.

Вот сейчас как раз такой момент, когда большой файлик прокачивается. Роутер пингуется. На него можно зайти по телнет. Но веб-интерфейс прорисоывается только в шапке, остальное вращается колесо и все.

 

Что выдает по телнет роутер:

(config)> show system

         hostname: Keenetic_GigaII
       domainname: KVVDACHA
          cpuload: 21
           memory: 28352/262144
             swap: 0/0
         memtotal: 262144
          memfree: 214188
       membuffers: 4288
         memcache: 15316
        swaptotal: 0
         swapfree: 0
           uptime: 240606
 

Т.е. по идее ресурсов достаточно.

В логи каждую секунду кидает нечто следующее:

Io::TcpSocket: failed to open: object state failed.

 

Причем после того, как передача завершилась, роутер так и не отвис. Т.е. в веб-интерфейс к нему зайти нельзя.
 

 

Edited by Vladislav Kravchenko

Share this post


Link to post
Share on other sites
  • 0
В 17.06.2017 в 19:35, Vladislav Kravchenko сказал:

В логи каждую секунду кидает нечто следующее:

Io::TcpSocket: failed to open: object state failed.

В таком случае предлагаю выложить сюда селф-тест в момент передачи скрытым постом.

Share this post


Link to post
Share on other sites
  • 0
17 минут назад, KorDen сказал:

В таком случае предлагаю выложить сюда селф-тест в момент передачи скрытым постом.

Может автору  опробовать экспериментальную прошивку? После 2.06 все же вышли 2.07,2.08,2.09 и возможно 2.10(неофициально).

Edited by AndreBA

Share this post


Link to post
Share on other sites
  • 0
В 18.06.2017 в 20:00, KorDen сказал:

В таком случае предлагаю выложить сюда селф-тест в момент передачи скрытым постом.

Попробую. Роутер стоит на даче, не всегда там бываю, а удаленно может не получиться подключиться вообще. Из телнет Self-test можно выполнить? Что-то не могу найти в справочнике.

 

В 18.06.2017 в 20:15, AndreBA сказал:

Может автору  опробовать экспериментальную прошивку? После 2.06 все же вышли 2.07,2.08,2.09 и возможно 2.10(неофициально).

Пока не рискую переходить на более свежую, но не официальную (слишком много всего настроено, куча IoT и т.п.). Проблема была на 2.05, продолжается и на 2.04, возможно, что была и на более ранних версиях.

Share this post


Link to post
Share on other sites
  • 0
В 18.06.2017 в 20:00, KorDen сказал:

В таком случае предлагаю выложить сюда селф-тест в момент передачи скрытым постом.

Попробую. Роутер стоит на даче, не всегда там бываю, а удаленно может не получиться подключиться вообще. Из телнет Self-test можно выполнить? Что-то не могу найти в справочнике.

 

В 18.06.2017 в 20:15, AndreBA сказал:

Может автору  опробовать экспериментальную прошивку? После 2.06 все же вышли 2.07,2.08,2.09 и возможно 2.10(неофициально).

Пока не рискую переходить на более свежую, но не официальную (слишком много всего настроено, куча IoT и т.п.). Проблема была на 2.05, продолжается и на 2.04, возможно, что была и на более ранних версиях.

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, Vladislav Kravchenko сказал:

Попробовал отключить IPSec - проблема ушла полностью. Хотя в настройках стоит самое хилое шифрование, прямо совсем хилое DES и MD5. Хилее некуда. И что теперь делать?

Использовать прошивку 2.08 и новее.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
В 20.06.2017 в 15:27, Vladislav Kravchenko сказал:

Пока не рискую переходить на более свежую, но не официальную (слишком много всего настроено, куча IoT и т.п.). Проблема была на 2.05, продолжается и на 2.04, возможно, что была и на более ранних версиях.

99,9 % вероятность, что после установки версии от 2.08 и выше, что всё останется в штатном режиме. Прежде чем мигрировать, сохраните firmware и startup-config, для отката. 

Share this post


Link to post
Share on other sites
  • 0

От версии 2.08 и выше есть аппаратное поддержка шифрования, keendns и ещё много чего вкусного... 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Поставил 8-ю версию (но так и не понял, может быть надо ставить было 9-ю из-за каких-то более других фич) - проблема ушла (настройки не слетели). При прокачке по VPN через Resilio ничего не ложится. Доступ в роутер по веб-интерфейсу есть. Загрузку егойного процессора кажет в районе 20% и все.

Всем спасибо за советы.

Share this post


Link to post
Share on other sites
  • 0
5 часов назад, Vladislav Kravchenko сказал:

Поставил 8-ю версию (но так и не понял, может быть надо ставить было 9-ю из-за каких-то более других фич) - проблема ушла (настройки не слетели). При прокачке по VPN через Resilio ничего не ложится. Доступ в роутер по веб-интерфейсу есть. Загрузку егойного процессора кажет в районе 20% и все.

Всем спасибо за советы.

Коли вам хватает 2.08, то и не зачем заморачиваться на 2.09. Нынче актуально уже 2.10 преальфа. Можете вместе с нами протестировать... 

Share this post


Link to post
Share on other sites
  • 0
3 часа назад, Mamay сказал:

Коли вам хватает 2.08, то и не зачем заморачиваться на 2.09. Нынче актуально уже 2.10 преальфа. Можете вместе с нами протестировать... 

Я вот не очень понимаю, что в новых нового :) В списке в шапке форума нет понятного сравнения между 2.09, 2.08, 2.10 :) Ибо там с течением времени в той же версии в треклисте все время что-то новое появляется.

 

PS. Был доволен и 2.06, доволен и 2.08. Пока работает вполне стабильно и замечательно. 

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Vladislav Kravchenko сказал:

Я вот не очень понимаю, что в новых нового :) В списке в шапке форума нет понятного сравнения между 2.09, 2.08, 2.10 :) Ибо там с течением времени в той же версии в треклисте все время что-то новое появляется.

Как бы changelog говорит сам за себя. Убеждён, что не составит труда вычитать про все вкусняшки с полезняшками, а так же изменения в соответствующих топах 2.082.092.10, чтобы вкурить разницу...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...