Jump to content
Sign in to follow this  
alexxx0677

Некорректное отображение активного подключения при использовании OpenVPN

Recommended Posts

Использую 4G-модем и OpenVPN для выхода в интернет. Настроил OpenVPN клиента, соединяется и работает хорошо. Проблемы начинаются при разрыве или переподключении OpenVPN соединения. Следующее по приоритету подключение (модем) остается резервным, активным не становится. Значок подключения модема остается серым, а OpenVPN не может снова наладить соединение через модем. В логах пишет что нет подключения к интернету:

2017-10-14_18-16-02.jpg.43308e712f29433d423896fbba81f251.jpg

Тем временем пингчек сообщает, что подключение через модем доступно, превосходно пингует внешние ip. Так продолжается пока вручную не перезагрузишь модем. После перезагрузки модема его значок подключения снова становится зеленым, и OpenVPN соединяется на ура.

С другими шифрованиями такой проблемы нет, после отключения текущего следующее по приоритету зеленеет, да и через резервные (серые) подключения всё отлично соединяется..

 

И еще вопрос - при подключении OpenVPN всегда одна еругда в логах вылезает.

2017-10-14_18-27-08.jpg.56840c5f4b4c4505bef5b88d380450dc.jpg

Что это и как лечится?

 

Edited by alexxx0677

Share this post


Link to post
Share on other sites
58 минут назад, Lordmaster сказал:

Ответы ниже прикрепленного поста

Не думайте что я не просмотрел всю ту тему, ответов на свои вопросы там не нашел. Не будете ли вы так любезны ткнуть меня носом, если я чтото не доглядел?

У меня проблем с настройкой OpenVPN нету. Проблемы с переподключением, их настройками разве решить?

Автоматическую перезагрузку модема при отваливании OpenVPN кое как наладил, пингчекером пришлось пинговать самого себя с внешнего IP на той стороне впн.

Но исправлять прошивку всё равно надо.

Edited by alexxx0677

Share this post


Link to post
Share on other sites

@alexxx0677 у вас в self-test намешано как минимум работа ping-check, ручная перенастройка интерфейса и в итоге все равно OpenVPN соединился и работает. Потому ничего не понятно.

Можно попроще ситуацию: отключите pingcheck, ничего не перевключайте в web и воспроизведите эту ситуацию. Иначе гадание сплошное получается.

В моих тестах при дисконнекте openvpn все работает нормально.

Share this post


Link to post
Share on other sites
7 минут назад, Le ecureuil сказал:

@alexxx0677 у вас в self-test намешано как минимум работа ping-check, ручная перенастройка интерфейса и в итоге все равно OpenVPN соединился и работает. Потому ничего не понятно.

Можно попроще ситуацию: отключите pingcheck, ничего не перевключайте в web и воспроизведите эту ситуацию. Иначе гадание сплошное получается.

В моих тестах при дисконнекте openvpn все работает нормально.

Отключил пингчек, перезагрузил роутер - всё соединилось как нужно.

Отключил OpenVPN, модем зеленым не стал, остался в режиме резервирования.

2017-10-14_17-50-21.jpg.23de1d3da68da70e11db5613eba6d9f9.jpg

Включил OpenVPN снова - в логах ошибка об отсутствии сети, туннель не поднимается. Селфтест высылаю.

Из ручных настроек только сделал интерфейс модема private, чтобы из домашней сети никто через него не мог в интернет выйти. А то провайдер отслеживает и сразу блокирует. Другого способа не нашел, может есть такой?

Share this post


Link to post
Share on other sites

Стал отваливаться OpenVPN :(

Oct 20 09:25:17OpenVPN0
Connection reset, restarting [0]
Oct 20 09:25:17OpenVPN0
SIGTERM[soft,connection-reset] received, process exiting
Oct 20 09:25:17ndm
Service: "OpenVPN0": unexpectedly stopped.
Oct 20 09:25:17ndm
Network::Interface::OpenVpn: "OpenVPN0": system failed [0xcffd0823], unable to set down tunnel interface: no such device.
Oct 20 09:25:17ndm
Network::Interface::IP: "OpenVPN0": IP address cleared.
Oct 20 09:25:19OpenVPN0
OpenVPN 2.4.4 [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [AEAD]
Oct 20 09:25:19OpenVPN0
library versions: OpenSSL 1.1.0f 25 May 2017, LZO 2.10
Oct 20 09:25:19OpenVPN0
TCP/UDP: Preserving recently used remote address: [AF_INET]ххх.ххх.ххх.ххх:1194
Oct 20 09:25:19OpenVPN0
Attempting to establish TCP connection with [AF_INET]ххх.ххх.ххх.ххх:1194 [nonblock]
Oct 20 09:25:20OpenVPN0
TCP: connect to [AF_INET]ххх.ххх.ххх.ххх:1194 failed: Connection refused
Oct 20 09:25:20OpenVPN0
NOTE: UID/GID downgrade will be delayed because of --client, --pull, or --up-delay
Oct 20 09:25:20OpenVPN0
SIGUSR1[connection failed(soft),init_instance] received, process restarting
Oct 20 09:25:25OpenVPN0
TCP/UDP: Preserving recently used remote address: [AF_INET]ххх.ххх.ххх.ххх:1194
Oct 20 09:25:25OpenVPN0
Attempting to establish TCP connection with [AF_INET]ххх.ххх.ххх.ххх:1194 [nonblock]
Oct 20 09:25:26OpenVPN0
TCP: connect to [AF_INET]ххх.ххх.ххх.ххх:1194 failed: Connection refused

 

Share this post


Link to post
Share on other sites
7 минут назад, artsel сказал:

Стал отваливаться OpenVPN :(

Oct 20 09:25:17OpenVPN0
Connection reset, restarting [0]
Oct 20 09:25:17OpenVPN0
SIGTERM[soft,connection-reset] received, process exiting
Oct 20 09:25:17ndm
Service: "OpenVPN0": unexpectedly stopped.
Oct 20 09:25:17ndm
Network::Interface::OpenVpn: "OpenVPN0": system failed [0xcffd0823], unable to set down tunnel interface: no such device.
Oct 20 09:25:17ndm
Network::Interface::IP: "OpenVPN0": IP address cleared.
Oct 20 09:25:19OpenVPN0
OpenVPN 2.4.4 [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [AEAD]
Oct 20 09:25:19OpenVPN0
library versions: OpenSSL 1.1.0f 25 May 2017, LZO 2.10
Oct 20 09:25:19OpenVPN0
TCP/UDP: Preserving recently used remote address: [AF_INET]ххх.ххх.ххх.ххх:1194
Oct 20 09:25:19OpenVPN0
Attempting to establish TCP connection with [AF_INET]ххх.ххх.ххх.ххх:1194 [nonblock]
Oct 20 09:25:20OpenVPN0
TCP: connect to [AF_INET]ххх.ххх.ххх.ххх:1194 failed: Connection refused
Oct 20 09:25:20OpenVPN0
NOTE: UID/GID downgrade will be delayed because of --client, --pull, or --up-delay
Oct 20 09:25:20OpenVPN0
SIGUSR1[connection failed(soft),init_instance] received, process restarting
Oct 20 09:25:25OpenVPN0
TCP/UDP: Preserving recently used remote address: [AF_INET]ххх.ххх.ххх.ххх:1194
Oct 20 09:25:25OpenVPN0
Attempting to establish TCP connection with [AF_INET]ххх.ххх.ххх.ххх:1194 [nonblock]
Oct 20 09:25:26OpenVPN0
TCP: connect to [AF_INET]ххх.ххх.ххх.ххх:1194 failed: Connection refused

 

И вот по этому обрубку лога вы мне предлагаете как Ванге угадать, что же происходит?

Share this post


Link to post
Share on other sites

@Le ecureuil это то, что пишется в системных логах. Дальше соединение refused пока не рестартанешь сервер.

У меня роутер недавно и с кинетиками я только начал знакомиться, поэтому если что-то нужно еще, то говори что и как, постараюсь снять инфу

Share this post


Link to post
Share on other sites
29 минут назад, artsel сказал:

@Le ecureuil это то, что пишется в системных логах. Дальше соединение refused пока не рестартанешь сервер.

У меня роутер недавно и с кинетиками я только начал знакомиться, поэтому если что-то нужно еще, то говори что и как, постараюсь снять инфу

https://forum.keenetic.net/announcement/4-как-правильно-добавить-self-test-и-прочую-отладку-в-тему/

https://forum.keenetic.net/announcement/3-для-чего-этот-форум-или-кто-здесь/

Share this post


Link to post
Share on other sites

Попробуйте проверить на последнем draft, который выйдет в пятницу.

Share this post


Link to post
Share on other sites
23 часа назад, Le ecureuil сказал:

Попробуйте проверить на последнем draft, который выйдет в пятницу.

По последним тестам после отключения OpenVPN его приоритет продолжает действовать, все подключения с низшим приоритетом остаются в резерве. Делаю приоритет отключенного OpenVPN ниже - другие подключения становятся активными.

Share this post


Link to post
Share on other sites

И еще у OpenVPN с автопропиской маршрутов проблемы, через резервные подключения не соединяется так как L2TP например. Приходится добавлять статический маршрут вручную, тогда работает.

Share this post


Link to post
Share on other sites
В 24.10.2017 в 13:38, Le ecureuil сказал:

Попробуйте проверить на последнем draft, который выйдет в пятницу.

К сожалению положительных изменений нет, кое что даже хуже стало)

При отключении (галочкой в вебменю) OpenVPN с высоким приоритетом, следующее за ним подключение как и раньше остается резервным.

2017-10-28_10-25-43.jpg.9fa3dae48b15ed1decab0fa2abd261e3.jpg

Раньше достаточно было понизить приоритет OpenVPN, тогда L2TP становилось активным. Сейчас этого мало, приходится перещелкивать L2TP чтобы соединение установилось заново.

 

Share this post


Link to post
Share on other sites

1. 192.168.0.0/24 PPPoE (конец туннеля 172.18.1.1)  - белый ip

настройки OpenVPN

dev tun
proto tcp4-server
port 443
ifconfig 172.18.1.1 172.18.1.2
route 192.168.2.0 255.255.255.0

cipher AES-128-CBC
<secret>bla bla bla</secret>
 

2. 192.168.2.0/24 3G modem APN (конец туннеля 172.18.1.2) - серый ip c NATом от провайдера

настройки OpenVPN

dev tun
proto tcp4-client
remote 217.53.74.197 443
ifconfig 172.18.1.2 172.18.1.1
route 192.168.0.0 255.255.255.0
verb 3

cipher AES-128-CBC
<secret>bla bla bla</secret>

Пинги не проходят ни с 172.18.1.1 на 172.18.1.2 ни наоборот.

При этом я могу открыть из сети 192.168.0.0 web-интерфейс роутера на 172.18.1.1

Подскажите, а почему не пингуются концы туннеля OpenVPN?

Edited by cocojambo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...