Jump to content
TheBB

test
Asterisk-13.x/15.x

49 posts in this topic

3 минуты назад, Piligrimm сказал:

А что насчет  Entware, какой и откуда ставить?

Учитесь пользоваться поиском...

Share this post


Link to post
Share on other sites
1 час назад, Piligrimm сказал:

sip.conf - копия с работающего астериска в этой же сети.

Интересует минимальный набор устанавливаемых пакетов(именно устанавливаемых), чтоб было так - установил минимум запустил, если все работает то устанавливаем следующий и проверяем. И желательно порядок установки минимального набора (а то там зависимости всякие).

Так может у старого в этом параметре его IP указан? Тут обычно говорят - конфиги в студию...

У астериска, который собирается из исходников на обычном сервере, есть специальная команда для установки минимальных конфигурационных файлов. Так что я не вспомню минимум. Тем боле что я всегда при сборке добавляю необходимые мне пакеты.

Совет - выключи автозагрузку модулей и смотри ошибки. Там тебе написано будет каких модулей не хватает.

Share this post


Link to post
Share on other sites
9 минут назад, ChaoticSerg сказал:

Так может у старого в этом параметре его IP указан? Тут обычно говорят - конфиги в студию...

У астериска, который собирается из исходников на обычном сервере, есть специальная команда для установки минимальных конфигурационных файлов. Так что я не вспомню минимум. Тем боле что я всегда при сборке добавляю необходимые мне пакеты.

Совет - выключи автозагрузку модулей и смотри ошибки. Там тебе написано будет каких модулей не хватает.

У меня в конфиге параметр externaddr не установлен (закомментирован).

Сейчас переустанавливаю всё. Изменил прошивку, ставлю другую версию Entware и будет другая сборка астериска. Потом отпишусь.

Share this post


Link to post
Share on other sites
1 час назад, Mamay сказал:

Учитесь пользоваться поиском...

Как не странно, но этот совет действительно помог ;)

При установки Entware в журнале событий кинетика 2 красные строчки:

Mar 30 13:05:39    ndmOpkg::Manager: invalid initrc "/opt/etc/initrc": no such file or directory, trying /opt/etc/init.d/.
Mar 30 13:06:18    ndmService: "Coala Agent": unexpectedly stopped.

Насколько это критично?

 

Share this post


Link to post
Share on other sites
1 минуту назад, Piligrimm сказал:

Как не странно, но этот совет действительно помог ;)

Mar 30 13:06:18    ndmService: "Coala Agent": unexpectedly stopped.

Насколько это критично?

 

Плохо искали...

Share this post


Link to post
Share on other sites
В 30.03.2018 в 12:25, Piligrimm сказал:

У меня в конфиге параметр externaddr не установлен (закомментирован)

А вы припишите. У роутера слишком много сетевых интерфейсов. И локальные адреса тоже пропишите.

Share this post


Link to post
Share on other sites
3 часа назад, ChaoticSerg сказал:

А вы припишите. У роутера слишком много сетевых интерфейсов. И локальные адреса тоже пропишите.

Нет смысла. Все маршруты построены (динамические и статические), все сети и сервера доступны. После переустановки всё заработало и так. В принципе и должно было работать, видать глюк был.

Как я и сказал, всё заработало. Сейчас просто привожу всё в порядок (заодно и мысли) и документирую. Чуть позже поделюсь.

Да, вот вопрос. Астериск не опознает команду Read в экстеншене. Видать надо какой-то модуль доустановить. Может подскажите какой?

Всем очень признателен.

Share this post


Link to post
Share on other sites
Цитата

Проекты Entware-ng и Entware-ng-3x объединились под общим названием Entware.

все актуальные сборки теперь по адресу http://bin.entware.net/ , asterisk, представленный в этой теме, обновлён и остался по старому адресу...

Share this post


Link to post
Share on other sites
12 часа назад, TheBB сказал:

все актуальные сборки теперь по адресу http://bin.entware.net/ , asterisk, представленный в этой теме, обновлён и остался по старому адресу...

Сервер не доступен. Пинги не идут. Это только у меня?

Share this post


Link to post
Share on other sites
1 час назад, Piligrimm сказал:

Причём оба сервера. 

Оба сервера отвечают...

Share this post


Link to post
Share on other sites
36 минут назад, Mamay сказал:

Оба сервера отвечают...

Да. Странно как-то. Перезагрузил кинетик и у меня всё заработало. А до перезагрузки не пинговался только этот сервер (эти сайты на одном сервере), всё остальное работало

 

Share this post


Link to post
Share on other sites
16 часов назад, Piligrimm сказал:

Да, вот вопрос. Астериск не опознает команду Read в экстеншене. Видать надо какой-то модуль доустановить. Может подскажите какой?

 

Сам себе отвечу

asterisk13-app-read

Правда перед ним установил модуль asterisk13-app-readexten, который  сам по себе ни какого эффекта не дал, но может эти оба  модуля должны быть установлены как сейчас у меня.

Share this post


Link to post
Share on other sites

Доброе время суток, уважаемые форумчане!

Я новичек в данной теме - потому прошу помощи

Мой роутер:

Model Keenetic Giga II
Service tag 032-963-116-107-021
NDMS version v2.06(AAFS.0)C3

 

Хочется вставить GSM модем и использовать какой то SIP сервис (например Zadarma.com) для VOIP2GSM 

Заранее спасибо! Сорри если не туда написал. 

Прошу ткнуть носом куда смотреть.

 

Edited by Kobzantsev Maxim

Share this post


Link to post
Share on other sites
3 часа назад, Kobzantsev Maxim сказал:

Доброе время суток, уважаемые форумчане!

Я новичек в данной теме - потому прошу помощи

Мой роутер:

Model Keenetic Giga II
Service tag 032-963-116-107-021
NDMS version v2.06(AAFS.0)C3

 

Хочется вставить GSM модем и использовать какой то SIP сервис (например Zadarma.com) для VOIP2GSM 

Заранее спасибо! Сорри если не туда написал. 

Прошу ткнуть носом куда смотреть.

 

Вам нужен 2G/3G модем с активированным голосовым модулем, вот тут пример как это настроить -  https://asterisk-pbx.ru/wiki/artikle/gsm_voip_usb_chan_datacard_dongle_asterisk_huawei_e1550_e173 или https://habrahabr.ru/post/160299/

Share this post


Link to post
Share on other sites

Все новую версию asterisk' а забросили чтоли?

Кто-нибудь уже использует  в бою 15 версию на роутере?

Share this post


Link to post
Share on other sites

Доброе время суток, уважаемые форумчане!

Помогите нубу.

Имеется Астериск 11, установленный отсюда .  С работой в терминале разобрался, но, похоже, не до конца. Проблема в следующем: после правки файлов конфигурации всё работает до перезагрузки роутера. Потом все правленые файлы конфигураций перезаписываются исходными ( как до правки). Нужна команда для сохранения? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×