Jump to content
  • 0
Andrew Voronkov

Нет доступа к провайдерскому Huawei через KeenDNS

Question

Приветствую. Домашняя сеть, ультра2 на 192.168.1.1.

Основной канал - выделенка.

МТС роутер Huawei CPE B315 по проводу как второй ipoe - в режиме резерва на 192.168.2.1. 

В локальной сети прекрасно открывается мтс роутер Huawei по его ip 192.168.2.1 что когда он в резерве, что в активе. 

Чтобы получить доступ к нему через keendns сделал, как советовали: 

ip http proxy mts
upstream http 192.168.2.1 80
domain ndns
allow public

При этом при переходе по mts.bla-bla.mykeenetic.ru извне - браузер редиректится на http://192.168.2.1/html/index.html?url=mts.bla-bla.mykeenetic.ru - и, соответственно, ничего не открывается.

Написал в саппорт, там после долгих изучений ответили: 

Цитата

Посмотрел, это то о чем я предупреждал, в одном из своих первых ответов.

Внимание! Возможность такой работы также зависит от реализации веб-интерфейса самого usb-модема. 
Например, успешной работы удалось добиться с модемом ZTE 823 (тикет 358188). Также обнаружилась проблема с модемом E3372 (тикет 362246), где модем на запрос отвечает HTTP'307 - Temporary Redirect и форвардит запрос на URI, который доступен только при прямом обращении к модему.

То есть CPE B315 форвардит на 192.168.2.1 в любом случае, даже при обращении извне через keendns. 

 

Есть ли какой вариант обойти это или исправить в будущих прошивках? В настройках самого CPE B315 я такого не нашёл. Возможно, подскажете, куда копать. В CLI разбираюсь слабо, но готовые команды вбить могу без проблем. 

 

Спасибо! 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Похоже ваш запрос дошел до меня, разбираемся. Сотрудничайте дальше с поддержкой, они подскажут что делать.

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Le ecureuil сказал:

Похоже ваш запрос дошел до меня, разбираемся. Сотрудничайте дальше с поддержкой, они подскажут что делать.

В идеале хотелось бы иметь возможность добавлять имена устройствам в keendns не только в одной подсети, но и в других - стандартными методами через меню, а не через CLI как сейчас. Очень актуально для резервных каналов интернета (в том числе для операторских роутеров, а так же модемов в режиме хайлинк). И нужна возможность добавлять авторизацию с логином-паролем от основного роутера - для тех устройств в сети, которые авторизации вообще не имеют (пока сделал через CLI, но было бы круто делать это галкой около имени устройства через веб интерфейс keendns что-то типа "добавить принудительную авторизацию"). Ну и вопрос с редиректом некоторых роутеров типа моего - тоже открыт. 

Спасибо большое за содействие! Если будет необходимо - могу дать доступ через teamviewer. 

 

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, Andrew Voronkov сказал:

В идеале хотелось бы иметь возможность добавлять имена устройствам в keendns не только в одной подсети, но и в других - стандартными методами через меню, а не через CLI как сейчас. Очень актуально для резервных каналов интернета (в том числе для операторских роутеров, а так же модемов в режиме хайлинк). И нужна возможность добавлять авторизацию с логином-паролем от основного роутера - для тех устройств в сети, которые авторизации вообще не имеют (пока сделал через CLI, но было бы круто делать это галкой около имени устройства через веб интерфейс keendns что-то типа "добавить принудительную авторизацию"). Ну и вопрос с редиректом некоторых роутеров типа моего - тоже открыт. 

Спасибо большое за содействие! Если будет необходимо - могу дать доступ через teamviewer. 

 

Про веб ничего не обещаю, потому что не моя сфера.

Но вот про редирект - постараемся решить.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
21 час назад, Le ecureuil сказал:

Про веб ничего не обещаю, потому что не моя сфера.

Но вот про редирект - постараемся решить.

А можно параллельно потыкать кого-нибудь, кто за веб отвечает? 

Ещё раз спасибо! 

Share this post


Link to post
Share on other sites
  • 0

@Le ecureuil

вот это

HTTP: включена подмена хоста в заголовке Host на ip http proxy upstream 

Связано с описанной проблемой?

Как то это надо настраивать? У меня 2.12.A.1.0-2 доступ на модем через keendns продолжает редиректить на адрес модема (192.168.0.1).

Или это не то?

Share this post


Link to post
Share on other sites
  • 0
13 минуты назад, r13 сказал:

@Le ecureuil

вот это


HTTP: включена подмена хоста в заголовке Host на ip http proxy upstream 

Связано с описанной проблемой?

Как то это надо настраивать? У меня 2.12.A.1.0-2 доступ на модем через keendns продолжает редиректить на адрес модема (192.168.0.1).

Или это не то?

Да, это то. По идее должно помочь.

Скиньте дампы обмена с модемом при заходе через keendns, и при заходе локально.

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Le ecureuil сказал:

Да, это то. По идее должно помочь.

Скиньте дампы обмена с модемом при заходе через keendns, и при заходе локально.

Ок вечером сделаю.

Share this post


Link to post
Share on other sites
  • 0
6 часов назад, Le ecureuil сказал:

Да, это то. По идее должно помочь.

Скиньте дампы обмена с модемом при заходе через keendns, и при заходе локально.

сделал дампы на интерфейсе модема

в следующем посте.

Редирект уже по видимому работает, так как

До добавления редиректа было типа так:

http://192.168.2.1/html/index.html?url=mts.bla-bla.mykeenetic.ru

Теперь же

http://192.168.2.1/html/index.html

Т.е. модем уже keendns url не получает

Но все равно не keendns имя в url возвращается.

Edited by r13
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
18 часов назад, r13 сказал:

сделал дампы на интерфейсе модема

в следующем посте.

Редирект уже по видимому работает, так как

До добавления редиректа было типа так:

http://192.168.2.1/html/index.html?url=mts.bla-bla.mykeenetic.ru

Теперь же

http://192.168.2.1/html/index.html

Т.е. модем уже keendns url не получает

Но все равно не keendns имя в url возвращается.

Да, такой подлянки от вендора этого модема мы не ожидали :)

Видимо все же придется делать команду которая отключает передачу заголовка "Host" вообще - видимо из-за этого и не работает.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
5 часов назад, Le ecureuil сказал:

Да, такой подлянки от вендора этого модема мы не ожидали :)

Видимо все же придется делать команду которая отключает передачу заголовка "Host" вообще - видимо из-за этого и не работает.

Zte кстати себя так же ведет, так что не только этот вендор, а оба китайца себя так ведут. 

Зы может они так доступ из wan ограничивают...

Edited by r13

Share this post


Link to post
Share on other sites
  • 0

Очередной подход к снаряду.
В следующем draft будет добавлен код, который удаляет заголовок Host вообще, если upstream задан как IP-адрес. Заодно удаляется заголовок "Authorization", который не должен "утекать" в upstream.
По идее теперь редиректа быть не должно.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
В 24.01.2018 в 00:02, Le ecureuil сказал:

Очередной подход к снаряду.
В следующем draft будет добавлен код, который удаляет заголовок Host вообще, если upstream задан как IP-адрес. Заодно удаляется заголовок "Authorization", который не должен "утекать" в upstream.
По идее теперь редиректа быть не должно.

Коварный редирект не сдается :)

На версии а2 после редиректа в адресной строке браузера остается http://index.html/ то есть адрес вырезается полностью.

Дамп пакетов нужен?

Share this post


Link to post
Share on other sites
  • 0

Короче удалять заголовок Host оказалось немного плохой идеей: 

Что касается редиректа, то тут возможно наверное придумать rewrite какой-то, но это уже костыль и пока у меня нет идей как сделать его красивым и универсальным.

Проще всего запомнить URI, на который редиректит с "/", и потом заходить по адресу <proxy>.<kdns>/<uri>. По сообщениям пользователей, так работает нормально:

Цитата

При обращении напрямую к usb-modem.test.keenetic.pro он редиректит на 192.168.2.1/html/index.html, и это, похоже, никак не исправить. Но если обратиться к http://usb-modem.test.keenetic.pro/html/index.html, интерфейс модема открывается нормально.

 

Share this post


Link to post
Share on other sites
  • 0
26 минут назад, r13 сказал:

Коварный редирект не сдается :)

На версии а2 после редиректа в адресной строке браузера остается http://index.html/ то есть адрес вырезается полностью.

Дамп пакетов нужен?

Наверное нет, пока хватит издевательств над всеми :)

Попробуйте идею с URI, возможно подойдет.

Share this post


Link to post
Share on other sites
  • 0
14 минуты назад, Le ecureuil сказал:

Наверное нет, пока хватит издевательств над всеми :)

Попробуйте идею с URI, возможно подойдет.

На этот способ подопытный включил черный юмор :)

2018-01-25.thumb.png.3aaed8e33c42e981884b218bd233607c.png

Share this post


Link to post
Share on other sites
  • 0

Роутер 4G (KN-1210)
2.11.B.1.0-0

 

Проделал сию махинацию на хуавей 3372s

Версия ПО:    22.300.09.00.00

Версия веб-интерфейса:    17.100.17.00.143-Mod1.20

Переадресовывает на IP в любом случае. Хоть с приставкой /html/home.html хоть без приставки.


В это версии прошивки модема есть некий аналог файла hosts

И прописанная туда по умолчанию строка

hi.link 192.168.8.1 180 вполне корректно работает. При указании в браузер адреса hi.link - открывает то что нужно (находясь в локалке с этим роутером и модемом)

 

Я попробовал указать строкувида

modem.domen.mykeenetic.ru 192.168.8.1:80 180

Ничего не вышло - переадресация на IP модема.

Потом я делаю

ip http proxy modem
  upstream http hi.link 80
  domain ndns
  allow public
  exit

Таже петрушка - переадресация на IP модема.

 

 

 

Edited by Tritel

Share this post


Link to post
Share on other sites
  • 0
3 часа назад, Tritel сказал:

Роутер 4G (KN-1210)
2.11.B.1.0-0

 

Проделал сию махинацию на хуавей 3372s

Версия ПО:    22.300.09.00.00

Версия веб-интерфейса:    17.100.17.00.143-Mod1.20

Переадресовывает на IP в любом случае. Хоть с приставкой /html/home.html хоть без приставки.


В это версии прошивки модема есть некий аналог файла hosts

И прописанная туда по умолчанию строка

hi.link 192.168.8.1 180 вполне корректно работает. При указании в браузер адреса hi.link - открывает то что нужно (находясь в локалке с этим роутером и модемом)

 

Я попробовал указать строкувида

modem.domen.mykeenetic.ru 192.168.8.1:80 180

Ничего не вышло - переадресация на IP модема.

Потом я делаю

ip http proxy modem
  upstream http hi.link 80
  domain ndns
  allow public
  exit

Таже петрушка - переадресация на IP модема.

 

 

 

У меня на руках сейчас как раз 3372 в hilink (проверяю на тему отвалов), проверю что там с ним.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
29 минут назад, Le ecureuil сказал:

проверяю на тему отвалов

Отваливается (перезагружается) по питанию. Качественный USB не более двух метров для стабильной работы.
Когда на гране по питалову - нужно поддать жару чтоб добиться "устойчивости появления этой плавающей неисправности". Нагрузить большой передачей данных. Типа Ютюб в 5 соединений.
Ну а если на хорошем ЮСБ проводе отваливается - значит модем ранее был перегрет. Обычно клиенты перегревают его цепляя на южное окно.

Я их сотнями ставлю, если что - обращайтесь.

 

Так что мне бы хоть какойнибудь костыль чтоб в морду хайлинка пробраться.

Edited by Tritel

Share this post


Link to post
Share on other sites
  • 0
15 минут назад, Tritel сказал:

Отваливается (перезагружается) по питанию. Качественный USB не более двух метров для стабильной работы.
Когда на гране по питалову - нужно поддать жару чтоб добиться "устойчивости появления этой плавающей неисправности". Нагрузить большой передачей данных. Типа Ютюб в 5 соединений.
Ну а если на хорошем ЮСБ проводе отваливается - значит модем ранее был перегрет. Обычно клиенты перегревают его цепляя на южное окно.

Я их сотнями ставлю, если что - обращайтесь.

 

Так что мне бы хоть какойнибудь костыль чтоб в морду хайлинка пробраться.

Да тут вот, в соседней теме ваши коллеги по несчастью: 

 

Share this post


Link to post
Share on other sites
  • 0
В 01.03.2018 в 19:47, Tritel сказал:

Переадресовывает на IP в любом случае. Хоть с приставкой /html/home.html хоть без приставки.

@Andrew Voronkov @Tritel: исправлено в версии 2.12.A.4.0-9. Выяснилось, что прокси не пропускал HTTP-заголовки с подчеркиванием, без которых морда Huawei не может.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, ndm сказал:

@Andrew Voronkov @Tritel: исправлено в версии 2.12.A.4.0-9. Выяснилось, что прокси не пропускал HTTP-заголовки с подчеркиванием, без которых морда Huawei не может.

С html/home.html прекрасно теперь открывается веб Huawei LTE CPE B315

До этого релиза в любом случае открывалась заглушка модемная, что он уже подключен к сети интернет. Без возможности попасть в меню. 

Просто по адресу модема keendns открывается эта самая злополучная заглушка. Как бы сделать автоподстановку home.html для некоторых адресов, чтобы не вводить вручную? 

Кстати, с новым билдом исправились и локальные адреса keendns в той же подсети.

Отличная работа, спасибо! 

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
6 часов назад, Andrew Voronkov сказал:

С html/home.html прекрасно теперь открывается веб Huawei LTE CPE B315

До этого релиза в любом случае открывалась заглушка модемная, что он уже подключен к сети интернет. Без возможности попасть в меню. 

Просто по адресу модема keendns открывается эта самая злополучная заглушка. Как бы сделать автоподстановку home.html для некоторых адресов, чтобы не вводить вручную? 

Кстати, с новым билдом исправились и локальные адреса keendns в той же подсети.

Отличная работа, спасибо! 

Попробуйте почистить кэш браузера.

Если не поможет, то пожалуйста снимите дамп пакетов на CdcEthernet0 при отключенном ppe software в момент захода на корень (/) ресурса модема, посмотрим, что он отвечает не так.

Share this post


Link to post
Share on other sites
  • 0

@Le ecureuil

С e3276 все отлично заработало! Спасибо. 

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
В 24.03.2018 в 07:20, Le ecureuil сказал:

Попробуйте почистить кэш браузера.

Если не поможет, то пожалуйста снимите дамп пакетов на CdcEthernet0 при отключенном ppe software в момент захода на корень (/) ресурса модема, посмотрим, что он отвечает не так.

Чистка кэша не помогает. Отправил скрытым дамп.

Роутер вместо редиректа на http://mts.bla-bla.mykeenetic.ru/html/home.html делает редирект на страницу http://mts.bla-bla.mykeenetic.ru/html/opennewwindow.html с интерфейсом модема и надписью:

Устройство уже подключено к сети Интернет.
Если запрошенная страница не открывается, закройте текущий браузер и запустите другой.

Но с этой страницы никуда не уйти.

 

Если же вводить http://mts.bla-bla.mykeenetic.ru/html/home.html - то всё открывает отлично. 

Edited by Andrew Voronkov
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
В 3/26/2018 в 18:13, Andrew Voronkov сказал:

Чистка кэша не помогает. Отправил скрытым дамп.

Роутер вместо редиректа на http://mts.bla-bla.mykeenetic.ru/html/home.html делает редирект на страницу http://mts.bla-bla.mykeenetic.ru/html/opennewwindow.html с интерфейсом модема и надписью:

Устройство уже подключено к сети Интернет.
Если запрошенная страница не открывается, закройте текущий браузер и запустите другой.

Но с этой страницы никуда не уйти.

 

Если же вводить http://mts.bla-bla.mykeenetic.ru/html/home.html - то всё открывает отлично. 

Внимательно посмотрел дамп, и не нашел в нем запросов и редиректов на opennewwindow.html. Вы заходили не через proxy? Тогда понятно, но это не помогает понять проблему.

Пожалуйста, снимите этот дамп, когда заходите через ip http proxy - будет над чем работать.

Share this post


Link to post
Share on other sites
  • 0
20 минут назад, Le ecureuil сказал:

Пожалуйста, снимите этот дамп, когда заходите через ip http proxy - будет над чем работать.

Как зайти через прокси?

Данный редирект возникает при любом заходе - что с компьютера, что со смартфона, независимо от браузера. 

Странно, что его не видно в дампе. Прошлые дампы я делал ровно так же - в них всё вроде было видно. 

Share this post


Link to post
Share on other sites
  • 0
24 минуты назад, Andrew Voronkov сказал:

Как зайти через прокси?

Данный редирект возникает при любом заходе - что с компьютера, что со смартфона, независимо от браузера. 

Странно, что его не видно в дампе. Прошлые дампы я делал ровно так же - в них всё вроде было видно. 

Включить дамп, зайти по внешнему адресу, прям на http://mts.bla-bla.mykeenetic.ru/. После редиректа на злополучный opennewwindow отключить дамп и скинуть сюда. В дампе должно быть буквально 10-15 секунд, не больше.

Все остальные вкладки в браузере, которые открыты на это устройство надо закрыть, иначе будет куча-мала.

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, Le ecureuil сказал:

Включить дамп, зайти по внешнему адресу, прям на http://mts.bla-bla.mykeenetic.ru/. После редиректа на злополучный opennewwindow отключить дамп и скинуть сюда. В дампе должно быть буквально 10-15 секунд, не больше.

Все остальные вкладки в браузере, которые открыты на это устройство надо закрыть, иначе будет куча-мала.

Так я именно так и сделал. Один раз зашел по прямому адресу, второй раз зашел по адресу с home. Чтобы вам можно было увидеть разницу. 

Если нужно зайти "чисто" - говорите, так и сделаю. 

Share this post


Link to post
Share on other sites
  • 0
5 минут назад, Andrew Voronkov сказал:

Так я именно так и сделал. Один раз зашел по прямому адресу, второй раз зашел по адресу с home. Чтобы вам можно было увидеть разницу. 

Если нужно зайти "чисто" - говорите, так и сделаю. 

Один раз заход на "/" я увидел в дампе, но там все отлично сработало с редиректом и правильно. Второго раза нет, :(  видимо что-то пошло не так или кэш в браузере сработал - кстати его стоит почистить или заходить из incognito mode.

Share this post


Link to post
Share on other sites
  • 0
9 минут назад, Le ecureuil сказал:

Один раз заход на "/" я увидел в дампе, но там все отлично сработало с редиректом и правильно. Второго раза нет, :(  видимо что-то пошло не так или кэш в браузере сработал - кстати его стоит почистить или заходить из incognito mode.

Отправил скрытым

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...