Jump to content
  • 0
zyzyxel

Обрывы при работе USB-модема

Question

Такой вопрос, на кинетике 4G III (A) + usb модем Huawei  E3131 постоянно вылетает коннект при отдаче трафика. То есть банальный спидтест на телефоне обрывает связь, как только начинается тест скорости на отдачу. Если, например, с ПК сливать файлы по FTP, то обрывы происходят не всегда. К слову, на Giga II вроде этой проблемы нет, он как-то стабильно держит подключение и не отваливается. По логике, можно предположить, что дело в 4г-2 кинетике, ибо такие обрывы случались на всех версиях прошивок:на заводских, 2.10, 2.12 etc/

Известна ли эта беда, либо эта проблема, возможно, из разряда частных случев?  Есть какая-то возможность избавиться от этой проблемы, поэксперементировав с настройками?

Share this post


Link to post
Share on other sites

42 answers to this question

  • 0
8 минут назад, zyzyxel сказал:

Такой вопрос, на кинетике 4G III (A) + usb модем Huawei  E3131 постоянно вылетает коннект при отдаче трафика. То есть банальный спидтест на телефоне обрывает связь, как только начинается тест скорости на отдачу. Если, например, с ПК сливать файлы по FTP, то обрывы происходят не всегда. К слову, на Giga II вроде этой проблемы нет, он как-то стабильно держит подключение и не отваливается. По логике, можно предположить, что дело в 4г-2 кинетике, ибо такие обрывы случались на всех версиях прошивок:на заводских, 2.10, 2.12 etc/

Известна ли эта беда, либо эта проблема, возможно, из разряда частных случев?  Есть какая-то возможность избавиться от этой проблемы, поэксперементировав с настройками?

Возможно питания не хватает, надо пробовать с активным хабом, или usb Y-кабалем...

Share this post


Link to post
Share on other sites
  • 0
4 минуты назад, r13 сказал:

Возможно питания не хватает, надо пробовать с активным хабом, или usb Y-кабалем...

Может не так понял, но вы имеете ввиду два конца кабеля включить в usb-входы на роутере? Можно было бы попробовать, беда что в 4г3 там один usb вход. С хабом можно попробовать, да. Но как-то не думал что даже из-за питания трабла может быть.

Share this post


Link to post
Share on other sites
  • 0
31 минуту назад, zyzyxel сказал:

Может не так понял, но вы имеете ввиду два конца кабеля включить в usb-входы на роутере? Можно было бы попробовать, беда что в 4г3 там один usb вход. С хабом можно попробовать, да. Но как-то не думал что даже из-за питания трабла может быть.

Не, второй конец y-кабеля в дополнительный блок питания

Edited by r13

Share this post


Link to post
Share on other sites
  • 0
31 minutes ago, zyzyxel said:

как-то не думал что даже из-за питания трабла может быть

С этими модемами часто такое.

Share this post


Link to post
Share on other sites
  • 0

@zyzyxel я уже устал чистить за вами, еще раз будете писать про свои проблемы в непредназначенных для этого темах - забаню.

Share this post


Link to post
Share on other sites
  • 0

У меня четыре Huawei 3131, ни с одним из них такой проблемы нет. Видимо у вас реально с питанием проблемы на 4G, тут без USB тестера поставить диагноз не получится.

 

Share this post


Link to post
Share on other sites
  • 0

GIGA III

C прошивки 2.12.A.1.0-2 постоянно отваливается модем  E3276 (в режиме RAS).

Возвращаюсь на последнюю 2.11.A.6.0-0 все нормально, предыдущих версий 2,12 к сожалению не сохранил, но все началось с 2.12.A.1.0-2

Подозреваю, что сломали исправляя :

  • исправлена работа модема E3272s-210 HiLink в режиме RNDIS

Share this post


Link to post
Share on other sites
  • 0

Версия 2.12.A.3.0-0 модем заработал и весьма устойчиво

Жаль, разработчик в журнале изменений не пишет этого. Приходится узнавать методом тыка.

Еще плюс у модема стал показывать параметры: Сигнал (CINR / RSSI)

Share this post


Link to post
Share on other sites
  • 0

Простите, погорячился.

Разработчики занимаются своими делами.

Модем держал долго - около 1,5 часов - обрадовал.

Если отваливается то роутер его не перезапускает. Тупо и глупо. (

Вернулся на 2.11.A.6.0-0 и перезапуск на ура.

Печально, что все равно

Share this post


Link to post
Share on other sites
  • 0
19 часов назад, Вячеслав сказал:

Простите, погорячился.

Разработчики занимаются своими делами.

Модем держал долго - около 1,5 часов - обрадовал.

Если отваливается то роутер его не перезапускает. Тупо и глупо. (

Вернулся на 2.11.A.6.0-0 и перезапуск на ура.

Печально, что все равно

А вы можете self-test с включенным system debug предоставить с 2.11.A.6.0-0 и с текущего драфта, где он отваливается? Было бы очень полезно для нахождения причины.

Share this post


Link to post
Share on other sites
  • 0
В 25.01.2018 в 19:33, Вячеслав сказал:

GIGA III

C прошивки 2.12.A.1.0-2 постоянно отваливается модем  E3276 (в режиме RAS).

Возвращаюсь на последнюю 2.11.A.6.0-0 все нормально, предыдущих версий 2,12 к сожалению не сохранил, но все началось с 2.12.A.1.0-2

Подозреваю, что сломали исправляя :

  • исправлена работа модема E3272s-210 HiLink в режиме RNDIS

Оно как бы не пересекается, RAS и HiLink это разные режимы, как и используемые драйвера...

Share this post


Link to post
Share on other sites
  • 0
4 часа назад, McMCC сказал:

Оно как бы не пересекается

как бы :-) Нужно верить в совпадение?

16 часов назад, Le ecureuil сказал:

А вы можете self-test с включенным system debug предоставить с 2.11.A.6.0-0 и с текущего драфта, где он отваливается? Было бы очень полезно для нахождения причины.

Стесняюсь спросить, кто стер мои ссылки на self-test ?

Share this post


Link to post
Share on other sites
  • 0
52 минуты назад, Вячеслав сказал:

Стесняюсь спросить, кто стер мои ссылки на self-test ?

Если Вы сами их не скрывали то это могли сделать администраторы, так как в self-test содержится конфиденциальная информация. 

Share this post


Link to post
Share on other sites
  • 0
13 часа назад, Вячеслав сказал:

Стесняюсь спросить, кто стер мои ссылки на self-test ?

Они здесь, мы их видим. Большое спасибо.

Share this post


Link to post
Share on other sites
  • 0
16 часов назад, Вячеслав сказал:

как бы :-) Нужно верить в совпадение?

И где тут совпадения кроме слова модем? Я вам точно говорю, что новое исправление для RNDIS, не что иное, как дополнение из новых команд для протокола NDIS, коих раньше и сейчас нет в драйвере Linux, без этих команд не поднимается сетевой интерфейс внутри конкретного модема, у вас же нет никаких сетевых езренет интерфейсов в режиме RAS, т.к. используется PPP. Более того, эту фичу сделали пока только под единственный модем на Qualcom с конкретным PID/VID, где реализован режим rndis, не знаю, почему так решил производитель, но в других HiLink модемах используется cdc-ether, так что совпадения исключены.....

 

Share this post


Link to post
Share on other sites
  • 0
21 час назад, McMCC сказал:

И где тут совпадения кроме слова модем?

 

21 час назад, McMCC сказал:

Более того, эту фичу сделали пока только под единственный модем

А Вы в курсе E3272 и E3276 практически близнецы по железу и даже прошивкам (в том числе и HiLink)?.

Это не совпадение в моем случае?

 

 

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, Вячеслав сказал:

 

А Вы в курсе E3272 и E3276 практически близнецы по железу и даже прошивкам (в том числе и HiLink)?.

Это не совпадение в моем случае?

 

 

Только прошивки hilink и ras это 2 независимые ветки 21 и 22. 

Share this post


Link to post
Share on other sites
  • 0
15 минут назад, r13 сказал:

Только прошивки hilink и ras это 2 независимые ветки 21 и 22.

Я в курсе. 5 лет назад наигрался со всеми прошивками.

Ну обьясните тогда (доказывающие) почему 3276 перестал работать именно с прошивки в которой подкрутили 3272 ??? 

И модемы идентичные по железу.

ZTE у меня как работал, так и продолжает работать, а 3276 отваливается и не хочет перезапускаться

Edited by Вячеслав

Share this post


Link to post
Share on other sites
  • 0
25 минут назад, Вячеслав сказал:

Я в курсе. 5 лет назад наигрался со всеми прошивками.

Ну обьясните тогда (доказывающие) почему 3276 перестал работать именно с прошивки в которой подкрутили 3272 ??? 

И модемы идентичные по железу.

ZTE у меня как работал, так и продолжает работать, а 3276 отваливается и не хочет перезапускаться

Не знаю, у меня 3276 на hilink работает стабильно.

Share this post


Link to post
Share on other sites
  • 0
3 часа назад, r13 сказал:

Не знаю, у меня 3276 на hilink работает стабильно.

Какой уровень сигнала у Вас?.

 

Хотя какая разница. У вас hilink а у меня RAS.

На hilink уже не перейду, слишком много ограничений и узок круг "революционеров".

Этот модем часто используется как мобильный с другими устройствами, многие из которых с hilink не работают.

И модем то работает, но кинетик в случае отключения не перезапускает модем.

 

 

 

Edited by Вячеслав

Share this post


Link to post
Share on other sites
  • 0
В 05.02.2018 в 20:07, Вячеслав сказал:

А Вы в курсе E3272 и E3276 практически близнецы по железу и даже прошивкам (в том числе и HiLink)?.

Это не совпадение в моем случае?

Естественно, я этими модемами занимаюсь лет 10, порою бывает одна и та же плата в разных корпусах, и вот вам уже разные модемы. Но речь шла про два разных варианта HiLink, самый распространенный вариант, это когда HiLink работает в качестве CDC-Ethernet, и менее встречающийся, когда HiLink работает в режиме RNDIS Host. Так вот, речь идет именно про последний вариант с драйвером rndis_host. Проблема состоит в том, что в этом режиме работает прошивка модема E3272s-210 от МТС, с помощью которой снимают привязку на оператора, с родной же прошивкой и с теми же VID/PID,  если выбрать HiLink, этот модем работает по первому варианту без проблем. Обычно проблем не бывает, модемы как правило прекрасно работают в CDC-Ethernet и RNDIS Host, но в данном конкретном случае, модем определяется, загружается нужный драйвер и все зависает на получении IP адреса по DHCP, т.к. модем по не понятным причинам не поднял со своей стороны сетевой интерфейс. Все это происходит в Linux или в прошивках на базе ядра Linux, в Windows этой проблемы нет! Так вот, пришлось вооружится документацией по NDIS с сайта Microsoft и аппаратным USB сниффером, что бы разобраться в причине и дописать нужные команды в линуксовом драйвере rndis_host. Пока решили ограничиться одним модемом, где работают эти дополнительные команды, определяем его по VID/PID и то, что он RNDIS Host, но даже в тех вариантах, где эти команды были не нужны, проблем в работе не наблюдалось, решили просто перестраховаться, что бы потом не выслушивать подобных утверждений типа ваших....

Share this post


Link to post
Share on other sites
  • 0
В 06.02.2018 в 00:02, Вячеслав сказал:

На hilink уже не перейду, слишком много ограничений и узок круг "революционеров".

Достаточно двойного NAT, что бы отказаться от HiLink навсегда, но многим это не актуально, т.к. не хотят тратится на "белый" IP. К тому же есть варианты, что бы достучаться в локальную сеть из вне...

Share this post


Link to post
Share on other sites
  • 0

@McMCC E8278 кажись такой-же уникум - hilink, а работает в режиме NDIS

Share this post


Link to post
Share on other sites
  • 0
9 минут назад, r13 сказал:

@McMCC E8278 кажись такой-же уникум - hilink, а работает в режиме NDIS

Не, претензий к самому протоколу NDIS или HiLink нет, обычно RNDIS работает сразу по самой минимальной версии минипорта, в драйвере Linux так и сделано, устанавливаем инициализацию и просим NDIS работать по самой первой версии этого протокола, просто попался конкретный случай, где игнорируется эта просьба, возможно специально так сделали, что бы не могли использовать модем кроме как на ПК с Windows, вот он там и ждет команду, когда его попросят поднять сетевой интерфейс, чего в первых версиях этого протокола не требовалось....

Share this post


Link to post
Share on other sites
  • 0

@McMCC кстати не исследовали еще как в режиме ndis задействовать ipv6? В режиме dual-apn?

Share this post


Link to post
Share on other sites
  • 0
3 минуты назад, r13 сказал:

@McMCC кстати не исследовали еще как в режиме ndis задействовать ipv6? В режиме dual-apn?

Пока таких задач не было.

Share this post


Link to post
Share on other sites
  • 0

Кстати, вот как сейчас работает модем E3272s-210, для которого делался fix в RNDIS Host драйвере для режима HiLink, если кому интересно конечно... Это по wifi, роутер Keenetic Extra II, проверял, когда этот модем был у меня на руках...

Screenshot_20180117_150420.png

Share this post


Link to post
Share on other sites
  • 0

На очередной прошивке 2.12.A.3.0-3 переподключается модем (на 0-0, 0-1, 0-2 просто зависало переподключение), но ждать нужно 3-5 минут

Опять вернулся на 2.11.A.6.0-0  в течении дня переподключений почти не замечаю, хотя их много на самом деле.

Все плохо в ваших изысках, сломали вы мобильную версию.

В очередной раз разочаровали и уж думаю уйти с тестовых прошивок, для модемов не катит.

 

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, Вячеслав сказал:

На очередной прошивке 2.12.A.3.0-3 переподключается модем (на 0-0, 0-1, 0-2 просто зависало переподключение), но ждать нужно 3-5 минут

Опять вернулся на 2.11.A.6.0-0  в течении дня переподключений почти не замечаю, хотя их много на самом деле.

Все плохо в ваших изысках, сломали вы мобильную версию.

В очередной раз разочаровали и уж думаю уйти с тестовых прошивок, для модемов не катит.

 

Так никтож не заставляет на них сидеть. Выбирите на которой все работает, и успокойтесь.

Работает - не трож. 

Share this post


Link to post
Share on other sites
  • 0
В 11.02.2018 в 15:45, r13 сказал:

Так никтож не заставляет на них сидеть. Выбирите на которой все работает, и успокойтесь.

Работает - не трож. 

Это девиз бездарных программеров? 

П,С,

НЕ приходят сообщения о новых ответах. Т.е. тоже с этим смириться и успокоиться ? 

 

  • Upvote 1
  • Y'r wrong 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×