Jump to content
  • Announcements

    • Как правильно добавить self-test и прочую отладку в тему   08/18/2016

      self-test и логи могут содержать непубличную информацию, потому их не стоит прикреплять к постам бездумно. Однако, слать селф-тесты в личку абсолютно неправильно, поскольку это усложняет координацию между разработчиками и отрывает диагностику от темы с проблемой. Потому следует делать так: Пишете пост или создаете тему с описанием проблемы. Сразу после этого в этой же теме создаете сообщение с приложенным self-test, логами и прочей отладкой. В это же сообщение добавляете ссылку на предыдущее, чтобы не приходилось искать описание. Скрываете сообщение с отладкой. Эта функция доступна всем юзерам. Выбираете в меню поста (спасибо @KorDen):

      После этого эти сообщения станут доступны только администрации, а все пользователи не будут иметь к ней доступ.
  • 1
User624

Непонятные глюки с VPN сервером

Question

Модель    Keenetic Giga III
Версия NDMS    2.12.A.3.0-0
Обновления    Нет
Время работы    03:28:18

Проблема в следующем. На работе есть сервер, он постоянно подключен к моему роутеру через инет по VPN (MPPE 128).
После обновления на 2.12.A.3.0-0 начал замечать непонятные глюки, в журнале ошибок вроде нет, красноты тоже, при этом подключенный сервер не доступен, ни шара, ни rdp.
В VPN-подключениях видно, что соединение есть и активно, однако хост не доступен, и не пингуется. Никаких настроек как на той стороне, так и в роутере не было. Единственное, что было, это обновление прошивки роутера.
Ещё заметил, когда был подключен к роутеру по VPN с работы, то вдруг перестала открываться веб морда, пробовал разные браузеры, результат один, но стоило переподключить VPN и всё стало открываться.

З.Ы. На предыдущих версиях данной проблемы не наблюдается. Пробовал перезагружать железку, особо не помогает, вроде поначалу нормально, через несколько часов тупит.
Прошу глянуть селф, может причина будет ясна, если нужно включить режим отладки, то выложу позже.

Скрытый текст

 

2018-02-02_195632.png.a21489eee131acd7a1f4b73324a8716b.png

2018-02-02_195813.thumb.png.1ad3416e5a8cc8c7282396c8c34a2bc4.png

2018-02-02_195851.thumb.png.777b4531283b577f4ad0c1d1fbc74254.png

 

 

Edited by User624
  • Thanks 2

Share this post


Link to post
Share on other sites

14 answers to this question

  • 0

Спасибо за репорт!

В этом релизе было много изменений по PPTP, так что все возможно.

Причина примерно понятна, попробуем отладить сами.

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
В 2/3/2018 в 21:58, User624 сказал:

До кучи селф из режима отладка.

Попробуйте 2.12.A.3.0-2, должно стать лучше.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Le ecureuil сказал:

Попробуйте 2.12.A.3.0-2, должно стать лучше.

К сожалению отвалы стали чаще.

После подключения к роутеру, при заходе в веб морду и несколько кликов доступ пропадает, пинг не идёт, подключение вроде как активное, но потом падает с уведомлением (0260.png). На втором подключенном устройстве пинг некоторое время идёт, затем подключение полость падает с ошибкой.

В журнале приложений:
CoID={2F7B7C54-EF58-47B8-8B34-F553D8B4F5D2}: Пользователь User624 установил удаленное подключение HomeZyxel, которое завершилось сбоем. Возвращен код ошибки 807.

Информация о версии браузера

FireFox 54.0 (32-бит)
Opera 51.0.2830.23 beta
Система:    Windows 7 64-bit (WoW64)

Если в веб морду роутера не заходить, то пинг пропадает примерно через пол часа.

Скрытый текст

0260.png.9bf52dd8c893e2ce7a0e710e61dc9da0.png

Edited by User624
дополнил
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

@Le ecureuil  @Dmitry Tishkin обновление 2.12.A.3.0-3 особо ситуацию не улучшило. Протестировав немного, связь теряется при попытке передачи данных по vpn, как через web так и через rdp.  Однако если подключаться с телефона, связь более стабильна, обрывы гораздо реже. Пробовал откатить систему, не меняя настроек. Последний бекап который был 2.11.A.6.0-0. После отката подключение стабильно, обрывов нет.

Уважаемые разработчики, выйдет ли фикс для данного бага на этой неделе или пока лучше откатиться на рабочую версию?. Спасибо.

Edited by User624

Share this post


Link to post
Share on other sites
  • 0

Честно - не знаю, потому что пока только вы один жалуетесь на PPTP-сервер. Будем смотреть по ситуации.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Какие есть предложения, может что попробовать?
На неделе сделать сброс до заводских, может поможет, отпишусь о результатах.

Edited by User624

Share this post


Link to post
Share on other sites
  • 0
43 минуты назад, User624 сказал:

Какие есть предложения, может что попробовать?
На неделе сделать сброс до заводских, может поможет, отпишусь о результатах.

Попробуйте снять дамп трафика (GRE и TCP на 1723 входящий), может по нему что-то понятно будет.

Share this post


Link to post
Share on other sites
  • 0

При переходе на 2.12.A.3.0-3 также нет доступа к внутренним ресурсам через IPSec VPN. Настройки подключения не  изменял. Требуется ли снять какие-нибудь логи ? 

Edited by TDR2000 MK2

Share this post


Link to post
Share on other sites
  • 0
16 часов назад, Le ecureuil сказал:

Честно - не знаю, потому что пока только вы один жалуетесь на PPTP-сервер. Будем смотреть по ситуации.

У меня такая же проблема началась с 2.12.A.3, только модель Модель  Keenetic Ultra I, и соединение перестает работать в течении одной-двух минут. Дамп попробую вечером снять.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Есть идея, почему это могло сломаться. Правки уже внесены.

Попробуйте на следующем драфте, на нем же стоит и снимать дампы и self-test.

  • Thanks 2

Share this post


Link to post
Share on other sites
  • 0
В 13.02.2018 в 13:13, Le ecureuil сказал:

Есть идея, почему это могло сломаться. Правки уже внесены.

Попробуйте на следующем драфте, на нем же стоит и снимать дампы и self-test.

2.12.A.3.0-4, особо ситуация не поменялась :-(

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Что же, значит на следующей неделе продолжим искать проблему.

  • Upvote 2

Share this post


Link to post
Share on other sites
  • 0

Согласен с автором поста, действительно, при обновлении до 2.12.А.3.0.-4 ситуация с VPN сервером не изменилась. Пришлось откатиться до официальной бетки.

  • Upvote 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×