Jump to content
T@rkus

Пропадает соединение с трубкой Panasonic KX-TGA721

9 posts in this topic

@des Giga II 2.12.A.5.0-7 Уже несколько прошивок подряд пропадает соединение с трубкой Panasonic KX-TGA721. В итоге периодически до меня дозвониться не могут. К роутеру подключены 2 номера по мультифону. Стоит на трубе нажать кнопку вызова соединение с Dect-донглом восстанавливается. Self-Test прилагаю

 

2018-04-21_222150.png.f4e1e65b7095c5fcedea8d45c0ec1981.png

Edited by T@rkus

Share this post


Link to post
Share on other sites

@T@rkus

  1. Похоже, сломан перевод телефонии в режим расширенного логирования - в логе ничего не видно.
  2. Если можете - включите отладочное логирование на роутере, отключите телефонию, включите телефонию, подождите, пока трубка отвалится, сделайте входящий звонок, сохраните лог. Надеюсь, так в логе что-то будет видно. Если нет - давайте подождем, пока логирование начнет работать, как положено.

Share this post


Link to post
Share on other sites
55 минут назад, des сказал:

@T@rkus

  1. Похоже, сломан перевод телефонии в режим расширенного логирования - в логе ничего не видно.
  2. Если можете - включите отладочное логирование на роутере, отключите телефонию, включите телефонию, подождите, пока трубка отвалится, сделайте входящий звонок, сохраните лог. Надеюсь, так в логе что-то будет видно. Если нет - давайте подождем, пока логирование начнет работать, как положено.

Self-test приложил

  • Thanks 1

Share this post


Link to post
Share on other sites

@T@rkusспасибо.

Мы проверяем, включена ли трубка, отсылкой на нее сервисных звонков:

Apr 23 12:27:57 nvox: |-> setup req id10 SN audio=E255 clip=

Если трубка включена, она сбрасывает звонок с каким-то кодом ошибки:

Apr 23 12:28:00 nvox: |<- reject ind reason 1 id1B

Если трубка не отвечает, через какое-то время донгл сбрасывает звонок на трубку с кодом ошибки 15:

Apr 23 12:29:13 nvox: |<- reject ind reason 15 id1A

Из этого кода ошибки (15 или нет) мы предполагаем, включена ли трубка.

Вот эта трубка сначала присылает код 1, потом - 15. И на следующие звонки тоже не отвечает. Похоже, ей поплохело от сервисного звонка.

Отключу опрос состояния этой модели трубки. Теперь не будет видно, она включена или выключена, но должна (?) перестать глючить при входящих вызовах.

Share this post


Link to post
Share on other sites
11 минуту назад, des сказал:

@T@rkusспасибо.

Мы проверяем, включена ли трубка, отсылкой на нее сервисных звонков:

Apr 23 12:27:57 nvox: |-> setup req id10 SN audio=E255 clip=

Если трубка включена, она сбрасывает звонок с каким-то кодом ошибки:

Apr 23 12:28:00 nvox: |<- reject ind reason 1 id1B

Если трубка не отвечает, через какое-то время донгл сбрасывает звонок на трубку с кодом ошибки 15:

Apr 23 12:29:13 nvox: |<- reject ind reason 15 id1A

Из этого кода ошибки (15 или нет) мы предполагаем, включена ли трубка.

Вот эта трубка сначала присылает код 1, потом - 15. И на следующие звонки тоже не отвечает. Похоже, ей поплохело от сервисного звонка.

Отключу опрос состояния этой модели трубки. Теперь не будет видно, она включена или выключена, но должна (?) перестать глючить при входящих вызовах.

Вот точно не помню но по моему эта беда началась с 2.12. До этого все корректно  работало. Есть смысл 2.11 залить и посмотреть какое поведение у трубы будет?

Edited by T@rkus

Share this post


Link to post
Share on other sites
2 minutes ago, T@rkus said:

Вот точно не помню но по моему эта беда началась с 2.12. До этого все корректно  работало. Есть смысл 2.11 залить и посмотреть какое на ней поведение у трубы будет?

Нет, если верно помню, в 2.12 добавили опрос состояния трубок (включена/выключена). Скорее всего, это с ним трубка не дружит. Попробуйте следующую версию (в пятницу или когда она будет). Надеюсь, исправится.

Share this post


Link to post
Share on other sites
Только что, des сказал:

Нет, если верно помню, в 2.12 добавили опрос состояния трубок (включена/выключена). Скорее всего, это с ним трубка не дружит. Попробуйте следующую версию (в пятницу или когда она будет). Надеюсь, исправится.

Ок.

Share this post


Link to post
Share on other sites
Только что, des сказал:

@T@rkusпроблема еще наблюдается в последних прошивках?

Нет. Спасибо трубка связь с донглом не теряет

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×