Jump to content
Александр Сухоруков

Кривой пакет squid_3.5.27-1_mipsel-3.4.ipk?

Recommended Posts

opkg update

Цитата

Downloading http://entware-3x.zyxmon.org/binaries/mipsel/Packages.gz.
Updated list of available packages in /opt/var/opkg-lists/keen3x.
Downloading http://bin.entware.net/mipselsf-k3.4/Packages.gz.
Updated list of available packages in /opt/var/opkg-lists/entware.
Downloading http://bin.entware.net/mipselsf-k3.4/keenetic/Packages.gz.
Updated list of available packages in /opt/var/opkg-lists/keendev.


~ # opkg install squid

Цитата

Installing squid (3.5.27-1) to root...
Downloading http://bin.entware.net/mipselsf-k3.4/squid_3.5.27-1_mipsel-3.4.ipk.
Installing libopenssl (1.0.2o-1) to root...
Downloading http://bin.entware.net/mipselsf-k3.4/libopenssl_1.0.2o-1_mipsel-3.4.ipk.
Installing zlib (1.2.11-2) to root...
Downloading http://bin.entware.net/mipselsf-k3.4/zlib_1.2.11-2_mipsel-3.4.ipk.
Installing libltdl (2.4.6-1) to root...
Downloading http://bin.entware.net/mipselsf-k3.4/libltdl_2.4.6-1_mipsel-3.4.ipk.
Configuring zlib.
Configuring libopenssl.
Configuring libltdl.
Configuring squid.

 squid

Цитата

squid: /opt/lib/libc.so.6: version `GLIBC_2.27' not found (required by squid)

Как бороться с этой ошибкой и почему она возникает?

Новая версия пакета? Раньше вроде все ставилось и работало без таких ошибок.

Share this post


Link to post
Share on other sites

Стоит обновить libc -  перестает подходить пароль к ssh

 

 opkg upgrade libc
 

Цитата

Upgrading libc on root from 2.25-8 to 2.27-8...
Downloading http://bin.entware.net/mipselsf-k3.4/libc_2.27-8_mipsel-3.4.ipk.
Removing obsolete file /opt/lib/libresolv-2.25.so.
Removing obsolete file /opt/lib/libdl-2.25.so.
Removing obsolete file /opt/lib/ld-2.25.so.
Removing obsolete file /opt/lib/libutil-2.25.so.
Removing obsolete file /opt/lib/libnsl-2.25.so.
Removing obsolete file /opt/lib/libm-2.25.so.
Removing obsolete file /opt/lib/libcrypt-2.25.so.
Removing obsolete file /opt/lib/libcidn-2.25.so.
Removing obsolete file /opt/lib/libanl-2.25.so.
Removing obsolete file /opt/lib/libnss_files-2.25.so.
Removing obsolete file /opt/lib/libc-2.25.so.
Removing obsolete file /opt/lib/libnss_dns-2.25.so.
Configuring libc.

Ошибках в логах

 

Цитата

 

May 31 12:52:02dropbear[4891]

Login attempt for nonexistent user from 192.168.1.2:53568

 

 

Share this post


Link to post
Share on other sites
~ # squid -v
Squid Cache: Version 3.5.27
Service Name: squid

This binary uses OpenSSL 1.0.2o  27 Mar 2018. For legal restrictions on distribution see https://www.openssl.org/source/license.html

configure options:  ......

Полсе opkg update следует сразу сделать opkg upgrade. Но даже эта обязательная операция не всегда приводит к согласованности библиотек. В wiki есть решение на эту тему. Вы, похоже, ни разу opkg upgrade (без параметров) не делали. В результате бардак версий похоже полнейший. Сохраняйте конфиги, список пакетов и устанавливайте все с нуля.

PS В openwrt немного другая идеология обновлений в связи с желанием сохранить место в jffs. Если привыкли - отвыкайте.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...