Jump to content
  • 0
AlexU

После обновления не могу войти в web-интерфейс

Question

 

Доброго времени суток!

Обновил прошивку на Giga. После обновления всё заработало, ну как всё -- wifi, интернет и т.п. -- кроме возможности войти в web-интерфейс для настройки роутера. Говорит логин/пароль не правильные. После нескольких попыток решил сбросить настройки. После сброса настроек web-интерфейс радостно меня поприветствовал:

 

Скрытый текст

keenetic_setup_1.thumb.jpeg.eb15944e1363c99d6702ae45e4931a6d.jpeg

и попросил задать пароль для пользователя 'admin'. Решил попробовать простейший пароль '12345':

Скрытый текст

keenetic_setup_2.thumb.jpeg.7fa1594f9a36364e85f20367657d646f.jpeg

но на следующем шаге опять получил:

Скрытый текст

keenetic_setup_3.thumb.jpeg.afb1af1a904a4de1aefe9f7911badddd.jpeg

Можно как-то исправить или "доктор сказал в морг значит в морг"? 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

У меня случилась такая же беда. Версия ОС2.15.C.5.0-0. Случилось это уже довольно давно, когда обновился на указанную версию, с какой не помню давно было. И в общем то меня это не парило т.к. все работало и все настройки я уже сделал, но есть проблема. У меня стоит белый фильтр по мак адресам, а сегодня я купил новый телефон и естественно я не могу им войти в вафлю. Так шта человек вам сообщил все верно, у меня те же симптомы, но я не стал заниматься секасом со сбросами/перепрошивками, а первым делом начал гуглить шо с этим всем делать. Короче ваша прошивка все еще содержит этот глюк, так шо исчите и фиксите.

Share this post


Link to post
Share on other sites
  • 0

А и еще, у меня было два аккаунта, один admin второй я сам создал для жены только на чтение. И что вы думаете? Второй то работает, только ничего поменять не может. Т.е. проблема касается исключительно пароля встроенной учетной записи admin. Я перепробовал все варианты паролей которые пришли мне в голову включая тот что на задней стороне для вафли естественно ничего не подошло. Смотрите код который работает с паролем admin там точно бага. Где то какое то граничное условие приводит к сбросу пароля в пустую строку или дефолтное значение (что вряд ли). Предположу что сброс хеша админского пароля идет до пустой строки. Очевидно, что хеш от любого пароля (включая пустой) будет не пустым, т.е. никакой пароль никогда не пройдет проверку. Короче чините, я почти уверен в своей гипотезе, сколько таких багов я уже перефиксил.

Share this post


Link to post
Share on other sites
  • 0
13 минуты назад, AntonDyachenko сказал:

Я перепробовал все варианты паролей которые пришли мне в голову включая тот что на задней стороне для вафли естественно ничего не подошло.

Через telnet или ssh пробовали заходить?

Share this post


Link to post
Share on other sites
  • 0

Столкнулся с аналогичной проблемой на приобретенной железке: после обновления по воздуху с прошивки 2.15 на прошивку 3.1.6 появился глюк: на стационарном компе не пускает в вэбморду с правами админа. С телефона захожу через программу MyKeenetic и Хрома нормально.
Пробовал создать еще одну учетную запись - эффект тот же.
Сбросил настройки к заводским, настроил заново - та же история. Сбросил пароль админа через telnet - с компа пускает, только устанавливаю пароль на админа, при входе пишет: пароль неверный.
Прошился через web на 3.01 - без изменений, с ПК не пускает.
Откатился через web на 2.15 - все замечательно, пускает через админа на всех устройствах.

P.S. Возможно, есть какая-то процедура обновления? Вроде, включить роутер, ударить в бубен, повернуться через левое плечо и начать прошивку?

Share this post


Link to post
Share on other sites
  • 0
14 минуты назад, PSL сказал:

Проблема решена.

Пояснили бы как решили. Для других пользователей у кого такая же проблема.

Share this post


Link to post
Share on other sites
  • 0
55 минут назад, AndreBA сказал:

Пояснили бы как решили.

Думал, что никого здесь нет)

Проблема решилась до банального обидно: чисткой браезуров на всех устройствах, кроме телефона, на котором установлен MyKeenetic.

Ради интереса, снова установил 2.15, а потом 3.1.6 - опять нужно чистить браузеры, чтобы был доступ в web-интерфейс

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
В 06.10.2019 в 18:45, PSL сказал:

Ради интереса, снова установил 2.15, а потом 3.1.6 - опять нужно чистить браузеры, чтобы был доступ в web-интерфейс

Вот интересно -- что такого сохраняется локально в кеше браузера (или в куках) раз приходиться "чистить браузеры"?

Share this post


Link to post
Share on other sites
  • 0

Залогиненный пользователь. Его текущая сессия. У меня там всего 10 параметров. Зайдите у себя в куки, посмотрите.

Share this post


Link to post
Share on other sites
  • 0
9 часов назад, keenet07 сказал:

Залогиненный пользователь. Его текущая сессия. У меня там всего 10 параметров. Зайдите у себя в куки, посмотрите.

Это был скорее риторический вопрос в контексте того, что:

В 05.08.2018 в 00:19, ndm сказал:

.....

Исправление вошло в версию 2.13.A.4.0-1, и будет перенесено в 2.12 в ближайшее время.

 

Похоже ни тестировщики, ни разработчики так и не поняли своих ошибок.

Share this post


Link to post
Share on other sites
  • 0

Столкнулся с еще одной интересной проблемой: решил вчера запустить dlna для ТВ. По ftp и smb пускает,  dlna - ни в какую.

Скакал с бубном часа 2. На последок решил переустановить приложение dlna и... все работает.

P.S. После покупки сброс сделал. Грешу на переходные глюки с прошивки 2.х на 3.х.

Новую тему не создавал, чтобы не мусорить.

Edited by PSL

Share this post


Link to post
Share on other sites
  • 0
В 16.10.2019 в 07:04, AlexU сказал:

Это был скорее риторический вопрос в контексте того, что:

Похоже ни тестировщики, ни разработчики так и не поняли своих ошибок.

Если что, это совсем разные проблемы.

Share this post


Link to post
Share on other sites
  • 0
В 15.10.2019 в 20:55, AlexU сказал:

Вот интересно -- что такого сохраняется локально в кеше браузера (или в куках) раз приходиться "чистить браузеры"?

Скорее всего в 3 версии был ужесточен парсер заголовка Cookie, и старые значения вызывают проблемы.

 

Share this post


Link to post
Share on other sites
  • 0

У меня Keenetic Giga III, после обновления до 3.1.10 не работает веб-интерфейс, телнет и приложение работают, лог завален ошибками

Тестовые ветки тоже не помогают, откатиться назад не могу, сбрасывать роутер очень бы не хотелось, там куча настроек. Что ещё можно сделать?

IMG_20191102_075857_960.jpg

Share this post


Link to post
Share on other sites
  • 0
В 02.11.2019 в 08:06, Виталий Лахин сказал:

У меня Keenetic Giga III, после обновления до 3.1.10 не работает веб-интерфейс, телнет и приложение работают, лог завален ошибками

Тестовые ветки тоже не помогают, откатиться назад не могу, сбрасывать роутер очень бы не хотелось, там куча настроек. Что ещё можно сделать?

IMG_20191102_075857_960.jpg

В техподдержку, они помогут снять self-test, и по нему мы поймем что не так.

Share this post


Link to post
Share on other sites
  • 0

конец 2019 года, а проблемма осталась, после обовления KN-1010 зайти через web нереально. неужели нельзя было ее решить. ситуация усложняется тем что система покупалась из 5 устройств и только на giga такое. есть какое-то решение на сегодняшний день?

Share this post


Link to post
Share on other sites
  • 0

Опишите что у вас случилось по-детальнее. С какой на какую версии обновились. И что значит зайти не реально? 

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0
В 05.11.2019 в 16:42, Le ecureuil сказал:

В техподдержку, они помогут снять self-test, и по нему мы поймем что не так.

Написал сразу же, завели тикет и тишина в ответ.

Скажите все же, какие у меня варианты есть? Я могу через телнет или как-то еще снять бекап пользовательских данных и/или откатиться на старую прошивку?

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, vitt76 сказал:

Написал сразу же, завели тикет и тишина в ответ.

Скажите все же, какие у меня варианты есть? Я могу через телнет или как-то еще снять бекап пользовательских данных и/или откатиться на старую прошивку?

Откатиться вы можете без всякого входа куда-либо. Через режим Recovery. https://help.keenetic.com/hc/ru/articles/214470865

Прошивку нужную выберите https://forum.keenetic.net/announcement/5-где-взять-тестовые-прошивки/ и скачайте тут 

Настройки после восстановлении остаются прежние. У меня всё сохранилось. Если у вас ещё что-то на флэшке сохранено, наверное её на всякий случай лучше отключить.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
В 01.11.2019 в 17:30, Le ecureuil сказал:

Если что, это совсем разные проблемы

Нееааа.

Если что -- проблема одна и та же: пропадает доступ к вебинтерфейсу после обновления. Хотя у этой проблемы причины могут быть разными.

И ваши разработчики и тестировщики (если они есть) так и не научились с этой проблемой бороться или выявлять её на этапе тестирования, не зависимо от причин появления.

Что, собственно, очень печально.

Может, всё-таки, вместо кучи менеджеров и администраторов форумов стоит нанять пару толковых технарей-программистов.... А то авторитет своей компании уверенно закапываете....

Share this post


Link to post
Share on other sites
  • 0

Моё последнее сообщение было адресовано сотрудникам компании, которая выпускает роутеры, обсуждаемые в этом форуме. Надеюсь, сообщение, всё-таки, найдёт своего адресата (или своих адресатов) и будут сделаны соответствующие выводы и наконец налажен процесс не просто выпуска обновлений, а выпуска обновлений, которые не приносят проблем пользователям.

PS;

Ошибки все допускают, в этом нет ни чего страшного -- главное понимать суть ошибок и их устранять. Вот только проблема в том, что сначала было заявлено, что проблема на моей стороне, т.к. разработчики не смогли повторить ошибку у себя. Потом заявили об устранении проблемы в новой прошивке, хотя, если проблема на моей стороне, зачем что-то устранять у себя и выпускать обновление. Потом выясняется, что обновление проблему так и не решило. Что, собственно, и не удивительно, т.к. разработчики так и не смогли проблему повторить у себя и соответственно не до конца понимают её суть. И есть подозрение, что это может продолжаться ещё долго....

И самое плохое в этой ситуации -- это то, что с роутерами других производителей ситуация не лучше, если не хуже...

Хотя на Али можно найти безшумные мини-системники с большим количеством Ethtrnet портов и WiFI по цене, сопоставимой с Giga, и на них накатить полноценный Linux... Там и проц. не самый слабый, и память от 4ГБ, и SSD можно воткнуть рядом с HDD...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...