Jump to content
  • 0
Alexandr_S

NAT не натирует трафик в PPTP туннель

Question

Читал инструкцию, искал на форуме ответы, находил близкое что-то, но... не то.

Уже несколько дней я пытаюсь настроить сделать белый ip роутеру следующим образом:

У меня есть роутер Keenetic Ultra II (прошивка: 2.13.C.0.0-3) и Keenetic Lite II (прошивка: 2.13.C.0.0-4 - отладочная).

На Keenetic Lite II поднят PPTP сервер (белыq IP), на Keenetic Ultra II - клиент (серый IP).

Я НЕ маршрутизирую подсети, т.к. это мне не надо. Мне вполне хватает IP, выданного PPTP сервером (из специально созданного для этого сегмента 172.16.1.0/30). 

Keenetic Lite II 172.16.1.1

Keenetic Ultra II имеет IP 172.16.1.2

DHCP в сегменте выключен, NAT не выключается, в PPTP NAT включен.

На Keenetic Ultra II настроен  firewall, который пропускает запросы из PPTP туннеля.

Итого, я могу обратиться из сети Keenetic Ultra II на адрес 172.16.1.1 и попасть в настройки интернет-центра Keenetic Lite II

Я могу обратиться из сети Keenetic Lite II (172.16.1.0/30) к 172.16.1.2 и попасть в настройки интернет-центра Keenetic Ultra II

В настройках firewall Keenetic Ultra II разрешил пинг - идёт, 0% потерь!

А вот с BroadBand nat на Keenetic Ultra II ну никак работать не хочет. Не натирует и всё тут! Порты указаны, вроде, верно (открыт нужный мне порт, направление на 80 порт по ip 172.16.1.2), но не работает... Не знаю что делать.

Решил захватить несколько пакетов. Не увидел, чтоб  Ultra пытался отправить ответ. А даже и пытался если, то куда он его отправит? На адрес source? Так это IP моего провайдера + динамический. Его там просто отбросят.

Как мне сделать нормальное натирование?

P.S. Не предлагайте мне убрать PPTP (заменить на другое), добавить маршруты сетей - мне это не нужно!

Спасибо за ответы.

 

Edited by Alexandr_S

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Задал вопрос и справился с проблемой.

Поставил галочку "Использовать для выхода в Интернет" в настройках PPTP клиента и всё заработало, но вот не понятно, почему заработало только так? По идее, роутер должен ответить PPTP в туннель, а не в инет (в том смысле, что PPTP виртуальная сеть не должна считаться за инет) и уже другой роутер передаст в инет. Возможно, что из-за source name  пакетов, но всё равно должен работать NAT.

Можно ли избежать установки галочки "Использовать для выхода в Интернет"?

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
On 11/14/2018 at 10:35 PM, Alexandr_S said:

А вот с BroadBand nat на Keenetic Ultra II ну никак работать не хочет. Не натирует и всё тут! Порты указаны, вроде, верно (открыт нужный мне порт, направление на 80 порт по ip 172.16.1.2), но не работает... Не знаю что делать.

Решил захватить несколько пакетов. Не увидел, чтоб  Ultra пытался отправить ответ. А даже и пытался если, то куда он его отправит? На адрес source? Так это IP моего провайдера + динамический. Его там просто отбросят.

Как мне сделать нормальное натирование?

Напишите понятнее:

  1. IP-адрес хоста, который отправляет запрос, и к чему этот хост подключен.
  2. На какой IP-адрес и порт он обращается
  3. Приложите self-test обоих устройств (скрытым постом)

Установите 2.14 (бета) — есть ли разница?

Share this post


Link to post
Share on other sites
  • 0
В 14.11.2018 в 23:32, Alexandr_S сказал:

Задал вопрос и справился с проблемой.

Поставил галочку "Использовать для выхода в Интернет" в настройках PPTP клиента и всё заработало, но вот не понятно, почему заработало только так? По идее, роутер должен ответить PPTP в туннель, а не в инет (в том смысле, что PPTP виртуальная сеть не должна считаться за инет) и уже другой роутер передаст в инет. Возможно, что из-за source name  пакетов, но всё равно должен работать NAT.

Можно ли избежать установки галочки "Использовать для выхода в Интернет"?

Натирование и маршрутизация это 2 разные вещи. Роутер отвечает в соответсвии с таблицей маршрутизации. Хотите чтобы роутер отвечал в PPTP без галки "Использовать для выхода в Интернет", настраивайте маршрутизацию конкретных сетей через этот интерфейс.

Share this post


Link to post
Share on other sites
  • 0
В 16.11.2018 в 10:28, r13 сказал:

Натирование и маршрутизация это 2 разные вещи. Роутер отвечает в соответсвии с таблицей маршрутизации. Хотите чтобы роутер отвечал в PPTP без галки "Использовать для выхода в Интернет", настраивайте маршрутизацию конкретных сетей через этот интерфейс.

Ну, я уже поменял несколько структуру сети (однако pptp как был, так и есть). Долгое время не возвращался к этой проблеме, но вот теперь подумал ещё и понял как можно это решить. Просто нужно, чтоб роутер (Keenetic Lite) ставил в source пакетов, идущих с адреса 172.16.1.1 не ip  внешного сервера, на свой ip (172.16.1.1). Тогда роутер пакеты из соединения pptp будет слать обратно в pptp. Только вот не совсем понятно как это сделать. Loopback-интерфейс помочь мог бы, но как таковой создать в кинетике? Или без него можно как-то завтавить кинетик свой адрес вставить в source пакета, идущего на сегмент?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...