Jump to content
  • 0
Sign in to follow this  
iples

vpn клиенты стали недоступны

Question

Нет теперь доступа к vpn-клиентам по их внутренним адресам. В статически маршрутах доступ прописан. Подключение по PPTP.

Edited by iples
  • Thanks 1

Share this post


Link to post
Share on other sites

22 answers to this question

  • 0

Получалось ли пробросить порты какие нибудь порты клиентов на глобальный белый IP и зайти из вне?

Share this post


Link to post
Share on other sites
  • 0

Порты на клиентах все проброшены tcp,udp. При возврате на 2,14 все начинает работать. Причем на клиентах оставлена 2.15. VPN сервер Giga 2. Клиенты Extra и Viva.

Edited by iples
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
29 минут назад, iples сказал:

Порты на клиентах все проброшены tcp,udp. При возврате на 2,14 все начинает работать. Причем на клиентах оставлена 2.15. VPN сервер Giga 2. Клиенты Extra и Viva.

Подтверждаю.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

С помощью этого просходит обьединение нескольких сетей. Клиенты соединяются с сервером по протоколу PPTP. (в роли клиентов и сервера выступают Zyxel маршрутизаторы) Но на прошивке 2.15 сервер не видит клиентов, т.е. подключение создается нормально, но со стороны сервера не видно сетей клиентов. При смене прошивки на сервере на 2.14 - все нормализуется.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Маршруты в сети клиентов прописаны правильно? Они добавляются в список активных при подключении клиентов?

Share this post


Link to post
Share on other sites
  • 0
14 часа назад, Le ecureuil сказал:

Давайте чуть подробнее.

Вообщем на 2.15 с устройств серверной сети недоступны устройства клиентской. При этом клиенты пингуются с Кинетика сервера, т.е. маршрут вроде как работает. А уже пинги с компа серверной сети до компа клиентской не проходят. Это на l2tp. Видимо на pptp картина аналогичная. 

Если откатиться на 2.14, то всё работает.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
16 минут назад, Кинетиковод сказал:

Вообщем на 2.15 с устройств серверной сети недоступны устройства клиентской. При этом клиенты пингуются с Кинетика сервера, т.е. маршрут вроде как работает. А уже пинги с компа серверной сети до компа клиентской не проходят. Это на l2tp. Видимо на pptp картина аналогичная. 

Если откатиться на 2.14, то всё работает.

действующие маршруты на клиенте покажите, может  только маршрут до сервера на клиентах. 

Share this post


Link to post
Share on other sites
  • 0
1 час назад, r13 сказал:

действующие маршруты на клиенте покажите, может  только маршрут до сервера на клиентах. 

gfhfgh.PNG.e7eebe1f9c3e07a1eebffbf0c94a872c.PNG

Сервер на 192.168.7.1

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Кинетиковод сказал:

gfhfgh.PNG.e7eebe1f9c3e07a1eebffbf0c94a872c.PNG

Сервер на 192.168.7.1

не, активные маршруты на кинетике клиенте.  на конечных устройствах их не будет. 

Share this post


Link to post
Share on other sites
  • 0
1 час назад, r13 сказал:

не, активные маршруты на кинетике клиенте.  на конечных устройствах их не будет. 

На Кинетиках маршруты присутствуют и работают. Я ж говорю, что с Кинетиков обе сети пингуются, а с устройств серверной сети в клиентскую не достучаться.

Share this post


Link to post
Share on other sites
  • 0

Ситуация начала проясняться. Если у клиента стоит галка "использовать для выхода в интернет", то клиентская сеть доступна, если не стоит, то недоступна. И клиент и сервер на 2.15.A.3.0-1

Share this post


Link to post
Share on other sites
  • 0
17 минут назад, Кинетиковод сказал:

Ситуация начала проясняться. Если у клиента стоит галка "использовать для выхода в интернет", то клиентская сеть доступна, если не стоит, то недоступна. И клиент и сервер на 2.15.A.3.0-1

Значит таки правильного роута на клиенте кинетике нет, и пакеты улетают не в туннель, а в интернет.

Еще раз прочекайте действующие маршруты на клиенте кинетике.

Share this post


Link to post
Share on other sites
  • 0
35 минут назад, r13 сказал:

Значит таки правильного роута на клиенте кинетике нет, и пакеты улетают не в туннель, а в интернет.

Еще раз прочекайте действующие маршруты на клиенте кинетике.

С галкой:

fghgh.PNG.190268752eb00a081b3d2e6e5e9b5974.PNG

Без галки:

fhghfh.PNG.03dd5474c1102cbe28b2bb96a708c190.PNG

Чего не хватает?

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Кинетиковод сказал:

С галкой:

fghgh.PNG.190268752eb00a081b3d2e6e5e9b5974.PNG

Без галки:

fhghfh.PNG.03dd5474c1102cbe28b2bb96a708c190.PNG

Чего не хватает?

Не хватает маршрута до сети сервера 192.168.7.0/24 через l2tp

Добавите его, и все должно заработать.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, r13 сказал:

Не хватает маршрута до сети сервера 192.168.7.0/24 через l2tp

Добавите его, и все должно заработать.

Заработало. Стало быть сервер его не присылает, а должен бы.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
Только что, Кинетиковод сказал:

Заработало. Стало быть сервер его не присылает, а должен бы.

Не, не обязательно. По умолчанию только сам сервер.

Доп маршруты для пуша с сервера в cli прописываются

Типа так(так же актуально для pptp и sstp):

crypto map <l2tp-server> dhcp route ‹address› ‹mask›

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
44 минуты назад, r13 сказал:

Не, не обязательно. По умолчанию только сам сервер.

На 2.14 прилетел, на 2.15 нет.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Точно такая же проблем. Только подключение через SSTP. Клиенты не видят внутреннюю сеть, тот же жесткий диск. Откатил на 2.14 все заработало.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
7 часов назад, Кинетиковод сказал:

На 2.14 прилетел, на 2.15 нет.

значит вернут! ;) 

@Кинетиковод @immya проверьте с командой которую я давал, вдруг механизм dhcp inform сломали, тогда и она не поможет. 

Edited by r13
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, r13 сказал:

значит вернут! ;) 

@Кинетиковод @immya проверьте с командой которую я давал, вдруг механизм dhcp inform сломали, тогда и она не поможет. 

Ага, спасибо за диагностику. Починим.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×