Jump to content
  • 0
BeaViSs

"гибридный" порт wan

Question

есть необходимость работы со стороны WAN интерфейса как с тегированным, так и нетегированным трафиком.

Из web как я понимаю настроить такую схему нереально. Через CLI - непонятно и ощущение, что тоже невозможно?

 

interface FastEthernet0/Vlan3509
    rename ISP-Vlan
    description ROSTELEKOM
    security-level public
    ip address dhcp
    ip dhcp client dns-routes
    ip dhcp client name-servers
    igmp upstream
    up
!

interface FastEthernet0/0
    rename 0
    role inet for ISP-Vlan
    switchport mode trunk
    switchport trunk vlan 3509
    up

сейчас через влан 3509 устанавливается пппое к провайдеру для доступа к интернету.

 

Думал, что switchport friend vlan поможет, но из описания в доке не то чтобы сильно понятно что это вообще такое

image.png.9ce67031f44b7d578ce551fe034a1e0d.png

 

Может есть дока на английском, в котором это описано понятнее?

 

Как включить режим работы с тегированным и нетегированным трафиком?

на нетегированный инетфейс надо будет статик ип повесить :)

Edited by BeaViSs

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
3 часа назад, Le ecureuil сказал:

Зависит от железа. Что у вас за устройство?

Keenetic Extra (KN-1710) , бета версия софта

image.png.2d03ca292f39e1dda18c137f726a5688.png

! $$$ Model: Keenetic Extra
! $$$ Version: 2.06.1

Edited by BeaViSs

Share this post


Link to post
Share on other sites
  • 0
6 часов назад, BeaViSs сказал:

Как включить режим работы с тегированным и нетегированным трафиком?

    switchport mode access
    switchport mode trunk
    switchport access vlan 123
    switchport trunk vlan 567

ну и дальше interface FastEthernet0/Vlan123...

Такое работает только на свичовых портах. Не-свичовые - это например, WAN в Giga/Ultra, там linux-way  нетегированный это сам GigabitEthernet1, тегированный это GigabitEthernet1/Vlan567

Голосуйте за компанию...

Для домашних сегментов уже можно из веба настраивать в том числе гибридные порты, объединить логику с интернет-подключениями пока еще не осилили

Edited by KorDen

Share this post


Link to post
Share on other sites
  • 0

@KorDen, для Switchport все понятно, что нужно сделать.

с ультрой у меня нет такой задачи. Есть задача на Экстре, на которой нет GigabitEthernet1, там только FastEthernet0, но для него из дерева ip команд есть только mtu :)

Share this post


Link to post
Share on other sites
  • 0
18 минут назад, BeaViSs сказал:

@KorDen, для Switchport все понятно, что нужно сделать.

с ультрой у меня нет такой задачи. Есть задача на Экстре, на которой нет GigabitEthernet1, там только FastEthernet0, но для него из дерева ip команд есть только mtu :)

на экстре это на конкретном порту надо делать, например FastEthernet0/0

Share this post


Link to post
Share on other sites
  • 0

@BeaViSs, вы не поняли мысль.

Есть как минимум два варианта сетевой части. Один - все порты, включая WAN (0), на свиче (FastEthernet, GigabitEthernet - не важно). Если ничего не путаю, все нынешние стомегабитники, включая Extra, вроде как именно такие. Второй вариант - порт WAN (0) это отдельная сетевушка, порты LAN на свиче. Это как минимум на MT7621 (Ultra II)

Собственно смотрите разницу дефолтных конфигураций нетегированного инета (ISP):

WAN на свиче (Zyxel Keenetic Air):

interface FastEthernet0
    up
!

interface FastEthernet0/Vlan2
    rename ISP
    mac address factory wan
    security-level public
    ip address dhcp
....................
!
interface FastEthernet0/0
    rename 0
    role inet for ISP
    switchport mode access
    switchport access vlan 2
    up
!

По аналогии в Zyxel Keenetic Giga II и Ultra вместо FastEthernet0 будет GigabitEthernet0.

В таком случае (это ваш случай по идее), как я выше описывал, вы навешиваете на порт одновременно влан в access (untagged) и trunk (tagged) И создаете влан на свиче, а уже внутри влана прописываете ip. Не для FastEthernet0 (это свич), а для FastEthernet0/Vlan123, который выгружается как access на порт 0!

А во втором случае (Giga III/Ultra II и новых), у нас есть GigabitEthernet0 и GigabitEthernet1. GE0 - это свич по аналогии выше (но только для портов LAN), GE1 - это сетевушка для порта WAN (0). GigabitEthernet1/0 - это физический порт, параметры IP же вы настраиваете на GE1.

И там linux-way, т.е. сама сетевушка - GigabitEthernet1 - это нетегированный трафик (и вы на него уже навешиваете IP), а вланы вы просто создаете на нем (GigabitEthernet1/Vlan123), никаких switchport там нет.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...