Jump to content
  • 0
breeze

Проблема с SIP в Keenetic Lite (KN-1310) [по Wi-Fi]

Question

Приветствую!

Поменял роутер (D-link DIR-300) на Keenetic Lite (KN-1310) в связи с переходом на новый тариф у того же провайдера.
Всё отлично, только обнаружилась проблема с SIP (подключение по Wi-FI) - нестабильная связь, при коннекте бывают звуковые "ямы" (когда не слышно собеседника), в основном всё слышно, но иногда бывают пробелы в звуке, как-будто плохая связь.
Интернет у меня 50 МБ\с, раньше был 15 МБ\с и на старом роутере таким проблем не было, связь была идеальная. На старом роутере, чтобы пользоваться SIP, я делал DMZ хосту.
У Keenetic Lite (KN-1310) всё работает "из коробки". Пробовал с установленным "Шлюз прикладного уровня (ALG) для SIP" и без него, проблема не исчезла, прерывания также присутствуют.
Думал, что проблема решится с установкой новой прошивки: Версия Keenetic OS 2.14.C.0.0-4 (перешёл с 2.10.B.1.0-1), но проблема осталась.

Подскажите, как можно исправить проблему?

Edited by breeze

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0
11 минуту назад, breeze сказал:

Приветствую!

Поменял роутер (D-link DIR-300) на Keenetic Lite (KN-1310) в связи с переходом на новый тариф у того же провайдера.
Всё отлично, только обнаружилась проблема с SIP (подключение по Wi-FI) - нестабильная связь, при коннекте бывают звуковые "ямы" (когда не слышно собеседника), в основном всё слышно, но иногда бывают пробелы в звуке, как-будто плохая связь.
Интернет у меня 50 МБ\с, раньше был 15 МБ\с и на старом роутере таким проблем не было, связь была идеальная. На старом роутере, чтобы пользоваться SIP, я делал DMZ хосту.
У Keenetic Lite (KN-1310) всё работает "из коробки". Пробовал с установленным "Шлюз прикладного уровня (ALG) для SIP" и без него, проблема не исчезла, прерывания также присутствуют.
Думал, что проблема решится с установкой новой прошивки: Версия Keenetic OS 2.14.C.0.0-4 (перешёл с 2.10.B.1.0-1), но проблема осталась.

Подскажите, как можно исправить проблему?

А при подключении по кабелю не тестировали?

Share this post


Link to post
Share on other sites
  • 0
19 минут назад, Илья Картавенко сказал:

А при подключении по кабелю не тестировали?

Спасибо!
Только что проверил по кабелю и работает идеально.
Не понимаю в чём проблема, так как по Wi-Fi у меня выдает 47 МБ\с через speedtest.net

В чём может быть проблема и как решить можно?

Share this post


Link to post
Share on other sites
  • 0
1 час назад, breeze сказал:

Спасибо!
Только что проверил по кабелю и работает идеально.
Не понимаю в чём проблема, так как по Wi-Fi у меня выдает 47 МБ\с через speedtest.net

В чём может быть проблема и как решить можно?

47 Мбит/с это нормально, при условии что у вас по тарифу 50. Я так понял проверяете вы на ноутбуке. Попробуйте очистить кэш dns, на ноутбуке. В командной строке выполните комманду   ipconfig /flushdns и перезагрузите ноутбук. Вопрос поддерживает ли на ноутбуке wifi адаптер полосу проускания 40 МГц.?

  • Y'r wrong 1

Share this post


Link to post
Share on other sites
  • 0
42 минуты назад, Илья Картавенко сказал:

47 Мбит/с это нормально, при условии что у вас по тарифу 50. Я так понял проверяете вы на ноутбуке. Попробуйте очистить кэш dns, на ноутбуке. В командной строке выполните комманду   ipconfig /flushdns и перезагрузите ноутбук. Вопрос поддерживает ли на ноутбуке wifi адаптер полосу проускания 40 МГц.?

Спасибо за помощь!
Проверяю на стационарном компьютере с Wi-Fi адаптером D-link DWA-125 (Wireless N 150 USB Adapter).
К сожалению, не нашёл информации по поводу поддержки полосы пропускания 40 МГц, но подключение с этим адаптером показывает 40 МГц в списке подключений.

ipconfig /flushdns - такое ощущение, что помогло немного, частота прерываний сократилась, но они остались.

Может как-то можно соединение на 20 МГц переключить, чтобы проверить? (в настройках адаптера такого не нашёл) 

Что-то ещё можно сделать?

Edited by breeze

Share this post


Link to post
Share on other sites
  • 0
4 минуты назад, breeze сказал:

Спасибо за помощь!
Проверяю на стационарном компьютере с Wi-Fi адаптером D-link DWA-125 (Wireless N 150 USB Adapter).
К сожалению, не нашёл информации по поводу поддержки полосы пропускания 40 МГц, но подключение с этим адаптером показывает 40 МГц в списке подключений.

ipconfig /flushdns - такое ощущение, что помогло немного, частота прерываний сократилась, но они остались.

Может как-то можно соединение на 20 МГц переключить, чтобы проверить? (в настройках адаптера такого не нашёл) 

Что-то ещё можно сделать?

Можно сделать сброс сети, Если win 10 то это можно сделать в сетевых настройках. Если более ранние версии, то в коммандной строке выполните последовательно комманды

  

netsh winsock reset 

netsh int ip reset all 

netsh winhttp reset proxy

И перезагрузите компьютер. 

Для настройки адаптера зайдите в диспетчер устройств, найдите там его, откройте свойства, и на вкладке дополнительно, будет масса параметров, в том числе и управление полосой проускания.

В настройках роутера для wifi проверьте и выставьте настройки так, что бы полная мощность, что бы роутер выбирал канал автоматически и чтобы работали обе полосы пропускания.

А зачем вы на стационарном компьютере используете wi-fi, если есть возможность подключиться кабелем?

  • Y'r wrong 1

Share this post


Link to post
Share on other sites
  • 0
53 минуты назад, Илья Картавенко сказал:

А зачем вы на стационарном компьютере используете wi-fi, если есть возможность подключиться кабелем?

Повсеместный бзик пользователей сделавших "Евроремонт" и забывших о прокладке кабелей. Оправдываюся тем что с Wi-Fi меньше проблем. НО забывают о том, что он, это самый WiFi разрабатывался изначально как протокол для работы именно мобильных устройств: смартфоны, ноутбуки и т.д.
Но нашему пользователю подавай всё по WiFi: стационарный ПК, ТВ, NAS, не хочет он заморачиваться прокладкой проводов, муторно это и затратно. И не хочет этот пользователь понимать, что провод в тысячу крат надёжнее любого радиоканала.
Вот буду мучаться, но не отступлю от своего плана.
Ёжики ели кактус, кололись, плакали, но всё равно продолжали есть. Так и тут.

Edited by Fandor
  • Upvote 2

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Fandor сказал:

Повсеместный бзик пользователей сделавших "Евроремонт" и забывших о прокладке кабелей. Оправдываюся тем что с Wi-Fi меньше проблем. НО забывают о том, что он, это самый WiFi разрабатывался изначально как протокол для работы именно мобильных устройств: смартфоны, ноутбуки и т.д.
Но нашему пользователю подавай всё по WiFi: стационарный ПК, ТВ, NAS, не хочет он заморачиваться прокладкой проводов, муторно это и затратно. И не хочет этот пользователь понимать, что провод в тысячу крат надёжнее любого радиоканала.

Да, вы правы. проводное соединение действительно надежнее. Wi-fi изначально вообще разрабатывался для работы кассовых аппаратов. Я понимаю, когда реально нет возможности проложить кабель, тогда да, можно использовать wifi, но так то кабель проложить даже дешевле на мой взгляд выйдет. Мы у себя один раз проложили кабель, и только когда появилась необходимость перенести компьютер в другой угол комнаты, его же перетянули. Все никаких проблем.

Share this post


Link to post
Share on other sites
  • 0
17 минут назад, Илья Картавенко сказал:

Можно сделать сброс сети, Если win 10 то это можно сделать в сетевых настройках. Если более ранние версии, то в коммандной строке выполните последовательно комманды

  

netsh winsock reset 

netsh int ip reset all 

netsh winhttp reset proxy

И перезагрузите компьютер. 

Для настройки адаптера зайдите в диспетчер устройств, найдите там его, откройте свойства, и на вкладке дополнительно, будет масса параметров, в том числе и управление полосой проускания.

В настройках роутера для wifi проверьте и выставьте настройки так, что бы полная мощность, что бы роутер выбирал канал автоматически и чтобы работали обе полосы пропускания.

А зачем вы на стационарном компьютере используете wi-fi, если есть возможность подключиться кабелем?

Илья, спасибо за подсказку! Нашёл такую настройку в параметрах адаптера: Multimedia/Gaming Environment и сделал Enable.
И кажется теперь всё встало на свои места, потестировал и глюки со связью пропали на 99%.
Если и далее будут наблюдаться прерывания, то сделаю ограничение на 20 Мгц и потестирую (AP Mode Force BW20)

Также попробую сделать сброс сети по вашему совету, если ничего не поможет.

А кабель не подключаю, потому что есть адаптер (длинный провод надо покупать) и тянуть его не хочется из другой комнаты, меньше проводов - и на душе приятнее ;)
Но в крайнем случае, если уж совсем ничего не поможет, то рассмотрю покупку другого адаптера или же кину кабель. Но опять же, проблема похоже решена! Спасибо вам ещё раз!

Напишу вам в ЛС, если понадобится помощь по этой проблеме.

Share this post


Link to post
Share on other sites
  • 0
7 минут назад, breeze сказал:

Илья, спасибо за подсказку! Нашёл такую настройку в параметрах адаптера: Multimedia/Gaming Environment и сделал Enable.
И кажется теперь всё встало на свои места, потестировал и глюки со связью пропали на 99%.
Если и далее будут наблюдаться прерывания, то сделаю ограничение на 20 Мгц и потестирую (AP Mode Force BW20)

Также попробую сделать сброс сети по вашему совету, если ничего не поможет.

А кабель не подключаю, потому что есть адаптер (длинный провод надо покупать) и тянуть его не хочется из другой комнаты, меньше проводов - и на душе приятнее ;)
Но в крайнем случае, если уж совсем ничего не поможет, то рассмотрю покупку другого адаптера или же кину кабель. Но опять же, проблема похоже решена! Спасибо вам ещё раз!

Напишу вам в ЛС, если понадобится помощь по этой проблеме.

Да здесь и пишите. Уменьшение полосы проускания приведет к снижению скорости соединения между адаптером и роутером. Извините, забыл об этом предупредить. Стационарный компьютер все же лучше подключить кабелем. Не за что обращайтесь, форум для этого и существует.

Edited by Илья Картавенко

Share this post


Link to post
Share on other sites
  • 0
21 минуту назад, Илья Картавенко сказал:

Кстати порт всеже откройте 

ЗАЧЕМ?! В очередной раз повторю - перестаньте давать людям вредные советы "лишь бы помочь", не разбираясь в ситуации. Сигнализация и RTP у ТС ходит корректно (иначе была бы односторонняя слышимость и недозвоны), заикания - это исключительно проблемы  стабильности WiFi-соединения по каким-либо причинам.

Тут либо крутить/сбрасывать настройки адаптера, либо крутить настройки кинетика, либо искать расположение роутера для более устойчивого приема. В частности, пробовать 20 МГц, и всякие параметры энергосбережения адаптера еще могут вляить.

1 час назад, Илья Картавенко сказал:

чтобы работали обе полосы пропускания.

шта?!

31 минуту назад, Илья Картавенко сказал:

Уменьшение полосы проускания приведет к снижению скорости соединения между адаптером и роутером

К "шашечкам" приведет, к "ехать" - it depends. Если нестабильные условия приема и адаптер при этом сам не сваливается в 20МГц - включение 20МГц-only скорее всего увеличит RSSI и стабилизирует линк, и возможно даже что средняя скорость получится повыше, чем скачки на 40 МГц.

Edited by KorDen
  • Y'r wrong 1

Share this post


Link to post
Share on other sites
  • 0
45 минут назад, breeze сказал:

AP Mode Force BW20

Лучше на кинетике измените ширину канала на 20 МГц для ТД.

  • Y'r wrong 1

Share this post


Link to post
Share on other sites
  • 0
13 минуты назад, KorDen сказал:

ЗАЧЕМ?! В очередной раз повторю - перестаньте давать людям вредные советы "лишь бы помочь", не разбираясь в ситуации. Сигнализация и RTP у ТС ходит корректно (иначе была бы односторонняя слышимость и недозвоны), заикания - это исключительно проблемы  стабильности WiFi-соединения по каким-либо причинам.

Тут либо крутить/сбрасывать настройки адаптера, либо крутить настройки кинетика, либо искать расположение роутера для более устойчивого приема.

шта?!

К "шашечкам" приведет, к "ехать" - it depends. Если нестабильные условия приема и адаптер при этом сам не сваливается в 20МГц - включение 20МГц-only скорее всего увеличит RSSI и стабилизирует линк, и возможно даже что средняя скорость получится повыше, чем скачки на 40 МГц.

Вот он и крутит настройки, ВЫ бы сами что то бы подсказали, если вы так хорошо разобрались в ситуации. .  а то я уже в который раз вижу подобного рода сообщения от вас. В данной ситуации нужно проверять все. Я даю советы, не лишь бы помочь. А чтобы помочь человеку, и вместе с ним разобраться в его ситуации. 

Edited by Илья Картавенко

Share this post


Link to post
Share on other sites
  • 0
10 часов назад, Fandor сказал:

Повсеместный бзик пользователей сделавших "Евроремонт" и забывших о прокладке кабелей. Оправдываюся тем что с Wi-Fi меньше проблем. НО забывают о том, что он, это самый WiFi разрабатывался изначально как протокол для работы именно мобильных устройств: смартфоны, ноутбуки и т.д.
Но нашему пользователю подавай всё по WiFi: стационарный ПК, ТВ, NAS, не хочет он заморачиваться прокладкой проводов, муторно это и затратно. И не хочет этот пользователь понимать, что провод в тысячу крат надёжнее любого радиоканала.
Вот буду мучаться, но не отступлю от своего плана.
Ёжики ели кактус, кололись, плакали, но всё равно продолжали есть. Так и тут. 

Согласен, что кабель лучше, но возникают вопросы :

1. Разработчики роутеров в своей прошивки делают поддержки таких режимов как "Адаптер", "Усилитель", "Точка доступа"

2. Разработчики ТВ/приставок помимо LAN есть и Wi-fi

Зачем ?

Не которые дают ответ - маркетинг, увеличить число продаж, а там что будет => а зачем вообще тогда придумывать 802.11 gn - ac оставили бы "802.11b" и кабель.

Пользователь живет в частном доме, соседей нет тогда что.

Проверял ExtraII для трансляции 4К потока по схеме

ТВ--<--5GHz--<--ExtraII--<--5GHz--<--KN1010--<--LAN

Нагрузил специально фильмом в котором поток до 110Мбит, кроме ТВ к wi-fi больше не кто не подключен.

 

 

ExtraII-KN1010.jpg

ExtraII-5GHz.jpg

ExtraII-CPU.jpg

Edited by vasek00

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...