Jump to content
  • 5
Зухель

2.15.A.4.0-1 - Нет доступа по SSTP. Нет информации во вкладке "Диагностика"

Question

При обновлении на 2.15.A.4.0-1:

1. Потерял доступ по SSTP.  

2. При переходе на вкладку "Диагностика" отображается "

{{title}} 

"

Share this post


Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0
5 часов назад, Зухель сказал:

При обновлении на 2.15.A.4.0-1:

2. При переходе на вкладку "Диагностика" отображается "

{{title}} 

"

Уже есть, тут.

Share this post


Link to post
Share on other sites
  • 0

Giga II тоже отвалился SSTP

 

(4G III - сервер, Giga II - клиент)

Edited by whbear
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

В связке по SSTP GIGA II - 4G III поменял местами клиент-сервер, в обоих случаях соединение не поднимается, на сервере статус "включено", на клиенте "Нет соединения".

Диагностика недоступна и там и там, поломана страница.

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, whbear сказал:

В связке по SSTP GIGA II - 4G III поменял местами клиент-сервер, в обоих случаях соединение не поднимается, на сервере статус "включено", на клиенте "Нет соединения".

Диагностика недоступна и там и там, поломана страница.

Можно скачать селфтест на странице общие настройки, или посмотреть лог через мобильное приложение.

Share this post


Link to post
Share on other sites
  • 0
30 минут назад, r13 сказал:

Можно скачать селфтест на странице общие настройки, или посмотреть лог через мобильное приложение.

Спасибо, в логе в моб. приложении многочисленные ошибки:

Service: "SSTP0": unexpectedly stopped.

 

Upd: откат одной GIGA II на дельту ( 2.14.C.0.0-4 ) по SSTP ничего не дал.

Янв 13 12:28:23
ndm
Network::Interface::Base: "SSTP0": interface is up.
Янв 13 12:28:23
ndm
Network::Interface::PppTunnel: "SSTP0": remote endpoint is resolved to "X.X.X.X".
Янв 13 12:28:23
ndm
Network::Interface::PppTunnel: "SSTP0": connecting via CdcEthernet0 (CdcEthernet0).
Янв 13 12:28:23
ndm
Network::Interface::PppTunnel: "SSTP0": local endpoint is resolved to "192.168.8.100".
Янв 13 12:28:23
ndm
Network::Interface::PppTunnel: "SSTP0": added host route to X.X.X.X via 192.168.8.1 (CdcEthernet0).
Янв 13 12:28:23
ndm
Network::Interface::Ppp: "SSTP0": enabled connection via any interface.
Янв 13 12:28:25
pppd[660]
Plugin sstp-pppd-plugin.so loaded.
Янв 13 12:28:25
pppd[660]
pppd 2.4.4-4 started by root, uid 0
Янв 13 12:28:25
pppd[660]
Using interface ppp0
Янв 13 12:28:25
pppd[660]
Connect: ppp0 <--> /dev/pts/0
Янв 13 12:28:27
sstpc_SSTP0[661]
Server certificate verification failed, ignoring
Янв 13 09:28:27
sstpc_SSTP0[661]
Connection was aborted, Unknown Status Attribute
Янв 13 12:28:27
pppd[660]
Modem hangup
Янв 13 12:28:27
ndm
Network::Interface::PppTunnel: "SSTP0": added host route to X.X.X.X via 192.168.8.1 (CdcEthernet0).
Янв 13 12:28:27
pppd[660]
Connection terminated.
Янв 13 12:28:27
pppd[660]
Exit.
Янв 13 12:28:27
ndm
Service: "SSTP0": unexpectedly stopped.

 

Edited by whbear
откат, лог
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Судя по
 

Server certificate verification failed, ignoring

у вас сервер не в сети (облако keendns перенаправляет запрос на страницу-заглушку).

Просто доступ к web по доменному имени работает при этом?

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Le ecureuil сказал:

Просто доступ к web по доменному имени работает при этом?

Работал.

1 минуту назад, Le ecureuil сказал:

А вообще нужны оба self-test - и с клиента, и с сервера.

Оба устройства откатил на 2.14.C.0.0-4, SSTP поднялось само, без перенастроек.

Share this post


Link to post
Share on other sites
  • 0
7 минут назад, Зухель сказал:

Можно расчитывать на скорейшую починку SSTP ? 

Без self-test ов от вас с обоих сторон в момент проблемы - нет.

Share this post


Link to post
Share on other sites
  • 0
38 минут назад, Le ecureuil сказал:

Без self-test ов от вас с обоих сторон в момент проблемы - нет.

Постараюсь, если меня не опередят, в ЛК скину, жду, когда клиенты заснут.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

4G III - сервер, GIGAII - клиент
Порядок действий (настройки SSTP не изменяются ни на одном из шагов):
1. ОС везде  2.14.C.0.0-4, SSTP - работает.
2. прошиваю draft в сервер через cli: туннель не поднимается, сервер через Keenetic Cloud доступен, на сервере статус VPN SSTP - работает, на клиенте - нет соединения.
3. снимаю селфтест сервера.
4. прошиваю draft в клиент через cli: туннель не поднимается, сервер через Keenetic Cloud доступен, на сервере статус VPN SSTP - работает, на клиенте - нет соединения.
5. снимаю селфтест клиента.
6. шлю селфтесты в ЛК.

 

Upd: после возврата на 2.14 туннель сам поднялся, без дополнительных действий.

Edited by whbear
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Вот со стороны клиента. Клиент, в данном случае, Ubuntu 16.04

Настройки ни на клиенте ни на роутере не менялись!!!!! С предыдущими версиями прошивок на кинетике всё отрабатывало (в том числе и на 2.15.A.3.0-3). Подключение по SSTP к кинетику происходит через кинетик клоуд. MPPE шифрование через кинетик клоуд, как я понял, не поддерживается, поэтому было изначально отключено на клиенте. 

Скрытый текст

Jan 14 18:09:10 SONY-*** NetworkManager[1268]: <info>  [1230.8757] audit: op="connection-activate" uuid="***" name="to_Keenetic" pid=2714 uid=1000 result="success"
Jan 14 18:09:10 SONY-*** NetworkManager[1268]: <info>  [1230.8810] vpn-connection[0x1**,***,"to_Keenetic",0]: Started the VPN service, PID 19078
Jan 14 18:09:10 SONY-*** NetworkManager[1268]: <info>  [1230.8912] vpn-connection[0x1**,***,"to_Keenetic",0]: Saw the service appear; activating connection
Jan 14 18:09:10 SONY-*** NetworkManager[1268]: <info>  [1230.9904] vpn-connection[0x1**,***,"to_Keenetic",0]: VPN connection: (ConnectInteractive) reply received
Jan 14 18:09:10 SONY-*** NetworkManager[1268]: nm-sstp[19078] <info>  pppd started with pid 19086
Jan 14 18:09:10 SONY-*** NetworkManager[1268]: <info>  [1230.9928] vpn-connection[0x1**,***,"to_Keenetic",0]: VPN plugin: state changed: starting (3)
Jan 14 18:09:10 SONY-*** pppd[19086]: Plugin /usr/lib/pppd/2.4.7/nm-sstp-pppd-plugin.so loaded.
Jan 14 18:09:10 SONY-*** NetworkManager[1268]: Plugin /usr/lib/pppd/2.4.7/nm-sstp-pppd-plugin.so loaded.
Jan 14 18:09:10 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] initializing
Jan 14 18:09:10 SONY-*** pppd[19086]: pppd 2.4.7 started by root, uid 0
Jan 14 18:09:10 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] phasechange: status 3 / phase 'serial connection'
Jan 14 18:09:11 SONY-*** pppd[19086]: Using interface ppp0
Jan 14 18:09:11 SONY-*** NetworkManager[1268]: nm_device_get_device_type: assertion 'NM_IS_DEVICE (self)' failed
Jan 14 18:09:11 SONY-*** NetworkManager[1268]: Using interface ppp0
Jan 14 18:09:11 SONY-*** NetworkManager[1268]: Connect: ppp0 <--> /dev/pts/1
Jan 14 18:09:11 SONY-*** pppd[19086]: Connect: ppp0 <--> /dev/pts/1
Jan 14 18:09:11 SONY-*** NetworkManager[1268]: <info>  [1231.0019] manager: (ppp0): new Generic device (/org/freedesktop/NetworkManager/Devices/853)
Jan 14 18:09:11 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] phasechange: status 5 / phase 'establish'
Jan 14 18:09:11 SONY-*** NetworkManager[1268]: <info>  [1231.0163] devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Jan 14 18:09:11 SONY-*** NetworkManager[1268]: <info>  [1231.0164] device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] phasechange: status 6 / phase 'authenticate'
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] passwd-hook: requesting credentials...
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] passwd-hook: got credentials from NetworkManager-sstp
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] sstp-plugin: sending mppe keys
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] sstp-plugin: MPPE keys exchanged with sstpc
Jan 14 18:09:13 SONY-*** sstpc[19092]: Connection was aborted, Unknown Status Attribute
Jan 14 18:09:13 SONY-*** pppd[19086]: Modem hangup
Jan 14 18:09:13 SONY-*** NetworkManager[1268]: Modem hangup
Jan 14 18:09:13 SONY-*** NetworkManager[1268]: Connection terminated.
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] phasechange: status 5 / phase 'establish'
Jan 14 18:09:13 SONY-*** NetworkManager[1268]: nm-sstp[19078] <info>  Terminated ppp daemon with PID 19086.
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] phasechange: status 11 / phase 'disconnect'
Jan 14 18:09:13 SONY-*** pppd[19086]: Connection terminated.
Jan 14 18:09:13 SONY-*** NetworkManager[1268]: <error> [1233.3597] platform-linux: do-change-link[854]: failure changing link: failure 19 (Нет такого устройства)
Jan 14 18:09:13 SONY-*** NetworkManager[1268]: <warn>  [1233.3598] device (ppp0): failed to disable userspace IPv6LL address handling
Jan 14 18:09:13 SONY-*** NetworkManager[1268]: <info>  [1233.3601] vpn-connection[0x1**,***,"to_Keenetic",0]: VPN service disappeared
Jan 14 18:09:13 SONY-*** NetworkManager[1268]: <info>  [1233.3690] devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] phasechange: status 1 / phase 'dead'
Jan 14 18:09:13 SONY-*** pppd[19086]: nm-sstp[19078] <info>  [helper-19086] exit: cleaning up
Jan 14 18:09:13 SONY-*** pppd[19086]: Exit.

Вижу ошибку "Connection was aborted, Unknown Status Attribute"

Edited by Зухель
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Со стороны кинетика в логах появляется всего лишь одна строчка:

Jan 15 00:09:46 ndm: Http::SslServer: "SSL proxy 100.75.ххх.ххх: 57796": new SSTP tunnel: 100.75.ххх.ххх:57796 (SSL) <-> (sstp).

Edited by Зухель
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Всем спасибо за дебаг, проблема была обнаружена.

После обновления серверного кода, новая версия стала строже проверять CMAC, и это привело к несовместимости. На самом деле проблема в клиенте.

Потому для временного решения можно установить только PAP-авторизацию на клиенте, и все заработает. Безопасность заметно не пострадает, поскольку PAP-обмен происходит внутри SSL-соединения.

Через cli:

> interface SSTP0 authentication pap

 

Фикс будет в ближайших сборках.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, Le ecureuil сказал:

для временного решения можно установить только PAP-авторизацию на клиенте

Да, через PAP заработало.

Share this post


Link to post
Share on other sites
  • 0
7 часов назад, ndm сказал:

MS-CHAPv2-авторизация иправлена в версии 2.15.A.4.0-2.

Подтверждаю, на моих конфигурациях после обновления заработало.

СПАСИБО!

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

А у меня после обновления на 2.15.A.4.0-2 с клиента на ubuntu 16.04 не завелось :( Попрежнему только через PAP.

Сейчас соберу логи.

Edited by Зухель

Share this post


Link to post
Share on other sites
  • 0

При попытке поднять VPN, со стороны кинетика Giga II (выступает в роли SSTP-сервера) в журнале появляется следующее сообщение:

Скрытый текст

Http::SslServer: "SSL proxy 100.ххх.ххх.ххх: 57043": new SSTP tunnel: 100.ххх.ххх.ххх:57043 (SSL) <-> (sstp).

Со стороны ubuntu 16.04 (выступает в роли клиента), при использовании метода аутентификации MSCHAPv2:

Скрытый текст

Jan 20 18:58:03 SONY-*** NetworkManager[1199]: <info>  [1233.0690] audit: op="connection-activate" uuid="***" name="to_Keenetic" pid=2407 uid=1000 result="success"
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: <info>  [1233.0764] vpn-connection[0x123,***,"to_Keenetic",0]: Started the VPN service, PID 3731
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: <info>  [1233.0854] vpn-connection[0x123,***,"to_Keenetic",0]: Saw the service appear; activating connection
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: <info>  [1233.1932] vpn-connection[0x123,***,"to_Keenetic",0]: VPN connection: (ConnectInteractive) reply received
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: nm-sstp[3731] <info>  pppd started with pid 3739
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: <info>  [1233.2031] vpn-connection[0x123,***,"to_Keenetic",0]: VPN plugin: state changed: starting (3)
Jan 20 18:58:03 SONY-*** pppd[3739]: Plugin /usr/lib/pppd/2.4.7/nm-sstp-pppd-plugin.so loaded.
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: Plugin /usr/lib/pppd/2.4.7/nm-sstp-pppd-plugin.so loaded.
Jan 20 18:58:03 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] initializing
Jan 20 18:58:03 SONY-*** pppd[3739]: pppd 2.4.7 started by root, uid 0
Jan 20 18:58:03 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] phasechange: status 3 / phase 'serial connection'
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: nm_device_get_device_type: assertion 'NM_IS_DEVICE (self)' failed
Jan 20 18:58:03 SONY-*** pppd[3739]: Using interface ppp0
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: Using interface ppp0
Jan 20 18:58:03 SONY-*** pppd[3739]: Connect: ppp0 <--> /dev/pts/2
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: <info>  [1233.2286] manager: (ppp0): new Generic device (/org/freedesktop/NetworkManager/Devices/2)
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: Connect: ppp0 <--> /dev/pts/2
Jan 20 18:58:03 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] phasechange: status 5 / phase 'establish'
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: <info>  [1233.2412] devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Jan 20 18:58:03 SONY-*** NetworkManager[1199]: <info>  [1233.2426] device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] phasechange: status 6 / phase 'authenticate'
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] passwd-hook: requesting credentials...
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] passwd-hook: got credentials from NetworkManager-sstp
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] sstp-plugin: sending mppe keys
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] sstp-plugin: MPPE keys exchanged with sstpc
Jan 20 18:58:04 SONY-*** sstpc[3744]: Connection was aborted, Unknown Status Attribute
Jan 20 18:58:04 SONY-*** pppd[3739]: Modem hangup
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: Modem hangup
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: Connection terminated.
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] phasechange: status 5 / phase 'establish'
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] phasechange: status 11 / phase 'disconnect'
Jan 20 18:58:04 SONY-*** pppd[3739]: Connection terminated.
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: nm-sstp[3731] <info>  Terminated ppp daemon with PID 3739.
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: <error> [1234.5130] platform-linux: do-change-link[3]: failure changing link: failure 19 (Нет такого устройства)
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: <warn>  [1234.5131] device (ppp0): failed to disable userspace IPv6LL address handling
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: <warn>  [1234.5154] vpn-connection[0x123,***,"to_Keenetic",0]: VPN plugin: failed: connect-failed (1)
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: <info>  [1234.5154] vpn-connection[0x123,***,"to_Keenetic",0]: VPN plugin: state changed: stopping (5)
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: <info>  [1234.5154] vpn-connection[0x123,***,"to_Keenetic",0]: VPN plugin: state changed: stopped (6)
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: <info>  [1234.5165] vpn-connection[0x123,***,"to_Keenetic",0]: VPN plugin: state change reason: unknown (0)
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: <info>  [1234.5178] devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Jan 20 18:58:04 SONY-*** NetworkManager[1199]: <info>  [1234.5179] vpn-connection[0x123,***,"to_Keenetic",0]: VPN service disappeared
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] phasechange: status 1 / phase 'dead'
Jan 20 18:58:04 SONY-*** pppd[3739]: nm-sstp[3731] <info>  [helper-3739] exit: cleaning up
Jan 20 18:58:04 SONY-*** pppd[3739]: Exit.

 

Edited by Зухель

Share this post


Link to post
Share on other sites
  • 0
17 часов назад, Зухель сказал:

При попытке поднять VPN, со стороны кинетика Giga II (выступает в роли SSTP-сервера) в журнале появляется следующее сообщение:

  Скрыть содержимое

Http::SslServer: "SSL proxy 100.ххх.ххх.ххх: 57043": new SSTP tunnel: 100.ххх.ххх.ххх:57043 (SSL) <-> (sstp).

Со стороны ubuntu 16.04 (выступает в роли клиента), при использовании метода аутентификации MSCHAPv2:

  Показать содержимое

 

Да, это баг клиента. В убунте он тот же самый, и не будет работать с mschap, только с pap.

Я автору написал, но пока оно прилетит в обновления, придется жить вот так.

  • Thanks 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...