Jump to content
  • 0
track2

Проблема с отображением компов в сети (сетевое окружение)

Question

Добрый день.

Есть офис с небольшим количеством ПК в сети (около 20). После замены роутера на Keenetic Extra начались проблемы с компами, подключенными по WiFi (ноутбуки, ОС: Win7, Win10) - а именно, компы перестали видеть что-либо в сетевом окружении (организация маленькая, сеть без домена). При этом на некоторых  net view выдает список ПК в сети, на некоторых совсем глухо. 

Проводная сеть и WiFi в одном VLAN, изоляции нет (тогда бы компы в принципе друг друга не видели при прямом обращении, да и в интерфейсе вроде нет такого в последней прошивке).

Смотрел в сторону Master Browser сначала, запретил некоторым машинам со старыми ОС становиться мастер браузером, но не помогло. Да и не в нём, похоже, дело - кто подключен проводом видят всю сетку. Похоже на какие то проблемы хождения broadcast LAN-wLAN, раньше с подобным не сталкивался.

Подскажите, куда копать?? Может через CLI что то поднастроить можно?

Share this post


Link to post
Share on other sites

28 answers to this question

  • 0

А если по именам к этим машинам обращаться то все нормально? Нпривер так 

image.png.7108502cfca4d0eaf3acfdfe6b3eca38.png

 

image.png

Edited by Илья Картавенко

Share this post


Link to post
Share on other sites
  • 0

Ещё как вариант выяснить на десктопах включена ли поддержка smb v.1...

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Чаще всего - да. 

Пишу "чаще всего", потому что бывает вообще странный момент: шара не открывается по имени, при этом комп по имени можно пропинговать... После пинга шара снова доступна!

Бывает что ни пинг не проходит, ни по имени не открыть. Тогда отключаю/подключаю WiFi соединение и снова по имени могу попасть на общий ресурс!

Завтра планирую послушать эфир вайршарком, но знать бы что искать при таких странных глюках :(

Кроме роутера ничего в сети не менялось.

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, Mamay said:

Ещё как вариант выяснить на десктопах включена ли поддержка smb v.1...

SMB v1 включил, это первое, что проверил ))

Share this post


Link to post
Share on other sites
  • 0
Только что, track2 сказал:

Кроме роутера ничего в сети не менялось.

В этом может быть косвенная причина. Например, брандмауэр винды просек, что пакеты поменяли адрес назначения и запараноил. Роутер ведь тоже не умеет "то работаю, то нет" при неизменных внешних данных. Только smb и только по wifi, но не каждый раз - это какая-то шляпа. Может в сторону стабильности Wi-Fi посмотреть все-таки?

 

Какая на Extra прошивка сейчас и что вместо нее стояло раньше?

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, Илья Картавенко said:

А везде ли хороший сигнал от wi-fi?

Изначально  роутер стоял в коридоре за бетонной стеной, сигнал был не очень. Тоже в его сторону грешил - перенес в основной кабинет, теперь у всех шкала на максимуме! )

4 minutes ago, Mikesk said:

В этом может быть косвенная причина. Например, брандмауэр винды просек, что пакеты поменяли адрес назначения и запараноил. Роутер ведь тоже не умеет "то работаю, то нет" при неизменных внешних данных. Только smb и только по wifi, но не каждый раз - это какая-то шляпа. Может в сторону стабильности Wi-Fi посмотреть все-таки?

 

Какая на Extra прошивка сейчас и что вместо нее стояло раньше?

Я уже для теста на всех проблемных машинах отключил брэндмауэр - не помогло. 

Версия ОС 2.14.C.0.0-4, стояла изначально прошивка со старым интерфейсом.

На счет смены адреса назначения думал немного в другом ключе - роутер воткнут в порт тупого свича, я просто из старого роутера переткнул кабель в новый, свич не перезагружал при этом. Но тоже вряд ли в этом причина может быть :(

Если завтра буду слушать трафик - на что обратить внимание? 

Share this post


Link to post
Share on other sites
  • 0
34 минуты назад, Илья Картавенко сказал:

@Mamay, кстати, а какая версия smb поддерживается в последних прошивках?

Ясно понятно что smb v. 2/3. 

Share this post


Link to post
Share on other sites
  • 0
42 минуты назад, Mikesk сказал:

 Например, брандмауэр винды просек, что пакеты поменяли адрес назначения и запараноил

Не брандмауэр, а "расположение" (домашняя/рабочая/общественная для w7, частный/общий для w10), оно ЕМНИП зависит от мака default gateway.

Share this post


Link to post
Share on other sites
  • 0
35 minutes ago, Илья Картавенко said:

Попробуйте на проблемных машинах сбросить днскэш

Сбрасывал кэш NBT (nbtstat -R)

Сеть без домена, потому /flushdns не пробовал, на всякий случай попробую завтра... Но роутер больше недели стоит - все кэши переобновились уже по любому ))

11 minutes ago, KorDen said:

Не брандмауэр, а "расположение" (домашняя/рабочая/общественная для w7, частный/общий для w10), оно ЕМНИП зависит от мака default gateway.

Расположение тоже поменял! он по умолчанию всех Общественными сделал... Поменял на частную (w10) и рабочую/домашнюю (7). Дополнительные параметры общего доступа перепроверил после, на всякий случай.

Share this post


Link to post
Share on other sites
  • 0
40 минут назад, track2 сказал:

Если завтра буду слушать трафик - на что обратить внимание? 

C IP вашего клиента на IP роутера, порты 138,139,445

1319140726_-2.thumb.jpg.86a17d42168836d589ee5ae91b7b4202.jpg

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, Илья Картавенко said:

А кроме этой, наблюдаются другие проблемы с сетью после замены роутера?

Нет, все работает, интернет без нареканий... Стабильно, не лагает, пинг до роутера хороший.

Странная проблема, почему и обратился за помощью!) 

Share this post


Link to post
Share on other sites
  • 0

Более того, сторонний сканер nbtscanner (Nirsoft) без проблем всю сеть рисует и пишет кто в ней мастер обозреватель!

К сожалению, плохо знаю протокол SMB, чтобы делать какие то выводы :(

Share this post


Link to post
Share on other sites
  • 0
17 minutes ago, Илья Картавенко said:

smb/cifs на роутере включен?

был выключен, в понедельник включил - без разницы

Share this post


Link to post
Share on other sites
  • 0

Если к роутеру ни чего не подключено - флешки жесткие диски к которым нужен общий доступ, то лучше выключить, он на роутере только для этого, ну и принтеров

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Илья Картавенко said:

Если к роутеру ни чего не подключено - флешки жесткие диски к которым нужен общий доступ, то лучше выключить, он на роутере только для этого, ну и принтеров

Флешек нет, принтер тоже не подключен... сейчас отключу, завтра проверим результат

UPD: спрошу здесь, чтобы не плодить лишние сущности! :) Куда в данном роутере спрятали настройки DHCP? Ни резервирования IP, ни времени аренды не нашел... Неужели даже такие тривиальные вещи теперь через командную строку настраиваются?

Edited by track2

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, track2 сказал:

UPD: спрошу здесь, чтобы не плодить лишние сущности! :) Куда в данном роутере спрятали настройки DHCP? Ни резервирования IP, ни времени аренды не нашел... Неужели даже такие тривиальные вещи теперь через командную строку настраиваются?

http://192.168.1.1/controlPanel/segments/Домашняя%20сеть

Плохо искали... 

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
9 часов назад, track2 сказал:

UPD: спрошу здесь, чтобы не плодить лишние сущности! :) Куда в данном роутере спрятали настройки DHCP? Ни резервирования IP, ни времени аренды не нашел... Неужели даже такие тривиальные вещи теперь через командную строку настраиваются?

Для более детального вида:

Цитата

25421406__048.thumb.png.e6793be2d92cfb27e618aace5cbda70f.png

 

Share this post


Link to post
Share on other sites
  • 0

Так, время аренды вижу, а зарезервировать адрес, чтобы о нем был в курсе dhcp как можно?

Share this post


Link to post
Share on other sites
  • 0
14 минуты назад, track2 сказал:

зарезервировать адрес, чтобы о нем был в курсе dhcp

На странице Список устройств.

Edited by Kiborg_Man

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Kiborg_Man said:

На странице Список устройств.

Интуитивно тоже так подумал! Зарегистрировал два адреса, но IP адрес меняется все равно...

В списке зарегистрированных устройств при этом вижу соответствие имени и MAC адреса (IP не указан).

Share this post


Link to post
Share on other sites
  • 0

@track2 Для зарегистрированных устройств, чтобы ip не менялся, надо поставить у каждого галочку "постоянный ip".

И ip указать, те которые вам будут удобны.

 

3.png

Share this post


Link to post
Share on other sites
  • 0

Нда, внутрь пользователя зайти не догадался... :))))

Спасибо!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×