Jump to content
  • 2
Vichigor

Отображение списка устройств

Question

Версия приложения:5.70. Прошивка 2.15.b.001. В приложении все устройства помечены offline

Screenshot_20190213-210511.png

Screenshot_20190213-210210.png

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Ок. Возможно это мой локальный баг. Подождём либо подтверждения, либо отрицания от иных участников процесса...

Share this post


Link to post
Share on other sites
  • 0

Тщательнее перепроверив, выяснил, что активные устройства WiFi сети видны online, устройства Ethernet находятся в offline... 

Share this post


Link to post
Share on other sites
  • 0

Мистика. Пока писал предыдущий пост, МК/облако отдуплились и всё стало корректно...

Share this post


Link to post
Share on other sites
  • 0

@Mamay Черного списка нет. Пока всё нормально отображается.

Share this post


Link to post
Share on other sites
  • 0

@Mamay Прошу CID в личку, чтобы посмотреть.
Мне человек сегодня жаловался на подобную проблему после обновления на 3.0, но у него, говорит, иногда подгружает список.

Share this post


Link to post
Share on other sites
  • 0
8 минут назад, Alex Sh. сказал:

@Mamay Прошу CID в личку, чтобы посмотреть.
Мне человек сегодня жаловался на подобную проблему после обновления на 3.0, но у него, говорит, иногда подгружает список.

Просьба обратить внимание на мою же тему связанную с web интерфейсом. Похожая ситуация когда авторизируктся null. Из-за этого очень долго думает. 

Share this post


Link to post
Share on other sites
  • 0
В 01.04.2019 в 13:02, Alex Sh. сказал:

@Mamay
Мне человек сегодня жаловался на подобную проблему после обновления на 3.0, но у него, говорит, иногда подгружает список

Beta 5 (82), keenetic os 3.00.A.1.0-3. 

Чехарда с online/offline продолжается. При заходе в МК, абсолютно все девайсы находятся offline. После нескольких десятков секунд, внезапно online становятся wifi клиенты, через несколько десятков секунд всё становится корректно, то есть wifi/ethernet клиенты online. Через некоторое время всё опять offline и так по кругу... 

Share this post


Link to post
Share on other sites
  • 0

Создалось впечатление, что при синхронизации с облаком, при каждом новом запрос/ответе, приходят разные данные. 

Первый запрос - ответ нет никто. Второй запрос - ответ wifi клиенты online. Третий запрос - ответ всё хорошечно. Четвёртый запрос - дома нет никто! И так по циклу...  

Share this post


Link to post
Share on other sites
  • 0
17 минут назад, Mamay сказал:

Создалось впечатление, что при синхронизации с облаком, при каждом новом запрос/ответе, приходят разные данные. 

Первый запрос - ответ нет никто. Второй запрос - ответ wifi клиенты online. Третий запрос - ответ всё хорошечно. Четвёртый запрос - дома нет никто! И так по циклу...  

Почти прям как у меня в веб. По LAN устройства скачут.

Цитата

 

 

Share this post


Link to post
Share on other sites
  • 0
В 31.03.2019 в 18:57, Mamay сказал:

У меня при смене версии с 2.15.C.2.0-2 на 3.00.A.1.0-3, список устройств online пуст. До того как, всё было ровно... 

Лучше не стало? Пофиксили один баг на бэк-енде.

Share this post


Link to post
Share on other sites
  • 0
18 минут назад, Alex Sh. сказал:

Лучше не стало? Пофиксили один баг на бэк-енде.

Стало. Вчерась проверял. В моём случае почему-то нет Giga II (ТД) online, хотя в списке keenetic оно зарегистрировано...

Share this post


Link to post
Share on other sites
  • 0

Только что запустил МК и мне он выкинул push уведомление, что де мол мой злополучный Giga ll (ТД) якобы исчез из поля видимости, хотя в webui он чётко виден online... 

Share this post


Link to post
Share on other sites
  • 0

О да! МК корректно показывает что клиент висит на WiFi на точке доступа. Webui же в лучшем случае кажет, что любой клиент с ТД якобы ethernet клиент... 

Спасибо за проделанную работу! 

Share this post


Link to post
Share on other sites
  • 0

@Mamay В Keenetic app (не МК) список подключенных устройств можно забрать непосредственно с каждого Кинетика в локации, поэтому, да, тип подключения будет отображаться точнее, чем в вебе без Wi-Fi-системы.
При включенной Wi-Fi-системе веб тоже будет корректно показывать подключенные к ТД устройства, поскольку ТД шлют эти данные на контроллер.

Share this post


Link to post
Share on other sites
  • 0

@Вова Буянов, @MDP Да, я тоже наблюдал такое поведение. Это последствия одной известной проблемы взаимодействия с сервером. Она решается в данный момент и, надеюсь, будет исправлена на этой неделе. Я тогда напишу в эту ветку.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
33 минуты назад, Kiborg_Man сказал:

@Alex Sh., у меня по прежнему устройства оффлайн.

... чет тоже не пофиксилось....

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
... чет тоже не пофиксилось....

Подтверждаю , все устройства офлайн


Отправлено с моего iPhone используя Tapatalk
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, Alex Sh. сказал:

@Kiborg_Man@MDP@PASPARTU А Cloud Control 1 включен у вас? Если нет, попробуйте включить.

Включил и всё заработало.

Share this post


Link to post
Share on other sites
  • 0

Понятно. Это особенность временно внедренного костыля для поддержки устройств со старыми версиями ОС (2.15). Там в списке облачных устройств еще должно появиться 2 клиента "Cloud". Не удивляйтесь, если увидите )
И, кстати, если там полный список этих Клаудов, то стоИт поудалять, чтобы освободить 2 места.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
4 часа назад, Alex Sh. сказал:

Там в списке облачных устройств еще должно появиться 2 клиента "Cloud".

Вы про это?

Цитата

 

Или нет?

Edited by AndreBA

Share this post


Link to post
Share on other sites
  • 0

@Alex Sh., у меня что-то опять все устройства оффлайн, хоть и включены обе облачные службы.

Share this post


Link to post
Share on other sites
  • 0

@Kiborg_ManВ облачных клиентах есть два места свободных?
В логах нет ничего вроде:
Io::UdpSocket: unable to write data: operation not permitted?

Share this post


Link to post
Share on other sites
  • 0
11 минуту назад, Alex Sh. сказал:

@Kiborg_ManВ облачных клиентах есть два места свободных?
В логах нет ничего вроде:
Io::UdpSocket: unable to write data: operation not permitted?

у меня проскакивают такие записи.... проблема идентичная

Screenshot_2019-06-28-16-00-27-195_com.keenetic.kn.png

Edited by MDP

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Alex Sh. сказал:

@Kiborg_ManВ облачных клиентах есть два места свободных?
В логах нет ничего вроде:
Io::UdpSocket: unable to write data: operation not permitted?

Первый вопрос не понял. Если что у меня 2 облачных клиента отображаются на странице общих настроек.

По логу пока сказать немого случайно его очистил т.к. смотрел через приложение. Надо бы подтверждение действие удаления лога запилить.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...