Jump to content
  • 0
dexter

Keenetic Ultra 2 обсуждаем работу прошивки

Question

Поставил прошивку v2.06(AAUX.0)A7.

Создал на каждый порт по vlan (vlan3-vlan9).

Добавил 7 интерфейсов по типу "interface GigabitEthernet0/Vlan3 - interface GigabitEthernet0/Vlan9".

После создания 3его интерфейса вебморде такое:

file.php?mode=view&id=46&sid=087e8a08e61af4019eef45848bc2cd71

Так же не работает DHCP-Relay + существует лимит на роль "lan" равное 4. Логичнее сделать его равным количеству портов устройства.

self-test - прилагаю.

1.jpg.2f2ebdf6279bedc0ab4e2ad9587ceb9c.j

self-test.rar

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Прошивка v2.06(AAUX.0)A7

Если добавить через веб-интерфейс статический маршрут с адресом шлюза из другой подсети , то его уже не удалить (для удаления надо менять его на адрес из домашней сети); так же этот маршрут не виден во вкладке "системный монитор => маршруты"

маршрут из openvpn.conf до локалки на той стороне не добавляется автоматом, как это было на V1+entware

собссно, так и не смог достучаться до удалённой сети

Share this post


Link to post
Share on other sites
  • 0

Текущая морда не умеет работать более чем с двумя подключениями IPoE. Если через CLI настроить больше, нет ничего удивительного, что она криво отрисовывает. Мы гарантируем, что она нормально покажет только то, что настроено через неё же.

Share this post


Link to post
Share on other sites
  • 0
Всё понял - спасибо. А про DHCP Relay, что можете сказать?

Говорю, лимит ланов поднимем до 8, нет проблем.

Share this post


Link to post
Share on other sites
  • 0

Извиняюсь, вы меня не правильно поняли.

Там есть проблема и с самим DHCP Relay.

Если его включить на дефолтном конфиге на бридж "Home", то он работает. Но если добавить ещё 1 "Lan"(интерфейс или бридж) то работать он перестает. Адреса не резолвятся ни на "Home", ни на другом "Lan"(интерфейс или бридж).

И пока роутер до заводских не сбросишь и заново не включишь он не работает.

Я в первом сообщении self-test.rar выкладывал именно из-за этого.

Можете сами проверить создав интерфейс и попробовав добавить его как "Lan" к DHCP Relay.

Из консоли нет возможности смотреть параметры DHCP Relay?

Share this post


Link to post
Share on other sites
  • 0
Извиняюсь, вы меня не правильно поняли.

Там есть проблема и с самим DHCP Relay.

Если его включить на дефолтном конфиге на бридж "Home", то он работает. Но если добавить ещё 1 "Lan"(интерфейс или бридж) то работать он перестает. Адреса не резолвятся ни на "Home", ни на другом "Lan"(интерфейс или бридж).

И пока роутер до заводских не сбросишь и заново не включишь он не работает.

Я в первом сообщении self-test.rar выкладывал именно из-за этого.

Можете сами проверить создав интерфейс и попробовав добавить его как "Lan" к DHCP Relay.

Из консоли нет возможности смотреть параметры DHCP Relay?

В данной реализации, для работы DHCP-relay необходимо настроить IP-адреса на LAN-интерфейсах.

[E] Dec 11 22:13:00 ndhcpr: failed to get IP address for interface "eth3.7" (address not available).

[E] Dec 11 22:13:00 ndhcpr: failed to get IP address for interface "eth3.5" (address not available).

[E] Dec 11 22:13:00 ndhcpr: failed to get IP address for interface "eth3.8" (address not available).

[E] Dec 11 22:13:00 ndhcpr: failed to get IP address for interface "eth3.4" (address not available).

Share this post


Link to post
Share on other sites
  • 0

Но, то ли лыжи не едут, то ли я .......

Имеем 2 бриджа в первом с 1 по 5 порт + обе точки Wifi и второй в нем 6 и 7 порт.(Все порты в разных Vlan).

На одном бридже IP 192.168.1.1 на втором IP 192.168.110.254. Добавляем их как "Lan" к DHCP Relay и ничего не работает.

Плюс словил вот это: "ag HTTP::CoreInterface: NDM core connection timeout", но тогда селф-тест устройство не выдало, а просто отвалилось.

Ещё вот это в логе:

Dec 15 18:41:38ndhcpcGigabitEthernet1: NDM DHCP client (version 3.0.5) started. 
Dec 15 18:41:39agHTTP::IO::LooseBuffer: timed out. 
Dec 15 18:41:39ndmlib::libndmCore: failed to send a source file. 

self-test.rar

Share this post


Link to post
Share on other sites
  • 0

self-test отвалился на полпути (бОльшая часть информации почему-то оказалась потеряна), если несложно сделайте его пожалуйста еще раз.

Share this post


Link to post
Share on other sites
  • 0

Судя по логу все должно работать.

Пришлите пожалуйста описание и конфигурацию вышестоящего DHCP-сервера, будем пытаться собрать у себя аналогичную схему и испытать.

Share this post


Link to post
Share on other sites
  • 0

Хорошо, вечером приложу dhcpd.conf и сделаю графическое описание.

А пока можете, если есть устройство, добавить интерфейс загнать его в другой bridge, включить DHCP Relay и посмотреть чем дело кончится.

Share this post


Link to post
Share on other sites
  • 0

В архиве схема сети, файл конфигурации dhcpd.conf и основная инфа по серверу.

И ещё такое в логе.

Dec 16 19:40:03agHTTP::CoreInterface: NDM core connection timeout. 

Вылезло это сообщение после загрузки роутера, когда на компе я делал "release/renew"

Запустил tcpdump на сервере, ничего не прилетает со стороны роутера. Роутер не хорошо себя ведет в конфигурации из селф-теста.

server.rar

Share this post


Link to post
Share on other sites
  • 0

Несмотря на некоторую нестандартность, ваша схема была проверена на прошивке A7 (http://files.keenopt.ru/firmware/Keenetic_Ultra_II/2015-12-05/), и все работает - и с Bridge2, и с других бриджей запросы достигают DHCP сервера через relay и клиенты получают ответ в обоих подсетях. DHCP-сервер был настроен на отдельной машине (в его роли выступал udhcpd, практически в дефолте).

Тем не менее, во время тестирования выявились проблемы с настройкой вашей схемы через web, что будет поправлено.

Прилагаю self-test с нашего устройства во время тестирования, если вам интересно.

self-test(4).txt.zip

Share this post


Link to post
Share on other sites
  • 0

А ведь и правда работает. Адрес он получает. А когда делаешь "release/renew" в консоле ошибки выпадают.

Спасибо за Ваш труд.

Share this post


Link to post
Share on other sites
  • 0
А ведь и правда работает. Адрес он получает. А когда делаешь "release/renew" в консоле ошибки выпадают.

Спасибо за Ваш труд.

В консоли Keenetic Ultra II, который является dhcp relay?

Просьба приложить ошибки в режиме system debug, без этого ничего подсказать не могу.

Сегодня проверил работу также с release/renew на ubuntu 14.04 и windows 7 sp1. Оба они при команде release не отправляют вообще ничего, а при renew просто запрашивают новый адрес как ни в чем не бывало в рамках новой dhcp-транзакции, и никаких ошибок не появляется.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...