Jump to content
  • 0
Sign in to follow this  
doc_bravn

Не открывается порт 8001 для доступа снаружи

Question

Добрый день. 

Роутер Ultra 2. Прошивка 3.1 alpha 2. Прописал в правилах переадресации  проброс порта 8001 на домашний сервак.

Мне нужно чтобы внешний порт 8001 перебрасывался на внутренний 8001 моего сервака подключенного к роутеру. 

Правило в роутере такое:

ip static tcp PPPoE0 8001 4c:02:89:0f:a6:29 8001 out_8001 

Также у меня открыт на этот же сервак порт 80 и 443. По 80 и 443 открываются и доступ к ним снаружи есть. Интернет подключается по PPPoE. После поднятия PPPoE роутер получает реальный внешний IP адрес. 

Подскажите пожалуйста что не так и как заставить его работать? 

У меня дома два сервака и оба на линуксе работают. Непосредственно на самом серваке порт 8001 открыт. Я с второго на тот на котором открыт порт 8001 телнетом без проблем подключаюсь на порт 8001. И nmap показывает, что порт 8001 открыт. А вот снаружи через роутер не подключается.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
17 минут назад, doc_bravn сказал:

Добрый день. 

Роутер Ultra 2. Прошивка 3.1 alpha 2. Прописал в правилах переадресации  проброс порта 8001 на домашний сервак.

Мне нужно чтобы внешний порт 8001 перебрасывался на внутренний 8001 моего сервака подключенного к роутеру. 

Правило в роутере такое:

ip static tcp PPPoE0 8001 4c:02:89:0f:a6:29 8001 out_8001 

Также у меня открыт на этот же сервак порт 80 и 443. По 80 и 443 открываются и доступ к ним снаружи есть. Интернет подключается по PPPoE. После поднятия PPPoE роутер получает реальный внешний IP адрес. 

Подскажите пожалуйста что не так и как заставить его работать? 

У меня дома два сервака и оба на линуксе работают. Непосредственно на самом серваке порт 8001 открыт. Я с второго на тот на котором открыт порт 8001 телнетом без проблем подключаюсь на порт 8001. И nmap показывает, что порт 8001 открыт. А вот снаружи через роутер не подключается.

варианта два - вы что-то не так делаете, либо ваш провайдер блокирует порт (да, белый IP не панацея). Как проверяете доступ (извне или изнутри стучитесь по внешнему адресу)? По какому адресу или имени обращаетесь? Если по keendns, убедитесь что выбран прямой режим - облачный ни порт, ни протокол не поддерживает. Ну и самый верный способ понять что происходит - собрать пакеты на внешнем и локальном интерфейсе роутера и посмотреть, где пакет по 8001 теряется.

Share this post


Link to post
Share on other sites
  • 0
16 минут назад, Mikesk сказал:

варианта два - вы что-то не так делаете, либо ваш провайдер блокирует порт (да, белый IP не панацея). Как проверяете доступ (извне или изнутри стучитесь по внешнему адресу)? По какому адресу или имени обращаетесь? Если по keendns, убедитесь что выбран прямой режим - облачный ни порт, ни протокол не поддерживает. Ну и самый верный способ понять что происходит - собрать пакеты на внешнем и локальном интерфейсе роутера и посмотреть, где пакет по 8001 теряется.

Доступ проверяю извне, стучусь на внешний IP с работы. Обращаюсь по внешнему IP который получил роутер от провайдера,  keendns компонент даже не установлен в роутере и не используется.  Провайдер у меня Ростелеком.

Если смотреть вариант, что я не так что-то делаю, то как нужно правильно настроить? Сейчас у меня доступен только телнет до роутера, веб интерфейс не доступен, т.к. наружу выведен мой домашний web сервер и по 80 порту доступен он, а не вебморда роутера.

Share this post


Link to post
Share on other sites
  • 0
11 минуту назад, doc_bravn сказал:

Если смотреть вариант, что я не так что-то делаю, то как нужно правильно настроить? Сейчас у меня доступен только телнет до роутера, веб интерфейс не доступен, т.к. наружу выведен мой домашний web сервер и по 80 порту доступен он, а не вебморда роутера.

В вашем случае лучше открыть веб роутера

> ip http port {выберите_порт}
> ip http security-level puplic

 

А потом так. Если это окажется сложно, то сюда.

Share this post


Link to post
Share on other sites
  • 0
44 минуты назад, Mikesk сказал:

В вашем случае лучше открыть веб роутера


> ip http port {выберите_порт}
> ip http security-level puplic

Что ж, попробовал так сделать. Сменил порт на веб морде. Она стала доступна извне. Удалил правило проброса порта, затем заново его создал. Но хоть убейся не пускает на порт 8001. Открываются какие угодно порты кроме 8001. 8050 открывается, 8030 открывается, 8080 тоже открывается, а 8001 не открывается. Буду узнавать у провайдера. Может реально они блокируют.

Share this post


Link to post
Share on other sites
  • 0
18 минут назад, doc_bravn сказал:

 Открываются какие угодно порты кроме 8001. 8050 открывается, 8030 открывается, 8080 тоже открывается, а 8001 не открывается. Буду узнавать у провайдера. Может реально они блокируют.

либо его использует какое-то другое приложение по upnp. Не проще ли порт у сервера сменить? )

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...