Jump to content
  • 0
r777ay

Web: DNS Провайдера

Question

@Alexander Podyakov Проводные подключения:

1550245938_18-07-2019110057.png.e18336f948c8fad7b44c81921c7da6f3.png

- Не сохраняется снять, установить чекбокс (Игнорировать DNS)

- Нарушена логика работы (Игнорировать DNS), если стоит чекбокс DNS выдаются и на оборот.

Share this post


Link to post
Share on other sites

24 answers to this question

Recommended Posts

  • 0
10 минут назад, r777ay сказал:

@Alexander Podyakov Проводные подключения:

1550245938_18-07-2019110057.png.e18336f948c8fad7b44c81921c7da6f3.png

- Не сохраняется снять, установить чекбокс (Игнорировать DNS)

- Нарушена логика работы (Игнорировать DNS), если стоит чекбокс DNS выдаются и на оборот.

А у Вас какая версия прошивки? У меня на 3.1 Alpha 6 исчез такой пункт.Здесь писал.

Edited by AndreBA

Share this post


Link to post
Share on other sites
  • 0
12 минуты назад, AndreBA сказал:

А у Вас какая версия прошивки? У меня на 3.1 Alpha 6

 

Скриншот 18-07-2019 112544.png

Edited by r777ay

Share this post


Link to post
Share on other sites
  • 0
32 минуты назад, r777ay сказал:

@Alexander Podyakov Проводные подключения:

1550245938_18-07-2019110057.png.e18336f948c8fad7b44c81921c7da6f3.png

- Не сохраняется снять, установить чекбокс (Игнорировать DNS)

- Нарушена логика работы (Игнорировать DNS), если стоит чекбокс DNS выдаются и на оборот.

Подтверждаю. На Giga III (3.1 Alpha 6) аналогичная ситуация.

Edited by T@rkus
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
54 минуты назад, r777ay сказал:

 

Скриншот 18-07-2019 112544.png

Подключение PPPoE?

Share this post


Link to post
Share on other sites
  • 0
1 час назад, r777ay сказал:

IPoE

Возможно в этом разница.

 

2 часа назад, T@rkus сказал:

Подтверждаю. На Giga III (3.1 Alpha 6) аналогичная ситуация.

А у Вас тоже IPoE?

Share this post


Link to post
Share on other sites
  • 0
Только что, AndreBA сказал:

Возможно в этом разница.

 

А у Вас тоже IPoE?

Да

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

У меня PPPoE и этот пункт пропал пару версий прошивок назад.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, r777ay said:

@Alexander Podyakov Проводные подключения:

1550245938_18-07-2019110057.png.e18336f948c8fad7b44c81921c7da6f3.png

- Не сохраняется снять, установить чекбокс (Игнорировать DNS)

- Нарушена логика работы (Игнорировать DNS), если стоит чекбокс DNS выдаются и на оборот.

спасибо, взяли в работу

3 hours ago, AndreBA said:

А у Вас какая версия прошивки? У меня на 3.1 Alpha 6 исчез такой пункт.Здесь писал.

да, для PPP пункт отсутствует

  • Thanks 3

Share this post


Link to post
Share on other sites
  • 0

 В 3.1 Beta 1 не исправлено.

@enpa Как все это дело можно в cli отключать и включать?

 

Share this post


Link to post
Share on other sites
  • 0
1 час назад, T@rkus сказал:

 В 3.1 Beta 1 не исправлено.

@enpa Как все это дело можно в cli отключать и включать?

 

Здесь писали. Не пойдёт?

Share this post


Link to post
Share on other sites
  • 0

@T@rkus Кейс создан, в процессе починки.

Пример работы в cli.

Отключить получение провайдерских DNS:

(config)> no interface ISP ip dhcp client name-servers 
Dhcp::Client: ISP DHCP name servers are disabled.
(config)> system configuration save 
Core::ConfigurationSaver: Saving configuration...

Включение получение провайдерских DNS:

(config)> interface ISP ip dhcp client name-servers 
Dhcp::Client: ISP DHCP name servers are enabled.
(config)> system configuration save 
Core::ConfigurationSaver: Saving configuration...

Проверяем DNS:

(config)> show ip name-server 

           server: 
              address: 8.8.8.8
                 port: 
               domain: 
               global: 0

           server: 
              address: 8.4.4.8
                 port: 
               domain: 
               global: 0

           server: 
              address: 193.0.175.xx
                 port: 
               domain: 
               global: 700

           server: 
              address: 193.0.174.xx
                 port: 
               domain: 
               global: 700

 

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

@enpa Похоже, что связанный с этим баг. Viva 3.1 beta1. Чекбокс доступен, но после нажатия Save остается не отмеченным

 

Selection_001.png.6ace641d5ee790acd39312cc3095da5c.png

Share this post


Link to post
Share on other sites
  • 0

IPoE. Косяк коннкретный - смысл галки полностью инвертирован. Сегодня после эксеримента с ДНС провайдера еле вернул интернет в строй. Требуется починка.

  • Upvote 2

Share this post


Link to post
Share on other sites
  • 0

Не знаю что там у вас исправлено.

У меня PPPoE и на бете 3 этого пункта в вебе не было. В бете 4 он появился. Но лучше его не было.

Итак в бете 4 в PPPoE при включении этой галки в конфиге получаем

ip dhcp client no name-servers

И на PPPoE прекрасно получаем провайдерские DNS

 

А почему. А потому что для PPPoE согласно этой вашей статье https://help.keenetic.com/hc/ru/articles/213966649-Использование-публичных-DNS-серверов-в-интернет-центре нужно для PPPoE прописать в конфиге

ipcp no name-servers

и тогда у меня на PPPoE провайдерские DNS не прилетают.

Поэтому появившийся пункт в бете 4 для PPPoE бесполезен.

Share this post


Link to post
Share on other sites
  • 0
6 часов назад, Gim12 сказал:

Не знаю что там у вас исправлено.

У меня PPPoE и на бете 3 этого пункта в вебе не было. В бете 4 он появился. Но лучше его не было.

Итак в бете 4 в PPPoE при включении этой галки в конфиге получаем


ip dhcp client no name-servers

И на PPPoE прекрасно получаем провайдерские DNS

По этой команде отключаем получение DNS клиентов по DHCP, а не отключение провайдерских(по крайней мере так при подключении по PPPoE)

Скрытый текст

3.31.83 interface ip dhcp client name-servers
Описание Использовать адреса серверов DNS полученные по DHCP. По умолчанию
эта функция включена.
Команда с префиксом no запрещает использовать адреса DNS-серверов
полученные по DHCP.

 

Share this post


Link to post
Share on other sites
  • 0
В 14.08.2019 в 14:30, Alexander Podyakov сказал:

@AndreBA @Gim12 @r777ay

Спасибо за тесты. Поправим поведение данной галочки!

@eraldeСпасибо! Исправили на 3.1 Beta 5.1. Теперь отрабатывает ка нужно (ipcp no name-servers).

 

В 12.08.2019 в 22:16, Gim12 сказал:

Не знаю что там у вас исправлено.

У меня PPPoE и на бете 3 этого пункта в вебе не было. В бете 4 он появился. Но лучше его не было.

Итак в бете 4 в PPPoE при включении этой галки в конфиге получаем


ip dhcp client no name-servers

И на PPPoE прекрасно получаем провайдерские DNS

 

А почему. А потому что для PPPoE согласно этой вашей статье https://help.keenetic.com/hc/ru/articles/213966649-Использование-публичных-DNS-серверов-в-интернет-центре нужно для PPPoE прописать в конфиге


ipcp no name-servers

и тогда у меня на PPPoE провайдерские DNS не прилетают.

Поэтому появившийся пункт в бете 4 для PPPoE бесполезен.

Пробуйте. Исправлено.

Edited by AndreBA
  • Thanks 2

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, AndreBA сказал:

@eraldeСпасибо! Исправили на 3.1 Beta 5.1. Теперь отрабатывает ка нужно (ipcp no name-servers).

 

Пробуйте. Исправлено.

Подтверждаю.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Тут вот еще какой небольшой нюанс с этим переключателем, может быть так и должно быть, конечно. Если отключить провайдерские DNS по средствам этого переключателя, то и на странице подключения и в системном мониторинге в статистике подключения вместо времени пишет "Без доступа в интернет", хотя интернет исправно работает без провайдерских DNS т.к. включен фильтр AdGuard. Опять же, может так и должно быть, но как по мне выглядит не очень логично.

Share this post


Link to post
Share on other sites
  • 0
4 часа назад, Exter сказал:

Тут вот еще какой небольшой нюанс с этим переключателем, может быть так и должно быть, конечно. Если отключить провайдерские DNS по средствам этого переключателя, то и на странице подключения и в системном мониторинге в статистике подключения вместо времени пишет "Без доступа в интернет", хотя интернет исправно работает без провайдерских DNS т.к. включен фильтр AdGuard. Опять же, может так и должно быть, но как по мне выглядит не очень логично.

У меня пишет подключено.

Скрытый текст

1168185637__260.png.1dd9c9a0cef0b4bf8e52d92ab5a739b7.png1650276449__261.png.30d80a8c6924189ac190fadb8b9d0ce1.png

Правда в "Интернет-фильтр" прописаны "Серверы DNS-over-TLS".

Скрытый текст

77591014__262.thumb.png.d37977d4d666ff564625e3c2629dbf78.png

 

Share this post


Link to post
Share on other sites
  • 0
Цитата

Правда в "Интернет-фильтр" прописаны "Серверы DNS-over-TLS".

Ну так и должно быть.

У меня если DNS нигде не указанны, то при этой галке интернет не работает. А если их где то прописать в интернет фильтре, или в сетевых в компе DNS то интернет заработает.

Логично же ведь. PPPoE поднято, только без DNS

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Gim12 сказал:

Ну так и должно быть.

У меня если DNS нигде не указанны, то при этой галке интернет не работает. А если их где то прописать в интернет фильтре, или в сетевых в компе DNS то интернет заработает.

Логично же ведь. PPPoE поднято, только без DNS

Вы не поняли.

У @Exter при включенном "интернет-фильтре" глюк. Описал как у меня настроено.

Как что работает, я в курсе.

Edited by AndreBA

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...