Jump to content
  • 0
vitgan

Вопрос по VPN

Question

Здравствуйте, на роутере Lite 3 создан VPN сервер.

Удаленно к нему подключены роутеры (8 штук) Keenetic 4G III как клиенты PPTP через тунель (https://zyxel.by/kb/4536/) все клиенты подключены через 4G модемы.

Сделано только для доступа на вебморду роутеров.

Вопрос 1. Что будет происходить со скоростью интернета на клиентах при таком подключении?

Вопрос 2. Штатно в роутерах возможно создать пул адресов на VPN Сервере только 10 штук. Мне нужно 100, какое оборудование посоветуете для этой цели?

На данном устройстве https://zyxel.ru/zywall-110/ можно создать VPN Сервер с размером 100 пул адресов?

Share this post


Link to post
Share on other sites

29 answers to this question

Recommended Posts

  • 0

Вообщем, мне пришлось всё самому проверить. 

Согласно данной настройке VPN клиентов https://zyxel.by/kb/4536/ не ждите, что скорость Интернета подключённых к VPN будет превышать 10 мгб/с. При реальной скорости 80-90 мгб/с. Через модем.

Share this post


Link to post
Share on other sites

  • 0

Это может поднять скорость на клиентах?

Внимание! Если необходимо оставить выход в Интернет через локального провайдера, нужно будет прописать статические маршруты через интерфейс PPTP0 для всех клиентов, которые будут пользоваться пробросом портов.
Например, мы будем использовать проброс портов с удаленного клиента, который имеет IP-адрес выхода в Интернет 95.211.169.65. В этом случае для работы проброса портов на Keenetic, который является PPTP-клиентом, нужно прописать маршрут до этого узла в меню Интернет - Маршруты - Добавить маршрут через интерфейс PPTP.

Share this post


Link to post
Share on other sites

  • 0

Так а зачем вы ставите галку "задействовать для доступа в интернет" на PPTP-соединении? Если ее не ставить, то никакого понижения скорости не будет, ведь иначе клиенты ходят через ваш основной роутер. Если используете только для доступа на вебморду - попробуйте использовать KeenDNS ("модуль управления маршрутизатором через облачную службу"), описание есть здесь на форуме.

Share this post


Link to post
Share on other sites

  • 0
Только что, vitgan сказал:

Если галку не ставить, то подключиться удаленно невозможно. 

KeenDNS не работает через модем операторов... 

Еще как работает, выбирайте правильные настройки.

Share this post


Link to post
Share on other sites

  • 0
1 час назад, vitgan сказал:

Так я месяц бьюсь над этим? Готов упасть на колени, скажите что сделать нужно?

Вы лучше скажите что вы делаете и как именно у вас не работает, а также версию прошивки. Тогда мы сможем вам что-то подсказать или даже поправить, если реальный баг.

  • Thanks 1

Share this post


Link to post
Share on other sites

  • 0

Задача: получить удаленный доступ через VPN на вебморду для 30 роутеров Keenetic 4GIII (которые получают интернет через модем Huawei 3372). ЧТОБЫ НЕ РЕЗАЛО СКОРОСТЬ ИНТЕРНЕТА НА КЛИЕНТАХ.

Настройки VPN сервера

 

1.png

2.png

3.png

Share this post


Link to post
Share on other sites

  • 0

Сейчас скорость на клиентах не превышает 10 МБ/С при реальной скорости 80 МБ/С

Если убрать галку "использовать для выхода в интернет", то доступа к клиентам из вне нету.

Edited by vitgan

Share this post


Link to post
Share on other sites

  • 0
48 минут назад, vitgan сказал:

Сейчас скорость на клиентах не превышает 10 МБ/С при реальной скорости 80 МБ/С

Если убрать галку "использовать для выхода в интернет", то доступа к клиентам из вне нету.

Если убрать галку "использовать для выхода в интернет" то нужно  настроить static routing на клиентах до сети сервера.

И судя по наличию проброса портов пытаетесь заходить на них даже не из сети сервера??? если так то нужен роутинг до этих сетей.

(При наличии галки "использовать для выхода в интернет" все идет через default route)

Проще также по VPN подключиться к роутеру-серверу и через это соединение заходить на клиентов прописав правильно роутинг на сервере и клиентах

 

Edited by r13

Share this post


Link to post
Share on other sites

  • 0

Я не понимаю как это сделать, в том то и дело...

Прописал на клиенте маршрут до сервера. Из локальной сети пускает, а из вне - нет.

 

Скриншот 2016-08-31 16.07.33.png

Share this post


Link to post
Share on other sites

  • 0

Для "извне", нужен маршрут на "извне"

Самое простое подключаетесь к роутеру серверу извне так же через VPN назначив в роутере этому соединению статический IP скажем 172.16.1.100

и на клиенте прописать маршрут к адресу 172.16.1.100 через шлюз 172,16,1,33(шлюз из скриншота)

Share this post


Link to post
Share on other sites

  • 0

там же где и для клиентов роутеров, в настройках vpn сервера(ваш первый скриншот)

Предположу что пользователь с ником admin на 1м скриншоте это как раз клиент для удаленного подключения?

Если так, то он как раз и подойдет, для него назначен адрес 172.16.1.33

На этот адрес и надо добавить маршрут с роутера клиента.

Edited by r13

Share this post


Link to post
Share on other sites

  • 0

Это какой-то ужас. У меня ничего не получается и не работает. Нет ли готового решения в виде статьи с картинками?

Может мне кто-нибудь сможет помочь если я дам доступ к роутеру с VPN?

Естественно за вознаграждение за потраченное время...

Share this post


Link to post
Share on other sites

  • 0

@vitgan Только что воспроизвел, все работает,

Ультра 2 сервер подсеть 192.168.1.0

Гига 2 удаленный роутер подсеть 192.168.2.1, ip на vpn 172.16.1.2

Удаленный клиент ip на vpn 172.16.1.20

Надеюсь разберетесь.

Скрытый текст

2016-08-31 (6).png2016-08-31 (7).png2016-08-31 (8).png2016-08-31 (9).png2016-08-31 (10).png

 

Share this post


Link to post
Share on other sites

  • 0

Страна должна знать своих героев!

Огромное спасибо человеку с ником "r13" который удаленно помог мне все настроить и указать на мои ошибки.

Теперь я насладился всеми прелестями VPN.

СПАСИБО!

  • Thanks 1

Share this post


Link to post
Share on other sites

  • 0

Что то странно себя ведет прошивочный pptp сервер. Пытаюсь подключиться к нему с роутера Tenda n301. Вроде подключается, первые секунд 20 даже интернет есть, потом интернет пропадает и еще через пару минут соединение разрывается. Думал дело в тенде и забросил, но сегодня понадобилось так же настроить подключение с роутера DIR-300 и оказалось что проблема та же, симптомы в точности совпадают с тендой. В логе при этом пишет:

Скрытый текст
Sep 16 20:58:09ndm
Core::Syslog: the system log has been cleared.
Sep 16 20:58:21pptpd[587]
CTRL: Client 10.58.73.99 control connection started
Sep 16 20:58:23ndm
kernel: Fast VPN ctrl: setup for src 10.58.73.99
Sep 16 20:58:23pptpd[587]
CTRL: Starting call (launching pppd, opening GRE)
Sep 16 20:58:23pptp[588]
Plugin pptp.so loaded.
Sep 16 20:58:23pptp[588]
PPTP plugin version 0.8.3 compiled against pppd 2.4.4-4
Sep 16 20:58:23pptp[588]
pppd 2.4.4-4 started by root, uid 0
Sep 16 20:58:23pptp[588]
Using interface vpn1
Sep 16 20:58:23pptp[588]
Connect: vpn1 <--> pptp (10.58.73.99)
Sep 16 20:58:29pptp[588]
MPPE protocol reject. MPPE is optional. Falling back to non-mppe
Sep 16 20:58:29pptp[588]
found interface br0 for proxy arp
Sep 16 20:58:29pptp[588]
local IP address 192.168.1.2
Sep 16 20:58:29pptp[588]
remote IP address 192.168.1.200
Sep 16 21:00:56pptp[588]
No response to 3 echo-requests
Sep 16 21:00:56pptp[588]
Serial link appears to be disconnected.
Sep 16 21:00:56pptp[588]
Connect time 2.5 minutes.
Sep 16 21:00:56pptp[588]
Sent 14021 bytes, received 5703 bytes.
Sep 16 21:01:02pptp[588]
Connection terminated.
Sep 16 21:01:02ndm
kernel: Fast VPN ctrl: release for src 10.58.73.99
Sep 16 21:01:02pptp[588]
Modem hangup
Sep 16 21:01:02pptp[588]
Exit.
Sep 16 21:01:02pptpd[587]
CTRL: Reaping child PPP[588]
Sep 16 21:01:02pptpd[587]
CTRL: Client pppd TERM sending
Sep 16 21:01:02pptpd[587]
CTRL: Client pppd finish wait
Sep 16 21:01:03pptpd[587]
CTRL: Client 10.58.73.99 control connection finished

 

Если подключаться windows клиентом или с андроид телефона все работает отлично, интернет есть, разрывов нет

Роутер Keenetic II, с прошивкой v2.06(AAFG.3)C1. Настройки сервера обычные:

Скрытый текст

Image 1.png

Вот сейчас к pptp серверу подключен компьютер через windows клиент, работает стабильно, без разрывов. Одновременно с компьютером подключал тенду, она уже третий раз разрывается :(

Скрытый текст

Image 2.png

 

Edited by GanjaKyp

Share this post


Link to post
Share on other sites

  • 0

Вчера, с горем пополам, настроил accel-ppp из entware в pptp режиме, с ним tenda работает нормально

Screenshot_2016-09-17-10-10-35.png

Получается проблема где то в настройках прошивочного pptpd

Share this post


Link to post
Share on other sites

  • 0
1 час назад, GanjaKyp сказал:

Вчера, с горем пополам, настроил accel-ppp из entware

Вы первый, кто на кинетках поднял accel-ppp. Значит рабочий!!! Я сам настраивал и проверял только xl2tpd и openvpn.

  • Thanks 1

Share this post


Link to post
Share on other sites

  • 0

Хотел проверить именно pptp. Кроме того у меня не срабатывают ip-up и down скрипты, из за этого iptables приходится настраивать вручную:(

Share this post


Link to post
Share on other sites

  • 0

Техподдержка посоветовала попробовать команду vpn-server no lcp echo. Теперь подключение не рвется, но интернета на роутере нет, хотя шлюз и маршрут вроде прописались

Скрытый текст

tenda.png

tenda2.png

 

Share this post


Link to post
Share on other sites

  • 0

В чем может быть проблема, целый день нет доступа на роутер через PPTP. Интернет на роутере появляется и через 5 секунд гаснет...

Лог прилагаю.

log.txt

Share this post


Link to post
Share on other sites

  • 0
9 часов назад, vitgan сказал:

В чем может быть проблема, целый день нет доступа на роутер через PPTP. Интернет на роутере появляется и через 5 секунд гаснет...

Лог прилагаю.

log.txt

Модель роутера? Версия прошивки? self-test? Давно так стало, или только вчера?

Share this post


Link to post
Share on other sites

  • 0

На данном роутере это случилось вчера, но есть ещё несколько роутеров на которых наблюдается похожая проблема.

Итак: Keenetic 4G III, прошивка v2.07(AAUR.2)C1

Сегодня роутер опять был недоступен около 5 часов...

 

log.txt

self-test.txt

Share this post


Link to post
Share on other sites

  • 0
В Saturday, September 17, 2016 в 07:16, GanjaKyp сказал:

Вчера, с горем пополам, настроил accel-ppp из entware в pptp режиме, с ним tenda работает нормально

Screenshot_2016-09-17-10-10-35.png

Получается проблема где то в настройках прошивочного pptpd

А есть возможность описать настройку accel-pptp?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...