Jump to content
Himmler

Редкий баг, так и не выловленный со времён 2.14

Recommended Posts

Итак, на неделе вновь случилось, теперь на 2.16. Очень редкий баг (1 - 2 раза в год.), описывался мною ранее:

Цитата

Сегодня впервые за годы поймал на удалённом кинетике 2.14 такую же проблему, которая продолжается до настоящего времени. Веб-морда не грузится, CLI работает худо-бедно (system reboot не исполняется). В логах CLI весьма насторожила многократно повторяющаяся строчка: W [Feb 27 20:18:38] ndm: Core::Watchdog: Event sender holds SSL_SERVER (19) lock 15660 seconds acquired Feb 27 15:57:37. Аптайм около 9-10 суток, памяти свободно около 40%, CPU загружен на 1-5 %.

Цитата

Ну что ж, спустя 2,5 месяца я вновь поймал ту же самую проблему. W [May 7 22:03:09] ndm: Core::Watchdog: Event sender holds SSL_SERVER (19) lock 19439 seconds acquired May 7 16:39:10. Опять точно такие же симптомы, что и ранее, без каких-либо отличий, кроме того, что теперь это на 2.15.C.3.0-2. Ребята, с этим надо что-то делать.

Цитата

Опишу более подробно: В веб-морду заходит и через ip, и через keenDNS-имя. При первом заходе в поломанном состоянии удаётся даже авторизоваться, но dashboard после этого не загружается (пустая страница) Все последующие попытки авторизации безуспешны, потому как в консоли браузера при загрузке веб-морды: Ошибка синтаксического анализа XML: корневой элемент не найден Адрес: http://192.168.1.1/auth Строка 1, символ 1: Telnet при этом худо-бедно работает, даёт глянуть лог и кое-что прочее, но вот reboot не выполняет.

 

Ребята, ну вы бы хоть посмотрели, а то вроде как 2.16 это "старая/добрая/стабильная/надёжная", а баг тянется ещё вон откуда.

  • Upvote 1

Share this post


Link to post
Share on other sites

Если временно отключить KeenDNS ситуация не меняется?

Вы случайно ничего лишнего в брандмауэре не заблокировали? Возможно роутер не может обновить сертификат. Но я не утверждаю. 

Share this post


Link to post
Share on other sites

Брандмауэр отключен, а вот KeenDNS я отключить не могу, ибо нужен постоянно, а баг случается раз в полгода.

Edited by Himmler

Share this post


Link to post
Share on other sites

Я бы и рад предоставить больше сведений, вот только роутер в этом состоянии еле живой, и максимум дебажной информации мне удалось получить только из лога через telnet.

Share this post


Link to post
Share on other sites

В 3.0 и выше поправлено.

Поскольку 2.16 поддерживается только мной, то исправление выйдет когда у меня будет время на перенос в 2.11 и 2.16.

  • Thanks 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...