Jump to content
  • 0
Glazami

2.16.D.1.0-0 двойной dns? или как установить альтернативный dns но всё равно остаться с dns провайдера поверх

Question

111111111111111111111111111.JPG.6faed8e7d0c7ae48d4a74fe76c7101f6.JPG

Здравствуйте, кто-то знает почему так? устанавливаю альтернативные dns сервера, перезагружаю роутер и стоят двойные dns сервера... так обычно происходит если сохранить добавленные альтернативные DNS сервера но не перезагрузить роутер.

Если в разделе Интернет-Фильтр выбрать один из предустановленных adguard или яндекс, то после сохранения новые dns вместо dns провайдера не устанавливаются, даже после перезагрузки.

При добавлении альтернативных dns выбрав графу "подключение: любой" dns не меняется вообще а просто устанавливается двойной dns в подключениях так и отображается первичным всё равно dns провайдера. а к примеру выбрать для каждого dns отдельно подключение то после перезагрузки в подробностях подключения отображаются только альтернативные dns. но через какое-то время  dns провайдера автоматически всплывают при чём первичными. как это побороть? в чём дело?

Возможно это я что-то не так делаю? вроде всё так. Нигде больше dns сервера провайдера не прописаны. И да это PPPoE подключение, но но пропадают после перезагрузки роутера dns сервера провайдера только если сделать как ниже на скрине.

image.png.cce4ae4f24a08dec4b3f4ade3d0a1264.png

И при этом всё равно через время возвращаются dns сервера провайдера. как их побороть? 😂 в чём дело?

 

Дополнительные DNS-серверы help.keenetic.com

 

Edited by Glazami

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Если просто добавляю альтернативные dns сервера и по умолчанию в графе подключение стоит "любой", dns просто не меняются даже после перезагрузки.

Если сделать как на втором скрине то dns сервера ставятся после перезагрузки роутера но со временем становится как на первом скрине.

Если просто выбрать один из предустановленных dns вне зависимости от профиля семейный или без фильтрации, в свойствах подключения показывает dns провайдера. выходит предустановленные dns и не работают вовсе что бы не выбирал. так и раньше было с dns нортон (когда они ещё были в составе ПО роутера.) с ними кстати у меня вообще интернет отрубался вроде. ну видимо и не с проста их удалили.

Share this post


Link to post
Share on other sites
  • 0

Может нужно вообще для всех подключений вручную прописать dns как на втором скрине только для вообще всех подключений?

Подозреваю что возможно когда устройства по wifi обращаются к интернету а конкретно для wifi вручную не выбран dns то он и подключается к dns провайдера.

Но выбирая графу "любой" тип подключение, dns всегда остаётся провайдера.

Share this post


Link to post
Share on other sites
  • 0

image.png.b0fb112646860b192f8afc712ee1e72f.pngЕсли вручную задать dns для каждого подключения в списке. 😂

И кто знает... возможно через какое-то время dns провайдера снова появится без ведома. На данный момент моя теория работает... Но так очевидно не должно быть. возможно какой-то косяк в коде (ПО роутера.)

Ведь всё должно работать и без ручного выставления всех настроек а применяться на "любое" подключение. так и предустановленные dns сервера должны работать но что не выбирай ничего не меняется даже после перезагрузки.

Share this post


Link to post
Share on other sites
  • 0

Вы так много написали, но сложно понять в чем вопрос. )

Обращение к DNS серверам идёт по наименьшему пингу (отклику DNS сервера). Если есть DNS провайдера, то он практически всегда из всего списка добавленных DNS серверов будет первым в этой цепочке, т.к. тупо находится ближе всего.

По крайней мере всё это справедливо при настройке DoT/DoH серверов. Но по моему и для обычных так же. 

Если вопрос в чем-то другом. Напишите покороче что вы хотите. )

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0
1 час назад, keenet07 сказал:

Вы так много написали, но сложно понять в чем вопрос. )

Обращение к DNS серверам идёт по наименьшему пингу (отклику DNS сервера). Если есть DNS провайдера, то он практически всегда из всего списка добавленных DNS серверов будет первым в этой цепочке, т.к. тупо находится ближе всего.

По крайней мере всё это справедливо при настройке DoT/DoH серверов. Но по моему и для обычных так же. 

Если вопрос в чем-то другом. Напишите покороче что вы хотите. )

DNS провайдера нет. они нигде не вбиты. Ни в каких настройках их нет. но dns провайдера самый тупой и медленный.... Логично я хочу заменить dns провайдера альтернативным, вбиваяю в настройках ТОЛЬКО альтернативный dns и если не делать как на последнем скрине то dns провайдера автоматически всплывает в подключении. То-есть задан dns яндекса, но роутер игнорирует их и подключается к dns провайдера которых в настройках роутера нету вообще. то-есть выставляются автоматически.

Я хочу сказать что я хочу зайти в меню "Интернет-Фильтр" выбрать там предустановленный производителем dns adguard или яндекс dns, Но они не работают. что бы ты не выбирал в свойствах подключения даже не всплывает адрес dns серверов адгуарда или яндекса. В таком случае только dns провайдера.

И если вбить вручную dns адреса для (Любых подключений) то-есть для всех. (по умолчанию.) то dns также не работает и не высвечивается даже вторым рядом в свойствах подключения.

Если выбрать вместо (Любых) подключений конкретное "PPPoE" к примеру, то после перезагрузки dns сервера установлены те которые прописываю я. Но вскоре они встают вторым рядом после dns провайдера, то-есть dns провайдера автоматически сменяет dns прописанный мной.

И только если сделать так

image.png.474d4827220949a64290fffb1e2a8c14.png

dns не сменяются на dns провайдера. Это же бред. так не должно быть...

Если в столбе "подключение" выбран пункт "любой" то dns подключается от провайдера. то-есть не работает. А ДОЛЖНО. именно такой способ и описан в инструкции по ссылке. как добавить альтернативные dns? просто переходишь в раздел "Интернет-Фильтр" выбираешь там или из предустановленных dns или вбиваешь адрес альтернативного dns и всё. всё должно работать. по умолчанию "подключение" стоит "любой" но не работает.

Может там понятнее.

Edited by Glazami

Share this post


Link to post
Share on other sites
  • 0

Понятно. Основная проблема у вас DNS провайдера от которых вы хотите избавиться. 

Настройте для проводного соединения вместо автоматического режима работы DHCP получение адресов вручную. И пропишите там адрес, маску подсети и шлюз которые вы получаете от провайдера, но поля DNS не заполняйте. Или впишите туда те которые вам нужны.

Точно так же настройте и DHCP PPPoE соединения. Настройка IP: ручная.

Всё. Больше им просто неоткуда будет взяться.

 

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0

@Glazami Через CLI пропишите (только правильно interface пропишите):

interface PPPoE0
ipcp no name-servers
system configuration save

или

не знаю есть ли в 2.16 в веб интерфейсе такая настройка, если есть то так:

Скрытый текст

1442574379__348.thumb.png.848f03454d1d075530442636aab668cb.png

 

Edited by AndreBA

Share this post


Link to post
Share on other sites
  • 0
5 часов назад, keenet07 сказал:

Понятно. Основная проблема у вас DNS провайдера от которых вы хотите избавиться. 

Настройте для проводного соединения вместо автоматического режима работы DHCP получение адресов вручную. И пропишите там адрес, маску подсети и шлюз которые вы получаете от провайдера, но поля DNS не заполняйте. Или впишите туда те которые вам нужны.

Точно так же настройте и DHCP PPPoE соединения. Настройка IP: ручная.

Всё. Больше им просто неоткуда будет взяться.

 

я думал тоже об этом, но ip динамический. в ip вписал 192.168.0.1 в ip "домашней сети" стоит 192.168.1.1 dns оставил пустыми. выбрал потом предустановленные. проверяю на странице с проверкой подключен ли dns, показывает подключен, рекламу блокирует и т.п

Но в свойствах подключения всё равно стоит ip провайдера.

На сайтах

https://checkadblock.ru/   

При выбранном режиме блокировка рекламы от adguard не блокирует ничего.

https://adguard.com/ru/test.html

тут в тесте пишет что "Похоже, что AdGuard не включен:("

ниже пишет: (Вы используете режим AdGuard DNS "По умолчанию" ) с зелёной галочкой. (Хотя выбран режим без рекламы.) ну и как выше сказал в свойствах сети стоят dns провайдера.

Также стоило поменять настройки на ручные, не смотря на вбитые вручную dns для всех подключений сразу же снова выставились dns провайдера в свойствах подключения.

2 часа назад, AndreBA сказал:

@Glazami Через CLI пропишите (только правильно interface пропишите):


interface PPPoE0
ipcp no name-servers
system configuration save

или

не знаю есть ли в 2.16 в веб интерфейсе такая настройка, если есть то так:

  Показать содержимое

1442574379__348.thumb.png.848f03454d1d075530442636aab668cb.png

 

прописал, команды приняты но не помогло.

(config)> interface PPPoE0     

Network::Interface::Repository: "PPPoE0" interface created. 

(config-if)> ipcp no name-servers     

not using remote name servers     

Core::ConfigurationSaver: Saving configuration...                                                                       

в 2.16 нет функции "игнорировать DNS" к сожалению.

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, Glazami said:

в 2.16 нет функции "игнорировать DNS" к сожалению.

Эта функция делает то же, что и введённые команды.

7 minutes ago, Glazami said:

прописал, команды приняты но не помогло.

Соединение выкл/вкл сделали? Команды работают, использую очень давно.

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, AndreBA сказал:

С информацией ознакомился, там в основном для версии ПО3. но полезное тоже подчеркнул.

Например цитата

Если в настройках роутера используются DoT/DoH-сервера, они не отображаются на странице "Системный монитор" в строке "DNS-серверы". Когда DNS провайдера отключены, будут использоваться адреса сервиса DoT/DoH.

Я правильно понимаю? когда я выбрал предустановленные dns яндекс, adguard или skydns, (а они подходят под DoT/DoH) то  "Системный монитор" и "подробнее о соединении" там не должен dns отображаться вообще. Но у меня отображается dns провайдера.

Ну я тогда не знаю😂

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Sergey Zozulya сказал:

Эта функция делает то же, что и введённые команды.

Соединение выкл/вкл сделали? Команды работают, использую очень давно.

Даже перезагрузил роутер.

Share this post


Link to post
Share on other sites
  • 0

image.png.c12cb56299df8f7b5cbd93e8c9bd666e.png

Спустя все настройки. что не меняй. а в "Аутентификация у провайдера (PPPoE)" я не могу вбить ip, ну точнее могу вписать что угодно но после сохранения "настройки ip" переходят из ручных в автоматические.

Уже спустя столько переподключений меня провайдер банить начал.

Edited by Glazami

Share this post


Link to post
Share on other sites
  • 0

Спасибо тем кто пытался вникнуть или помочь. вечером ещё почитаю статьи может ещё что найду за что зацепиться или на край откачу прошивку на стабильную версию. или сброшу настройки и попробую всё с нуля настроить.

Ну или пора новый роутер купить со свежей прошивкой.😂

Share this post


Link to post
Share on other sites
  • 0

Если DHCP провайдера всё-равно умудряется где-то заслать вам пакет с DNS провайдера, я бы попробовал полностью заблокировать эти пакеты на интерфейсе с помощью Межсетевого экрана.

Share this post


Link to post
Share on other sites
  • 0

Ещё можно заблокировать сами IP адреса DNS серверов провайдера, если они не находятся вместе с какими-то другими необходимыми.

Share this post


Link to post
Share on other sites
  • 0

В "Межсетевом экране" заблокировал ip адреса, dns провайдера. Для всех подключений выставил это 53 порт TCP DNS и UDP DNS.

После перезагрузки роутера, Интернет работает, dns провайдера на месте. Не смотря на то что они заблокированы и нигде не указаны в настройках подключений к сети они всё равно откуда-то берутся.

после команды

interface PPPoE0
ipcp no name-servers
system configuration save

  вообще появилось дополнительное соединение кстати.

image.thumb.png.6deda90d39cd0547ecb5c9861a0afa8e.png

Кликнув по нему всплывает окно со следующим содержимым
image.png.83cddc8eb9e42e5b1c61242de0da965e.png

Пытаюсь понять это я что-то не так делаю ПО ИНСТРУКЦИИ. Что-то не так с роутером? с прошивкой? или с провайдером?

Share this post


Link to post
Share on other sites
  • 0

image.thumb.png.66af501f2e6bb5727e903b1ba74e6b28.png

Оказывается ещё и порт другой нежели можно выбрать в настройках "53" выставляется если выбрать из списка TCP DNS, UDP DNS

В том числе заблокировал третий ip из уже этого списка. Тоже ноль результата заблокировал все три как ip.

Вообще непонятно что происходит. тут одни ip адреса и сколько не блокирует бесполезно, запускаю через сайт для теста dns он показывает что у меня один dns стоит немецкий от "Choopa, LLC" сервер франкфурт. второй Россия Ростелеком, и ip адреса вообще другие.

Share this post


Link to post
Share on other sites
  • 0

Покажите правило блокировки DNS. 

Имейте в виду что создавая правила вы блокируете входящие соединения. 

Запрос DNS это исходящее на 53, но ответ приходит с другого порта.

Покажите на каком интерфейсе вы пытаетесь их заблокировать. 

И вообще. Если ваш PPPoE соединение сможет работать с выставленными вручную настройками вместо того, что идёт по DHCP, то просто заблокируйте сам запрос или ответ DHCP сервера. Это UDP 67.

Соответственно не получите эти DNS адреса. И не нужно будет потом каждый блокировать. Они просто там не должны появиться, если всё правильно сделаете. Я же вам писал уже.

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0

Пытался блокировать на интерфейсе ip, на интерфейсе TCP, указывая как 67 так и 32 порт, оба правила одновременно и TCP DNS 53 порт и UDP DNS 53 порт.

ставлю поверх dns cloudflare, проверяю на сайте показывает также как и в свойствах соединения, показывает и сервера cloudflare и ростелеком одновременно.

Edited by Glazami

Share this post


Link to post
Share on other sites
  • 0
6 минут назад, Glazami сказал:

Пытался блокировать на интерфейсе ip, на интерфейсе TCP, указывая как 67 так и 32 порт, оба правила одновременно и TCP DNS 53 порт и UDP DNS 53 порт.

DHCP это чисто UDP 67, причем блокировать нужно исходящий запрос на интерфейсе PPPoE. Что обычным правилом в веб-интерфейсе вы не сделаете. Нужно из CLI блокировать исходящее.

Или если интересно могу подсказать как сделать вкладку для Межсетевого экрана с Исходящими на нужном интерфейсе. И уже в ней создать правило блокировки UDP 67.

 

А где вы блокируете я так и не понял. Вместо интерфейса пишите мне о протоколе.

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0

Зачем у вас в адресе источника стоят эти адреса? Это адреса DNS серверов? Их тут быть вообще не должно.

Мы сейчас блокируем обращение к DHCP серверу.

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0

Нужно вот такое правило. Но только для исходящего соединения. Пока-что вы его создать не сможете.

1419289415_.thumb.JPG.58d35385fdb290371a9aa8a85392a328.JPG

Сейчас у вас нет такой вкладки в Межсетевом экране. Там все для входящих.

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0

Извиняюсь, а консольной команды для создания такого правила нет? в прошивке ждать бесполезно, как я понял обновлений не предвидится. (Жаль роутер новый сейчас покупать особо смысла тоже нет, этого хватает по функционалу а скорость ограничена только 100мегабитами провайдера.) Видимо мой провайдер просто ну очень хочет контролировать все мои dns запросы через свой цод. проблема в том что бывает отрубается интернет и при попытке восстановить подключение появляется ошибка. (И ранее кстати работали альтернативные dns на более старой прошивке но и видимо провайдер тоже обновил что-то. а ещё работал доступ через приложение кинетик к роутеру из любой точки мира при доступе к интернету, сейчас не работает да и нет острой необходимости.

120438755_.JPG.789e7f8ed3424b4f8045b47f2467416d.JPG

Хочу гигу последнюю взять как у вас или дождаться уже обновления линейки. Даже не знаю как скоро могут обновить линейку, год-два. а может совсем скоро (Маловероятно мне кажется.)

Странно что процессор https://www.mediatek.com/products/homeNetworking/mt7623n-a#

выпустили уже давно, но устройств в которых его используют найти не удалось кроме одной платы на али.

 

Share this post


Link to post
Share on other sites
  • 0
9 часов назад, Glazami сказал:

Извиняюсь, а консольной команды для создания такого правила нет?

Есть конечно. Но нужно правильно её сформировать. Я по CLI не большой специалист. Нужно в доки лезть.

А вообще до того как пробовать создавать правило блокировки DHCP на конкретном интерфейсе, хотелось бы убедиться, что ваш интернет через PPPoE соединение сможет работать с выставленными в ручную настройками. Вы мне так и не ответили проверяли ли вы такую возможность или там серый IP меняется при каждом соединеннии. 

Настройте вручную и сделайте скрин. Иначе просто смысла нет. Заброкируем DHCP и пропадет у вас инет после перезагрузки. Потом будете спрашивать как отменить это правило.

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0
4 часа назад, keenet07 сказал:

А вообще до того как пробовать создавать правило блокировки DHCP на конкретном интерфейсе, хотелось бы убедиться, что ваш интернет через PPPoE соединение сможет работать с выставленными в ручную настройками. Вы мне так и не ответили проверяли ли вы такую возможность или там серый IP меняется при каждом соединеннии. 

Настройте вручную и сделайте скрин. Иначе просто смысла нет. Заброкируем DHCP и пропадет у вас инет после перезагрузки. Потом будете спрашивать как отменить это правило.

Я писал что ip динамический, и меняется ну почти каждый раз при переподключении. (Иногда ip не меняется даже после нажатия кнопки обновить ip в роутере, даже после перезагрузки соединения, бывает даже после перезагрузки роутера появляется тотже ip что и был до.) ip адрес сейчас выглядит как-то так  100.79.17.XXX   прошлый выглядел так 178.45.126.13

Я забивал настройки вручную, и dns в настройках подключения забивал альтернативный и пробовал оставить поле пустым. Ручные настройки ip, не знал что забить туда пробовал 192.168.0.1 и после сохранения всё обнулялось. поля снова пустые. (Естественно я не знаю что туда забить у меня нет статического ip а те что были выданы при подключении не встают.)

Ещё  поле "Параметры IP и DNS" по умолчанию выбрано "Автоматически DHCP" но также высвечивается красным " IP-адрес не получен ", по этому у меня выбрано в соответствии с инструкцией "без ip адреса".

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...