Jump to content
  • 0
Вова Буянов

Пропал Сервисный код Keenetic_Giga_II

Question

Recommended Posts

  • 0

@ndm, а рецепт вот этот не катит на второй гиге?

заходите телнетом на роутер
и вводите команду factory (после входа попадаете в config>)

вводите две команды (можно три если хост апгрейдов хотите прописать)
(находитесь в меню factory>)
env set zyxelsn SXXХХХхХхХ (ваш серийный номер с наклейки)
env set servicetag 123123123123 (ваш сервисный номер с наклейки)
и... вуаля - все начинает работать, апгрейдиться через сайт без всяких
плясок с бубном и UBoot через консоль

 

ps: сам не пробовал. пока не слетало. :27_sunglasses:

Edited by Goblin

Share this post


Link to post
Share on other sites

  • 0

@ndm, не плохо бы такие прошивки, вставить в этот архив. тогда действительно будет: "Эта программа поможет вам восстановить операционную систему интернет-центра серии Keenetic." (с)

Share this post


Link to post
Share on other sites

  • 0

@Goblin Мы провели исследование данной проблемы. Восстановление factory-раздела после сбоя возможно без вмешательства пользователя, с высокой вероятностью успеха. Сейчас работаем над тем, чтобы в следующем обновлении прошивка восстанавливала параметры сама из поврежденной части.

  • Thanks 1

Share this post


Link to post
Share on other sites

  • 0
В 14.10.2016 в 15:15, ndm сказал:

@Goblin Мы провели исследование данной проблемы. Восстановление factory-раздела после сбоя возможно без вмешательства пользователя, с высокой вероятностью успеха. Сейчас работаем над тем, чтобы в следующем обновлении прошивка восстанавливала параметры сама из поврежденной части.

Закончена ли работа над прошивкой?

Какой верcией прошивки воспользоваться, чтобы восстановить Сервисный код?

Share this post


Link to post
Share on other sites

  • 0
16 часов назад, verka18 сказал:

Закончена ли работа над прошивкой?

Какой верcией прошивки воспользоваться, чтобы восстановить Сервисный код?

Если у вас на текущих 2.08 / 2.09 есть проблемы, то обратитесь в техподдержку.

Share this post


Link to post
Share on other sites

  • 0

Хочу добавить, как владелец нескольких старых "белых" Кинетиков, в разное время переходил с прошивки v.1 на v.2 (вроде максимально возможная - 2.04).

И во всех случаях (подчеркну - во всех), слетал сервисный код - почему-то оставались только 9 цифр.

Техподдержка говорит - привозите на ПЛАТНОЕ восстановление.

Мне кажется, это косяк производителя, который они признавать не хотят. То есть говорят просто - "неудачно прошилось", но сейчас могу показать вот под рукой 3 разных Кинетика (4G, обычный и GIGA), который вот так "криво прошились" - а это уже - статистика.

 

Share this post


Link to post
Share on other sites

  • 0
42 минуты назад, konsvet сказал:

Хочу добавить, как владелец нескольких старых "белых" Кинетиков, в разное время переходил с прошивки v.1 на v.2 (вроде максимально возможная - 2.04).

И во всех случаях (подчеркну - во всех), слетал сервисный код - почему-то оставались только 9 цифр.

Техподдержка говорит - привозите на ПЛАТНОЕ восстановление.

Мне кажется, это косяк производителя, который они признавать не хотят. То есть говорят просто - "неудачно прошилось", но сейчас могу показать вот под рукой 3 разных Кинетика (4G, обычный и GIGA), который вот так "криво прошились" - а это уже - статистика.

 

Что то свою белую GIGA прошивал много раз с v.1 на v.2 и обратно много раз, сервисный код никогда не слетал.

Share this post


Link to post
Share on other sites

  • 0

Я рад за ваши роутеры, тем не менее я решил (частично) проблему, через Uboot, подсоединившись к разъему UART на плате и прописав там servicetag командой.

Теперь сервисный код восстановлен (красных ошибок в логе нет), но очень странная ситуация - обновились лишь часть компонентов, но важная часть - ни в какую не хочет восстанавливаться (типа поддержка NTFS). Задав вопрос в официальную техподдержку - никакого ответа по сути не получил, типа прошивайтесь еще раз, если не поможет - идите за деньги в СЦ. Весело. Чем может быть вызвана такая полупроблема?

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

  • 0

@konsvet скиньте в личку фото роутера (наклейку с сервис-тегом), содержимое printenv, и какой командой восстановили.

Отдельно поясните, что значит часть не хочет восстанавливаться? Все компоненты собираются и ставятся одновременно.

Share this post


Link to post
Share on other sites

  • 0

Объясняю - часть компонентов загрузил, потом стали нужны другие из списка, в ответ дежурное окошко, что нет связи с интернетом, давайте работать офлайн

Хотя интернет есть и отлично раздается. Пробовал кстати получать интернет и по WAN и через 4G - модем, обновляться не хочет.

Повторная перепрошивка и RESET дали тот же результат - "давайте работать офлайн"

Завтра скину

Edited by konsvet

Share this post


Link to post
Share on other sites

  • 0
12 часа назад, konsvet сказал:

нет связи с интернетом, давайте работать офлайн

Да, возможно сервер не принимает запрос, не хватает данных для авторизации.

Share this post


Link to post
Share on other sites

  • 0
В 3/16/2017 в 20:35, konsvet сказал:

Завтра скину

Получили, всё в норме, сходится с данными по базе. Но по логу много ошибок 507 — выбранные компоненты не помещаются. Прошивка старой версии не умеет сообщать об этом, всегда пишет "сервер офлайн". Уберите что-нибудь ненужное.

error_507.jpg

Share this post


Link to post
Share on other sites

  • 0

Это очень странно - в Кинетике памяти 64 Мб, это все сейчас заняло 15 Мб - и больше нет места?

То есть 15 Мб - верхний предел для собранной прошивки?

 

 

Edited by konsvet

Share this post


Link to post
Share on other sites

  • 0
2 минуты назад, konsvet сказал:

Это очень странно - в Кинетике памяти 64 Мб, это все сейчас заняло 15 Мб - и больше нет места?

То есть 15 Мб - верхний предел для собранной прошивки?

Прошивка лежит во флеш-памяти, а у вас её всего 8.

Share this post


Link to post
Share on other sites

  • 0
24 минуты назад, konsvet сказал:

Это очень странно - в Кинетике памяти 64 Мб, это все сейчас заняло 15 Мб - и больше нет места?

То есть 15 Мб - верхний предел для собранной прошивки?

 

 

Для Giga II - да.

На Giga I (белой) - 7 Мбайт.

Share this post


Link to post
Share on other sites

  • 0

Спасибо, почти понятно. Буду продолжать попытки.

Вчера опять перепрошился, прошив заново, reset. Загрузил пару небольших компонентов (ping и поддержку NTFS), и все - при следующей попытке  больше ничего не позволил загрузить.  То есть смог загрузить еще меньше компонентов, чем прошлый раз.

К слову сказать, имеющийся Кинетик 4G (белый) загрузил без проблем почти все компоненты, за исключением ipv6 (тот и правда большой на полмегабайта). Получается, флэш в 4G оказался больше, чем у Giga?

 

Share this post


Link to post
Share on other sites

  • 0
3 часа назад, konsvet сказал:

Спасибо, почти понятно. Буду продолжать попытки.

Вчера опять перепрошился, прошив заново, reset. Загрузил пару небольших компонентов (ping и поддержку NTFS), и все - при следующей попытке  больше ничего не позволил загрузить.  То есть смог загрузить еще меньше компонентов, чем прошлый раз.

К слову сказать, имеющийся Кинетик 4G (белый) загрузил без проблем почти все компоненты, за исключением ipv6 (тот и правда большой на полмегабайта). Получается, флэш в 4G оказался больше, чем у Giga?

 

Потому что там нет компонентов USB, кроме поддержки модемов.

Share this post


Link to post
Share on other sites

  • 0

Спасибо всем подсказавшим.

Два дня пересобирал прошивку в белой "гиге", пришел к выводу:

- максимальный объем (согласно счетчику на странице компонентов) - 5.6 Мб, больше ничего не впихнуть. И это вместе с ядром NDMS. То есть почти 1.4 Мб неизвестно чем заняты.

- с большим трудом впихнул три "тяжелых" компонента вместе: SMB сервер + Transmission + DLNA сервер, остальное вырезал по-максимуму.

Вывод - действительно, объем флэша был достаточен только для 1-й версии прошивки, новая встает ну очень урезанно функционально.

Второй вывод - официальная техподдержка Zyxel свалилась ниже плинтуса - не в состоянии разобраться дать такой простой ответ, а тупо отсылала в обоих случаях в сервис.

Третий вывод - если бы в прошивке была простейшая индикация причин незагрузки компонентов (или отображалась хотя бы во внутреннем логе), таких глупых вопросов бы не возникало.

И последний вывод - причина слетания сервис-кода при смене прошивки 1->2 (Четко по мануалу) осталась неизвестной.

Считаю, тут вина целиком на производителе.

Edited by konsvet

Share this post


Link to post
Share on other sites

  • 0

Да Вы, батенька, софистикой увлекаетесь?! Браво!!!

Скрытый текст

 

1 час назад, konsvet сказал:

Спасибо всем подсказавшим.

Два дня пересобирал прошивку в белой "гиге", пришел к выводу:

- максимальный объем (согласно счетчику на странице компонентов) - 5.6 Мб, больше ничего не впихнуть. И это вместе с ядром NDMS. То есть почти 1.4 Мб неизвестно чем заняты.

- с большим трудом впихнул три "тяжелых" компонента вместе: SMB сервер + Transmission + DLNA сервер, остальное вырезал по-максимуму.

Вывод - действительно, объем флэша был достаточен только для 1-й версии прошивки, новая встает ну очень урезанно функционально.

Второй вывод - официальная техподдержка Zyxel свалилась ниже плинтуса - не в состоянии разобраться дать такой простой ответ, а тупо отсылала в обоих случаях в сервис.

Третий вывод - если бы в прошивке была простейшая индикация причин незагрузки компонентов (или отображалась хотя бы во внутреннем логе), таких глупых вопросов бы не возникало.

И последний вывод - причина слетания сервис-кода при смене прошивки 1->2 (Четко по мануалу) осталась неизвестной.

Считаю, тут вина целиком на производителе.

Изменено пользователем konsvet

 

Share this post


Link to post
Share on other sites

  • 0

Я купил себе SSD на 32 Gb. Ранние версии Windows, читай 95, 98, 2000, xp влезали на это пространство, а новые читай Visa 7, 8, 8.1, 10 ну никак не хотят. Места им мало почему-то. Считаю это виной производителей SSD... 

Share this post


Link to post
Share on other sites

  • 0
3 часа назад, Mamay сказал:

Я купил себе SSD на 32 Gb. Ранние версии Windows, читай 95, 98, 2000, xp влезали на это пространство, а новые читай Visa 7, 8, 8.1, 10 ну никак не хотят. Места им мало почему-то. Считаю это виной производителей SSD... 

Сравнение не много не в точку, так как на планшетах c 32Gb c Windows 10 проблем нет, другой вопрос оставшееся место под доп.приложения. На планшете Win10 на 64Gb с установленными прогами для повседневной в остатке от 58Gb (так как 6Gb резерв восстановления) имеется 29-30Gb (он прошел обновление с Win8 до 10, но не допускал в остатке ниже 26Gb).

Konsvet а зачем ставить на данный роутер такую прогу как Transmission, для проца будут тяжелые будни RT3052 на Giga и RT3050 на простом Keenetic.

Share this post


Link to post
Share on other sites

  • 0
1 час назад, vasek00 сказал:

Konsvet а зачем ставить на данный роутер такую прогу как Transmission, для проца будут тяжелые будни

Белая GIGA работала с transmission хорошо. Но скорость отдачи низкая.

Share this post


Link to post
Share on other sites

  • 0

Извиняюсь, если что-то криво объяснил, я стараюсь не уходить от темы ТС - что слет сервис-кода на ровном месте  - не вина потребителя, и что юзерам "белых" кинетиков перепрошивку с версий 1->2 может и не стоит рекомендовать.

А насчет объема флеш-памяти - я просто констатировал, что max доступная пользователю - 5.6 Мб, а не 7. Как я вижу, данный факт тоже не афишируется.

Само собой, эти архивные железки уже обсуждать можно по остаточному принципу.

 

Share this post


Link to post
Share on other sites

  • 0
44 минуты назад, AndreBA сказал:

Белая GIGA работала с transmission хорошо. Но скорость отдачи низкая.

Насколько помню, это было сделано специально - не нагружать слабый проц, а то про роутинг пакетов процессор забудет :)

Собственно, то же касается и прочих подпрограмм, работающих с USB.

Share this post


Link to post
Share on other sites

  • 0

Добрый день! Не нашел куда написать, эта ветка самая близкая по смыслу.

Есть роутер OMNI II и 4G III rev. A.
OMNI II помер вследствие неправильной эксплуатации ( пока я был в отъезде сестра начудила). У меня на нем работал модуль DECT телефонии + 4G модем. 
Сейчас не могу использовать DECT на 4G III, потому как его USB порт не поддерживает DECT (я купил активный хаб, ноль эмоций, в компонентах на прошивке версии 2.09.A.5.0-2 рне нашел компонента "Беспроводная телефонная станция DECT Plus". Насколько вычитал из форумов, 4G не поддерживает полнофункциональный USB. Закинул на него прошивку от OMNI II, но компонент этот так и не появился... Попробовал через factory сменить сереийник на своем живом 4G III, на тот который у меня на мертвом OMNI II, но это я так понимаю как то заблокировано. Скажите пожалуйста, что б снизить затраты на оборудование, как мне можно сменить серийник на коробке или сделать так что б 4G III поддерживал DECT? Без него прям вообще не торт для частного дома - у меня связь между этажами, входной звонок и телефон через него работали... Спасибо большое заранее!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...