Jump to content
  • 2
Sign in to follow this  
r3L4x

Долгое открытие сайтов при использовании AdGuard DNS

Question

После обновления на драфт стали долго открываться сайты в браузере что с ПК, что с телефона.

Используется фильтр AdGuard DNS, профиль - без рекламы.

Один из сайтов, на котором воспроизводится: http://forum.ru-board.com/

Либо тут: https://vk.com/

Если на 3.3.10 обновление странички происходит мгновенно, то на драфте 3.4 обновляется чуть дольше + крутится ещё некоторое время loading circle.

Если отключить AdGuard DNS и использовать, например, прописанные серверы DoT\DoH (гугл, клаудфлаер и прочие), то всё работает быстро.

Кто-то может проверить?

  • Thanks 1

Share this post


Link to post
Share on other sites

21 answers to this question

Recommended Posts

  • 0

@Le ecureuil на Alpha 6 порядок. Спасибо! А вы 0.0.0.0 убрали в том числе и для dns-proxy rebind-protect strict? У меня на нём сайты нормально открываются, хотя я предполагал, что этот режим включает более расширенный список блокировки.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 1

@Le ecureuil на всякий случай проинформирую: ваше предположение оказалось верным.

Выполнил:

no dns-proxy rebind-protect
system configuration save
system reboot

И теперь загрузка сайтов вновь быстрая.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
3 минуты назад, r3L4x сказал:

Один из сайтов, на котором воспроизводится: http://forum.ru-board.com/

На руборде с начала месяца просрочен сертификат. Сайт может с затыком загружаться. Зависит от браузера. Сначала пробует по https, когда не получается, если разрешено в браузере лезет по http.

C vk не знаю.

Share this post


Link to post
Share on other sites
  • 0

Про сертификат я в курсе.

На 3.3.10 нет такого эффекта.

Без AdGuard DNS, но на 3.4 - тоже.

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, r3L4x сказал:

Без AdGuard DNS, но на 3.4 - тоже

А проверьте в Диагностике Адгуард в альфе корректно выходит на профиль без рекламы? Или может быть что-то там перепуталось и он через семейный лезет. По моим заметкам семейный профиль работает заметно медленнее.

Share this post


Link to post
Share on other sites
  • 0

@keenet07 там фигурируют 2 DNS от AdGuard: 176.103.130.130 и 176.103.130.131. Вроде так и должно быть.

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, r3L4x сказал:

@keenet07 там фигурируют 2 DNS от AdGuard: 176.103.130.130 и 176.103.130.131. Вроде так и должно быть.

Да. Всё верно. Видимо проблема, если она есть, в чем-то другом.

И ещё на всякий случай проверьтесь на https://www.dnsleaktest.com/ в extended test.

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, keenet07 said:

Да. Всё верно. Видимо проблема, если она есть, в чем-то другом.

Иногда, кстати, появляются и *.132, *.134, но достаточно быстро пропадают.

В диагностике, вообще, много всех DNS мелькают, в том числе CloudFlare, Google и прочие. Причём они там постоянно присутствуют. Только AdGuard там никогда не бывает.

8 minutes ago, keenet07 said:

И ещё на всякий случай проверьтесь на https://www.dnsleaktest.com/ в extended test.

У меня тут вообще показало мой VPS на Vultr и ISP - Choopa, LLC. Там wireguard поднят. Но он сейчас выключен.

Edited by r3L4x

Share this post


Link to post
Share on other sites
  • 0
Только что, r3L4x сказал:

Иногда, кстати, появляются и *.132, *.134, но достаточно быстро пропадают.

В диагностике, вообще, много всех DNS мелькают, в том числе CloudFlare, Google и прочие. Причём они там постоянно присутствуют. Только AdGuard там никогда не бывает.

У меня тут вообще показало мой VPS на Vultr и ISP - Choopa, LLC.

Это плохо. Такого быть не должно. Утечка DNS. Должна быть только Choopa когда всё корректно.

На 3.3 у вас так же было?

Share this post


Link to post
Share on other sites
  • 0

Я, видимо, вас неправильно понял. На DNS leak test показало один сервер - 95.179.191.247.vultr.com.

А вот в диагностике на роутере постоянно мелькает масса DNS-серверов.

Share this post


Link to post
Share on other sites
  • 0
3 минуты назад, r3L4x сказал:

В диагностике, вообще, много всех DNS мелькают, в том числе CloudFlare, Google и прочие. Причём они там постоянно присутствуют. Только AdGuard там никогда не бывает.

Те что мелькают это на 53 порт? Это нормально. Они нужны для работы самого фильтра.

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, keenet07 said:

Те что мелькают это на 53 порт?

И 53, и 443, и 853. У меня прописаны DoT/DoH из статьи отсюда: 

 

То, что они все мелькают в диагностике, хоть включён фильтр AdGuard - это нормально? Так было и на 3.3.х и вообще давно уже.

Share this post


Link to post
Share on other sites
  • 0
8 минут назад, r3L4x сказал:

И 53, и 443, и 853. У меня прописаны DoT/DoH из статьи отсюда: 

То, что они все мелькают в диагностике, хоть включён фильтр AdGuard - это нормально? Так было и на 3.3.х и вообще давно уже.

При включенном фильтре Адгуард там должны быть только по-моему 6 адресов на 53 порт. Это всё bootstrap. И только выбранные в самом фильтре адгуарда. Два простых и два семейных (если задействован).

Никаких других из прописанных в DOT/DOH туда проникать вроде не должно. 

Edited by keenet07

Share this post


Link to post
Share on other sites
  • 0

На 3.4 вообще что-то странное в плане DNS.

Если настроить всё, как тут: 

 

То не проходит проверку 1.1.1.1 \ 1.0.0.1 и AdGuardDNS. Типо к ним нет коннекта и они выключены. На 3.3.10 всё работает исправно.

Share this post


Link to post
Share on other sites
  • 0

@Le ecureuil какие-то дополнительные данные от меня требуются, помимо скрытого поста с селф-тестами? Или может в поддержку лучше запрос, чем тут?

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

3.4 Alpha 5

Проблема на месте. Особенно заметно, когда используется 3.3.12, обновляем страничку ру-борда, далее апдейт до 3.4 и снова обновляем страничку. Если в первом случае всё происходит мгновенно, то во втором loading circle крутится секунд 5.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Понятно.

Многие сервисы фильтрации DNS отправляют 0.0.0.0 в виде заглушек на рекламные домены.

Уберем 0.0.0.0 из списков dns rebind.

  • Thanks 2

Share this post


Link to post
Share on other sites
  • 0
В 07.03.2020 в 19:12, r3L4x сказал:

@Le ecureuil на Alpha 6 порядок. Спасибо! А вы 0.0.0.0 убрали в том числе и для dns-proxy rebind-protect strict? У меня на нём сайты нормально открываются, хотя я предполагал, что этот режим включает более расширенный список блокировки.

Да, убрали отовсюду. Все равно 0.0.0.0 - это невалидный адрес, и злоумышленик врядли сможет его использовать в своих целях - ваши устройства не пойдут на него соединяться.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...