Jump to content
yrzorg

Dropbear и авторизация по ключу

Recommended Posts

Собственно вопрос - возможно ли отключение пароля и авторизация по ssh-ключу в версии dropbear для keenopt?

В entware добавлялись ключи запуска -s -g, а в keenopt как? Скрип запуска в одном месте, конфиг в другом ... Не соображу, короче

Share this post


Link to post
Share on other sites

А что там такого сложного? Запуск dropbear находится в /opt/etc/init.d/S01dropbear, то, что вы называете конфигом, лежит в /opt/etc/default/dropbear, но в нем можно только поменять номер порта и включить/выключить загрузку при старте, особо конфигом это не назовешь. Прописывайте свои ключи в S01dropbear, больше этого нигде не сделать...

Share this post


Link to post
Share on other sites

1. закинул публичный ключ в /opt/etc/dropbear/authorized_keys

2. в параметрах запуска dropbear указал -s

3. прекрасно заходил по ssh

4. ....

5. поставил openvpn

6. перестал заходить по ssh, вообще порта не видно, видимо, сервис не запущен. ЧЯДНТ?

7. как теперь вернуть доступ к устройству через ssh без перезагрузки?

Edited by linuxmaster
Очередной пункт..

Share this post


Link to post
Share on other sites

Все верно. Только что у себя настроил так же. Только добавил публичный ключ от сгенерированной на телефоне в ssh клиенте пары в файл /opt/etc/dropbear/authorized_keys и все, после перезапуска dropbear меня пускает без пароля.



Share this post


Link to post
Share on other sites

А кто-нибудь знает как отключить вход по логину-паролю для dropbear? В моей версии папки /opt/etc/default/ не существует, и /opt/etc/config/ тоже...

v2.09(AAGK.7)A3

Edited by Dzmitry

Share this post


Link to post
Share on other sites

~ # dropbear --help
Invalid option --
Dropbear server v2016.74 https://matt.ucc.asn.au/dropbear/dropbear.html
Usage: dropbear [options]
-b bannerfile   Display the contents of bannerfile before user login
                (default: none)
-r keyfile  Specify hostkeys (repeatable)
                defaults:
                rsa /opt/etc/dropbear/dropbear_rsa_host_key
                ecdsa /opt/etc/dropbear/dropbear_ecdsa_host_key
-R              Create hostkeys as required
-F              Don't fork into background
-E              Log to stderr rather than syslog
-w              Disallow root logins
-s              Disable password logins
-g              Disable password logins for root
-B              Allow blank password logins
-j              Disable local port forwarding
-k              Disable remote port forwarding
-a              Allow connections to forwarded ports from any host
-p [address:]port
                Listen on specified tcp port (and optionally address),
                up to 10 can be specified
                (default port is 22 if none specified)
-P PidFile      Create pid file PidFile
                (default /opt/var/run/dropbear.pid)
-W <receive_window_buffer> (default 24576, larger may be faster, max 1MB)
-K <keepalive>  (0 is never, default 0, in seconds)
-I <idle_timeout>  (0 is never, default 0, in seconds)
-V    Version

Перевод нужен?

  • Thanks 1

Share this post


Link to post
Share on other sites

Перевод не нужен, спасибо.

НО подтскажите, пожалуйста, где именно можно указать опцию, чтобы после перезагрузки модема dropbear стартовал с опцией -s?

Share this post


Link to post
Share on other sites

Сам отвечаю на свой вопрос:

За автозапуск отвечает скрипт /opt/etc/init.d/rc.unslung - во всяком случае, если верить написанному в нем, - который производит start каждого скрипта, который находится в /opt/etc/init.d/

Самый простой способ - это подправить уже имеющийся скрипт запуска, т. е. в данном конкретном случае, в /opt/etc/init.d/SXXdropbear (где ХХ - две цифры исходя из конкретной конфигурации) нужно исправить функцию start() на

$DROPBEAR -s -p $PORT -P $PIDFILE

после перезапуска, dropbear перестанет разрешать вход по паролю, так что рекомендую делать это внимательно и осторожно!

 

Share this post


Link to post
Share on other sites

Подскажите пожалуйста, пытаюсь добавить на сервер dropbear свой rsa-ключ созданный в openssh. При выполнении команды ssh-copy-id root@server ключ копируется в /root/.ssh/authorized_keys, но подключится не получается. Пробовал его вручную переместить по пути указанному выше - тоже фейл. Как это победить? Может его надо как то сконвертировать? Хотя вроде говорят, что dropbear и openssh совместимы.

 

UPD: Простите вопрос снимается..

cd /opt/etc/dropbear/
chmod 600 authorized_keys

После рестарта все работает.

Edited by Sergey Sh.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...