Jump to content
4e.Guevara

Спонтанные ребуты после обновления на 2.16.D.1.0-1

Recommended Posts

В общем, за несколько дней после обновы на 2.16.D.1.0-1 словил с десяток спонтанных ребутов на Giga II. В журнале чисто, словить закономерность не могу(((

Edited by 4e.Guevara
  • Need more info 2

Share this post


Link to post
Share on other sites

Надеюсь вы сами понимаете что это бесполезный багрепорт без self-test и всё такое? 

  • Upvote 1
  • Y'r wrong 2

Share this post


Link to post
Share on other sites
10 часов назад, 4e.Guevara сказал:

после обновы на 2.16.D.1.0-1 словил с десяток спонтанных ребутов на Giga II

У меня всё нормально.

Share this post


Link to post
Share on other sites
1 час назад, Rootdiv сказал:

У меня всё нормально.

Та же Giga2 2.16.D.1.0-1. Ни единого разрыва... 

Share this post


Link to post
Share on other sites
16 часов назад, Mamay сказал:

Надеюсь вы сами понимаете что это бесполезный багрепорт без self-test и всё такое? 

Сорри, запустил. После отвала скину сюда. Думаю, что завтра будет ибо эти ребуты случаются почти каждый день

Share this post


Link to post
Share on other sites
2 часа назад, 4e.Guevara сказал:

Ну вот опять упал. После падения режим отладки выключился, поэтому опять включил, подождал минуту и сохранил. Плюс системный журнал

Рекомендую вам скрыть это сообщение:

self-test и логи могут содержать непубличную информацию, потому их не стоит прикреплять к постам бездумно. Однако, слать селф-тесты в личку абсолютно неправильно, поскольку это усложняет координацию между разработчиками и отрывает диагностику от темы с проблемой.

Потому следует делать так:

  • Пишете пост или создаете тему с описанием проблемы.
  • Сразу после этого в этой же теме создаете сообщение с приложенным self-test, логами и прочей отладкой. В это же сообщение добавляете ссылку на предыдущее, чтобы не приходилось искать описание.
  • Скрываете сообщение с отладкой. Эта функция доступна всем юзерам. Выбираете в меню поста (спасибо @KorDen?

    firefox_2016-08-21_10-30-52.png

После этого эти сообщения станут доступны только администрации, а все пользователи не будут иметь к ней доступ.

Share this post


Link to post
Share on other sites
13 часа назад, krass сказал:

После этого эти сообщения станут доступны только администрации, а все пользователи не будут иметь к ней доступ.

Спасибо, скрыл. Только теперь и сам не вижу это сообщение. Я так понимаю, что если понадобится еще раз логи, то просто заливаю их и так же скрываю сообщение?

Share this post


Link to post
Share on other sites
8 минут назад, 4e.Guevara сказал:

Спасибо, скрыл. Только теперь и сам не вижу это сообщение. Я так понимаю, что если понадобится еще раз логи, то просто заливаю их и так же скрываю сообщение?

Ну если свежие логи - то да) . 

  • Upvote 1

Share this post


Link to post
Share on other sites

Пока ничего внятного не видно. Может быть даже аппаратной проблемой.

Share this post


Link to post
Share on other sites
29 минут назад, Le ecureuil сказал:

Пока ничего внятного не видно. Может быть даже аппаратной проблемой.

Какая же аппаратная проблема, если на предыдущей версии 2,16 таких проблем нету и на 2,11, на которой я сидел очень долго, нету??? Я даже специально откатывал прошивку и сидел на ней два дня - ни одного ребута. Вообще и близко не аппаратная 

Share this post


Link to post
Share on other sites

Без дампа с uart ничего сказать не могу - в логах и self-test нет никаких подсказок.

Share this post


Link to post
Share on other sites
2 часа назад, Le ecureuil сказал:

Без дампа с uart ничего сказать не могу - в логах и self-test нет никаких подсказок.

Ясно... Откатываюсь на 2.16.D.1.0-0

Share this post


Link to post
Share on other sites

Я таки не ушел с прошивки и сижу ловлю этот баг. Вот, что сегодня было в журнале, может поможет. Ниже прикреплю полный лог - день каким то образом без ребутов проработал. Я вот грешу, что может кто то мне ложит роутер, пытаясь постоянно к нему подключиться?? В логах вижу пробы по фтп. Может как то предыдущая прощивка была более стойкая, или я не знаю... Пока заблочу данный IP в фаере и еще посмотрю

Буфер обмена01.jpg

Share this post


Link to post
Share on other sites
27 минут назад, Le ecureuil сказал:

Еще компонент cloudcontrol2 попробуйте удалить.

Удалить или отключить? В компонентах пишет, что обязательный компонент

Буфер обмена01.jpg

Share this post


Link to post
Share on other sites
4 минуты назад, 4e.Guevara сказал:

В компонентах пишет, что обязательный компонент

У вас, наверное,  SSTP VPN-сервер установлен. Без него доступен для удаления:

Скрытый текст

components.png.19bfd8740c3a0c12a254b47fd6447391.png

 

Share this post


Link to post
Share on other sites
13 часа назад, 4e.Guevara сказал:

Вот, что сегодня было в журнале, может поможет.

Если вы про CoAP, то вряд ли это причина проблемы. Протокол CoAP создавался для устройств с ограниченными ресурсами, например для беспроводных датчиков.

Посматривайте в "Диагностика -> Активные соединения", есть ли там коннекты на порт udp/5683. Этот порт используется этим протоколом.

Хотя, похоже, что и облачная служба его использует, т.к. у меня в коннектах висит вот такое соединение:

Скрытый текст

CoAP_port_connect.thumb.png.2cdec1bcf7de81d6fd576b8fd7a46372.png

И в обратную сторону есть коннект с этого порта:

Скрытый текст

connect_to_cloud.thumb.png.86bed53d888469b68c53589f7331e1b3.png

 

Share this post


Link to post
Share on other sites
37 минут назад, Albram сказал:

У вас, наверное,  SSTP VPN-сервер установлен. Без него доступен для удаления:

Да, так и есть, не досмотрелся про зависимости. Ну пока просто отключил облачную службу, погляжу

Share this post


Link to post
Share on other sites
6 часов назад, Albram сказал:

Если вы про CoAP, то вряд ли это причина проблемы. Протокол CoAP создавался для устройств с ограниченными ресурсами, например для беспроводных датчиков.

То, для чего он создавался, и совместимость с облаком сейчас - две большие разницы, как говорят в Одессе.

Варианта два - отрезать новое облако, как в 2.11 (я склоняюсь к нему), или перенести из 3.4. Если автор реализации не соизволит и не перенесет, я это все отрежу, потому что при разработке облака на старье никто не рассчитывает, только на актуальные версии.

  • Thanks 1

Share this post


Link to post
Share on other sites
2 часа назад, Le ecureuil сказал:

Варианта два - отрезать новое облако, как в 2.11 (я склоняюсь к нему), или перенести из 3.4.

У меня оба облачных клиента включены в настройках, и старый, и новый (видно на предыдущем моём скриншоте коннекты на обе службы), и проблем нет, оба работают.

И при недавнем падении канала у провайдера сообщение из приложения прислал только новый. Будет жаль, если новый выпилите, а старый не будет информировать в подобных случаях.

Share this post


Link to post
Share on other sites

У автора может быть что-то еще, но в любом случае без uart-лога это все бесполезно.

Share this post


Link to post
Share on other sites

Да, я тоже очень привык к новому облачному клиенту - очень удобно. Вот сейчас отключил и страдаю))) 

47 минут назад, Le ecureuil сказал:

У автора может быть что-то еще, но в любом случае без uart-лога это все бесполезно.

Немного почитал про этот лог и так понимаю, что снять его в домашних условиях у меня не получится?

Share this post


Link to post
Share on other sites

Я тоже использую новый клиент, будет жалко если его выпилят.

Share this post


Link to post
Share on other sites
10 часов назад, 4e.Guevara сказал:

Да, я тоже очень привык к новому облачному клиенту - очень удобно. Вот сейчас отключил и страдаю))) 

Немного почитал про этот лог и так понимаю, что снять его в домашних условиях у меня не получится?

Если кратко, то да. Разве что попробовать внешний syslog и на него половить.

Share this post


Link to post
Share on other sites
16 часов назад, Albram сказал:

У меня оба облачных клиента включены в настройках, и старый, и новый (видно на предыдущем моём скриншоте коннекты на обе службы), и проблем нет, оба работают.

И при недавнем падении канала у провайдера сообщение из приложения прислал только новый. Будет жаль, если новый выпилите, а старый не будет информировать в подобных случаях.

@Le ecureuil У меня тоже оба нормально работают. И будет действительно жаль если новый выпилите.

Share this post


Link to post
Share on other sites

У эта версия стоит на Ultra с момента её появления, оба облака включены и работают. Ни одного ребута.

Share this post


Link to post
Share on other sites
22 часа назад, Le ecureuil сказал:

У автора может быть что-то еще, но в любом случае без uart-лога это все бесполезно.

@Le ecureuil А на 1810 uart тут или где?

765874182_.png.664f69de9378c80cb2d4fac2af50fa37.png

Чета у меня он на 5й альфе тоже начал ребутиться, надо лог поснимать :)

  • Thanks 1

Share this post


Link to post
Share on other sites
16 минут назад, r13 сказал:

А на 1810 uart тут или где?

► 3V3 TX RXGND

  • Thanks 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...