Jump to content
Le ecureuil

K3, VOX, DSL, LTE на 2.16 - в канале draft

Recommended Posts

1 час назад, dmotovilov сказал:

ДВС. Формат startup-config отличается между 2.11 и 2.16?

Немного. В 2.16 есть добавления. Но лучше со сбросом после обновления все делать, через зажатие Reset на 10 секунд.

Share this post


Link to post
Share on other sites
8 минут назад, Le ecureuil сказал:

Немного. В 2.16 есть добавления. Но лучше со сбросом после обновления все делать, через зажатие Reset на 10 секунд.

Вроде обновился и настройки подхватил.

Share this post


Link to post
Share on other sites

Заметил такой момент: на 2.11 при подключенном по юсб жестком диске горел соответствующий индикатор, на 2.16 - индикатор не загорается. LTE

Edited by dmotovilov

Share this post


Link to post
Share on other sites
2 часа назад, dmotovilov сказал:

да, про него

Почитал код, есть ощущение где может быть неприятность. Постараюсь поправить к следующей сборке.

Share this post


Link to post
Share on other sites
7 часов назад, dmotovilov сказал:

А в веб интерфейсе, в настройках wifi-сети кнопку "включить wps" убрали в 2.16? или перенесли куда то? найти не могу

Вы про эту кнопку?

Скрытый текст

857354251__2021-01-13_184829.png.379c77d2b5893fa0ff677b1ebc7e1377.png

 

Share this post


Link to post
Share on other sites

Нет, это для клиентского подключения к провайдеру по wifi. Я про подключение к сети раутера, в 2.16, сейчас, только по пину через wps можно подключиться, в 2.11 была возможность без пина, нажимаешь кнопку в вебморде, а на клиентском устройстве просто подключаешся по wps. Если из my keenetic этот режим включать, то в логах:

Янв 13 18:59:51
ndm
Network::Interface::Rtx::Wps: "WifiMaster0/AccessPoint0": WPS enabled.
Янв 13 18:59:51
ndm
Network::Interface::Rtx::Wps: "WifiMaster0/AccessPoint0": an auto self PIN mode disabled.
Янв 13 18:59:51
ndm
Network::Interface::Rtx::Wps: "WifiMaster0/AccessPoint0": WPS PBC session started.

Вроде в прошивке возможность осталась, просто в вебе кнопки нет. Да, и на хардовые кнопки эту функцию можно повесить.

Edited by dmotovilov
дополнение

Share this post


Link to post
Share on other sites
58 минут назад, dmotovilov сказал:

Нет, это для клиентского подключения к провайдеру по wifi. Я про подключение к сети раутера, в 2.16, сейчас, только по пину через wps можно подключиться, в 2.11 была возможность без пина, нажимаешь кнопку в вебморде, а на клиентском устройстве просто подключаешся по wps. Если из my keenetic этот режим включать, то в логах:


Янв 13 18:59:51
ndm
Network::Interface::Rtx::Wps: "WifiMaster0/AccessPoint0": WPS enabled.
Янв 13 18:59:51
ndm
Network::Interface::Rtx::Wps: "WifiMaster0/AccessPoint0": an auto self PIN mode disabled.
Янв 13 18:59:51
ndm
Network::Interface::Rtx::Wps: "WifiMaster0/AccessPoint0": WPS PBC session started.

Вроде в прошивке возможность осталась, просто в вебе кнопки нет. Да, и на хардовые кнопки эту функцию можно повесить.

Тогда скорее всего здесь:

Скрытый текст

2139327112__872.thumb.png.ebc4eb483b09e3bef66612b6a8ee227e.png

 

Share this post


Link to post
Share on other sites
В 12.01.2021 в 20:49, dmotovilov сказал:

Заметил такой момент: на 2.11 при подключенном по юсб жестком диске горел соответствующий индикатор, на 2.16 - индикатор не загорается. LTE

Проверьте на 2.16.D.10.0-0

Share this post


Link to post
Share on other sites

Камрады, привет! Имею в одной конторе Keenetic III.

Инфа show version: 

hw_version: 10430000-B

hw_id: in_rb

Прошивка официальная родная 2.08. Понадобился L2TP-сервер (превед Билайну с его обрезкой pptp), которого нет в 2.08, но который есть в 2.16. Читаю за обновление до 2.16 и вижу, что требуется обязательный сброс настроек до заводских перед(после) обновления. Проблема в том, что роутер на другом конце города и обновление хочу сделать удаленно поздно вечером. Интернет на роутере через pppoe от РТК, т.е. удаленный сброс на заводские не прокатит - я попросту обрежу себе кислород. 

И в связи с этим вопрос: сброс на заводские для обновления на 2.16 точно обязателен для Кинетик III? Мне все равно придется потом конфиг накатить старый, так как слишком много там настроек и заново с нуля их настраивать как-то трудоемко. 

Я почему спрашиваю, обновлял Кинетик лайт II, лайт III до 2.16 (с 2.07) так же удаленно в других конторах, там требований про заводские не фигурировало и все обновилось на ура и работает с прежними конфигами. Закинул только прошивку, перегрузил и все ок.

Почему такая дискриминация с заводскими по половому признаку для Кинетик III ? 

Share this post


Link to post
Share on other sites
4 часа назад, light_gray сказал:

Камрады, привет! Имею в одной конторе Keenetic III.

Инфа show version: 

hw_version: 10430000-B

hw_id: in_rb

Прошивка официальная родная 2.08. Понадобился L2TP-сервер (превед Билайну с его обрезкой pptp), которого нет в 2.08, но который есть в 2.16. Читаю за обновление до 2.16 и вижу, что требуется обязательный сброс настроек до заводских перед(после) обновления. Проблема в том, что роутер на другом конце города и обновление хочу сделать удаленно поздно вечером. Интернет на роутере через pppoe от РТК, т.е. удаленный сброс на заводские не прокатит - я попросту обрежу себе кислород. 

И в связи с этим вопрос: сброс на заводские для обновления на 2.16 точно обязателен для Кинетик III? Мне все равно придется потом конфиг накатить старый, так как слишком много там настроек и заново с нуля их настраивать как-то трудоемко. 

Я почему спрашиваю, обновлял Кинетик лайт II, лайт III до 2.16 (с 2.07) так же удаленно в других конторах, там требований про заводские не фигурировало и все обновилось на ура и работает с прежними конфигами. Закинул только прошивку, перегрузил и все ок.

Почему такая дискриминация с заводскими по половому признаку для Кинетик III ? 

Он не обязателен конечно, но будьте готовы к сюрпризам, может что-то пойти не так.

Если уже есть опыт обновления на 2.16, то тут ничем не отличается (только телефонии встроенной больше не будет).

Share this post


Link to post
Share on other sites

Здравствуйте уважаемые товарищи! Спасибо за ваш труд. 

Имею keenetic dsl, жажду получить безшовный роумнг (есть и другие утсройства), роуминг добавился в прошивке начиная с версии 13 и 15. Подскажи пожалуйста, будет ли доступна эта опция для моего аппарата если обновить?

Share this post


Link to post
Share on other sites

  

On 2/15/2021 at 2:04 PM, Le ecureuil said:

Нет, недоступна.

Здравствуйте!

Похожий вопрос для VOX. Ответ "нет" для всех аппаратов в ветке или есть различия? --- Хочу подключить VOX к Speedster. Будет ли бесшовный роуминг (поддержка стандартов 802.11r/k/v)?

И вопрос по работе USB у VOX в режиме ретранслятора (в каком-нибудь из подключений усилитель/точка доступа). Будет ли доступен USB диск подключенный к VOX с главного контроллера (Speedster)? (например, для DLNA)

Share this post


Link to post
Share on other sites
1 час назад, RomanL сказал:

  

Здравствуйте!

Похожий вопрос для VOX. Ответ "нет" для всех аппаратов в ветке или есть различия? --- Хочу подключить VOX к Speedster. Будет ли бесшовный роуминг (поддержка стандартов 802.11r/k/v)?

И вопрос по работе USB у VOX в режиме ретранслятора (в каком-нибудь из подключений усилитель/точка доступа). Будет ли доступен USB диск подключенный к VOX с главного контроллера (Speedster)? (например, для DLNA)

Для всех у кого WiFi RT5392/RT5592/RT3593:  https://bit.ly/keenetic-routers

Share this post


Link to post
Share on other sites

Здравствуйте. Подскажите пожалуйста, будет ли в 2.16 CloudFlare DNS в качестве компонента? Когда-то же был Norton DNS в качестве компонента, но потом компонент исчез по понятным причинам. Может CloudFlare займет вакантное место...

Edited by ipkirill21x

Share this post


Link to post
Share on other sites
3 часа назад, ipkirill21x сказал:

Здравствуйте. Подскажите пожалуйста, будет ли в 2.16 CloudFlare DNS в качестве компонента? Когда-то же был Norton DNS в качестве компонента, но потом компонент исчез по понятным причинам. Может CloudFlare займет вакантное место...

Возможно.

Share this post


Link to post
Share on other sites

Здравствуйте! Можно ли в будущем добавить команду включения заголовков X-Real-IP и X-Forwarded-For? 

ip http proxy {name} x-real-ip

Надеюсь, это поможет решить проблемы, связанные с ошибками авторизации на некоторых ресурсах при работе через облако Keendns, в частности в Home assistant. Начиная с версий 3.5 данная возможность появилась, было бы здорово увидеть ее и в 2.16.

Share this post


Link to post
Share on other sites
1 час назад, Alexey Shlyakhov сказал:

Здравствуйте! Можно ли в будущем добавить команду включения заголовков X-Real-IP и X-Forwarded-For? 

ip http proxy {name} x-real-ip

Надеюсь, это поможет решить проблемы, связанные с ошибками авторизации на некоторых ресурсах при работе через облако Keendns, в частности в Home assistant. Начиная с версий 3.5 данная возможность появилась, было бы здорово увидеть ее и в 2.16.

Добавлю.

  • Upvote 1

Share this post


Link to post
Share on other sites

Обнаружил проблему в прошивке 2.16.D.11.0-0 - через дня два работы роутера, загрузка ЦП вырастает до ~53% и ниже не падает, а через 3-4 дня, загрузка ЦП выходит на 100% и так постоянно и висит. Пробовал сделать сброс через зажатие кнопки сброс на роутере в течение 20 сек, но это не помогло. До этого стояла прошивка 2.11.D... такой проблемы не было точно. 

Порылся в интернете, нашел похожие ситуации, проблема возможна из-за:

1.  опроса подключенных устройств show/ip/hotpost, а именно опроса встроенного коммутатора (таблица mac и т.п.);

2. ошибки в работе сервиса upnp.

Подскажите, пожалуйста, как можно выявить в чем реальная проблема и как можно посмотреть процессы, которые грузят в настоящий момент процессор?

Если нужно, могу отправить self-test - в открытом доступе выкладывать не хочу.

Keenetic LTE

Версия ОС 2.16.D.11.0-0

Share this post


Link to post
Share on other sites
14 минуты назад, Alexey Shlyakhov сказал:

Обнаружил проблему в прошивке 2.16.D.11.0-0 - через дня два работы роутера, загрузка ЦП вырастает до ~53% и ниже не падает, а через 3-4 дня, загрузка ЦП выходит на 100% и так постоянно и висит. Пробовал сделать сброс через зажатие кнопки сброс на роутере в течение 20 сек, но это не помогло. До этого стояла прошивка 2.11.D... такой проблемы не было точно. 

Порылся в интернете, нашел похожие ситуации, проблема возможна из-за:

1.  опроса подключенных устройств show/ip/hotpost, а именно опроса встроенного коммутатора (таблица mac и т.п.);

2. ошибки в работе сервиса upnp.

Подскажите, пожалуйста, как можно выявить в чем реальная проблема и как можно посмотреть процессы, которые грузят в настоящий момент процессор?

Если нужно, могу отправить self-test - в открытом доступе выкладывать не хочу.

Keenetic LTE

Версия ОС 2.16.D.11.0-0

Нужен вывод из cli
>show threads
и 
>show processlist
в момент, когда все тормозит.

Share this post


Link to post
Share on other sites
37 minutes ago, Le ecureuil said:

Нужен вывод из cli
>show threads
и 
>show processlist
в момент, когда все тормозит.

Странно, но при постоянной загрузке ЦП на 100% (она ниже не падает) особо ничего и не тормозит, по крайней мере в глаза не бросается явно, может немного web-интерфейс роутера.

Память 35% (44/128 Мбайт). Файлы в приложении.

show_processes.txt show_threads.txt

  • Thanks 1

Share this post


Link to post
Share on other sites

 

Имеется 2 аппарата ZK Viva (MT7620).
На одном 2.16.D.3.0-5, на втором 2.16.D.11.0-0.
На обоих был настроен PPTP-сервер. Windows-клиенты использует их как основные шлюзы.
Обнаружилось, что с клиентов часть сайтов не открывается ни одним браузером (например yandex.ru), но в то же время они пингуются.
Один из аппаратов был прошит в 2.11.D.9.0-1 без изменения настроек.
На клиентах, к нему подключенных, проблема с доступом к сайтам исчезла.
Это проблема PPTP-сервера в 2.16 или требуется выполнить какие-то допнастройки?

Share this post


Link to post
Share on other sites

Получилось попробовать PPTP-сервер на Omni с прошивкой 3.6.3
страница yandex.ru не открывается, но пингуется (((

Edited by sb73

Share this post


Link to post
Share on other sites
5 минут назад, sb73 сказал:

Получилось попробовать PPTP-сервер на Omni с прошивкой 3.6.3
страница yandex.ru не открывается, но пингуется (((

А если уменьшить на сервере mtu до 1300?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...