Jump to content
  • 0
rustrict

Проблемы с определением USB-флешки

Question

@ndm @sergeyk, 3.4 Alpha 12. После перехода с 3.3 на 3.4 моя флешка с Entware (ext4) определяется с ошибками:

Мар 29 14:09:40 kernel usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd ndm rqt 128 rq 6 len 2 ret -145
Мар 29 14:09:41 kernel usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd ndm rqt 128 rq 6 len 2 ret -145
Мар 29 14:09:41 ndm Usb::Device: system failed [0xcffd00b0], operation timed out.
Мар 29 14:09:41 ndm Usb::Device: failed to get a string descriptor header.
Мар 29 14:09:41 ndm Usb::Device: unable to read available language IDs.

Ранее такого никогда не было.

Перезагрузки при этом не помогают. А вот если физически переподключить, тогда этих ошибок нет.

Выводы show usb:

Скрытый текст

 

До переподключения


usb: 
 device: 
       name: Media0
       DEVICE: /devices/platform/xhci-mtk/usb1/1-2/1-2:1.0
      DEVPATH: /devices/platform/xhci-mtk/usb1/1-2/1-2:1.0/host0/target0:0:0/0:0:0:0/block/sda
 manufacturer: General
      product: USB Flash Disk
       serial: 04KNU9GZ6QY8N5VN
    subsystem: media
         port: 2
power-control: yes

и после


usb: 
 device: 
       name: Media0
       DEVICE: /devices/platform/xhci-mtk/usb1/1-2/1-2:1.0
      DEVPATH: /devices/platform/xhci-mtk/usb1/1-2/1-2:1.0/host0/target0:0:0/0:0:0:0/block/sda
 manufacturer: General
      product: USB Flash Disk
       serial: 04KNU9GZ6QY8N5VN
    subsystem: media
         port: 2
power-control: yes
  usb-version: 2.00

 

Есть ещё странность с отмонтированием: кнопку "Отключить" нажал, но лампочка не погасла до тех пор, пока не извлёк. И при этом ругается в лог на "unsafely unplugged without ejecting":

Мар 29 14:17:15 ndm Opkg::Manager: disk unmounted.
Мар 29 14:17:15 ndm Core::FileSystem::Repository: "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:" unmounted.
Мар 29 14:17:29 kernel usb 1-2: USB disconnect, device number 2
Мар 29 14:17:29 kernel sd 0:0:0:0: [sda] Synchronizing SCSI cache
Мар 29 14:17:29 kernel sd 0:0:0:0: [sda] Synchronize Cache(10) failed: Result: hostbyte=0x01 driverbyte=0x00
<...>
Мар 29 14:17:29 ndm Storage::Manager: "Media0": a media was unsafely unplugged without ejecting.
Мар 29 14:17:29 ndm Storage::Manager: removed "Media0", port 2.

Селф-тесты постом ниже.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

@rustrict

[I] Mar 29 14:17:15 dropbear[677]: Early exit: Terminated by signal
[I] Mar 29 14:17:15 ndm: Opkg::Manager: disk unmounted.
[I] Mar 29 14:17:15 ndm: Core::FileSystem::Repository: "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:" unmounted.
[I] Mar 29 14:17:29 kernel: usb 1-2: USB disconnect, device number 2
[W] Mar 29 14:17:29 kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
[I] Mar 29 14:17:29 kernel: sd 0:0:0:0: [sda] Synchronize Cache(10) failed: Result: hostbyte=0x01 driverbyte=0x00
[I] Mar 29 14:17:29 ndm: Core::FileSystem::Repository: unregistering "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:" filesystem...
[I] Mar 29 14:17:29 ndm: Storage::Manager: "Media0": unregistered partition "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:".
[I] Mar 29 14:17:29 ndm: Storage::Manager: "Media0": removed partition "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:".
[C] Mar 29 14:17:29 ndm: Storage::Manager: "Media0": a media was unsafely unplugged without ejecting.
[I] Mar 29 14:17:29 ndm: Storage::Manager: removed "Media0", port 2.

Попробуйте подождать подольше (возможно даже после отмонтирования раздела остаются работающие приложения, запущенные с USB-диска). Сообщение

[I] Mar 29 14:17:29 kernel: usb 1-2: USB disconnect, device number 2
[W] Mar 29 14:17:29 kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
[I] Mar 29 14:17:29 kernel: sd 0:0:0:0: [sda] Synchronize Cache(10) failed: Result: hostbyte=0x01 driverbyte=0x00

означает, что диск был физически извлечен из порта до сброса кеша SCSI-устройства.

Share this post


Link to post
Share on other sites
  • 0
32 минуты назад, sergeyk сказал:

Попробуйте подождать подольше (возможно даже после отмонтирования раздела остаются работающие приложения, запущенные с USB-диска).

Попробовал подождать после отмонтирования 10 минут - к сожалению, аналогично. Лампочка так и не погасла до извлечения, и то же сообщение в логе:

Мар 29 17:17:46 dropbear[1772] Early exit: Terminated by signal
Мар 29 17:17:46 ndm Opkg::Manager: disk unmounted.
Мар 29 17:17:46 ndm Core::FileSystem::Repository: "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:" unmounted.
<...>
Мар 29 17:27:31 kernel usb 1-2: USB disconnect, device number 3
Мар 29 17:27:31 kernel sd 0:0:0:0: [sda] Synchronizing SCSI cache
Мар 29 17:27:31 kernel sd 0:0:0:0: [sda] Synchronize Cache(10) failed: Result: hostbyte=0x01 driverbyte=0x00
Мар 29 17:27:31 ndm Core::FileSystem::Repository: unregistering "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:" filesystem...
Мар 29 17:27:31 ndm Storage::Manager: "Media0": unregistered partition "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:".
Мар 29 17:27:31 ndm Storage::Manager: "Media0": removed partition "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:".
Мар 29 17:27:31 ndm Storage::Manager: "Media0": a media was unsafely unplugged without ejecting.
Мар 29 17:27:31 ndm Storage::Manager: removed "Media0", port 2.

 

Share this post


Link to post
Share on other sites
  • 0

@rustrict Бала проблема на EXTRA II(именно только на ней) с индикацией

Цитата

 

Сейчас проверил у себя на Giga (KN-1010) (подключен диск тремя разделами, один из них SWAP) - отмонтировалось корректно.

ULTRA KN-1810(флешка) - тоже все корректно.

Share this post


Link to post
Share on other sites
  • 0

@sergeyk @AndreBA, оказалось, что зависит от места, где отключаешь. Я пробовал только на странице "Приложения", а если в дашборде нажать на "Безопасное извлечение", то ок: и лампочка гаснет, и кеш SCSI сбрасывается.

Скрытый текст

Мар 29 17:37:40 ndm Core::FileSystem::Repository: unregistering "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:" filesystem...
Мар 29 17:37:40 ndm Storage::Manager: started "Media0" eject.
Мар 29 17:37:40 dropbear[13274] Early exit: Terminated by signal
Мар 29 17:37:40 ndm Opkg::Manager: /opt/etc/init.d/rc.unslung: exit code 1.
Мар 29 17:37:40 ndm Opkg::Manager: disk unmounted.
Мар 29 17:37:40 ndm Storage::Manager: "Media0": unregistered partition "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:".
Мар 29 17:37:40 sdetach Media0: synchronized SCSI device cache.
Мар 29 17:37:40 sdetach Media0: stopped a SCSI device.
Мар 29 17:37:40 sdetach Media0: brought a block device to offline.
Мар 29 17:37:40 kernel sd 0:0:0:0: [sda] Synchronizing SCSI cache
Мар 29 17:37:41 sdetach Media0: unbound a driver.
Мар 29 17:37:41 ndm Storage::Manager: "Media0": ejected.
Мар 29 17:37:41 ndm Storage::Manager: "Media0": removed partition "d2dd8fe7-c0da-d501-50d0-8ee7c0dad501:".
Мар 29 17:37:41 ndm Storage::Manager: removed "Media0", port 2.
Мар 29 17:38:29 kernel usb 1-2: USB disconnect, device number 4

 

Непонятно только, должно ли это работать именно так? Ну и ошибки после ребута на месте, приходится извлекать и вставлять обратно.

Share this post


Link to post
Share on other sites
  • 0

@eralde

4 минуты назад, rustrict сказал:

Непонятно только, должно ли это работать именно так?

 

Share this post


Link to post
Share on other sites
  • 0
5 минут назад, rustrict сказал:

оказалось, что зависит от места, где отключаешь. Я пробовал только на странице "Приложения", а если в дашборде нажать на "Безопасное извлечение", то ок: и лампочка гаснет, и кеш SCSI сбрасывается.

В разделе "Системный монитор" - отмонтирует полностью(только переподключение устройства)

В "Приложениях" - отключает с возможностью подключения без переподключения устройства.

Почему сделано так - не знаю. 

Edited by AndreBA

Share this post


Link to post
Share on other sites
  • 0
3 часа назад, rustrict сказал:

После перехода с 3.3 на 3.4 моя флешка с Entware (ext4) определяется с ошибками:


Мар 29 14:09:40 kernel usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd ndm rqt 128 rq 6 len 2 ret -145
Мар 29 14:09:41 kernel usb 1-2: usbfs: USBDEVFS_CONTROL failed cmd ndm rqt 128 rq 6 len 2 ret -145
Мар 29 14:09:41 ndm Usb::Device: system failed [0xcffd00b0], operation timed out.
Мар 29 14:09:41 ndm Usb::Device: failed to get a string descriptor header.
Мар 29 14:09:41 ndm Usb::Device: unable to read available language IDs.

Ранее такого никогда не было.

Перезагрузки при этом не помогают. А вот если физически переподключить, тогда этих ошибок нет.

@sergeyk, а чем эти ошибки вызваны непонятно? :(

В 3.3 и раньше не сталкивался.

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, rustrict сказал:

@sergeyk @AndreBA, оказалось, что зависит от места, где отключаешь. Я пробовал только на странице "Приложения", а если в дашборде нажать на "Безопасное извлечение", то ок: и лампочка гаснет, и кеш SCSI сбрасывается.

  Показать содержимое

Непонятно только, должно ли это работать именно так? Ну и ошибки после ребута на месте, приходится извлекать и вставлять обратно.

Пока дашборд и страница "Приложения" работают в этом плане по-разному. В будущем, вероятно, на странице "Приложения" что-то поменяется.

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

После обновления KN-1010 на 3.4.12 отвалился внешний USB диск. Ребут роутера, переподключение в ручную результата не дает. Лог + селф тест прикрепил в сообщении ниже

Screenshot_16.jpg

Screenshot_17.jpg

Screenshot_18.jpg

Edited by stefbarinov@mail.ru

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, stefbarinov@mail.ru сказал:

После обновления KN-1010 на 3.4.12 отвалился внешний USB диск. Ребут роутера, переподключение в ручную результата не дает.

Screenshot_16.jpg

Screenshot_17.jpg

Screenshot_18.jpg

В лог про ошибки на диске не пишет?

Проверти на ошибки на всякий случай.

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, AndreBA сказал:

В лог про ошибки на диске не пишет?

Проверти на ошибки на всякий случай.

 

Screenshot_19.jpg

Share this post


Link to post
Share on other sites
  • 0
11 минуту назад, AndreBA сказал:

В лог про ошибки на диске не пишет?

Проверти на ошибки на всякий случай.

У меня на домашнем ПК ОС  Windows, а HDD, подключенный к роутеру имеет ФС ext4, винда просто не увидит этот жесткий) Хочу уточнить: когда обновился на 3.4.12 - всё было норм, сегодня установил 3/удалил 1 компонент(а)  и началось))) установил wireguard, SFTP и ping-cheker, удалил FTP. сейчас попробую поочерёдно вернуть всё, как было

Edited by stefbarinov@mail.ru

Share this post


Link to post
Share on other sites
  • 0
Только что, stefbarinov@mail.ru сказал:

У меня на домашнем ПК ОС  Windows, а HDD, подключенный к роутеру имеет ФС ext4, винда просто не увидит этот жесткий)

Тогда через Live диск.

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, AndreBA сказал:

Тогда через Live диск.

В будущем, конечно, буду подключать HDD к роутеру в формате NTFS, так как плюсов в быстродействии от EXT4 по сравнению с НТФС я не заметил

Share this post


Link to post
Share on other sites
  • 0

Удалил 3 выше оговоренных компонента, установил обратно ftp,в общем сделал всё как было, через кнопку FN2 откл hdd, затем руками передёрнул порт usb и всё норм заработало! Ниже скрытым сообщением приложу лог и селф, вдруг пригодится) Как раз выше сообщением будет лог и селф с проблемой, а ниже - без проблемы)

Screenshot_20.jpg

Edited by stefbarinov@mail.ru
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Установил вновь ping-checker и снова отвалился usb диск, на сей раз записи в журнале другие и предыдущие манипуляции не помогают вернуть usb "к жизни", лог + селф ниже скрытым постом

Screenshot_1.jpg

Screenshot_2.jpg

Share this post


Link to post
Share on other sites
  • 0
5 минут назад, stefbarinov@mail.ru сказал:

Установил вновь ping-checker и снова отвалился usb диск, на сей раз записи в журнале другие и предыдущие манипуляции не помогают вернуть usb "к жизни", лог + селф ниже скрытым постом

Screenshot_1.jpg

Screenshot_2.jpg

Все же проверьте диск на ошибки и файловую систему.

Share this post


Link to post
Share on other sites
  • 0
3 минуты назад, AndreBA сказал:

Все же проверьте диск на ошибки и файловую систему.

Вернул Версию ПО на 3.3.16 и всё прекрасно заработало! Останусь пока на ней. Проверю в случае подобной ошибки и на 3.3.16, но скорее всего ошибки не будет!

Edited by stefbarinov@mail.ru

Share this post


Link to post
Share on other sites
  • 0

Сегодня Giga III обновилась на 3.4.1 (с 3.3.16).

Отвалился USB диск (JetFlash Transcend 4GB) - использовался для хранения настроек сетевых медиаплейеров.

Был отформатирован в FAT32.

Диск проверил (все ок), переформатировал в NTFS - не помогло.

Цитата

Май 15 20:37:52 kernel usb 1-2: new high-speed USB device number 8 using xhci-mtk
Май 15 20:37:52 kernel usb 1-2: New USB device found, idVendor=8564, idProduct=1000
Май 15 20:37:52 kernel usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Май 15 20:37:52 kernel usb 1-2: Product: Mass Storage Device
Май 15 20:37:52 kernel usb 1-2: Manufacturer: JetFlash
Май 15 20:37:52 kernel usb 1-2: SerialNumber: 0SPCL2EM
Май 15 20:37:52 kernel usb-storage 1-2:1.0: USB Mass Storage device detected
Май 15 20:37:52 kernel scsi host0: usb-storage 1-2:1.0
Май 15 20:37:53 kernel scsi 0:0:0:0: Direct-Access JetFlash Transcend 4GB 8.07 PQ: 0 ANSI: 2
Май 15 20:37:53 kernel sd 0:0:0:0: Attached scsi generic sg0 type 0
Май 15 20:37:53 kernel sd 0:0:0:0: [sda] 7847936 512-byte logical blocks: (4.02 GB/3.74 GiB)
Май 15 20:37:53 kernel sd 0:0:0:0: [sda] Write Protect is off
Май 15 20:37:53 kernel sd 0:0:0:0: [sda] Mode Sense: 03 00 00 00
Май 15 20:37:53 kernel sd 0:0:0:0: [sda] No Caching mode page found
Май 15 20:37:53 kernel sd 0:0:0:0: [sda] Assuming drive cache: write through
Май 15 20:37:53 kernel sd 0:0:0:0: [sda] Attached SCSI removable disk
Май 15 20:37:53 ndm Storage::Manager: created "Media0", port 1.

В логах диск определяется, в устройствах - отсутствует.

Две другие USB Flash Silicon Power 8G - аналогично, не видит.

При этом USB Flash Transcend 128 Gb - видит отлично.

Но для моих целей хранения - это перебор.

При откате на 3.3.16 - все USB видны.

 

Share this post


Link to post
Share on other sites
  • 0
11 час назад, alekssmak сказал:

Сегодня Giga III обновилась на 3.4.1 (с 3.3.16).

Отвалился USB диск (JetFlash Transcend 4GB) - использовался для хранения настроек сетевых медиаплейеров.

Был отформатирован в FAT32.

Диск проверил (все ок), переформатировал в NTFS - не помогло.

В логах диск определяется, в устройствах - отсутствует.

Две другие USB Flash Silicon Power 8G - аналогично, не видит.

При этом USB Flash Transcend 128 Gb - видит отлично.

Но для моих целей хранения - это перебор.

При откате на 3.3.16 - все USB видны.

 

Опробовал несколько флешек, проблемы не заметил

Скрытый текст

1279645832__521.thumb.png.37eded8e2d3e4b0db6121c85a09efceb.png

 

Share this post


Link to post
Share on other sites
  • 0

Extra 2 после обновления на stable 3.4.1 с 3.3.16 не видит MicroSD карту в USB картридере.

Никакие танцы с бубном не помогают.

Карта отформатирована в ext4.

В компе все работает!

Откат на backup 3.3.16, и снова все работает!

И это стабильный релиз?, да уж.

Edited by Игорь Слесаренко

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Игорь Слесаренко сказал:

Extra 2 после обновления на stable 3.4.1 с 3.3.16 не видит MicroSD карту в USB картридере.

Никакие танцы с бубном не помогают.

Карта отформатирована в ext4.

В компе все работает!

Откат на backup 3.3.16, и снова все работает!

И это стабильный релиз?, да уж.

Полностью согласен. У некоторых там вообще-то OPKG крутится..некие системы, подсистемы - и после обновления - вуаля..и всё..! И назад вариантов - нет! Это стабильный релиз? Ведь даже базовые функции перестали работать.

Share this post


Link to post
Share on other sites
  • 0

Ну это же ведь не тотально. Я, к примеру, не ощутил никакого дискомфорта при смене версии на 3.4.1, пройдя весь путь 3.4 с нуля. Винт&флешка с ext3 как работали, так и работают.

Share this post


Link to post
Share on other sites
  • 0
10 минут назад, Mamay сказал:

Ну это же ведь не тотально. Я, к примеру, не ощутил никакого дискомфорта при смене версии на 3.4.1, пройдя весь путь 3.4 с нуля. Винт&флешка с ext3 как работали, так и работают.

Вы обновились по каналу "Тестовая сборка"?

Share this post


Link to post
Share on other sites
  • 0
13 минуты назад, Mamay сказал:

Ну это же ведь не тотально

Если у Вас нормально, то это не значит что проблемы не существует.

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, AndreBA сказал:

Вы обновились по каналу "Тестовая сборка"?

У меня не вышло на альфе почему-то. Я перепрыгнул на бету. 

Share this post


Link to post
Share on other sites
  • 0
Только что, Игорь Слесаренко сказал:

Если у Вас нормально, то это не значит что проблемы не существует.

А я этого и не говорил. Посмотрите сколько тем создано. Но повторюсь. Это не тотально. Проблема есть и парни в курсе. Ожидайте корректирующий релиз скоро...

Share this post


Link to post
Share on other sites
  • 0

Если честно, то это не совсем связано с 3.4.1, это было и раньше.

При установке обновления и перезагрузке роутера самба не запускалась и раньше ( или запускалась, но устройства не находила).

Помогало  физическое передергивание устройства.

При удаленной работе устройств приходилось бегать по объектам и передергивать винты.

Так что это не связано с ошибками на винтах или флешках.

Роутер.png

Роутер1.png

Роутер2.png

Edited by Валера-2
добавил фото

Share this post


Link to post
Share on other sites
  • 0
В 22.05.2020 в 04:20, Игорь Слесаренко сказал:

На 3.4.2 без изменений, все так же печально.

 

В 02.04.2020 в 11:07, stefbarinov сказал:

Вернул Версию ПО на 3.3.16 и всё прекрасно заработало! Останусь пока на ней. Проверю в случае подобной ошибки и на 3.3.16, но скорее всего ошибки не будет!

На версии 3.4.1 всё нормализовалось!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...