Jump to content
  • 0
DaDe

2 VLAN на отдельный порт

Question

Добрый день.

Не подскажите, как вывести 2 тэгированных VLAN на отдельный порт.

С помощью IPTV удается прокинуть 1 VLAN.

В настройках IPTV есть дополнительный VLAN ID, но видимо это что-то не то.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Через cli:

interface GigabitEthernetX/X
    switchport mode trunk
    switchport trunk vlan X
    switchport trunk vlan Y

где "Х" название и номер нужного интерфейса/порта.

vlan "X", vlan "Y" номер вашего влана.

Нужно прописать на входящем и исходящем порту. Роутер у Вас Lite III?

Edited by dexter

Share this post


Link to post
Share on other sites
  • 0
On 6/25/2020 at 7:46 PM, dexter said:

Через cli:


interface GigabitEthernetX/X
    switchport mode trunk
    switchport trunk vlan X
    switchport trunk vlan Y

где "Х" название и номер нужного интерфейса/порта.

vlan "X", vlan "Y" номер вашего влана.

Нужно прописать на входящем и исходящем порту. Роутер у Вас Lite III?

Да, keenetic lite III.

Сделал таким образом, но доступа не в один VLAN нет.

KN-1310_stable_3.04.C.6.0-0__router_startup-config.txt

Share this post


Link to post
Share on other sites
  • 0

Вы пригнали вланы

interface FastEthernet0/0
    rename 0
    role inet for ISP
    switchport mode access
    switchport mode trunk
    switchport access vlan 2
    switchport trunk vlan 1690
    switchport trunk vlan 1694
    up
!

и дальше их пустили в 

interface FastEthernet0/1
    rename 1
    switchport mode access
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 1690
    switchport trunk vlan 1694
    up
!

За этим портом управляемый свитч, который эти вланы дальше по "access" портам раскрывает? Приставка ТВ в какой порт воткнута? Она должна тэгированный трафик принимать?

Share this post


Link to post
Share on other sites
  • 0

Согласно статье нужно создать интерфейс FastEthernet0/VlanXXX, где XXX - ваш VLAN. По аналогии с имеющимся по дефолту FastEthernet0/Vlan2.

Share this post


Link to post
Share on other sites
  • 0
On 6/28/2020 at 11:06 PM, dexter said:

Вы пригнали вланы


interface FastEthernet0/0
    rename 0
    role inet for ISP
    switchport mode access
    switchport mode trunk
    switchport access vlan 2
    switchport trunk vlan 1690
    switchport trunk vlan 1694
    up
!

и дальше их пустили в 


interface FastEthernet0/1
    rename 1
    switchport mode access
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 1690
    switchport trunk vlan 1694
    up
!

За этим портом управляемый свитч, который эти вланы дальше по "access" портам раскрывает? Приставка ТВ в какой порт воткнута? Она должна тэгированный трафик принимать?

Да, согласен, хрень сделал. В синтаксисе пока сложно разобраться. От провайдера приходит не тэгируемый интернет, а двумя тэгами VLAN до двух точек. Хотелось эти две точки из VLAN выгнать в "access" один из LAN портов, чтобы в него подключить компьютер.

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Mikesk said:

Согласно статье нужно создать интерфейс FastEthernet0/VlanXXX, где XXX - ваш VLAN. По аналогии с имеющимся по дефолту FastEthernet0/Vlan2.

Таким что-ли способом:

!
interface FastEthernet0/0
    rename 0
    role inet for ISP
    switchport mode access
    switchport mode trunk
    switchport access vlan 2
    switchport trunk vlan 1690
    switchport trunk vlan 1694
    up
!
interface FastEthernet0/Vlan1690
    description "VLAN1690"
    security-level public
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface FastEthernet0/Vlan1694
    description "VLAN1694"
    security-level public
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface FastEthernet0/1
    rename 1
    switchport mode access
    switchport access vlan 1690
    switchport access vlan 1694
    up
!

 

Share this post


Link to post
Share on other sites
  • 0

"access vlan" может быть только один на порт. В один порт  "switchport access vlan 1690" в другой порт "switchport access vlan 1694".

По идее должно заработать и без "'interface FastEthernet0/Vlan1690" и "interface FastEthernet0/Vlan1694", т.к. происходит в рамках одного физического свитча.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...