Jump to content
  • 6
Andrex

TSMB: потеря работоспособности спустя некоторое время

Question

Достаточно загрузить  роутер  хоть с последним релизом прошивки, хоть с последней альфой и оставить роутер на 2 дня (больше этого срока CIFS/SMB не живёт) и после этого попробовать зайти на диск хоть по IP хоть по сетевому имени и получить отлуп! Всё.

  • Upvote 1
  • Need more info 1

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
3 часа назад, iggo сказал:

подключен постоянно.

Подключёк как сетевой диск? Или по сетевому пути? Это важно! Всё дело в том, что диск не отваливается и у меня - FTP и DLNA, а также доступ из WEB роутера к нему всегда работают. Падает TSMB и не позже чем через двое суток обязательно. У меня ничего не может быть индивидуального, так как на прошиках до последнего релиза всё работало и НИЧЕГО не менялось. 

Share this post


Link to post
Share on other sites
  • 0

Вот так в Win7

Цитата

Или по сетевому пути

.959084218_.png.01bfad4a26943fb960ca4a8b53b2a804.png

Edited by iggo

Share this post


Link to post
Share on other sites
  • 0

Возможно различия в версиях Windows являются ключевыми.

Share this post


Link to post
Share on other sites
  • 0
13 минуты назад, iggo сказал:

Возможно различия в версиях Windows являются ключевыми.

Возможно. У меня Win10 x64 Версия 2004

Share this post


Link to post
Share on other sites
  • 0
18 минут назад, iggo сказал:

Вот так в Win7

Это не сетевой диск. Так у меня тоже работало. А вот так умирает через 48 часов максимум. В win7 тоже можно подключить диск - попробуй, если не трудно. 

067.png

Share this post


Link to post
Share on other sites
  • 0

Да, это доступ к сетевой папке по сетевому пути. Я попробую ваш вариант с сетевым диском.

Сделал:

146874657_4.png.38e5ceb69703d41c19af078b4cdb8107.png

Edited by iggo

Share this post


Link to post
Share on other sites
  • 0

именно на 3.5 падает?

на 3.4.6 винда 8.1/10, Макос, ios, iPadOS—не падает

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, Andrex сказал:

Это не сетевой диск. Так у меня тоже работало. А вот так умирает через 48 часов максимум. В win7 тоже можно подключить диск - попробуй, если не трудно. 

067.png

У меня Win7 и именно сетевой диск. Не падает.

Share this post


Link to post
Share on other sites
  • 0
4 часа назад, iggo сказал:

Сделал:

Ок. Ждём 48 часов.

3 часа назад, enterfaza сказал:

именно на 3.5 падает?

И на 3.5 и на 3.4.6! Не падало на 3.4.3

Share this post


Link to post
Share on other sites
  • 0
13 часа назад, enterfaza сказал:

именно на 3.5 падает?

на 3.4.6 винда 8.1/10, Макос, ios, iPadOS—не падает

3.4.6 падает на iPadOS, MacOS, iOS, Win 10. После перезагрузки роутера работает несколько часов и неизбежный отвал. Такая же ситуация с 3.5

 

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

@Supermaks Посмотрел селфтест. Не обнаружил там каких-то ошибок, связанных с SMB. Это тоже результат, значит проблема на уровне протокола. Переходим на сбор дампов трафика.

 

@Andrex Пожалуйста не голосуйте за посты, нарушается хронология.

Share this post


Link to post
Share on other sites
  • 0
14 часа назад, Andrex сказал:

Ок. Ждём 48 часов.

Пока все ок, сетевой диск доступен. До связи.

Share this post


Link to post
Share on other sites
  • 0

Только что еще раз повторилось всё в точности еще раз.

Self-test сохранил себе, правда уже после перезапуска tsmb, но не уверен надо ли загружать снова.

 

Edited by Supermaks

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Supermaks сказал:

Только что еще раз повторилось всё в точности еще раз.

Self-test сохранил себе, правда уже после перезапуска tsmb, но не уверен надо ли загружать снова.

 

дамп снимите. Попробуйте зайти на отвалившийся диск и заснифьте эту попытку вайршарком на интерфейсе компьютера.

Share this post


Link to post
Share on other sites
  • 0
19 минут назад, Mikesk сказал:

дамп снимите. Попробуйте зайти на отвалившийся диск и заснифьте эту попытку вайршарком на интерфейсе компьютера.

Нет, wireshark для меня уже магия. да и откатился я на 3.4.1 ибо нужен подмонтированный диск.

Share this post


Link to post
Share on other sites
  • 0

24 часа - все норм. До связи.

Share this post


Link to post
Share on other sites
  • 0

Подтверждаю проблему на версии 3.5 Giga 1010

Что-то около 1-2 недель работает доступ.

Далее NAS на linux начинает ругаться, что ночью дамп скинуть на диск в роутере он не смог.

С винды зайти на \\192.168.1.1 также не получается - пароль не принимается.

После отключения smb слайдером в админке и повторного включения, пароль принимается, заходит.

Раньше такой проблемы не было.

Поставил последнюю альфу, буду ждать повторения.

Кто-нибудь из ответственных, напишите алгоритм, что сделать, что предоставить и кому, когда проблема повторится? 

Share this post


Link to post
Share on other sites
  • 0

48 часов. Проблема не обнаружена, все работает. Так что в плане диагностики проблемы я пас, у меня не воспроизводится

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, iggo сказал:

48 часов. Проблема не обнаружена, все работает. Так что в плане диагностики проблемы я пас, у меня не воспроизводится

Значит похоже, что на Win7 проблемы нет. 

ВСЕМ

Отпишитесь те у кого есть проблема - у кого какая операционка стоит?

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, Andrex сказал:

Значит похоже, что на Win7 проблемы нет. 

У меня Win 7, проблемы с отвалом шары Кинетика нет. Есть проблема, когда Андроид перестаёт видеть Винду. Если Винду переподключить или на Андроиде выполнить сканирование сети, то шара компа снова доступна смартфону. Связано это с Кинетиком или нет точно неизвестно, но вроде такая проблема появляется периодически и на старых прошивках её не было. Кстати при VPN подключении с Андроида шара Винды также недоступна, когда её клинит. Возможно это связано с обновами смартфона, которые периодически прилетают, а может и нет. Ну а Win 7 больше не обновляется.

Share this post


Link to post
Share on other sites
  • 0
9 часов назад, Andrex сказал:

Значит похоже, что на Win7 проблемы нет.

У меня проблема на 3.4.6 есть и на Win7 и на Win10.

Share this post


Link to post
Share on other sites
  • 0
33 минуты назад, Supermaks сказал:

У меня проблема на 3.4.6 есть и на Win7 и на Win10.

Обе операционки в сети? Есть подозрение, что проблема появляется когда в сети есть Win10, а остальные её уже испытывают. Если же Win7 одна, то проблема не проявляется. Может так?

Share this post


Link to post
Share on other sites
  • 0
19 минут назад, Andrex сказал:

Обе операционки в сети? Есть подозрение, что проблема появляется когда в сети есть Win10, а остальные её уже испытывают. Если же Win7 одна, то проблема не проявляется. Может так?

Win10 в сети, Win7 постоянно в гибернации, включается периодически.

На Win7 проблему всегда ловил при включении, то есть TSMB "умерло" пока Win7 было выключено.

Edited by Supermaks

Share this post


Link to post
Share on other sites
  • 0
2 минуты назад, Supermaks сказал:

Win10 в сети, Win7 постоянно в гибернации, включается периодически.

На Win7 проблему всегда ловил при включении, то есть TSMB "умерло" пока Win7 было выключено.

Всё правильно. Win10 вешает TSMB, а Win7, просыпаясь, уже испытывает проблему повесившегося TSMB. Если бы была одна Win7, то TSMB не вешалась бы. Такое предположение. Отключи Win10 от сети и поработай больше двух суток с одной Win7. Если TSMB не умрёт, значит предположение верно, если умрёт - нет.

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, Supermaks сказал:

Увы, не могу.

Тогда нужны подтверждения/опровержения тех, у кого в сети одна Win7. Есть ли те, у кого одна Win7 и нет проблем? И наоборот. Один ответ есть, но это мало.

Share this post


Link to post
Share on other sites
  • 0

давно бы свои логи/дампы скинул может и ошибку поправили бы. тайны какие-то хранит... американский шпиён не иначе.

  • Upvote 2

Share this post


Link to post
Share on other sites
  • 0
29 минут назад, Goblin сказал:

давно бы свои логи/дампы скинул может и ошибку поправили бы. тайны какие-то хранит...

Скинули уже выше - нет там ничего. Да и не видно особого желания что-либо править у разрабов в этой теме...

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, Andrex сказал:

Скинули уже выше - нет там ничего. Да и не видно особого желания что-либо править у разрабов в этой теме...

Дампов не скидывали, как @vst просил. Видимо запуск вайршарка для всех на техническом форуме - магия.

 

PS: Скинул бы давно, да нет проблем. Вот и следующая бета подоспела, пойду обновлюсь.

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Andrex сказал:

Скинули уже выше - нет там ничего.

ну тут много от чего зависит. например я где-то читал, что у последней windows 10 2004 какие-то проблемы с самбой. ссылку уже не помню нашел. может еще какие нюансы есть. короче, чем больше логов/дампов с разных устройств для обнаружения проблемы оно лучше.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...