Jump to content
  • 0
Sign in to follow this  
Michel

Ограниченный доступ к сайтам через PPTP

Question

Картина:
1) в деревне работа идёт через старый Zyxel Keenetic Omni II, ОС версия 2.16.D.3.0-5  
2) Omni II через  PPTP VPN подключен к расположенному в городе Extra (KN-1710). OC версия 3.3.16, сам канал - USB модем Huawei 3372, TELE2, 4G
3) Extra в городе подключен к исправному провайдеру по Ethernet

Т.е. "деревенский" трафик идет не прямо через 4G, а через PPTP в/из города, а 4G канал - в данном случае только транспорт.

При этом наблюдается выборочный доступ к сайтам, например -
яндекс доступен, http://japan-sumo.ru/ отваливается в браузере  too long to respond.
mail.ru , e.mail.ru почта доступна, а новости news.mail.ru too long to respond.

При непосредственном подключении в городе этих проблем нет.
Сам канал Tele2 если работать прямо - глючный, на нём картина похожая, но часто обратная (нет mail.ru, нет yandex'a, но есть гугл и http://japan-sumo.ru/ ), единственное здравое объяснение (но фиг знает, так ли это) - злые козни оператора из-за фиксированной TTL=64 на модеме Huawei 3372 и/или перешитого "смартфонного" IMSI.

Пытался разобраться - картина не складывается.
Варианты которые приходят в голову - 
(1) какая-то кривизна PPTP в принципе
(2) что-то не так наконфигурено на PPTP на стороне сервера и/или клиента
(3) пакостит оператор, портит трафик

Есть идеи? Кто может помочь?
 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Проверить PING внутри канала на потери.

И поэкспериментируйте с DNS на стороне деревни.

Share this post


Link to post
Share on other sites
  • 0

DNS - на домашней подсети Omni II в деревне?

Ping прекрасный, потерь нет, отклики в пределах 100мс если не лезть в Африку.
Все проблемные имена нормально ресолвятся, даже если сайт получает too long to respond в браузере.

Edited by Michel

Share this post


Link to post
Share on other sites
  • 0

DNS в локальной сети "деревни" не меняет поведения, пробовал 8.8.8.8 - та же беда.
Ping работает хорошо, в канале и в VPN. С разрешением имён всё ОК.
В браузере что-то ломается при обращении ресурсу (?) Беда где-то выше по стеку протоколов. 

Edited by Michel

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, Michel сказал:

Картина:
1) в деревне работа идёт через старый Zyxel Keenetic Omni II, ОС версия 2.16.D.3.0-5  
2) Omni II через  PPTP VPN подключен к расположенному в городе Extra (KN-1710). OC версия 3.3.16, сам канал - USB модем Huawei 3372, TELE2, 4G
3) Extra в городе подключен к исправному провайдеру по Ethernet

Т.е. "деревенский" трафик идет не прямо через 4G, а через PPTP в/из города, а 4G канал - в данном случае только транспорт.

При этом наблюдается выборочный доступ к сайтам, например -
яндекс доступен, http://japan-sumo.ru/ отваливается в браузере  too long to respond.
mail.ru , e.mail.ru почта доступна, а новости news.mail.ru too long to respond.

При непосредственном подключении в городе этих проблем нет.
Сам канал Tele2 если работать прямо - глючный, на нём картина похожая, но часто обратная (нет mail.ru, нет yandex'a, но есть гугл и http://japan-sumo.ru/ ), единственное здравое объяснение (но фиг знает, так ли это) - злые козни оператора из-за фиксированной TTL=64 на модеме Huawei 3372 и/или перешитого "смартфонного" IMSI.

Пытался разобраться - картина не складывается.
Варианты которые приходят в голову - 
(1) какая-то кривизна PPTP в принципе
(2) что-то не так наконфигурено на PPTP на стороне сервера и/или клиента
(3) пакостит оператор, портит трафик

Есть идеи? Кто может помочь?
 

Смотреть в сторону mtu. Автоподстройка tcp mss на pptp интерфесе включена?

Share this post


Link to post
Share on other sites
  • 0

Да, сейчас на клиентской стороне Adjustment of TCP MSS = ON.  выключить?

Edited by Michel

Share this post


Link to post
Share on other sites
  • 0
Только что, Michel сказал:

Да, сейчас Adjustment of TCP MSS = ON.  выключить?

Выключать не надо.

Share this post


Link to post
Share on other sites
  • 0

Фигасе. Пляска с бубном: вылечилось выключением шифрования:
на сервере With encryption only = OFF
на клиенте Data encryption = OFF
 

На клиенте оставлено: 
Data compression (CCP) = ON


Странное влияние шифрования. Баг?

Edited by Michel

Share this post


Link to post
Share on other sites
  • 0

Искренне признателен всем за поддержку.
Но если будут мысли, всё же хочется понять причину такой избирательности глюка.
Неужели оператор учинил столь суровый DPI чтобы выборочно коцать пакеты VPNа трафика HTTPS?

Edited by Michel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...