Jump to content
  • 2
MDP

Непонятная ситуация с startup-config и running-config на экстендере

Question

Дано:

Прошивка 3.5 beta 2

Контроллер Ultra II

Экстендер KN-1610

 

На LAN интерфейсах контроллера и экстендера выполняем команду:

interface <номер> role iseg
system configuration save

После выполнения в секциях интерфейса в файлах running-config и startup-config присутствует (пример для интерфейса 2):

interface FastEthernet0/2
    rename 2
    role iseg
    switchport mode access
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 2
    up

После перезагрузки на контроллере файлы running-config и startup-config идентичны, но на экстендере различаются:

running-config

interface FastEthernet0/2
    rename 2
    switchport mode access
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 2
    up

startup-config

interface FastEthernet0/2
    rename 2
    role iseg
    switchport mode access
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 2
    up

В чем загвоздка??? Ситуация как выяснилась не единичная.

Кроме того, после обновления с 3.5 beta 1 до версии 3.5 beta 2 на экстендере (на контроллере всё нормально) исчезли строки в startup-config на LAN интерфейсах

 role iseg

 

 

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Похоже я разработчиков чем то "обидел" ...или вопрос был как то задан некорректно...может хоть намекнут в личку...чего не так то? 

Share this post


Link to post
Share on other sites
  • 0
On 9/4/2020 at 8:13 PM, MDP said:

Похоже я разработчиков чем то "обидел" ...или вопрос был как то задан некорректно...может хоть намекнут в личку...чего не так то? 

Надо выбрать время, проверить. Роль не должна слетать при загрузке.

Share this post


Link to post
Share on other sites
  • 0
On 9/3/2020 at 5:00 AM, MDP said:

после обновления с 3.5 beta 1 до версии 3.5 beta 2 на экстендере (на контроллере всё нормально) исчезли строки в startup-config на LAN интерфейсах

На текущей версии воспроизвести не можем. Наблюдается ли проблема после обновления на beta 3? Если да, то нужен журнал загрузки системы. Точнее, то место, где из startup-конфига читается роль.

Share this post


Link to post
Share on other sites
  • 0
11 минуту назад, ndm сказал:

На текущей версии воспроизвести не можем. Наблюдается ли проблема после обновления на beta 3? Если да, то нужен журнал загрузки системы. Точнее, то место, где из startup-конфига читается роль.

Прикрепил скрытым

Share this post


Link to post
Share on other sites
  • 0

  

Цитата

Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/1": renamed to "1".
Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/1": assigned role "iseg" for FastEthernet0/1.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/1": access mode enabled.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/1": trunk mode enabled.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/1": set access VLAN ID: 1.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/1": set trunk VLAN ID: 2.
Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/1": interface is up.
Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/2": renamed to "2".
Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/2": assigned role "iseg" for FastEthernet0/2.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/2": access mode enabled.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/2": trunk mode enabled.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/2": set access VLAN ID: 1.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/2": set trunk VLAN ID: 2.
Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/2": interface is up.
Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/3": renamed to "3".
Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/3": assigned role "iseg" for FastEthernet0/3.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/3": access mode enabled.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/3": trunk mode enabled.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/3": set access VLAN ID: 1.
Sep  7 11:17:05 ndm: Network::Interface::Switch: "FastEthernet0/3": set trunk VLAN ID: 2.
Sep  7 11:17:05 ndm: Network::Interface::Base: "FastEthernet0/3": interface is up.

потом ниже

Цитата

Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/0": set access VLAN ID: 1.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/0": removed trunk VLAN ID: 1.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/0": trunk mode disabled.
Sep  7 11:17:38 ndm: Network::Interface::Base: "FastEthernet0/1": deleted all roles.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/1": access mode enabled.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/1": set access VLAN ID: 1.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/1": removed trunk VLAN ID: 1.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/1": trunk mode disabled.
Sep  7 11:17:38 ndm: Network::Interface::Base: "FastEthernet0/2": deleted all roles.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/2": access mode enabled.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/2": set access VLAN ID: 1.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/2": removed trunk VLAN ID: 1.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/2": trunk mode disabled.
Sep  7 11:17:38 ndm: Network::Interface::Base: "FastEthernet0/3": deleted all roles.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/3": access mode enabled.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/3": set access VLAN ID: 1.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/3": removed trunk VLAN ID: 1.
Sep  7 11:17:38 ndm: Network::Interface::Switch: "FastEthernet0/3": trunk mode disabled.

 

Цитата

Sep  7 11:17:39 ndm: Network::Interface::Base: "FastEthernet0/1": deleted all roles.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/1": trunk mode enabled.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/1": set trunk VLAN ID: 2.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/1": removed access VLAN ID: 2.
Sep  7 11:17:39 ndm: Network::Interface::Base: "FastEthernet0/2": deleted all roles.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/2": trunk mode enabled.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/2": set trunk VLAN ID: 2.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/2": removed access VLAN ID: 2.
Sep  7 11:17:39 ndm: Network::Interface::Base: "FastEthernet0/3": deleted all roles.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/3": trunk mode enabled.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/3": set trunk VLAN ID: 2.
Sep  7 11:17:39 ndm: Network::Interface::Switch: "FastEthernet0/3": removed access VLAN ID: 2.

 Beta 3 ещё не ставил

Edited by MDP

Share this post


Link to post
Share on other sites
  • 0
12 часа назад, ndm сказал:

 Наблюдается ли проблема после обновления на beta 3? Если да, то нужен журнал загрузки системы. 

Обновился до beta3 ...в итоге в startup-config на экстендере исчезли строки role iseg  ...ладно в running-config, но startup-config  почему и как???

После обновления на бета 3 выгрузил журналы контроллера и экстендера (прикрепил скрытым текстом далее).

 

 

Share this post


Link to post
Share on other sites
  • 0

После обновления на beta 4 в startup-config перестали затираться строки role iseg. Всё пришло в норму:

Цитата

interface FastEthernet0/1
    rename 1
    role iseg
    switchport mode access
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 2
    up

В running-config ситуация не изменилась строки отсутствуют:

Цитата

interface FastEthernet0/1
    rename 1
    switchport mode access
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 2
    up

 

Share this post


Link to post
Share on other sites
  • 0

@ndm версия 3.5 beta 6 проблема сохраняется на экстендере. Сброс до заводских делал.

Edited by MDP

Share this post


Link to post
Share on other sites
  • 0

Подскажите, не может ли удаляться роль на экстендере некой политикой исходящей от контроллера?

Share this post


Link to post
Share on other sites
  • 0

Да в общем теперь всё ясно, на экстендер "прилетает политика" с контроллера.

На экстендере выполнил:

interface <номер> role iseg

в running-config роль появилась.

Затем...даже не экстендер, а КОНТРОЛЛЕР перезагрузил !!!

После перезагрузки контроллера в running-config экстендера присвоенные роли ОТСУТСТВУЮТ,так как выполняется:

 Sep 28 05:33:56 ndm: Network::Interface::Base: "FastEthernet0/1": deleted all roles.

 

Я лично на 100% уверен, что данная ситуация абсолютно у всех имеет место быть,

@Le ecureuil @ndm ну не может такое не воспризводится

лог. с экстендера скрытым прикрепил....если он вам интересен. В 15-32 момент перезагрузки крнтроллера.

 

Edited by MDP

Share this post


Link to post
Share on other sites
  • 0
22 часа назад, Denis P сказал:

воспроизводится в подобной конфигурации, когда 1610 выступает в качестве экстендера.

в бета 6 не исправлено.

...ладно, короче я сдался...ну не прокатило.. не фартануло. пошел другим путём. Убрал присвоение роли к интерфейсам (толку их прописывать каждый раз, после перезагрузки роутера?). Логи и прочие измышления, которые выкладывал скрытым текстом скачаны 0 раз с 8 сентября. Проблема эта неинтересна от слова совсем разработчикам.))) 🍌...а может это вовсе и не проблема?

Edited by MDP

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, MDP сказал:

...ладно, короче я сдался...ну не прокатило.. не фартануло. пошел другим путём. Убрал присвоение роли к интерфейсам (толку их прописывать каждый раз, после перезагрузки роутера?). Логи и прочие измышления, которые выкладывал скрытым текстом скачаны 0 раз с 8 сентября. Проблема эта неинтересна от слова совсем разработчикам.))) 🍌...а может это вовсе и не проблема?

Об этой проблеме я упоминал в ТП (воспроизвести у них, не получалось), правда там была еще другая (основная), после перезагрузки контроллера, при выключеннном backhaul, он включался только на экстендере и постоянно сканировал эфир в попытке подключится, из-за чего нормально не работали wifi клиенты на нем (это тоже воспроизвести у ТП не получалось, но в 6 бете её пофиксили).

Есть подозрение что это наблюдается только на 1610 в качестве экстендера

Share this post


Link to post
Share on other sites
  • 0
14 минуты назад, Denis P сказал:

 

Есть подозрение что это наблюдается только на 1610 в качестве экстендера

😁😁😁 

Как бы мы не гадали, все равно ни хрена не выясним. Вот выбрали направление и идем. Нам главное до воды добраться, ясно?

©Кин-Дза-Дза

Прям у разработчиков нету 1610...

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

@Le ecureuil @ndm где то было в ченжлоге, что исправили эту проблему? На последней альфе как бы проблема решена. Либо тогда маякнули где нибудь в личку или с оф.тех.поддержки что ли? ...так то по крайней мере 2 человека ждут решения

Edited by MDP

Share this post


Link to post
Share on other sites
  • 0
В 04.12.2020 в 18:42, MDP сказал:

@Le ecureuil @ndm где то было в ченжлоге, что исправили эту проблему? На последней альфе как бы проблема решена. Либо тогда маякнули где нибудь в личку или с оф.тех.поддержки что ли? ...так то по крайней мере 2 человека ждут решения

https://help.keenetic.com/hc/ru/articles/360017998180 оно? Тогда маякнули.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...