Jump to content
  • 9
Space Alex

3.5.1 сваливание в 40 МГц

Question

Обратил внимание, что иногда некоторые устройства подключенные по 5ггц сваливаются на 40 МГц с 80 МГц и остаются там пока не вкл. выкл. Wi-Fi. Раньше такого никогда не наблюдал. Сегодня за пол дня на новой прошивке такое случилось с Mi Box S и Samsung Note 10. Если необходимо, то предоставлю селф-тест.

  • Upvote 2

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
3 часа назад, Eduard Bogdanov сказал:

У меня проблемы с honor (сваливание с 80 на 40) начались еще в 2.15 С0, когда разработчики обновили драйвер Wifi

От версии к версии, эта проблема повторялась. Я уже на автомате ставил не выше 40 при новых настройках.

В последнем релизе 3.5.1 я пока не провелял, сегодня выставлю на автомате 20/40/80/160 и проверю, возможно что разработчики учли прошлые ошибки и все заработает стабильно.

Вероятно, если у Вас начались проблемы со сваливанием, то у меня - они закончатся! :-))

На форуме много кстати где обсуждается Honor. Вот к примеру.

Может быть Вам тоже стоит по экспериментировать с выбранным каналом к примеру. Так же посмотреть в настройках самого устройства не включены ли какие-то энергосберенающие плюшки для Wi-Fi.

Share this post


Link to post
Share on other sites
  • 0

А не связано ли это описанной проблемой "региональными запретами" и работой в даном направление

 

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, vasek00 сказал:

А не связано ли это описанной проблемой "региональными запретами" и работой в даном направление

 

Я думаю, что с этим не связано. Так как происходит это только на 3.5.1 и рандомно с разными устройствами. Так же на 4pda есть жалобы на падение скорости даже keenetic + keenetic.

Screenshot_20201017-021837_Chrome.jpg

Screenshot_20201017-021826_Chrome.jpg

Edited by Space Alex

Share this post


Link to post
Share on other sites
  • 0

Обновился до 3.6 Alpha 1 на своем KN1010. Обратил внимание, что оба клиента (ноутбук AC-7265 и ТВ-бокс Ugos AM-6) работают с полосой 40 МГц. Исправил вечером вчера состояние переключением ширины канала на 20/40 и обратно на 20/40/80. 

С утра клиенты опять в режиме полосы 40 МГц. Переключил канал с 60-го на 64. В течении дня клиенты несколько раз уходили в сон на несколько часов и переподключались к роутеру по выходу из сна. За день "сваливания" больше не обнаружил.  Продолжаю наблюдать.

На версиях 3.5 Beta такой проблемы не встречал, а за 3.5.1 не успел понаблюдать.

Edited by shurings

Share this post


Link to post
Share on other sites
  • 0
9 часов назад, Space Alex сказал:

Я думаю, что с этим не связано. Так как происходит это только на 3.5.1 и рандомно с разными устройствами. Так же на 4pda есть жалобы на падение скорости даже keenetic + keenetic.

Участники событий в которых имеют место быть KN10/KN18 или на их базе контроллеры

[I] Jan  1 03:00:13 kernel: MT7615 AP Driver version: 5.0.5.0
и например
[I] Jan  1 03:00:14 kernel: MT7615 CPU 0 patch info:
[I] Jan  1 03:00:14 kernel:  Built date: 20180518100604a
[I] Jan  1 03:00:14 kernel: MT7615 CPU 0 firmware info:
[I] Jan  1 03:00:14 kernel:  Chip ID: 0x04
[I] Jan  1 03:00:14 kernel:  Eco version: 0x00
[I] Jan  1 03:00:14 kernel:  Built date: 20191220015534
[I] Jan  1 03:00:14 kernel: MT7615 CPU 1 firmware info:
[I] Jan  1 03:00:14 kernel:  Chip ID: 0x04
[I] Jan  1 03:00:14 kernel:  Eco version: 0x00
[I] Jan  1 03:00:14 kernel:  Built date: 20190415154149

И KN30 на котором я не заметил такого.

[I] Jan  1 03:00:14 kernel: MT7613 AP Driver version: 6.0.2.0
и например
[I] Jan  1 03:00:18 kernel: MT7663 CPU 0 patch info:
[I] Jan  1 03:00:18 kernel:  Built date: 1909041522d7653
[I] Jan  1 03:00:18 kernel: MT7663 CPU 0 firmware info:
[I] Jan  1 03:00:18 kernel:  Chip ID: 0x08
[I] Jan  1 03:00:18 kernel:  Eco version: 0x01
[I] Jan  1 03:00:18 kernel:  Built date: 20200114115632

 

Edited by vasek00

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, Space Alex said:

3.5.2 всё так же :(

3.6 Альфа 2 аналогично(( на 3.6 субъективно проблема усугубилась. «Игры» с настройками результатов не приносят.

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, Space Alex said:

3.5.2 всё так же :(

Всем привет. 

Подтверждаю. 

Keenetic Ultra (KN-1810), сегодня обновился на 3.5.2 с 3.5.1 - аналогичная проблема, устройств, которые не управляются по протоколам, r/k/v падают в 40 МГц. 

Одно из основных устройств в сети страдает таким - WI-FI адаптер - ASUS PCE AC88.

Изначально подключается по 802.11 AC 4x4, при малейшей загрузке переходит в 3x3, 80 МГц, а через некоторое время сваливается в 40 МГц и выше 600 Мбит не показывает, на 80 МГц обратно не возвращается. На 3.4.12 не наблюдалось такого. 

987.thumb.PNG.a6aa459e1bd969650b44db2dba2ef0b9.PNG

 

Кто-нибудь делал запрос в Тех.поддержку? Какой-нибудь ответ от Поддержки последовал?

Edited by Юрий Михайлин

Share this post


Link to post
Share on other sites
  • 0
9 часов назад, Юрий Михайлин сказал:

Всем привет. 

Подтверждаю. 

Keenetic Ultra (KN-1810), сегодня обновился на 3.5.2 с 3.5.1 - аналогичная проблема, устройств, которые не управляются по протоколам, r/k/v падают в 40 МГц. 

Одно из основных устройств в сети страдает таким - WI-FI адаптер - ASUS PCE AC88.

Изначально подключается по 802.11 AC 4x4, при малейшей загрузке переходит в 3x3, 80 МГц, а через некоторое время сваливается в 40 МГц и выше 600 Мбит не показывает, на 80 МГц обратно не возвращается. На 3.4.12 не наблюдалось такого. 

987.thumb.PNG.a6aa459e1bd969650b44db2dba2ef0b9.PNG

 

Кто-нибудь делал запрос в Тех.поддержку? Какой-нибудь ответ от Поддержки последовал?

У меня всё норм, сталкивания нет, всегда айфон сидит на 80МГц

Screenshot_1.jpg

Share this post


Link to post
Share on other sites
  • 0
38 минут назад, stefbarinov сказал:

У меня всё норм, сталкивания нет, всегда айфон сидит на 80МГц

Screenshot_1.jpg

Айфон у вас какой модели?

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, supilot сказал:

Айфон у вас какой модели?

iPhone 11Pro Max

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, stefbarinov сказал:

iPhone 11Pro Max

У меня 6S и 6S Plus. Они сваливаются. Видимо дело в старом железе.

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, supilot сказал:

У меня 6S и 6S Plus. Они сваливаются. Видимо дело в старом железе.

iOS 14.1 установили? Там вроде решили проблему с отвалом устройств по wifi

Share this post


Link to post
Share on other sites
  • 0
25 минут назад, stefbarinov сказал:

iOS 14.1 установили? Там вроде решили проблему с отвалом устройств по wifi

Нет. Пойду поставлю.

Share this post


Link to post
Share on other sites
  • 0

В принципе старые iphone @Padavan

 тут упоминал

 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
6 часов назад, supilot сказал:

6S и 6S Plus

на 3010 у меня всегда i6S сидит на 40 и редко на 80 перепрыгивает, а вот на g3 всегда на 80 и это единственное яблоко, которое так безобразит, так что тут не понять хто есть крайний 

Share this post


Link to post
Share on other sites
  • 0
6 часов назад, stefbarinov сказал:

Там вроде решили проблему с отвалом устройств по wifi

а там отвалов и не было, тупо 40 полоса

Share this post


Link to post
Share on other sites
  • 0
13 часа назад, enterfaza сказал:

на 3010 у меня всегда i6S сидит на 40 и редко на 80 перепрыгивает, а вот на g3 всегда на 80 и это единственное яблоко, которое так безобразит, так что тут не понять хто есть крайний 

 

Боюсь сглазить, но прогресс есть. 

Поставил iOS 14.1, сделал своей шестерке Сброс настройки сети, подключился к вайфаю.

Теперь стало так. 

Продолжаю наблюдать дальше. 

 

Снимок4.PNG

Edited by supilot
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
1 минуту назад, supilot сказал:

прогресс есть

хорошо если так

у самого пока 3.4.12, жду пока докрутят, но как и говорил, редко и у меня на 80 сидит, на яблоке 14 ось

Share this post


Link to post
Share on other sites
  • 0
36 минут назад, enterfaza сказал:

на яблоке 14 ось

Какая именно 14-я? Или 14.1, вышедшая на днях?

До 14.1 телефон тоже первоначально подключался якобы на 80, но стоило дать ему нагрузку - банальный спидтест запустить - как полоса сразу проваливалась до 40 . Причем реальный трафик получался совершенно дохлый, как и описал Padavan.

Edited by supilot

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, enterfaza сказал:

14.0.1

Именно в 14.1 отвалы «вылечили»

Share this post


Link to post
Share on other sites
  • 0
15 минут назад, stefbarinov сказал:

отвалы «вылечили»

так я ж говорю, отвалов нет, есть только постоянная 40 ширина у i6S на 3010 с 3.4.12 и редко 80, но с g3 на 3.4.12 с ним же всегда 80, со всеми другими яблоками выше i6S все гуд

а если на i6S на 14.1 вылечили это, как Вы говорите, то замечательно, будем пробовать, смотреть 

Share this post


Link to post
Share on other sites
  • 0

Напоминаю, что существует достаточно большое кол-во мобильных клиентов, прошивка которых включает региональное ограничение в 5ГГц. Начиная с iOS 13, это постигло и многие устройства Apple, например iPad Air2 и iPhone 6S (для Apple уже найдено решение, см. мой пост). Также региональное ограничение наблюдается на некоторых моделях мобильных устройств Huawei, LG, Apple (преимущественно на старых wifi чипах Broadcom).

В чем выражается региональное ограничение - такие устройства ограничивают полосу 40МГц в 5ГГц 11ac.

У тех устройств, где клиентский STA драйвер умеет делать это правильно, при подключении, в пакете Assoc Request он заполняют поле VHT Operation Info, где указывают Channel width 20/40. AP, понимая что такой клиент не поддерживает 80МГц, заносит его к себе в WCID таблицу с полосой 40 и работает с ним всегда не выше чем 40. Также, такие правильные клиенты могут при подключении в Assoc Request совсем не заполнить VHT Operation IE (при этом подключение произойдет с полосой 80), но через некоторое время прислать Action пакет VHT Operation Mode Notify, где просят переключить полосу на 40 (либо число стримов на 1). AP, получив такой пакет, переключает их в требуемый режим, до тех пор, пока клиент не пришлет новый Action пакет с VHT Operation Mode Notify с другим режимом. С такими устройствами всегда будет все хорошо.

Подавляющее большинство не очень "свежих" мобильных клиентов, которые включают региональное ограничение в 5ГГц, совершенно никак не информируют AP о том, что они ограничены 40МГц. Они не делают этого при подключении (VHT Operation IE отсутствует) и не присылают Action пакет с VHT Operation Mode Notify. С такими устройствами все идет по плохому сценарию, по той причине, что у них RX фильтр на фронтэнде режет полосу до 40. А сценарий такой:

  • новые чипы MT7915/7622/7615/7613 имеют внутри микрокода интеллектуальный rate_ctl, который через несколько десятков (сотен) отправленных пакетов в сторону клиента на полосе 80 по не-получению ACK и накручиванию ретрансмитов, может переключить такого клиента на полосу 40 и держать его там неопределенного долго. Весь механизм rate_ctl в этих чипах находится внутри микрокода. Версия микрокода видна при загрузке прошивки в системном логе. Если микрокод не поменялся между прошивками, нужно понимать, что rate_ctl не изменился. Снаружи он практически не управляется (кроме включения фиксированного рейта). Однако, механизм броска таких клиентов на 40 не всегда надежно срабатывает, при этом рейт плавает вниз до 6 и обратно, а полоса не высаживается в 40. При этом наблюдается сильная потери скорости (2..10mbps).  
  • cо старыми чипами MT7610 и MT7612 этот сценарий сразу же ведет к сильной потери скорости, она падает до 2..10mbps, потому что драйвер не может переключить такого клиента на 40. А даже переключив, быстро выбрасывает его опять на 80, потому что при 40 ре-трансмиты исчезают.

Для того чтобы хоть как-то решить эту проблему с такими клиентами (а она в принципе нерешаемая, если клиент режет полосу по регионалке и не информирует об этом), в 3.06 прошивке появилась возможность любого зарегистрированного клиента "прибить" к VHT 40. В web доступна галочка "Режим VHT-совместимости" в карточке клиента. Это одинаково хорошо работает c любыми чипами, как новыми, так и старыми.

Непосредственно по Apple, могу привести пример, что iPad Air2 RU, на iOS до 13 версии работал абсолютно на всех каналах в 80МГц, даже на блоке 132..144. С iOS 13 все каналы зарезали до 40, кроме 3 поддиапазона (149..161), там по-прежнему работает на 80. И печаль в том что его драйвер также никак не уведомляет о полосе 40. Я проверял на последней iOS 14.1, ничего не изменилось. На новых чипах он довольно быстро высаживается на 40МГц и для подобных клиентов это наоборот не минус, а плюс. На старых чипах MT7610 и MT7612 все также плохо, поэтому только новая галочка в 3.06 позволяет решить проблему достаточно красиво.

 

  • Thanks 6

Share this post


Link to post
Share on other sites
  • 0

@Padavan ясно/понятно

это особо не мешает, скорость на данном клиенте и не так важна, а дозволенные 400мбит на этой полосе на 5ггц вполне справляются с задачами

только вот Apple как всегда в своих «луДших» традициях заставляет многих пересаживаться с того, что и так не плохо трудилось 

Edited by enterfaza

Share this post


Link to post
Share on other sites
  • 0

Всё прочитал, очень интересно, но не совсем понятно почему на новый прошивках не старые Samsung Note 10+, Galaxy S10 стали уходить в 40 и откровенно плохо работать по воздуху. Даже происходит автопереход на 4G так как клиент решает что Wi-Fi не достаточно хорош.

Похоже сидеть мне пожизненно на 2.16, там всё работает идеально со всеми клиентами без отвалов и сваливаний :D

Edited by Space Alex

Share this post


Link to post
Share on other sites
  • 0

Также хотелось бы поговорить по новым прошивкам для Keenetic.

Для чипов MT7615 переход на драйвер 5.0.5.0 с более свежим микрокодом произошел при переходе с прошивки 3.04 на 3.05 в конце апреля. С тех пор версия микрокода не менялась, соответственно стратегия rate_ctl, которая управляет скоростью линка к клиенту, измениться не могла.

Для чипов MT7613, микрокод обновляется чаще, последний раз обновился 11 сентября.

Версия микрокода сейчас видна в системном логе при загрузке модуля драйвера.

Если пытаться анализировать проблемы свала клиентов в 40МГц, в диапазоне 5ГГц, то всех клиентов можно разбить на несколько групп:

  • клиент имеет региональное ограничение и уведомляет о полосе 40. Такие клиенты уходят в 40 сразу при подключении или почти сразу по уведомлению VHT Operation Mode Notify. Работают хорошо на всех Keenetic, включая старые устройства на чипах MT7610/7612. Все эти уведомления прекрасно видны при захвате эфира 802.11.
  • клиент имеет региональное ограничение и НЕ уведомляет о полосе 40. На старых Keenetic (MT7610/7612) всегда все плохо, скорости очень низкие, для них решение только ставить полосу 40 руками или в 3.06 ставить галочку "Режим VHT-совместимости" в карточке клиента. На новых Keenetic (MT7615/7613) логика rate_ctl может их быстро скинуть в 40 и скорость наладится. Однако 100% гарантии сброса в 40 нет, поэтому также лучше в 3.06 ставить галочку "Режим VHT-совместимости".
  • клиент не имеет регионального ограничения и работает в 80МГц на любом блоке каналов. Если такой клиент выбрасывается на 40, нужно смотреть эфир, слал ли он сам Action пакеты VHT Operation Mode Notify или нет. Если не слал, значит были ретрансмиты и логика rate_ctl его туда скинула. Это поведение на новых чипах зависит только от версии микрокода Wireless чипа.  

 

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Space Alex

Для нас в техническом плане очень важно понимать, в каких рамках прошивок возникла предполагаемая регрессия. И не менее важна модель Keenetic, так как все индивидуально для каждого чипа.

Share this post


Link to post
Share on other sites
  • 0
12 минуты назад, Padavan сказал:

Space Alex

Для нас в техническом плане очень важно понимать, в каких рамках прошивок возникла предполагаемая регрессия. И не менее важна модель Keenetic, так как все индивидуально для каждого чипа.

Пользовался всеми прошивками кроме 3.4 ... ее пропустил сидя на 2.16, но могу сказать точно что проблем со сваливанием на тех прошивках не наблюдал никогда. Модель KN-1810.
Судя по тому, что люди пишут на 4pda у многих начались сваливания в 40 после перехода с 3.4.12 на 3.5 с абсолютно разными клиентами. У меня еще было замечено на Mi Box S и на лаптопе Xiaomi. И всегда рандомно сваливается почему-то только кто-то один из 20 устройств :D да и кстати жалобы по моему только от пользователей KN-1810.

Edited by Space Alex

Share this post


Link to post
Share on other sites
  • 0

@Padavan я еще в начале темы прикреплял сэлф тэст после того как свалился Note 10+, может там можно что-то откопать)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...